{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2017-20287", "assignerOrgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "state": "PUBLISHED", "assignerShortName": "VulnCheck", "dateReserved": "2026-10-14T20:25:25.755Z", "datePublished": "2026-10-22T10:57:22.589Z", "dateUpdated": "2026-10-28T17:59:15.933Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "shortName": "VulnCheck", "dateUpdated": "2026-10-22T10:57:22.589Z" }, "datePublic": "2017-02-09T00:00:00.000Z", "title": "Javo Spot WordPress Theme < 3.0.0 Path Traversal via admin-ajax.php fn Parameter", "descriptions": [ { "lang": "en", "value": "Javo Spot theme for WordPress before 3.0.0 contains a path traversal vulnerability that allows unauthenticated attackers to read arbitrary files via the fn parameter of the jvfrm_spot_get_json AJAX action. Attackers can send GET requests to /wp-admin/admin-ajax.php with fn set to ../../wp-config.php to retrieve database credentials and secret keys. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19." } ], "tags": [ "x_known-exploited-vulnerability" ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')", "cweId": "CWE-22", "type": "CWE" } ] } ], "affected": [ { "defaultStatus": "unaffected", "vendor": "Javo Themes", "product": "Javo Spot", "versions": [ { "version": "0", "lessThan": "3.0.0", "status": "affected", "versionType": "custom" } ] } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "LOW", "attackRequirements": "NONE", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "subConfidentialityImpact": "NONE", "vulnIntegrityImpact": "NONE", "subIntegrityImpact": "NONE", "vulnAvailabilityImpact": "NONE", "subAvailabilityImpact": "NONE", "exploitMaturity": "NOT_DEFINED", "Safety": "NOT_DEFINED", "Automatable": "NOT_DEFINED", "Recovery": "NOT_DEFINED", "valueDensity": "NOT_DEFINED", "vulnerabilityResponseEffort": "NOT_DEFINED", "providerUrgency": "NOT_DEFINED", "version": "4.0", "baseSeverity": "HIGH", "baseScore": 8.7, "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N" } }, { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "NONE", "availabilityImpact": "NONE", "version": "3.1", "baseSeverity": "HIGH", "baseScore": 7.5, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N" } } ], "references": [ { "url": "https://codeseekah.com/2017/02/09/javo-themes-spot-lfi-vulnerability/", "name": "Researcher Blog", "tags": [ "technical-description", "exploit" ] }, { "url": "https://wpscan.com/vulnerability/2d465fc4-d4fa-43bb-9c0d-71dcc3ee4eab", "name": "WPScan Advisory", "tags": [ "third-party-advisory" ] }, { "url": "https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-javospot-lfi.yaml", "name": "Nuclei Template", "tags": [ "technical-description" ] }, { "url": "https://themeforest.net/item/javo-spot-multi-purpose-directory-wordpress-theme/13198068", "name": "Theme Download Page", "tags": [ "product" ] }, { "name": "VulnCheck Advisory: Javo Spot WordPress Theme < 3.0.0 Path Traversal via admin-ajax.php fn Parameter", "tags": [ "third-party-advisory" ], "url": "https://www.vulncheck.com/advisories/javo-spot-wordpress-theme-3.0.0-path-traversal-via-admin-ajax-php-fn-parameter" } ], "credits": [ { "lang": "en", "value": "soulseekah", "type": "finder" }, { "lang": "en", "value": "The Shadowserver Foundation", "type": "reporter" } ], "source": { "discovery": "UNKNOWN" }, "x_generator": { "engine": "vulncheck-kclub" } }, "adp": [ { "references": [ { "url": "https://wpscan.com/vulnerability/2d465fc4-d4fa-43bb-9c0d-71dcc3ee4eab/", "tags": [ "exploit" ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-10-28T17:58:51.181565Z", "id": "CVE-2017-20287", "options": [ { "Exploitation": "poc" }, { "Automatable": "yes" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-10-28T17:59:15.933Z" } } ] } }