{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "state": "PUBLISHED", "cveId": "CVE-2021-25315", "assignerOrgId": "404e59f5-483d-4b8a-8e7a-e67604dd8afb", "assignerShortName": "suse", "dateUpdated": "2024-09-16T21:03:45.719Z", "dateReserved": "2021-01-19T00:00:00.000Z", "datePublished": "2021-03-03T09:55:16.356Z" }, "containers": { "cna": { "title": "salt-api unauthenticated remote code execution", "datePublic": "2021-03-01T00:00:00.000Z", "providerMetadata": { "orgId": "404e59f5-483d-4b8a-8e7a-e67604dd8afb", "shortName": "suse", "dateUpdated": "2023-06-22T00:00:00.000Z" }, "descriptions": [ { "lang": "en", "value": "CWE - CWE-287: Improper Authentication vulnerability in SUSE Linux Enterprise Server 15 SP 3; openSUSE Tumbleweed allows local attackers to execute arbitrary code via salt without the need to specify valid credentials. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions." } ], "affected": [ { "vendor": "SUSE", "product": "SUSE Linux Enterprise Server 15 SP 3", "versions": [ { "version": "salt", "status": "affected", "lessThan": "3002.2-3", "versionType": "custom" } ] }, { "vendor": "openSUSE", "product": "Tumbleweed", "versions": [ { "version": "salt", "status": "affected", "lessThanOrEqual": "3002.2-2.1", "versionType": "custom" } ] } ], "references": [ { "url": "https://bugzilla.suse.com/show_bug.cgi?id=1182382" } ], "metrics": [ { "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "HIGH", "baseScore": 9.8, "baseSeverity": "CRITICAL" } } ], "problemTypes": [ { "descriptions": [ { "type": "CWE", "lang": "en", "description": "CWE - CWE-287: Improper Authentication", "cweId": "CWE-287" } ] } ], "x_generator": { "engine": "Vulnogram 0.0.9" }, "source": { "advisory": "https://bugzilla.suse.com/show_bug.cgi?id=1182382", "defect": [ "1182382" ], "discovery": "INTERNAL" } }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-03T20:03:04.112Z" }, "title": "CVE Program Container", "references": [ { "url": "https://bugzilla.suse.com/show_bug.cgi?id=1182382", "tags": [ "x_transferred" ] } ] } ] } }