{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2023-34214", "assignerOrgId": "2e0a0ee2-d866-482a-9f5e-ac03d156dbaa", "state": "PUBLISHED", "assignerShortName": "Moxa", "dateReserved": "2023-05-31T08:58:06.149Z", "datePublished": "2023-08-17T02:26:05.428Z", "dateUpdated": "2024-10-28T06:07:21.645Z" }, "containers": { "cna": { "affected": [ { "defaultStatus": "unaffected", "product": "TN-5900 Series", "vendor": "Moxa", "versions": [ { "lessThanOrEqual": "3.3", "status": "affected", "version": "1.0", "versionType": "custom" } ] }, { "defaultStatus": "unaffected", "product": "TN-4900 Series", "vendor": "Moxa", "versions": [ { "lessThanOrEqual": "1.2.4", "status": "affected", "version": "1.0", "versionType": "custom" } ] }, { "defaultStatus": "unaffected", "product": "EDR-810 Series", "vendor": "Moxa", "versions": [ { "lessThanOrEqual": "5.12.27", "status": "affected", "version": "1.0", "versionType": "custom" } ] }, { "defaultStatus": "unaffected", "product": "EDR-G902 Series", "vendor": "Moxa", "versions": [ { "lessThanOrEqual": "5.7.17", "status": "affected", "version": "1.0", "versionType": "custom" } ] }, { "defaultStatus": "unaffected", "product": "EDR-G903 Series", "vendor": "Moxa", "versions": [ { "lessThanOrEqual": "5.7.15", "status": "affected", "version": "1.0", "versionType": "custom" } ] } ], "descriptions": [ { "lang": "en", "supportingMedia": [ { "base64": false, "type": "text/html", "value": "TN-4900 Series firmware versions v1.2.4 and prior and TN-5900 Series firmware versions v3.3 and prior are vulnerable to the command-injection vulnerability. This vulnerability stems from insufficient input validation in the certificate-generation function, which could potentially allow malicious users to execute remote code on affected devices." } ], "value": "TN-4900 Series firmware versions v1.2.4 and prior and TN-5900 Series firmware versions v3.3 and prior are vulnerable to the command-injection vulnerability. This vulnerability stems from insufficient input validation in the certificate-generation function, which could potentially allow malicious users to execute remote code on affected devices." } ], "impacts": [ { "capecId": "CAPEC-248", "descriptions": [ { "lang": "en", "value": "CAPEC-248 Command Injection" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 7.2, "baseSeverity": "HIGH", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "HIGH", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H", "version": "3.1" }, "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ] } ], "problemTypes": [ { "descriptions": [ { "cweId": "CWE-78", "description": "CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')", "lang": "en", "type": "CWE" } ] } ], "providerMetadata": { "orgId": "2e0a0ee2-d866-482a-9f5e-ac03d156dbaa", "shortName": "Moxa", "dateUpdated": "2024-10-28T06:07:21.645Z" }, "references": [ { "tags": [ "vendor-advisory" ], "url": "https://www.moxa.com/en/support/product-support/security-advisory/mpsa-230402-tn-5900-and-tn-4900-series-web-server-multiple-vulnerabilities" } ], "solutions": [ { "lang": "en", "supportingMedia": [ { "base64": false, "type": "text/html", "value": "Moxa has developed appropriate solution to address the vulnerability. The solution for affected products is shown below:
" } ], "value": "Moxa has developed appropriate solution to address the vulnerability. The solution for affected products is shown below:\n * * TN-4900 Series: Please upgrade to firmware v3.0 or higher. https://www.moxa.com/en/products/industrial-network-infrastructure/secure-routers/en-50155-routers/tn-5900-series#resources \n * TN-5900 Series: Please upgrade to firmware v3.4 or higher. https://www.moxa.com/en/products/industrial-network-infrastructure/secure-routers/en-50155-routers/tn-5900-series#resources  \n * EDR-810 Series: Please upgrade to firmware v5.12.29 or higher. https://www.moxa.com/en/products/industrial-network-infrastructure/secure-routers/secure-routers/edr-810-series#resources \n * EDR-G902 Series: Please upgrade to firmware v5.7.21 or higher. https://www.moxa.com/en/products/industrial-network-infrastructure/secure-routers/secure-routers/edr-g902-series \n * EDR-G903 Series: Please upgrade to firmware v5.7.21 or higher. https://www.moxa.com/en/products/industrial-network-infrastructure/secure-routers/secure-routers/edr-g903-series#resources" } ], "source": { "discovery": "EXTERNAL" }, "title": "Second Order Command-injection Vulnerability in the Certificate-generation Function", "x_generator": { "engine": "Vulnogram 0.1.0-dev" } }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-02T16:01:54.270Z" }, "title": "CVE Program Container", "references": [ { "tags": [ "vendor-advisory", "x_transferred" ], "url": "https://www.moxa.com/en/support/product-support/security-advisory/mpsa-230402-tn-5900-and-tn-4900-series-web-server-multiple-vulnerabilities" } ] }, { "affected": [ { "vendor": "moxa", "product": "tn-5900", "cpes": [ "cpe:2.3:h:moxa:tn-5900:-:*:*:*:*:*:*:*" ], "defaultStatus": "unaffected", "versions": [ { "version": "1.0", "status": "affected", "lessThanOrEqual": "3.3", "versionType": "custom" } ] }, { "vendor": "moxa", "product": "tn-4900", "cpes": [ "cpe:2.3:h:moxa:tn-4900:-:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "1.0", "status": "affected", "lessThanOrEqual": "1.2.4", "versionType": "custom" } ] }, { "vendor": "moxa", "product": "edr-810", "cpes": [ "cpe:2.3:h:moxa:edr-810:-:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "1.0", "status": "affected", "lessThanOrEqual": "5.12.27", "versionType": "custom" } ] }, { "vendor": "moxa", "product": "edr-g902", "cpes": [ "cpe:2.3:h:moxa:edr-g902:-:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "1.0", "status": "affected", "lessThanOrEqual": "5.7.17", "versionType": "custom" } ] }, { "vendor": "moxa", "product": "edr-g903", "cpes": [ "cpe:2.3:h:moxa:edr-g903:-:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "1.0", "status": "affected", "lessThanOrEqual": "5.7.15", "versionType": "custom" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-10-08T17:30:32.666754Z", "id": "CVE-2023-34214", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-10-08T17:37:23.351Z" } } ] } }