{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2023-37917", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2023-07-10T17:51:29.612Z", "datePublished": "2023-07-21T20:13:22.401Z", "dateUpdated": "2024-10-10T18:37:38.475Z" }, "containers": { "cna": { "title": "Privilege Escalation in kubepi", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-269", "lang": "en", "description": "CWE-269: Improper Privilege Management", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "LOW", "baseScore": 9.1, "baseSeverity": "CRITICAL", "confidentialityImpact": "LOW", "integrityImpact": "HIGH", "privilegesRequired": "LOW", "scope": "CHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L", "version": "3.1" } } ], "references": [ { "name": "https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r" } ], "affected": [ { "vendor": "1Panel-dev", "product": "KubePi", "versions": [ { "version": "< 1.6.5", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2023-07-21T20:13:22.401Z" }, "descriptions": [ { "lang": "en", "value": "KubePi is an opensource kubernetes management panel. A normal user has permission to create/update users, they can become admin by editing the `isadmin` value in the request. As a result any user may take administrative control of KubePi. This issue has been addressed in version 1.6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability." } ], "source": { "advisory": "GHSA-757p-vx43-fp9r", "discovery": "UNKNOWN" } }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-02T17:23:27.620Z" }, "title": "CVE Program Container", "references": [ { "name": "https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r", "tags": [ "x_refsource_CONFIRM", "x_transferred" ], "url": "https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r" } ] }, { "affected": [ { "vendor": "fit2cloud", "product": "kubepi", "cpes": [ "cpe:2.3:a:fit2cloud:kubepi:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "0", "status": "affected", "lessThan": "1.6.5", "versionType": "custom" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-10-10T18:19:18.928442Z", "id": "CVE-2023-37917", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-10-10T18:37:38.475Z" } } ] } }