{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2023-50254", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2023-12-05T20:42:59.378Z", "datePublished": "2023-12-22T16:49:48.977Z", "dateUpdated": "2024-08-02T22:16:46.096Z" }, "containers": { "cna": { "title": "Deepin Reader RCE vulnerability due to a design flaw", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-27", "lang": "en", "description": "CWE-27: Path Traversal: 'dir/../../filename'", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-22", "lang": "en", "description": "CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.3, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "NONE", "privilegesRequired": "NONE", "scope": "CHANGED", "userInteraction": "REQUIRED", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495" }, { "name": "https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04" }, { "name": "https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6" } ], "affected": [ { "vendor": "linuxdeepin", "product": "developer-center", "versions": [ { "version": "< 6.0.7", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2023-12-22T16:49:48.977Z" }, "descriptions": [ { "lang": "en", "value": "Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue." } ], "source": { "advisory": "GHSA-q9jr-726g-9495", "discovery": "UNKNOWN" } }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-02T22:16:46.096Z" }, "title": "CVE Program Container", "references": [ { "name": "https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495", "tags": [ "x_refsource_CONFIRM", "x_transferred" ], "url": "https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495" }, { "name": "https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04", "tags": [ "x_refsource_MISC", "x_transferred" ], "url": "https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04" }, { "name": "https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6", "tags": [ "x_refsource_MISC", "x_transferred" ], "url": "https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6" } ] } ] } }