{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2024-1735", "assignerOrgId": "657f3255-0560-4aed-82e4-7f579ec6acfb", "state": "PUBLISHED", "assignerShortName": "LY-Corporation", "dateReserved": "2024-02-22T05:17:44.461Z", "datePublished": "2024-02-26T07:25:42.406Z", "dateUpdated": "2025-08-26T20:01:39.603Z" }, "containers": { "cna": { "affected": [ { "vendor": "LINE Corporation", "product": "Armeria", "versions": [ { "version": "0.69.0", "status": "affected", "versionType": "semver", "lessThan": "1.27.2" } ] } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "na" } ] } ], "descriptions": [ { "lang": "en", "value": "A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later." } ], "references": [ { "url": "https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54" } ], "metrics": [ { "format": "CVSS", "cvssV3_1": { "version": "3.1", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "NONE", "baseScore": 9.1, "baseSeverity": "CRITICAL", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N" } } ], "providerMetadata": { "orgId": "657f3255-0560-4aed-82e4-7f579ec6acfb", "shortName": "LY-Corporation", "dateUpdated": "2024-06-12T07:57:43.872Z" } }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-01T18:48:21.949Z" }, "title": "CVE Program Container", "references": [ { "url": "https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54", "tags": [ "x_transferred" ] } ] }, { "problemTypes": [ { "descriptions": [ { "type": "CWE", "cweId": "CWE-287", "lang": "en", "description": "CWE-287 Improper Authentication" } ] } ], "affected": [ { "vendor": "linecorp", "product": "armeria", "cpes": [ "cpe:2.3:a:linecorp:armeria:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "0.69.0", "status": "affected", "lessThan": "1.27.2", "versionType": "custom" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-03-04T21:31:51.106962Z", "id": "CVE-2024-1735", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-08-26T20:01:39.603Z" } } ] } }