{ "dataType": "CVE_RECORD", "cveMetadata": { "cveId": "CVE-2024-34340", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2024-05-02T06:36:32.436Z", "datePublished": "2024-05-13T15:26:32.364Z", "dateUpdated": "2025-11-04T16:12:18.537Z" }, "containers": { "cna": { "title": "Authentication Bypass when using using older password hashes", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-287", "lang": "en", "description": "CWE-287: Improper Authentication", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-697", "lang": "en", "description": "CWE-697: Incorrect Comparison", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "NONE", "baseScore": 9.1, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N", "version": "3.1" } } ], "references": [ { "name": "https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m" }, { "url": "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/" } ], "affected": [ { "vendor": "Cacti", "product": "cacti", "versions": [ { "version": "< 1.2.27", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2024-06-10T16:09:41.115Z" }, "descriptions": [ { "lang": "en", "value": "Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue." } ], "source": { "advisory": "GHSA-37x7-mfjv-mm7m", "discovery": "UNKNOWN" } }, "adp": [ { "title": "CVE Program Container", "references": [ { "name": "https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m", "tags": [ "x_refsource_CONFIRM", "x_transferred" ], "url": "https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m" }, { "url": "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/", "tags": [ "x_transferred" ] }, { "url": "https://lists.debian.org/debian-lts-announce/2024/09/msg00027.html" } ], "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2025-11-04T16:12:18.537Z" } }, { "affected": [ { "vendor": "cacti", "product": "cacti", "cpes": [ "cpe:2.3:a:cacti:cacti:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "0", "status": "affected", "lessThan": "1.2.27", "versionType": "custom" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-05-13T17:13:47.563016Z", "id": "CVE-2024-34340", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-08-21T20:47:27.400Z" } } ] }, "dataVersion": "5.2" }