{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2024-3105", "assignerOrgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "state": "PUBLISHED", "assignerShortName": "Wordfence", "dateReserved": "2024-03-29T19:14:03.962Z", "datePublished": "2024-06-15T08:42:14.653Z", "dateUpdated": "2026-04-08T16:36:37.357Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "shortName": "Wordfence", "dateUpdated": "2026-04-08T16:36:37.357Z" }, "affected": [ { "vendor": "themeisle", "product": "Woody Code Snippets – Insert PHP, CSS, JS, and Header/Footer Scripts", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "2.5.0", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "lang": "en", "value": "The Woody code snippets – Insert Header Footer Code, AdSense Ads plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.5.0 via the 'insert_php' shortcode. This is due to the plugin not restricting the usage of the functionality to high level authorized users. This makes it possible for authenticated attackers, with contributor-level access and above, to execute code on the server." } ], "title": "Woody code snippets – Insert Header Footer Code, AdSense Ads <= 2.5.0 -Authenticated (Contributor+) Remote Code Execution", "references": [ { "url": "https://www.wordfence.com/threat-intel/vulnerabilities/id/134ad095-b0a0-4f0f-832d-3e558d4a250a?source=cve" }, { "url": "https://plugins.trac.wordpress.org/browser/insert-php/trunk/includes/class.plugin.php#L166" }, { "url": "https://plugins.trac.wordpress.org/browser/insert-php/trunk/includes/shortcodes/shortcode-insert-php.php" }, { "url": "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3102522%40insert-php&new=3102522%40insert-php&sfp_email=&sfph_mail=" } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "CWE-94 Improper Control of Generation of Code ('Code Injection')", "cweId": "CWE-94", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H", "baseScore": 9.9, "baseSeverity": "CRITICAL" } } ], "credits": [ { "lang": "en", "type": "finder", "value": "Craig Smith" } ], "timeline": [ { "time": "2024-06-14T20:26:37.000Z", "lang": "en", "value": "Disclosed" } ] }, "adp": [ { "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2024-08-01T19:32:42.588Z" }, "title": "CVE Program Container", "references": [ { "url": "https://www.wordfence.com/threat-intel/vulnerabilities/id/134ad095-b0a0-4f0f-832d-3e558d4a250a?source=cve", "tags": [ "x_transferred" ] }, { "url": "https://plugins.trac.wordpress.org/browser/insert-php/trunk/includes/class.plugin.php#L166", "tags": [ "x_transferred" ] }, { "url": "https://plugins.trac.wordpress.org/browser/insert-php/trunk/includes/shortcodes/shortcode-insert-php.php", "tags": [ "x_transferred" ] }, { "url": "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3102522%40insert-php&new=3102522%40insert-php&sfp_email=&sfph_mail=", "tags": [ "x_transferred" ] } ] }, { "affected": [ { "vendor": "webcraftic", "product": "woody_ad_snippets", "cpes": [ "cpe:2.3:a:webcraftic:woody_ad_snippets:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "2.5.0", "versionType": "semver" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-08-09T19:57:07.267327Z", "id": "CVE-2024-3105", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-08-09T20:09:19.278Z" } } ] } }