{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2024-42473", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2024-08-02T14:13:04.615Z", "datePublished": "2024-08-09T21:16:17.683Z", "dateUpdated": "2024-08-10T14:21:04.103Z" }, "containers": { "cna": { "title": "OpenFGA Authorization Bypass", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-863", "lang": "en", "description": "CWE-863: Incorrect Authorization", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "NONE", "baseScore": 7.5, "baseSeverity": "HIGH", "confidentialityImpact": "NONE", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N", "version": "3.1" } } ], "references": [ { "name": "https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/openfga/openfga/security/advisories/GHSA-3f6g-m4hr-59h8" } ], "affected": [ { "vendor": "openfga", "product": "openfga", "versions": [ { "version": ">=1.5.7, <= 1.5.8", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2024-08-09T21:16:17.683Z" }, "descriptions": [ { "lang": "en", "value": "OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release." } ], "source": { "advisory": "GHSA-3f6g-m4hr-59h8", "discovery": "UNKNOWN" } }, "adp": [ { "affected": [ { "vendor": "openfga", "product": "openfga", "cpes": [ "cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "1.5.7", "status": "affected", "lessThanOrEqual": "1.5.8", "versionType": "custom" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-08-10T14:18:27.056147Z", "id": "CVE-2024-42473", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-08-10T14:21:04.103Z" } } ] } }