{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2024-54139", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2024-11-29T18:02:16.755Z", "datePublished": "2024-12-13T15:59:24.978Z", "dateUpdated": "2024-12-13T17:34:07.288Z" }, "containers": { "cna": { "title": "Combodo iTop vulnerable to XSS leading to CSRF breach on _table_id parameter", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-79", "lang": "en", "description": "CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-352", "lang": "en", "description": "CWE-352: Cross-Site Request Forgery (CSRF)", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "HIGH", "attackVector": "NETWORK", "availabilityImpact": "LOW", "baseScore": 7.9, "baseSeverity": "HIGH", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "LOW", "scope": "CHANGED", "userInteraction": "REQUIRED", "vectorString": "CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L", "version": "3.1" } } ], "references": [ { "name": "https://github.com/Combodo/iTop/security/advisories/GHSA-jmv2-wfh5-h5wg", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/Combodo/iTop/security/advisories/GHSA-jmv2-wfh5-h5wg" } ], "affected": [ { "vendor": "Combodo", "product": "iTop", "versions": [ { "version": "< 2.7.11", "status": "affected" }, { "version": ">= 3.0.0-alpha, < 3.1.2", "status": "affected" }, { "version": ">= 3.2.0-alpha1, < 3.2.0", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2024-12-13T15:59:24.978Z" }, "descriptions": [ { "lang": "en", "value": "Combodo iTop is an open source and web-based IT service management platform. Prior to versions 2.7.11, 3.1.2, and 3.2.0., iTop has a cross-site scripting vulnerability that can lead to cross-site request forgery on the `_table_id` parameter. Versions 2.7.11, 3.1.2, and 3.2.0 contain a patch for the issue." } ], "source": { "advisory": "GHSA-jmv2-wfh5-h5wg", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-12-13T17:33:51.255770Z", "id": "CVE-2024-54139", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-12-13T17:34:07.288Z" } } ] } }