{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2024-6386", "assignerOrgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "state": "PUBLISHED", "assignerShortName": "Wordfence", "dateReserved": "2024-06-27T10:17:18.971Z", "datePublished": "2024-08-21T20:29:23.090Z", "dateUpdated": "2026-04-08T17:33:51.326Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "shortName": "Wordfence", "dateUpdated": "2026-04-08T17:33:51.326Z" }, "affected": [ { "vendor": "WPML", "product": "WPML", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "4.6.12", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "lang": "en", "value": "The WPML plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.6.12 via Twig Server-Side Template Injection. This is due to missing input validation and sanitization on the render function. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server." } ], "title": "WPML Multilingual CMS <= 4.6.12 - Authenticated (Contributor+) Remote Code Execution via Twig Server-Side Template Injection", "references": [ { "url": "https://www.wordfence.com/threat-intel/vulnerabilities/id/f7fc91cc-e529-4362-8269-bf7ee0766e1e?source=cve" }, { "url": "https://wpml.org/" }, { "url": "https://sec.stealthcopter.com/wpml-rce-via-twig-ssti/" } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine", "cweId": "CWE-1336", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H", "baseScore": 9.9, "baseSeverity": "CRITICAL" } } ], "credits": [ { "lang": "en", "type": "finder", "value": "Matthew Rollings" } ], "timeline": [ { "time": "2024-06-19T00:00:00.000Z", "lang": "en", "value": "Discovered" }, { "time": "2024-08-21T08:00:14.000Z", "lang": "en", "value": "Disclosed" } ] }, "adp": [ { "affected": [ { "vendor": "wpml", "product": "wpml", "cpes": [ "cpe:2.3:a:wpml:wpml:*:*:*:*:*:wordpress:*:*" ], "defaultStatus": "unaffected", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "4.6.12", "versionType": "semver" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-08-21T20:36:04.624512Z", "id": "CVE-2024-6386", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-08-21T20:36:58.048Z" } } ] } }