{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2024-9931", "assignerOrgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "state": "PUBLISHED", "assignerShortName": "Wordfence", "dateReserved": "2024-10-14T11:53:29.303Z", "datePublished": "2024-10-26T01:58:34.373Z", "dateUpdated": "2026-04-08T16:50:27.932Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "shortName": "Wordfence", "dateUpdated": "2026-04-08T16:50:27.932Z" }, "affected": [ { "vendor": "jurredeklijn", "product": "Wux Blog Editor", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "3.0.0", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "lang": "en", "value": "The Wux Blog Editor plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.0.0. This is due to missing validation on the token being supplied during the autologin through the plugin. This makes it possible for unauthenticated attackers to log in to the first administrator user." } ], "title": "Wux Blog Editor <= 3.0.0 - Authentication Bypass to Administrator", "references": [ { "url": "https://www.wordfence.com/threat-intel/vulnerabilities/id/494ef738-c900-4d00-8739-3b261586d4ff?source=cve" }, { "url": "https://plugins.trac.wordpress.org/browser/wux-blog-editor/tags/3.0.0/External_Post_Editor.php#L675" } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "CWE-288 Authentication Bypass Using an Alternate Path or Channel", "cweId": "CWE-288", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "baseScore": 9.8, "baseSeverity": "CRITICAL" } } ], "credits": [ { "lang": "en", "type": "finder", "value": "István Márton" } ], "timeline": [ { "time": "2024-10-12T00:00:00.000Z", "lang": "en", "value": "Discovered" }, { "time": "2024-10-12T00:00:00.000Z", "lang": "en", "value": "Vendor Notified" }, { "time": "2024-10-25T00:00:00.000Z", "lang": "en", "value": "Disclosed" } ] }, "adp": [ { "affected": [ { "vendor": "jurre_de_klijn", "product": "wux_blog_editor", "cpes": [ "cpe:2.3:a:jurre_de_klijn:wux_blog_editor:*:*:*:*:*:*:*:*" ], "defaultStatus": "unknown", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "3.0.0", "versionType": "semver" } ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2024-10-28T16:33:38.150895Z", "id": "CVE-2024-9931", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2024-10-28T19:40:11.760Z" } } ] } }