{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2025-29927", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-03-12T13:42:22.136Z", "datePublished": "2025-03-21T14:34:49.570Z", "dateUpdated": "2025-04-08T15:17:05.315Z" }, "containers": { "cna": { "title": "Authorization Bypass in Next.js Middleware", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-285", "lang": "en", "description": "CWE-285: Improper Authorization", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "NONE", "baseScore": 9.1, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N", "version": "3.1" } } ], "references": [ { "name": "https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw" }, { "name": "https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2" }, { "name": "https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48" }, { "name": "https://github.com/vercel/next.js/releases/tag/v12.3.5", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vercel/next.js/releases/tag/v12.3.5" }, { "name": "https://github.com/vercel/next.js/releases/tag/v13.5.9", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vercel/next.js/releases/tag/v13.5.9" } ], "affected": [ { "vendor": "vercel", "product": "next.js", "versions": [ { "version": ">= 11.1.4, < 12.3.5", "status": "affected" }, { "version": ">= 14.0.0, < 14.2.25", "status": "affected" }, { "version": ">= 15.0.0, < 15.2.3", "status": "affected" }, { "version": ">= 13.0.0, < 13.5.9", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-04-08T13:59:00.478Z" }, "descriptions": [ { "lang": "en", "value": "Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3." } ], "source": { "advisory": "GHSA-f82v-jwr5-mffw", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-04-08T15:16:38.515188Z", "id": "CVE-2025-29927", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-04-08T15:17:05.315Z" } }, { "title": "CVE Program Container", "references": [ { "url": "http://www.openwall.com/lists/oss-security/2025/03/23/3" }, { "url": "http://www.openwall.com/lists/oss-security/2025/03/23/4" }, { "url": "https://security.netapp.com/advisory/ntap-20250328-0002/" } ], "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2025-03-28T15:03:09.597Z" } } ] } }