{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2025-3222", "assignerOrgId": "2cf0fb33-79e2-44e0-beb8-826cc5ce3250", "state": "PUBLISHED", "assignerShortName": "GE_Vernova", "dateReserved": "2025-04-03T13:47:11.155Z", "datePublished": "2025-11-07T16:28:45.217Z", "dateUpdated": "2025-11-13T17:16:35.591Z" }, "containers": { "cna": { "affected": [ { "defaultStatus": "unaffected", "platforms": [ "Windows", "Linux" ], "product": "Smallworld", "vendor": "GE Vernova", "versions": [ { "status": "affected", "version": "5.3.3", "versionType": "Linux" }, { "status": "affected", "version": "5.3.4", "versionType": "Windows" } ] } ], "credits": [ { "lang": "en", "type": "finder", "value": "Théo GOBINET" }, { "lang": "en", "type": "finder", "value": "Azaël MARTIN" } ], "descriptions": [ { "lang": "en", "supportingMedia": [ { "base64": false, "type": "text/html", "value": "Improper Authentication vulnerability in GE Vernova Smallworld on Windows, Linux allows Authentication Abuse.
This issue affects Smallworld: 5.3.3 and prior versions for Linux, and 5.3.4. and prior versions for Windows.
" } ], "value": "Improper Authentication vulnerability in GE Vernova Smallworld on Windows, Linux allows Authentication Abuse.This issue affects Smallworld: 5.3.3 and prior versions for Linux, and 5.3.4. and prior versions for Windows." } ], "impacts": [ { "capecId": "CAPEC-114", "descriptions": [ { "lang": "en", "value": "CAPEC-114 Authentication Abuse" } ] } ], "metrics": [ { "cvssV4_0": { "Automatable": "NOT_DEFINED", "Recovery": "NOT_DEFINED", "Safety": "NOT_DEFINED", "attackComplexity": "LOW", "attackRequirements": "NONE", "attackVector": "NETWORK", "baseScore": 9.3, "baseSeverity": "CRITICAL", "exploitMaturity": "NOT_DEFINED", "privilegesRequired": "NONE", "providerUrgency": "NOT_DEFINED", "subAvailabilityImpact": "NONE", "subConfidentialityImpact": "NONE", "subIntegrityImpact": "NONE", "userInteraction": "NONE", "valueDensity": "NOT_DEFINED", "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N", "version": "4.0", "vulnAvailabilityImpact": "HIGH", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnerabilityResponseEffort": "NOT_DEFINED" }, "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ] } ], "problemTypes": [ { "descriptions": [ { "cweId": "CWE-287", "description": "CWE-287 Improper Authentication", "lang": "en", "type": "CWE" } ] } ], "providerMetadata": { "orgId": "2cf0fb33-79e2-44e0-beb8-826cc5ce3250", "shortName": "GE_Vernova", "dateUpdated": "2025-11-13T17:16:35.591Z" }, "references": [ { "url": "https://www.gevernova.com/content/dam/cyber_security/global/en_US/pdfs/SecurityAdvisory_ImproperAuthentication_SWMFS.pdf" } ], "solutions": [ { "lang": "en", "supportingMedia": [ { "base64": false, "type": "text/html", "value": "GE Vernova recommends that users upgrade to the appropriate non-affected version listed above in accordance with their use case and architecture as this is the most complete method to address the Vulnerability.