{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2025-48877", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-05-27T20:14:34.296Z", "datePublished": "2025-06-09T12:36:29.651Z", "dateUpdated": "2025-06-09T15:17:08.586Z" }, "containers": { "cna": { "title": "Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-1038", "lang": "en", "description": "CWE-1038: Insecure Automated Optimizations", "type": "CWE" } ] } ], "metrics": [ { "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "LOW", "attackRequirements": "NONE", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "HIGH", "subConfidentialityImpact": "NONE", "subIntegrityImpact": "NONE", "subAvailabilityImpact": "NONE", "baseScore": 8.1, "baseSeverity": "HIGH", "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U", "version": "4.0" } } ], "references": [ { "name": "https://github.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv" } ], "affected": [ { "vendor": "discourse", "product": "discourse", "versions": [ { "version": "< 3.4.4", "status": "affected" }, { "version": "< 3.5.0.beta5", "status": "affected" }, { "version": "< 3.5.0.beta6-dev", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-06-09T12:36:29.651Z" }, "descriptions": [ { "lang": "en", "value": "Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`." } ], "source": { "advisory": "GHSA-cm93-6m2m-cjcv", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-06-09T15:11:20.634452Z", "id": "CVE-2025-48877", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-06-09T15:17:08.586Z" } } ] } }