{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2025-49002", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-05-29T16:34:07.175Z", "datePublished": "2025-06-03T20:37:40.449Z", "dateUpdated": "2025-06-04T13:50:51.641Z" }, "containers": { "cna": { "title": "Dataease H2 Database Remote Code Execution (RCE) Bypass Vulnerability", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-290", "lang": "en", "description": "CWE-290: Authentication Bypass by Spoofing", "type": "CWE" } ] } ], "metrics": [ { "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "HIGH", "attackRequirements": "NONE", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "HIGH", "subConfidentialityImpact": "NONE", "subIntegrityImpact": "NONE", "subAvailabilityImpact": "NONE", "baseScore": 8.2, "baseSeverity": "HIGH", "vectorString": "CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P", "version": "4.0" } } ], "references": [ { "name": "https://github.com/dataease/dataease/security/advisories/GHSA-999m-jv2p-5h34", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/dataease/dataease/security/advisories/GHSA-999m-jv2p-5h34" }, { "name": "https://github.com/dataease/dataease/security/advisories/GHSA-h7hj-4j78-cvc7", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/dataease/dataease/security/advisories/GHSA-h7hj-4j78-cvc7" } ], "affected": [ { "vendor": "dataease", "product": "dataease", "versions": [ { "version": "< 2.10.10", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-06-03T20:37:40.449Z" }, "descriptions": [ { "lang": "en", "value": "DataEase is an open source business intelligence and data visualization tool. Versions prior to version 2.10.10 have a flaw in the patch for CVE-2025-32966 that allow the patch to be bypassed through case insensitivity because INIT and RUNSCRIPT are prohibited. The vulnerability has been fixed in v2.10.10. No known workarounds are available." } ], "source": { "advisory": "GHSA-999m-jv2p-5h34", "discovery": "UNKNOWN" } }, "adp": [ { "references": [ { "url": "https://github.com/dataease/dataease/security/advisories/GHSA-h7hj-4j78-cvc7", "tags": [ "exploit" ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-06-04T13:50:16.450276Z", "id": "CVE-2025-49002", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-06-04T13:50:51.641Z" } } ] } }