{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2025-55282", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-08-12T16:15:30.236Z", "datePublished": "2025-08-18T16:44:02.944Z", "dateUpdated": "2025-08-18T19:49:56.981Z" }, "containers": { "cna": { "title": "aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-22", "lang": "en", "description": "CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.1, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "HIGH", "scope": "CHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9" }, { "name": "https://github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c5", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c5" } ], "affected": [ { "vendor": "aiven", "product": "aiven-db-migrate", "versions": [ { "version": "< 1.0.7", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-08-18T16:44:02.944Z" }, "descriptions": [ { "lang": "en", "value": "aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7." } ], "source": { "advisory": "GHSA-hmvf-93r4-36f9", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-08-18T19:49:31.049375Z", "id": "CVE-2025-55282", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-08-18T19:49:56.981Z" } } ] } }