{ "dataType": "CVE_RECORD", "dataVersion": "5.1", "cveMetadata": { "cveId": "CVE-2025-58357", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-08-29T16:19:59.010Z", "datePublished": "2025-09-04T00:30:09.292Z", "dateUpdated": "2025-09-04T14:02:28.135Z" }, "containers": { "cna": { "title": "5ire Chat Message XSS Vulnerability Enables Remote Code Execution", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-79", "lang": "en", "description": "CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.7, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "CHANGED", "userInteraction": "REQUIRED", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/nanbingxyz/5ire/security/advisories/GHSA-8527-3cch-95gf", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/nanbingxyz/5ire/security/advisories/GHSA-8527-3cch-95gf" }, { "name": "https://github.com/nanbingxyz/5ire/releases/tag/v0.14.0", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/nanbingxyz/5ire/releases/tag/v0.14.0" } ], "affected": [ { "vendor": "nanbingxyz", "product": "5ire", "versions": [ { "version": ">= 0.13.2, < 0.14.0", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-09-04T00:30:09.292Z" }, "descriptions": [ { "lang": "en", "value": "5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Version 0.13.2 contains a vulnerability in the chat page's script gadgets that enables content injection attacks through multiple vectors: malicious prompt injection pages, compromised MCP servers, and exploited tool integrations. This is fixed in version 0.14.0." } ], "source": { "advisory": "GHSA-8527-3cch-95gf", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-09-04T14:02:21.657418Z", "id": "CVE-2025-58357", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-09-04T14:02:28.135Z" } } ] } }