{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2025-66205", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-11-24T23:01:29.677Z", "datePublished": "2025-12-01T20:26:14.459Z", "dateUpdated": "2025-12-01T21:19:52.208Z" }, "containers": { "cna": { "title": "Frappe has the possibility of SQL Injection due to improper validations", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-89", "lang": "en", "description": "CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "LOW", "baseScore": 7.1, "baseSeverity": "HIGH", "confidentialityImpact": "HIGH", "integrityImpact": "NONE", "privilegesRequired": "LOW", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L", "version": "3.1" } } ], "references": [ { "name": "https://github.com/frappe/frappe/security/advisories/GHSA-mp93-8vxr-hqq9", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/frappe/frappe/security/advisories/GHSA-mp93-8vxr-hqq9" }, { "name": "https://github.com/frappe/frappe/commit/984c641bff9539b6126a01146096f133db6a955b", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/frappe/frappe/commit/984c641bff9539b6126a01146096f133db6a955b" } ], "affected": [ { "vendor": "frappe", "product": "frappe", "versions": [ { "version": ">= 15.0.0, < 15.86.0", "status": "affected" }, { "version": "< 14.99.2", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-12-01T20:26:47.841Z" }, "descriptions": [ { "lang": "en", "value": "Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2." } ], "source": { "advisory": "GHSA-mp93-8vxr-hqq9", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-12-01T21:19:47.994059Z", "id": "CVE-2025-66205", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-12-01T21:19:52.208Z" } } ] } }