{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2025-68929", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2025-12-24T23:40:31.797Z", "datePublished": "2025-12-29T15:10:59.510Z", "dateUpdated": "2025-12-29T16:13:17.680Z" }, "containers": { "cna": { "title": "Frappe may be vulnerable remote code execution due to server-side template injection", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-1336", "lang": "en", "description": "CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.1, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "LOW", "scope": "CHANGED", "userInteraction": "REQUIRED", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/frappe/frappe/security/advisories/GHSA-qq98-vfv9-xmxh", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/frappe/frappe/security/advisories/GHSA-qq98-vfv9-xmxh" }, { "name": "https://github.com/frappe/frappe/releases/tag/v14.99.6", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/frappe/frappe/releases/tag/v14.99.6" }, { "name": "https://github.com/frappe/frappe/releases/tag/v15.88.1", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/frappe/frappe/releases/tag/v15.88.1" } ], "affected": [ { "vendor": "frappe", "product": "frappe", "versions": [ { "version": "< 14.99.6", "status": "affected" }, { "version": ">= 15.0.0, < 15.88.1", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2025-12-29T15:10:59.510Z" }, "descriptions": [ { "lang": "en", "value": "Frappe is a full-stack web application framework. Prior to versions 14.99.6 and 15.88.1, an authenticated user with specific permissions could be tricked into accessing a specially crafted link. This could lead to a malicious template being executed on the server, resulting in remote code execution. Versions 14.99.6 and 15.88.1 fix the issue. No known workarounds are available." } ], "source": { "advisory": "GHSA-qq98-vfv9-xmxh", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2025-12-29T16:13:05.979153Z", "id": "CVE-2025-68929", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2025-12-29T16:13:17.680Z" } } ] } }