{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-115915", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-10-23T20:21:45.107Z", "datePublished": "2026-10-26T17:16:06.387Z", "dateUpdated": "2026-10-26T19:35:10.423Z" }, "containers": { "cna": { "title": "vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-20", "lang": "en", "description": "CWE-20: Improper Input Validation", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-183", "lang": "en", "description": "CWE-183: Permissive List of Allowed Inputs", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "HIGH", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 8.1, "baseSeverity": "HIGH", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h" }, { "name": "https://github.com/vllm-project/vllm/pull/60022", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vllm-project/vllm/pull/60022" }, { "name": "https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd" }, { "name": "https://github.com/vllm-project/vllm/releases/tag/v0.32.0", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/vllm-project/vllm/releases/tag/v0.32.0" } ], "affected": [ { "vendor": "vllm-project", "product": "vllm", "versions": [ { "version": "< 0.32.0", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-10-26T17:16:57.526Z" }, "descriptions": [ { "lang": "en", "value": "vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0." } ], "source": { "advisory": "GHSA-h3rc-j82p-2c3h", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-10-26T19:31:21.498549Z", "id": "CVE-2026-115915", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-10-26T19:35:10.423Z" } } ] } }