{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-119084", "assignerOrgId": "ff89ba41-3aa1-4d27-914a-91399e9639e5", "state": "PUBLISHED", "assignerShortName": "AMZN", "dateReserved": "2026-10-29T13:17:51.275Z", "datePublished": "2026-11-03T21:05:30.963Z", "dateUpdated": "2026-11-03T21:12:15.970Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "ff89ba41-3aa1-4d27-914a-91399e9639e5", "shortName": "AMZN", "dateUpdated": "2026-11-03T21:12:15.970Z" }, "title": "Remote Code Execution via Unsafe Class Loading in Amazon Redshift JDBC Driver Connection Parameters", "problemTypes": [ { "descriptions": [ { "lang": "en", "cweId": "CWE-470", "description": "CWE-470 Use of Externally-Controlled input to select classes or code ('unsafe reflection')", "type": "CWE" } ] } ], "impacts": [ { "capecId": "CAPEC-138", "descriptions": [ { "lang": "en", "value": "CAPEC-138 Reflection Injection" } ] } ], "affected": [ { "vendor": "AWS", "product": "amazon-redshift-jdbc-driver", "versions": [ { "status": "affected", "version": "0", "lessThan": "2.3.0", "versionType": "custom" } ], "defaultStatus": "unaffected" } ], "cpeApplicability": [ { "operator": "OR", "nodes": [ { "operator": "OR", "negate": false, "cpeMatch": [ { "vulnerable": true, "criteria": "cpe:2.3:a:aws:amazon-redshift-jdbc-driver:*:*:*:*:*:*:*:*", "versionStartIncluding": "0", "versionEndExcluding": "2.3.0" } ] } ] } ], "descriptions": [ { "lang": "en", "value": "Unsafe reflection in the connection parameter and credentials profile handling of Amazon Redshift JDBC Driver before 2.3.0 might allow an actor who can influence the JDBC connection URL or the AWS credentials profile to execute arbitrary code in the application context, provided a suitable class is available on the application classpath.\n\n\n\nTo remediate this issue, users should upgrade to version 2.3.0 or later.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "

Unsafe reflection in the connection parameter and credentials profile handling of Amazon Redshift JDBC Driver before 2.3.0 might allow an actor who can influence the JDBC connection URL or the AWS credentials profile to execute arbitrary code in the application context, provided a suitable class is available on the application classpath.

To remediate this issue, users should upgrade to version 2.3.0 or later.

" } ] } ], "references": [ { "url": "https://github.com/aws/amazon-redshift-jdbc-driver/releases/tag/v2.3.0", "tags": [ "release-notes", "patch" ] }, { "url": "https://aws.amazon.com/security/security-bulletins/2026-168-aws/", "tags": [ "vendor-advisory" ] }, { "url": "https://github.com/aws/amazon-redshift-jdbc-driver/security/advisories/GHSA-qrph-v96m-w2mv", "tags": [ "third-party-advisory" ] } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "version": "3.1", "attackVector": "NETWORK", "attackComplexity": "HIGH", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "HIGH", "baseSeverity": "HIGH", "baseScore": 8.1, "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H" } }, { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "LOW", "attackRequirements": "PRESENT", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "subConfidentialityImpact": "NONE", "vulnIntegrityImpact": "HIGH", "subIntegrityImpact": "NONE", "vulnAvailabilityImpact": "HIGH", "subAvailabilityImpact": "NONE", "exploitMaturity": "NOT_DEFINED", "Safety": "NOT_DEFINED", "Automatable": "NOT_DEFINED", "Recovery": "NOT_DEFINED", "valueDensity": "NOT_DEFINED", "vulnerabilityResponseEffort": "NOT_DEFINED", "providerUrgency": "NOT_DEFINED", "version": "4.0", "baseSeverity": "CRITICAL", "baseScore": 9.2, "vectorString": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N" } } ], "source": { "discovery": "UNKNOWN" }, "x_generator": { "engine": "Vulnogram 0.5.0" } } } }