{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-123542", "assignerOrgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "state": "PUBLISHED", "assignerShortName": "VulnCheck", "dateReserved": "2026-11-06T00:48:46.279Z", "datePublished": "2026-11-08T01:37:48.668Z", "dateUpdated": "2026-11-08T01:37:48.668Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "shortName": "VulnCheck", "dateUpdated": "2026-11-08T01:37:48.668Z" }, "datePublic": "2026-10-22T00:00:00.000Z", "title": "OpenAM before 16.1.4 PKCE Bypass in OAuth 2.0 Device Authorization Flow", "descriptions": [ { "lang": "en", "value": "OpenAM before 16.1.4 fails to enforce PKCE in the OAuth 2.0 device authorization flow, never validating the code verifier when device codes are exchanged for tokens. Attackers who obtain an approved device code from client logs or shared device storage can redeem it for access and ID tokens to impersonate the user." } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "Improperly Implemented Security Check for Standard", "cweId": "CWE-358", "type": "CWE" } ] } ], "affected": [ { "vendor": "OpenIdentityPlatform", "product": "OpenAM", "defaultStatus": "unaffected", "packageURL": "pkg:maven/org.openidentityplatform.openam/openam-oauth2", "versions": [ { "version": "0", "status": "affected", "versionType": "semver", "lessThan": "16.1.4" }, { "version": "16.1.4", "status": "unaffected", "versionType": "semver" } ] } ], "cpeApplicability": [ { "nodes": [ { "operator": "OR", "negate": false, "cpeMatch": [ { "vulnerable": true, "criteria": "cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:*", "versionEndExcluding": "16.1.4" } ] } ] } ], "metrics": [ { "format": "CVSS", "cvssV4_0": { "version": "4.0", "vectorString": "CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N", "attackVector": "NETWORK", "attackComplexity": "HIGH", "attackRequirements": "PRESENT", "privilegesRequired": "NONE", "userInteraction": "PASSIVE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "NONE", "subConfidentialityImpact": "NONE", "subIntegrityImpact": "NONE", "subAvailabilityImpact": "NONE", "baseScore": 7.6, "baseSeverity": "HIGH" } }, { "format": "CVSS", "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N", "attackVector": "NETWORK", "attackComplexity": "HIGH", "privilegesRequired": "NONE", "userInteraction": "REQUIRED", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "NONE", "baseScore": 6.8, "baseSeverity": "MEDIUM" } } ], "references": [ { "url": "https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-h93p-35jm-rj83", "tags": [ "vendor-advisory" ], "name": "GitHub Security Advisory (GHSA-h93p-35jm-rj83)" }, { "name": "VulnCheck Advisory: OpenAM before 16.1.4 PKCE Bypass in OAuth 2.0 Device Authorization Flow", "tags": [ "third-party-advisory" ], "url": "https://www.vulncheck.com/advisories/openam-before-16.1.4-pkce-bypass-in-oauth-2.0-device-authorization-flow" } ], "credits": [ { "lang": "en", "value": "manus-pi", "type": "reporter" }, { "lang": "en", "value": "vharseko", "type": "remediation developer" }, { "lang": "en", "value": "maximthomas", "type": "remediation reviewer" }, { "lang": "en", "value": "tsujiguchitky", "type": "remediation reviewer" }, { "lang": "en", "value": "manus-use", "type": "reporter" } ], "x_generator": { "engine": "vulncheck-endgame" } } } }