{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-12351", "assignerOrgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "state": "PUBLISHED", "assignerShortName": "ibm", "dateReserved": "2026-06-15T20:43:36.298Z", "datePublished": "2026-09-15T17:14:32.376Z", "dateUpdated": "2026-09-16T03:56:35.202Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "shortName": "ibm", "dateUpdated": "2026-09-15T17:14:32.376Z" }, "title": "IBM MQ is vulnerable to unauthenticated remote code execution via JNDI injection", "problemTypes": [ { "descriptions": [ { "lang": "en", "cweId": "CWE-74", "description": "CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')", "type": "CWE" } ] } ], "affected": [ { "vendor": "IBM", "product": "MQ", "versions": [ { "status": "affected", "version": "9.3.0.0", "lessThanOrEqual": "9.3.0.41 LTS", "versionType": "semver" }, { "status": "affected", "version": "9.3.0.0", "lessThanOrEqual": "9.3.5.1 CD", "versionType": "semver" }, { "status": "affected", "version": "9.4.0.0", "lessThanOrEqual": "9.4.0.25 LTS", "versionType": "semver" }, { "status": "affected", "version": "9.4.0.0", "lessThanOrEqual": "9.4.5.1 LTS", "versionType": "semver" }, { "status": "affected", "version": "10.0.0.0" } ], "cpes": [ "cpe:2.3:a:ibm:mq:9.3.0.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:9.3.0.41:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:9.3.5.1:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:9.4.0.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:9.4.0.25:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:9.4.5.1:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:mq:10.0.0.0:*:*:*:*:*:*:*" ] } ], "descriptions": [ { "lang": "en", "value": "IBM MQ 9.3.0.0 through 9.3.0.41 LTS, 9.3.0.0 through 9.3.5.1 CD, 9.4.0.0 through 9.4.0.25 LTS, 9.4.0.0 through 9.4.5.1 LTS, and 10.0.0.0 could allow a remote attacker to execute arbitrary code due to unsafe JNDI lookup processing when the IVT application is deployed.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "
IBM MQ 9.3.0.0 through 9.3.0.41 LTS, 9.3.0.0 through 9.3.5.1 CD, 9.4.0.0 through 9.4.0.25 LTS, 9.4.0.0 through 9.4.5.1 LTS, and 10.0.0.0 could allow a remote attacker to execute arbitrary code due to unsafe JNDI lookup processing when the IVT application is deployed.
" } ] } ], "references": [ { "url": "https://www.ibm.com/support/pages/node/7284541", "tags": [ "vendor-advisory", "patch" ] } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "version": "3.1", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "HIGH", "baseSeverity": "CRITICAL", "baseScore": 9.8, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H" } } ], "solutions": [ { "lang": "en", "value": "IBM strongly recommends addressing the vulnerability now.\n\n\n\nThis issue was addressed under known issue DT473754\n\n\n\nIBM MQ version 9.3 LTS\n\n\n\n Apply cumulative security update https://www.ibm.com/support/pages/downloading-ibm-mq-93-lts 9.3.0.42 https://www.ibm.com/support/pages/downloading-ibm-mq-93-lts \n\n\n\nIBM MQ version 9.4 LTS\n\n\n\n Apply cumulative security update 9.4.0.26 https://www.ibm.com/support/pages/downloading-ibm-mq-94-lts \n\n\n\nIBM MQ version 9.3 CD, 9.4 CD and 10.0.0.0\n\n\n\n Upgrade to IBM MQ version 10.0.0.5 https://www.ibm.com/support/pages/downloading-ibm-mq-100", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "IBM MQ version 9.3 LTS
Apply cumulative security update 9.3.0.42
IBM MQ version 9.4 LTS
Apply cumulative security update 9.4.0.26
IBM MQ version 9.3 CD, 9.4 CD and 10.0.0.0