{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-15396", "assignerOrgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "state": "PUBLISHED", "assignerShortName": "ibm", "dateReserved": "2026-07-10T13:16:32.862Z", "datePublished": "2026-09-14T20:08:38.336Z", "dateUpdated": "2026-10-22T18:55:25.157Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "shortName": "ibm", "dateUpdated": "2026-10-22T18:55:25.157Z" }, "title": "IBM WebSphere Application Server IBM WebSphere Application Server - Liberty HTTP Request Smuggling", "problemTypes": [ { "descriptions": [ { "lang": "en", "cweId": "CWE-444", "description": "CWE-444 Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')", "type": "CWE" } ] } ], "affected": [ { "vendor": "IBM", "product": "WebSphere Application Server", "versions": [ { "status": "affected", "version": "9.0" }, { "status": "affected", "version": "8.5" } ], "defaultStatus": "unaffected", "cpes": [ "cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*" ] }, { "vendor": "IBM", "product": "WebSphere Application Server - Liberty", "versions": [ { "status": "affected", "version": "17.0.0.3", "lessThanOrEqual": "26.0.0.5", "versionType": "semver" } ], "cpes": [ "cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.8:*:*:*:*:*:*:*" ] } ], "descriptions": [ { "lang": "en", "value": "IBM WebSphere Application Server 8.5 and 9.0, and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 are vulnerable to HTTP request smuggling, caused by improper parsing of the HTTP transfer-encoding request header. By sending a specially crafted HTTP transfer-encoding request header, an attacker could exploit this vulnerability to poison the web cache, bypass web application firewall protection, and conduct XSS attacks.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "
IBM WebSphere Application Server 8.5 and 9.0, and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 are vulnerable to HTTP request smuggling, caused by improper parsing of the HTTP transfer-encoding request header. By sending a specially crafted HTTP transfer-encoding request header, an attacker could exploit this vulnerability to poison the web cache, bypass web application firewall protection, and conduct XSS attacks.
" } ] } ], "references": [ { "url": "https://www.ibm.com/support/pages/node/7286610", "tags": [ "vendor-advisory", "patch" ] }, { "url": "https://www.ibm.com/support/pages/node/7286611", "tags": [ "vendor-advisory", "patch" ] } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "version": "3.1", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "LOW", "integrityImpact": "LOW", "availabilityImpact": "NONE", "baseSeverity": "MEDIUM", "baseScore": 6.5, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N" } } ], "solutions": [ { "lang": "en", "value": "IBM strongly recommends addressing the vulnerabilities now by applying the fix pack(s) listed below.\n\n\n\nFor IBM WebSphere Application Server traditional:\n\n\n\nFor V9.0.0.0 through 9.0.5.28:\n· Apply Fix Pack 9.0.5.29 SB0030823 (availability September 2026) or later fix pack. \n\n\n\nFor V8.5.0.0 through 8.5.5.30:\n· Apply Fix Pack 8.5.5.31 https://www.ibm.com/support/pages/node/7285869 (availability September 2026) or later fix pack. \n\n\n\n\n\n\n\n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8:\n· Apply Liberty Fix Pack 26.0.0.9 https://www.ibm.com/support/pages/node/7285875 (availability September 2026) or later fix pack.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "IBM strongly recommends addressing the vulnerabilities now by applying the fix pack(s) listed below.
For IBM WebSphere Application Server traditional:
For V9.0.0.0 through 9.0.5.28:
· Apply Fix Pack 9.0.5.29 (availability September 2026) or later fix pack.
For V8.5.0.0 through 8.5.5.30:
· Apply Fix Pack 8.5.5.31 (availability September 2026) or later fix pack.
For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8:
· Apply Liberty Fix Pack 26.0.0.9 (availability September 2026) or later fix pack.