{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-1278", "assignerOrgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "state": "PUBLISHED", "assignerShortName": "Wordfence", "dateReserved": "2026-01-20T22:08:30.988Z", "datePublished": "2026-03-21T03:27:11.384Z", "dateUpdated": "2026-04-08T17:29:10.782Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599", "shortName": "Wordfence", "dateUpdated": "2026-04-08T17:29:10.782Z" }, "affected": [ { "vendor": "ketanmujumdar", "product": "Mandatory Field", "versions": [ { "version": "0", "status": "affected", "lessThanOrEqual": "1.6.8", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "lang": "en", "value": "The Mandatory Field plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.6.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled." } ], "title": "Mandatory Field <= 1.6.8 - Authenticated (Administrator+) Stored Cross-Site Scripting via Settings Fields", "references": [ { "url": "https://www.wordfence.com/threat-intel/vulnerabilities/id/e262ec15-420a-4f52-90e0-e4a2e28402a1?source=cve" }, { "url": "https://downloads.wordpress.org/plugin/mandatory-fields.1.6.8.zip" }, { "url": "https://wordpress.org/plugins/mandatory-fields/" }, { "url": "https://plugins.trac.wordpress.org/browser/mandatory-fields/trunk/mandatory-plugin-option-page.php#L14" }, { "url": "https://plugins.trac.wordpress.org/browser/mandatory-fields/tags/1.6.8/mandatory-plugin-option-page.php#L14" } ], "problemTypes": [ { "descriptions": [ { "lang": "en", "description": "CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')", "cweId": "CWE-79", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N", "baseScore": 4.4, "baseSeverity": "MEDIUM" } } ], "credits": [ { "lang": "en", "type": "finder", "value": "Bhumividh Treloges" } ], "timeline": [ { "time": "2026-03-20T15:20:13.000Z", "lang": "en", "value": "Disclosed" } ] }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-03-24T14:00:14.190940Z", "id": "CVE-2026-1278", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-03-24T14:00:28.096Z" } } ] } }