{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-27968", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-02-25T03:24:57.793Z", "datePublished": "2026-02-26T01:57:12.752Z", "dateUpdated": "2026-02-26T14:53:10.334Z" }, "containers": { "cna": { "title": "Packistry accepts expired access tokens", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-287", "lang": "en", "description": "CWE-287: Improper Authentication", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-613", "lang": "en", "description": "CWE-613: Insufficient Session Expiration", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "NONE", "baseScore": 4.3, "baseSeverity": "MEDIUM", "confidentialityImpact": "LOW", "integrityImpact": "NONE", "privilegesRequired": "LOW", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N", "version": "3.1" } } ], "references": [ { "name": "https://github.com/packistry/packistry/security/advisories/GHSA-4r9m-jp53-vgmw", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/packistry/packistry/security/advisories/GHSA-4r9m-jp53-vgmw" }, { "name": "https://github.com/packistry/packistry/pull/276", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/packistry/packistry/pull/276" }, { "name": "https://github.com/packistry/packistry/commit/7740b48f0f4ecbe63099fb056c8a146180f8b283", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/packistry/packistry/commit/7740b48f0f4ecbe63099fb056c8a146180f8b283" } ], "affected": [ { "vendor": "packistry", "product": "packistry", "versions": [ { "version": "< 0.13.0", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-02-26T01:57:12.752Z" }, "descriptions": [ { "lang": "en", "value": "Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected." } ], "source": { "advisory": "GHSA-4r9m-jp53-vgmw", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-02-26T14:52:57.211685Z", "id": "CVE-2026-27968", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-02-26T14:53:10.334Z" } } ] } }