{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-41501", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-04-20T18:18:50.680Z", "datePublished": "2026-05-08T02:51:10.144Z", "dateUpdated": "2026-05-08T11:19:54.297Z" }, "containers": { "cna": { "title": "electerm has Command Injection Vulnerability via runLinux function", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-77", "lang": "en", "description": "CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.8, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hq", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hq" }, { "name": "https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128ee", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128ee" }, { "name": "https://github.com/electerm/electerm/releases/tag/v3.3.8", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/releases/tag/v3.3.8" } ], "affected": [ { "vendor": "electerm", "product": "electerm", "versions": [ { "version": "< 3.3.8", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-05-08T02:51:10.144Z" }, "descriptions": [ { "lang": "en", "value": "electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec(\"rm -rf ...\") command without validation. This issue has been patched in version 3.3.8." } ], "source": { "advisory": "GHSA-8x35-hph8-37hq", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-05-08T11:19:45.771219Z", "id": "CVE-2026-41501", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-05-08T11:19:54.297Z" } } ] } }