{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-42221", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-04-25T05:04:37.029Z", "datePublished": "2026-05-04T20:09:37.308Z", "dateUpdated": "2026-05-05T14:14:11.906Z" }, "containers": { "cna": { "title": "nginx-ui: Unauthenticated First-Run Installer Allows Remote Initial Admin Claim", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-306", "lang": "en", "description": "CWE-306: Missing Authentication for Critical Function", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "HIGH", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 8.1, "baseSeverity": "HIGH", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fp", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fp" }, { "name": "https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.8", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.8" } ], "affected": [ { "vendor": "0xJacky", "product": "nginx-ui", "versions": [ { "version": ">= 2.0.0, < 2.3.8", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-05-04T20:09:37.308Z" }, "descriptions": [ { "lang": "en", "value": "Nginx UI is a web user interface for the Nginx web server. From version 2.0.0 to before version 2.3.8, an unauthenticated network attacker can claim the initial administrator account on a fresh nginx-ui instance during the first-run setup window. The public /api/install endpoint is reachable without authentication, and the request-encryption flow only protects payload confidentiality in transit; it does not authenticate who is allowed to perform installation. A remote attacker who reaches the service before the legitimate operator can set the admin email, username, and password, causing permanent initial-instance takeover. This issue has been patched in version 2.3.8." } ], "source": { "advisory": "GHSA-h27v-ph7w-m9fp", "discovery": "UNKNOWN" } }, "adp": [ { "references": [ { "url": "https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fp", "tags": [ "exploit" ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-05-05T14:06:26.362325Z", "id": "CVE-2026-42221", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-05-05T14:14:11.906Z" } } ] } }