{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-43914", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-05-04T16:11:33.086Z", "datePublished": "2026-05-11T22:03:58.456Z", "dateUpdated": "2026-05-12T12:51:49.183Z" }, "containers": { "cna": { "title": "Vaultwarden: Brute-force protection bypass vulnerability", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-307", "lang": "en", "description": "CWE-307: Improper Restriction of Excessive Authentication Attempts", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "LOW", "baseScore": 7.3, "baseSeverity": "HIGH", "confidentialityImpact": "LOW", "integrityImpact": "LOW", "privilegesRequired": "NONE", "scope": "UNCHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L", "version": "3.1" } } ], "references": [ { "name": "https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g" }, { "name": "https://github.com/dani-garcia/vaultwarden/pull/6867", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/dani-garcia/vaultwarden/pull/6867" }, { "name": "https://github.com/dani-garcia/vaultwarden/releases/tag/1.35.4", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/dani-garcia/vaultwarden/releases/tag/1.35.4" } ], "affected": [ { "vendor": "dani-garcia", "product": "vaultwarden", "versions": [ { "version": "< 1.35.4", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-05-11T22:03:58.456Z" }, "descriptions": [ { "lang": "en", "value": "Vaultwarden is a Bitwarden-compatible server written in Rust. Prior to 1.35.4, there is a security vulnerability in Vaultwarden that allows bypassing the login brute-force protection if email 2fa is enabled. If email 2fa is enabled, the unprotected 2fa-function send_email_login (email.rs, api endpoint /api/two-factor/send-email-login) also acts as an oracle determining whether a username-password combination is correct. An attacker can abuse that endpoint to brute-force passwords without rate-limiting. This works even for users who don't have email 2fa configured. This vulnerability is fixed in 1.35.4." } ], "source": { "advisory": "GHSA-c5rv-q295-7w4g", "discovery": "UNKNOWN" } }, "adp": [ { "references": [ { "url": "https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g", "tags": [ "exploit" ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-05-12T12:51:45.245041Z", "id": "CVE-2026-43914", "options": [ { "Exploitation": "poc" }, { "Automatable": "yes" }, { "Technical Impact": "partial" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-05-12T12:51:49.183Z" } } ] } }