{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-43944", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-05-04T16:59:09.090Z", "datePublished": "2026-05-08T03:08:09.046Z", "dateUpdated": "2026-05-13T13:33:39.255Z" }, "containers": { "cna": { "title": "electerm: dangerous code can be run through links or command line", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-20", "lang": "en", "description": "CWE-20: Improper Input Validation", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-94", "lang": "en", "description": "CWE-94: Improper Control of Generation of Code ('Code Injection')", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-829", "lang": "en", "description": "CWE-829: Inclusion of Functionality from Untrusted Control Sphere", "type": "CWE" } ] } ], "metrics": [ { "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "LOW", "attackRequirements": "NONE", "privilegesRequired": "NONE", "userInteraction": "PASSIVE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "HIGH", "subConfidentialityImpact": "HIGH", "subIntegrityImpact": "HIGH", "subAvailabilityImpact": "HIGH", "baseScore": 9.4, "baseSeverity": "CRITICAL", "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H", "version": "4.0" } } ], "references": [ { "name": "https://github.com/electerm/electerm/security/advisories/GHSA-mpm8-cx2p-626q", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/electerm/electerm/security/advisories/GHSA-mpm8-cx2p-626q" }, { "name": "https://github.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507" }, { "name": "https://github.com/electerm/electerm/commit/8a6a17951e96d715f5a231532bbd8303fe208700", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/commit/8a6a17951e96d715f5a231532bbd8303fe208700" }, { "name": "https://github.com/electerm/electerm/commit/a79e06f4a1f0ac6376c3d2411ef4690fa0377742", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/commit/a79e06f4a1f0ac6376c3d2411ef4690fa0377742" }, { "name": "https://github.com/electerm/electerm/releases/tag/v3.8.15", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/electerm/electerm/releases/tag/v3.8.15" } ], "affected": [ { "vendor": "electerm", "product": "electerm", "versions": [ { "version": ">= 3.0.6, < 3.8.15", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-05-13T13:33:39.255Z" }, "descriptions": [ { "lang": "en", "value": "electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15." } ], "source": { "advisory": "GHSA-mpm8-cx2p-626q", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-05-11T18:06:05.901795Z", "id": "CVE-2026-43944", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-05-11T18:06:59.406Z" } } ] } }