{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-45558", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-05-12T19:00:14.599Z", "datePublished": "2026-06-10T14:01:42.317Z", "dateUpdated": "2026-06-10T15:43:53.271Z" }, "containers": { "cna": { "title": "Roxy-WI: Authenticated RCE on every managed HAProxy load balancer via `option` field config injection in section save", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-20", "lang": "en", "description": "CWE-20: Improper Input Validation", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-77", "lang": "en", "description": "CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-78", "lang": "en", "description": "CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')", "type": "CWE" } ] }, { "descriptions": [ { "cweId": "CWE-94", "lang": "en", "description": "CWE-94: Improper Control of Generation of Code ('Code Injection')", "type": "CWE" } ] } ], "metrics": [ { "cvssV3_1": { "attackComplexity": "LOW", "attackVector": "NETWORK", "availabilityImpact": "HIGH", "baseScore": 9.9, "baseSeverity": "CRITICAL", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "privilegesRequired": "LOW", "scope": "CHANGED", "userInteraction": "NONE", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H", "version": "3.1" } } ], "references": [ { "name": "https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-w2x4-66jj-3597", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-w2x4-66jj-3597" } ], "affected": [ { "vendor": "roxy-wi", "product": "roxy-wi", "versions": [ { "version": "<= 8.2.6.4", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-06-10T14:01:42.317Z" }, "descriptions": [ { "lang": "en", "value": "Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. In versions 8.2.6.4 and prior, the HAProxy section-save endpoints (POST /api/service/haproxy//section/ and the PUT / global / defaults variants) accept a JSON option field that is not validated, not escaped, and is rendered verbatim into the generated HAProxy configuration via the section.j2, global.j2, and defaults.j2 Ansible templates. Because Roxy-WI then pushes the generated config to the load balancer and runs systemctl reload haproxy, an authenticated user with role ≤ 3 (user) can inject arbitrary HAProxy directives into the config that runs on every load balancer their group manages — including option external-check + external-check command /bin/bash -c '…', which gives remote code execution on the load balancer as the haproxy user on every health-check tick. At time of publication, there are no publicly available patches." } ], "source": { "advisory": "GHSA-w2x4-66jj-3597", "discovery": "UNKNOWN" } }, "adp": [ { "references": [ { "url": "https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-w2x4-66jj-3597", "tags": [ "exploit" ] } ], "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-06-10T15:43:48.231187Z", "id": "CVE-2026-45558", "options": [ { "Exploitation": "poc" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-06-10T15:43:53.271Z" } } ] } }