{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-53488", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-06-09T17:05:25.059Z", "datePublished": "2026-07-01T00:11:20.610Z", "dateUpdated": "2026-07-03T03:56:07.868Z" }, "containers": { "cna": { "title": "containerd CRI plugin: — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-20", "lang": "en", "description": "CWE-20: Improper Input Validation", "type": "CWE" } ] } ], "metrics": [ { "cvssV4_0": { "attackVector": "LOCAL", "attackComplexity": "LOW", "attackRequirements": "NONE", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "HIGH", "subConfidentialityImpact": "HIGH", "subIntegrityImpact": "HIGH", "subAvailabilityImpact": "HIGH", "baseScore": 9.4, "baseSeverity": "CRITICAL", "vectorString": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H", "version": "4.0" } } ], "references": [ { "name": "https://github.com/containerd/containerd/security/advisories/GHSA-xhf5-7wjv-pqxp", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/containerd/containerd/security/advisories/GHSA-xhf5-7wjv-pqxp" } ], "affected": [ { "vendor": "containerd", "product": "containerd", "versions": [ { "version": "< 1.7.33", "status": "affected" }, { "version": ">= 2.0.0, < 2.0.10", "status": "affected" }, { "version": ">= 2.1.0, < 2.1.9", "status": "affected" }, { "version": ">= 2.2.0, < 2.2.5", "status": "affected" }, { "version": ">= 2.3.0, < 2.3.2", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-07-01T00:11:20.610Z" }, "descriptions": [ { "lang": "en", "value": "containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10." } ], "source": { "advisory": "GHSA-xhf5-7wjv-pqxp", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-07-02T00:00:00+00:00", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3", "id": "CVE-2026-53488" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-07-03T03:56:07.868Z" } } ] } }