{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-71253", "assignerOrgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "state": "PUBLISHED", "assignerShortName": "apache", "dateReserved": "2026-08-05T11:38:30.610Z", "datePublished": "2026-10-19T10:36:41.781Z", "dateUpdated": "2026-10-20T19:34:25.835Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "shortName": "apache", "dateUpdated": "2026-10-19T10:36:41.781Z" }, "title": "Apache Johnzon: ClassConverter loads & static-initializes an attacker-named class from untrusted JSON", "problemTypes": [ { "descriptions": [ { "description": "CWE-470 Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')", "lang": "en", "cweId": "CWE-470", "type": "CWE" } ] } ], "source": { "discovery": "EXTERNAL" }, "affected": [ { "vendor": "Apache Software Foundation", "product": "Apache Johnzon", "packageURL": "pkg:maven/org.apache.johnzon/johnzon-mapper", "versions": [ { "status": "affected", "version": "2.0.0", "lessThan": "2.2.0", "versionType": "semver" }, { "status": "affected", "version": "1.0.0", "lessThan": "1.3.1", "versionType": "semver" } ], "defaultStatus": "unaffected", "collectionURL": "https://repo.maven.apache.org/maven2", "packageName": "org.apache.johnzon:johnzon-mapper" } ], "descriptions": [ { "value": "Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon.\n\n\n\nClassConverter loads & static-initializes an attacker-named class from untrusted JSON.\n\n\n\n\nThis issue affects Apache Johnzon: from 1.0.0 before 2.2.0.\n\n\n\nUsers are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.", "lang": "en", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon.

ClassConverter loads & static-initializes an attacker-named class from untrusted JSON.

This issue affects Apache Johnzon: from 1.0.0 before 2.2.0.

Users are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.

" } ] } ], "references": [ { "url": "https://github.com/apache/johnzon/commit/dd3d00634c746a2173a2518e882e85e8a151bf30", "tags": [ "patch" ] }, { "url": "https://github.com/apache/johnzon/commit/91e7b0d21d08d138944e2570691939739422a3d6", "tags": [ "patch" ] }, { "url": "https://lists.apache.org/thread.html/3vgm1yo2sn9yhkvvs9lc4ro01vl3zt68", "tags": [ "vendor-advisory" ] } ], "metrics": [ { "other": { "type": "Textual description of severity", "content": { "text": "severity: LOW. Although a class initialiser can be triggered remotely it needs 2 separate preconditions: a) there must be a poisonous class-initialiser on the classpath (unlikely). b) there must be a REST POJO with a Class attribute on the project (unlikely as well)" } }, "scenarios": [ { "lang": "en", "value": "GENERAL" } ] } ], "credits": [ { "lang": "en", "value": "n0mi1k Security", "type": "finder" } ], "x_generator": { "engine": "Vulnogram 0.2.0" } }, "adp": [ { "metrics": [ { "cvssV3_1": { "scope": "UNCHANGED", "version": "3.1", "baseScore": 9.8, "attackVector": "NETWORK", "baseSeverity": "CRITICAL", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "integrityImpact": "HIGH", "userInteraction": "NONE", "attackComplexity": "LOW", "availabilityImpact": "HIGH", "privilegesRequired": "NONE", "confidentialityImpact": "HIGH" } }, { "other": { "type": "ssvc", "content": { "timestamp": "2026-10-20T19:34:08.742206Z", "id": "CVE-2026-71253", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-10-20T19:34:25.835Z" } } ] } }