{
"dataType": "CVE_RECORD",
"dataVersion": "5.2",
"cveMetadata": {
"cveId": "CVE-2026-73116",
"assignerOrgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09",
"state": "PUBLISHED",
"assignerShortName": "apache",
"dateReserved": "2026-08-10T21:14:20.996Z",
"datePublished": "2026-11-05T11:53:52.274Z",
"dateUpdated": "2026-11-05T11:53:52.274Z"
},
"containers": {
"cna": {
"providerMetadata": {
"orgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09",
"shortName": "apache",
"dateUpdated": "2026-11-05T11:53:52.274Z"
},
"title": "Apache Juneau: REST client forwards credentials to a different origin when following HTTP redirects",
"problemTypes": [
{
"descriptions": [
{
"description": "CWE-522 Insufficiently Protected Credentials",
"lang": "en",
"cweId": "CWE-522",
"type": "CWE"
}
]
}
],
"source": {
"discovery": "INTERNAL"
},
"affected": [
{
"vendor": "Apache Software Foundation",
"product": "Apache Juneau",
"packageURL": "pkg:maven/org.apache.juneau/juneau-rest-client",
"versions": [
{
"status": "affected",
"version": "0",
"lessThan": "9.2.1",
"versionType": "semver"
}
],
"defaultStatus": "unaffected",
"collectionURL": "https://repo.maven.apache.org/maven2",
"packageName": "org.apache.juneau:juneau-rest-client"
},
{
"vendor": "Apache Software Foundation",
"product": "Apache Juneau",
"packageURL": "pkg:maven/org.apache.juneau/juneau-rest-common",
"versions": [
{
"status": "affected",
"version": "0",
"lessThan": "9.2.1",
"versionType": "semver"
}
],
"defaultStatus": "unaffected",
"collectionURL": "https://repo.maven.apache.org/maven2",
"packageName": "org.apache.juneau:juneau-rest-common"
}
],
"descriptions": [
{
"value": "Insufficiently Protected Credentials vulnerability in Apache Juneau.\n\nThe Apache Juneau RestClient followed HTTP redirects while keeping credential headers from the original request, so a server that redirected the client to a different host or port, or from HTTPS to HTTP, could receive headers such as Authorization, Cookie, Proxy-Authorization and X-API-Key.\n\nThis issue affects Apache Juneau: through 9.2.0.\n\nUsers are recommended to upgrade to version 9.2.1, which fixes the issue. The fix applies to HTTP clients created by the RestClient builder; applications that supply their own HttpClient must disable automatic redirects or strip credential headers on cross-origin redirects themselves.",
"lang": "en",
"supportingMedia": [
{
"type": "text/html",
"base64": false,
"value": "Insufficiently Protected Credentials vulnerability in Apache Juneau.
The Apache Juneau RestClient followed HTTP redirects while keeping credential headers from the original request, so a server that redirected the client to a different host or port, or from HTTPS to HTTP, could receive headers such as Authorization, Cookie, Proxy-Authorization and X-API-Key.
This issue affects Apache Juneau: through 9.2.0.
Users are recommended to upgrade to version 9.2.1, which fixes the issue. The fix applies to HTTP clients created by the RestClient builder; applications that supply their own HttpClient must disable automatic redirects or strip credential headers on cross-origin redirects themselves."
}
]
}
],
"references": [
{
"url": "https://lists.apache.org/thread.html/j05q7vw08j48o96tdlzcsd4sozx1lyl6",
"tags": [
"vendor-advisory"
]
}
],
"metrics": [
{
"scenarios": [
{
"lang": "en",
"value": "GENERAL"
}
],
"format": "CVSS",
"cvssV4_0": {
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"attackRequirements": "NONE",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"vulnConfidentialityImpact": "HIGH",
"subConfidentialityImpact": "HIGH",
"vulnIntegrityImpact": "HIGH",
"subIntegrityImpact": "HIGH",
"vulnAvailabilityImpact": "HIGH",
"subAvailabilityImpact": "HIGH",
"exploitMaturity": "NOT_DEFINED",
"Safety": "NOT_DEFINED",
"Automatable": "NOT_DEFINED",
"Recovery": "NOT_DEFINED",
"valueDensity": "NOT_DEFINED",
"vulnerabilityResponseEffort": "NOT_DEFINED",
"providerUrgency": "NOT_DEFINED",
"version": "4.0",
"baseSeverity": "CRITICAL",
"baseScore": 10,
"vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
}
}
],
"x_generator": {
"engine": "Vulnogram 0.2.0"
}
}
}
}