{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-77405", "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "state": "PUBLISHED", "assignerShortName": "GitHub_M", "dateReserved": "2026-08-20T19:55:27.023Z", "datePublished": "2026-09-16T14:42:08.670Z", "dateUpdated": "2026-09-18T17:59:20.584Z" }, "containers": { "cna": { "title": "RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser", "problemTypes": [ { "descriptions": [ { "cweId": "CWE-326", "lang": "en", "description": "CWE-326: Inadequate Encryption Strength", "type": "CWE" } ] } ], "metrics": [ { "cvssV4_0": { "attackVector": "NETWORK", "attackComplexity": "HIGH", "attackRequirements": "PRESENT", "privilegesRequired": "NONE", "userInteraction": "NONE", "vulnConfidentialityImpact": "HIGH", "vulnIntegrityImpact": "HIGH", "vulnAvailabilityImpact": "NONE", "subConfidentialityImpact": "HIGH", "subIntegrityImpact": "LOW", "subAvailabilityImpact": "NONE", "baseScore": 9.4, "baseSeverity": "CRITICAL", "vectorString": "CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N", "version": "4.0" } } ], "references": [ { "name": "https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h", "tags": [ "x_refsource_CONFIRM" ], "url": "https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h" }, { "name": "https://github.com/rabbitmq/amqp091-go/pull/355", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/rabbitmq/amqp091-go/pull/355" }, { "name": "https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e" }, { "name": "https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0", "tags": [ "x_refsource_MISC" ], "url": "https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0" } ], "affected": [ { "vendor": "rabbitmq", "product": "amqp091-go", "versions": [ { "version": "< 1.13.0", "status": "affected" } ] } ], "providerMetadata": { "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa", "shortName": "GitHub_M", "dateUpdated": "2026-09-16T14:42:08.670Z" }, "descriptions": [ { "lang": "en", "value": "RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0." } ], "source": { "advisory": "GHSA-33mj-cw25-m34h", "discovery": "UNKNOWN" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-09-18T17:59:04.727483Z", "id": "CVE-2026-77405", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-09-18T17:59:20.584Z" } } ] } }