{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-80351", "assignerOrgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "state": "PUBLISHED", "assignerShortName": "apache", "dateReserved": "2026-08-26T09:58:12.381Z", "datePublished": "2026-09-10T07:42:57.856Z", "dateUpdated": "2026-09-10T16:00:02.698Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "shortName": "apache", "dateUpdated": "2026-09-10T07:42:57.856Z" }, "title": "Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod", "problemTypes": [ { "descriptions": [ { "description": "CWE-95 Improper neutralization of directives in dynamically evaluated code ('eval injection')", "lang": "en", "cweId": "CWE-95", "type": "CWE" } ] } ], "source": { "discovery": "INTERNAL" }, "affected": [ { "vendor": "Apache Software Foundation", "product": "Apache Camel K", "collectionURL": "https://hub.docker.com", "packageName": "apache/camel-k", "packageURL": "pkg:docker/apache/camel-k", "versions": [ { "status": "affected", "version": "2.0.0", "lessThan": "2.9.3", "versionType": "semver" }, { "status": "affected", "version": "2.10.1", "lessThan": "2.10.2", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "value": "Improper neutralization of directives in dynamically evaluated code ('eval injection') vulnerability in Apache Camel K.\n\n\n\nAn improper neutralization of directives in dynamically evaluated Maven configuration allows tenant-controlled repository content to influence code execution within the operator pod, potentially enabling tenants to execute arbitrary code with the privileges of the operator.\n\n\n\nThis issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2.\n\n\n\nUsers are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.", "lang": "en", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "

Improper neutralization of directives in dynamically evaluated code ('eval injection') vulnerability in Apache Camel K.

An improper neutralization of directives in dynamically evaluated Maven configuration allows tenant-controlled repository content to influence code execution within the operator pod, potentially enabling tenants to execute arbitrary code with the privileges of the operator.

This issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2.

Users are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.

" } ] } ], "references": [ { "url": "https://camel.apache.org/security/CVE-2026-80351.html", "tags": [ "vendor-advisory" ] } ], "metrics": [ { "other": { "type": "Textual description of severity", "content": { "text": "critical" } }, "scenarios": [ { "lang": "en", "value": "GENERAL" } ] } ], "x_generator": { "engine": "Vulnogram 1.0.3" } }, "adp": [ { "title": "CVE Program Container", "references": [ { "url": "http://www.openwall.com/lists/oss-security/2026/09/10/14" } ], "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2026-09-10T15:07:45.639Z" } }, { "metrics": [ { "cvssV3_1": { "scope": "UNCHANGED", "version": "3.1", "baseScore": 9.8, "attackVector": "NETWORK", "baseSeverity": "CRITICAL", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "integrityImpact": "HIGH", "userInteraction": "NONE", "attackComplexity": "LOW", "availabilityImpact": "HIGH", "privilegesRequired": "NONE", "confidentialityImpact": "HIGH" } }, { "other": { "type": "ssvc", "content": { "timestamp": "2026-09-10T15:59:45.659048Z", "id": "CVE-2026-80351", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-09-10T16:00:02.698Z" } } ] } }