{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-86460", "assignerOrgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "state": "PUBLISHED", "assignerShortName": "apache", "dateReserved": "2026-09-07T13:21:35.376Z", "datePublished": "2026-09-14T10:43:58.914Z", "dateUpdated": "2026-09-14T19:47:16.698Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09", "shortName": "apache", "dateUpdated": "2026-09-14T10:43:58.914Z" }, "title": "Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence", "problemTypes": [ { "descriptions": [ { "description": "CWE-89 Improper neutralization of special elements used in an SQL command ('SQL injection')", "lang": "en", "cweId": "CWE-89", "type": "CWE" } ] } ], "source": { "discovery": "UNKNOWN" }, "affected": [ { "vendor": "Apache Software Foundation", "product": "Apache Syncope", "collectionURL": "https://repo.maven.apache.org/maven2", "packageName": "org.apache.syncope.core:syncope-core-persistence-neo4j", "packageURL": "pkg:maven/org.apache.syncope.core/syncope-core-persistence-neo4j", "versions": [ { "status": "affected", "version": "3.0.0-M0", "lessThanOrEqual": "3.0.16", "versionType": "semver" }, { "status": "affected", "version": "4.0.0-M0", "lessThanOrEqual": "4.0.7", "versionType": "semver" }, { "status": "affected", "version": "4.1.0-M0", "lessThanOrEqual": "4.1.2", "versionType": "semver" } ], "defaultStatus": "unaffected" } ], "descriptions": [ { "value": "Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions.\n\n\n\nThis issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.\n\n\n\nUsers are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.", "lang": "en", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
" } ] } ], "references": [ { "url": "https://lists.apache.org/thread/cwcc0pz53q6cr0tms9dh5hycboqocw0d", "tags": [ "vendor-advisory" ] } ], "metrics": [ { "other": { "type": "Textual description of severity", "content": { "text": "moderate" } }, "scenarios": [ { "lang": "en", "value": "GENERAL" } ] } ], "credits": [ { "lang": "en", "value": "CyberLeo", "type": "finder" }, { "lang": "en", "value": "Ho1aAs", "type": "finder" } ], "x_generator": { "engine": "Vulnogram 1.0.3" } }, "adp": [ { "title": "CVE Program Container", "references": [ { "url": "http://www.openwall.com/lists/oss-security/2026/09/14/22" } ], "providerMetadata": { "orgId": "af854a3a-2127-422b-91ae-364da2661108", "shortName": "CVE", "dateUpdated": "2026-09-14T18:09:22.402Z" } }, { "metrics": [ { "cvssV3_1": { "scope": "UNCHANGED", "version": "3.1", "baseScore": 9.8, "attackVector": "NETWORK", "baseSeverity": "CRITICAL", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "integrityImpact": "HIGH", "userInteraction": "NONE", "attackComplexity": "LOW", "availabilityImpact": "HIGH", "privilegesRequired": "NONE", "confidentialityImpact": "HIGH" } }, { "other": { "type": "ssvc", "content": { "timestamp": "2026-09-14T19:46:58.122969Z", "id": "CVE-2026-86460", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-09-14T19:47:16.698Z" } } ] } }