{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-8646", "assignerOrgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "state": "PUBLISHED", "assignerShortName": "ibm", "dateReserved": "2026-05-14T20:38:35.335Z", "datePublished": "2026-06-22T14:44:42.460Z", "dateUpdated": "2026-06-24T03:56:09.798Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "9a959283-ebb5-44b6-b705-dcc2bbced522", "shortName": "ibm", "dateUpdated": "2026-06-22T14:44:42.460Z" }, "title": "IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by multiple vulnerabilities", "problemTypes": [ { "descriptions": [ { "lang": "en", "cweId": "CWE-444", "description": "CWE-444 Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')", "type": "CWE" } ] } ], "affected": [ { "vendor": "IBM", "product": "WebSphere Application Server", "versions": [ { "status": "affected", "version": "9.0.0", "lessThanOrEqual": "7.0.2 Interim Fix 035", "versionType": "semver" }, { "status": "affected", "version": "8.5.0", "lessThanOrEqual": "7.0.3 Interim Fix 017", "versionType": "semver" } ], "cpes": [ "cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*" ] }, { "vendor": "IBM", "product": "WebSphere Application Server - Liberty", "versions": [ { "status": "affected", "version": "17.0.0.3", "lessThanOrEqual": "26.0.0.6", "versionType": "semver" } ], "cpes": [ "cpe:2.3:a:ibm:websphere_application_server___liberty:17.0.0.3:*:*:*:*:*:*:*", "cpe:2.3:a:ibm:websphere_application_server___liberty:26.0.0.6:*:*:*:*:*:*:*" ] } ], "descriptions": [ { "lang": "en", "value": "IBM WebSphere Application Server 9.0 and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.6 are vulnerable to HTTP request smuggling. A remote attacker could smuggle a specially crafted request to the application server thereby allowing the attacker to bypass security controls, spoof identity, escalate privilege, and expose sensitive information.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "

IBM WebSphere Application Server 9.0 and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.6 are vulnerable to HTTP request smuggling. A remote attacker could smuggle a specially crafted request to the application server thereby allowing the attacker to bypass security controls, spoof identity, escalate privilege, and expose sensitive information.

" } ] } ], "references": [ { "url": "https://www.ibm.com/support/pages/node/7276579", "tags": [ "vendor-advisory", "patch" ] } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "version": "3.1", "attackVector": "NETWORK", "attackComplexity": "HIGH", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "UNCHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "NONE", "baseSeverity": "HIGH", "baseScore": 7.4, "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N" } } ], "solutions": [ { "lang": "en", "value": "IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71631 and PH71370. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\n\n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.6 using the servlet-3.0, servlet-3.1, servlet-4.0, servlet-5.0, servlet-6.0, servlet-6.1, websocket-1.0, websocket-1.1, websocket-2.0, websocket-2.1, or websocket-2.2 feature:\n\n\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH71631 https://www.ibm.com/support/pages/node/7276381 \n--OR--\n· Apply Fix Pack 26.0.0.7 or later (targeted availability 3Q2026).\n\n\n\n\n\nFor IBM WebSphere Application Server traditional:\n\n\n\nFor V9.0.0.0 through 9.0.5.28:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH71370 https://www.ibm.com/support/pages/node/7276399 \n--OR--\n· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  \n\n\n\nFor V8.5.0.0 through 8.5.5.29:\n· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves PH71370 https://www.ibm.com/support/pages/node/7276399 \n--OR--\n· Apply Fix Pack 8.5.5.30 or later (targeted availability 3Q2026).\n\n\n\n\n\n\n\nAdditional interim fixes may be available and linked off the interim fix download page.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "

IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71631 and PH71370. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to How to determine if Liberty is using a specific feature. 

For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.6 using the servlet-3.0, servlet-3.1, servlet-4.0, servlet-5.0, servlet-6.0, servlet-6.1, websocket-1.0, websocket-1.1, websocket-2.0, websocket-2.1, or websocket-2.2 feature:

· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH71631
--OR--
· Apply Fix Pack 26.0.0.7 or later (targeted availability 3Q2026).

For IBM WebSphere Application Server traditional:

For V9.0.0.0 through 9.0.5.28:
· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH71370
--OR--
· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  

For V8.5.0.0 through 8.5.5.29:
· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves PH71370
--OR--
· Apply Fix Pack 8.5.5.30 or later (targeted availability 3Q2026).

Additional interim fixes may be available and linked off the interim fix download page.

" } ] } ], "x_generator": { "engine": "ibm-cvegen" } }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-06-23T00:00:00+00:00", "options": [ { "Exploitation": "none" }, { "Automatable": "no" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3", "id": "CVE-2026-8646" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-06-24T03:56:09.798Z" } } ] } }