{ "dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": { "cveId": "CVE-2026-94169", "assignerOrgId": "21595511-bba5-4825-b968-b78d1f9984a3", "state": "PUBLISHED", "assignerShortName": "Patchstack", "dateReserved": "2026-09-21T00:20:20.797Z", "datePublished": "2026-10-16T07:00:38.023Z", "dateUpdated": "2026-10-16T18:38:00.753Z" }, "containers": { "cna": { "providerMetadata": { "orgId": "21595511-bba5-4825-b968-b78d1f9984a3", "shortName": "Patchstack", "dateUpdated": "2026-10-16T18:38:00.753Z" }, "title": "WordPress The Grid plugin <= 2.8.1 - Remote Code Execution (RCE) vulnerability", "datePublic": "2026-10-14T06:53:44.000Z", "descriptions": [ { "lang": "en", "value": "Improper Control of Generation of Code ('Code Injection') vulnerability in Theme-one The Grid the-grid allows Command Injection.This issue affects The Grid: from n/a through 2.8.1.", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "Improper Control of Generation of Code ('Code Injection') vulnerability in Theme-one The Grid the-grid allows Command Injection.
This issue affects The Grid: from n/a through 2.8.1.
" } ] } ], "affected": [ { "vendor": "Theme-one", "product": "The Grid", "packageName": "the-grid", "collectionURL": "https://wordpress.org/plugins", "defaultStatus": "unaffected", "versions": [ { "version": "0", "versionType": "custom", "status": "affected", "lessThanOrEqual": "2.8.1", "changes": [ { "at": "2.8.2", "status": "unaffected" } ] } ] } ], "references": [ { "url": "https://patchstack.com/database/wordpress/plugin/the-grid/vulnerability/wordpress-the-grid-plugin-2-8-1-remote-code-execution-rce-vulnerability?_s_id=cve", "tags": [ "vdb-entry" ] } ], "credits": [ { "lang": "en", "value": "Rafie Muhammad | Patchstack Bug Bounty Program", "type": "finder" } ], "metrics": [ { "format": "CVSS", "scenarios": [ { "lang": "en", "value": "GENERAL" } ], "cvssV3_1": { "version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H", "baseScore": 10, "baseSeverity": "CRITICAL", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "NONE", "userInteraction": "NONE", "scope": "CHANGED", "confidentialityImpact": "HIGH", "integrityImpact": "HIGH", "availabilityImpact": "HIGH" } } ], "problemTypes": [ { "descriptions": [ { "cweId": "CWE-94", "description": "Improper Control of Generation of Code ('Code Injection')", "lang": "en", "type": "CWE" } ] } ], "impacts": [ { "capecId": "CAPEC-248", "descriptions": [ { "lang": "en", "value": "Command Injection" } ] } ], "solutions": [ { "lang": "en", "value": "Update the WordPress The Grid plugin to the latest available version (at least 2.8.2).", "supportingMedia": [ { "type": "text/html", "base64": false, "value": "Update the WordPress The Grid plugin to the latest available version (at least 2.8.2)." } ] } ], "tags": [ "x_known-exploited-vulnerability", "x_open-source" ] }, "adp": [ { "metrics": [ { "other": { "type": "ssvc", "content": { "timestamp": "2026-10-16T14:19:37.498695Z", "id": "CVE-2026-94169", "options": [ { "Exploitation": "none" }, { "Automatable": "yes" }, { "Technical Impact": "total" } ], "role": "CISA Coordinator", "version": "2.0.3" } } } ], "title": "CISA ADP Vulnrichment", "providerMetadata": { "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0", "shortName": "CISA-ADP", "dateUpdated": "2026-10-16T14:20:04.331Z" } } ] } }