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Intro

Resultados en el texto
Bibliografia

Tablas de contenido
Enlaces

Ecuaciones

Plantillas

Ustedes

« Conocimientos bdasicos de Rmd
e Quieren escribir su tesis o articulos en Rmd



Créditos & Recursos

« Material de Rmarkdown.
Rmarkdown por Resul Umit
RMarkdown por RStudio
Rmarkdown por Yihui Xie

Dissertation

Otros paquetes en Rmarkdown.
» Bookdown

e Posterdown
o Pagedown


https://resulumit.com/teaching/rmd_workshop#1
https://rmarkdown.rstudio.com/lesson-2.html
https://bookdown.org/yihui/rmarkdown/
https://ourcodingclub.github.io/tutorials/rmarkdown-dissertation/
https://bookdown.org/yihui/bookdown/
https://github.com/brentthorne/posterdown
https://github.com/brentthorne/pagedown

Rmarkdown



. Rmarkdown

o Eficiente
Se puecle escribir texto, enlaces, tablas, analisis
Se pueden rehacer analisis y reduce las probilidades de equivocarse

» Flexible

Se puede exportar a varios formatos (pdf, word, html)

« Open access
El uso es gratis
Se pueden crear contenidos accesibles a cualquiera con computadora o con

internet
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1.2. Editor de texto

La clase pasada vimos como escribir y editar texto en Rmd
Pero no tienen que extrafiar su editor de texto..

Al darle click al compds nos permite editar el texto usando botones.
Cuando le den click les va a aparecer un mensaje, pueden decirle ok.

Listo! Se puede editar similar a office... y ademas te permite agregar imégenes.

@ rsw
C - -0 d - file/function ~ Addins =
@] Untitled1
BV QA kit v ‘a-
1 ---
2 title: "Clasermd"
3 author: "MiriamL"
4 date: "29/3/2021"
5 output: html_document
6a —=m
7
8~ " "{r setup, include=FALSE}
9 knitr::opts_chunk$set(echo = TRUE)
10+
11
12 - ## R Markdown
13

14 This is an R Markdown document. Markdown is a simple

authoring HTML, PDF, and MS Word documents. For more details on using R Markdown

see <http://rmarkdown.rstudic.com>.
15

21 |[@ ClaseRmd =

Console  Terminal Jobs

-/

R es un software libre y viene sin GARANTIA ALGUNA.
Usted puede redistribuirlo bajo ciertas circunstancias.

Escriba "license()' o 'licence()" para detalles de distribucion.

R es un proyecto colaborative con muchos contribuyentes.
Escriba 'contributors()' para obtener mas informacion y

'citation()' para saber como citar R o paquetes de R en publicaciones.

formatting syntax for

History G i Tutorial
B3 | 2 import Dataset + | &
% Global Environment =

)
L]

*Run ~

Environment is empty

Files Plots Packages Help Viewer
Ol install | @ Update

Name Description
User Library
R Markdown = abind Combine Multidimensional Arrays
aded Analysis of Ecological Data: Exploratory and
=] Euclidean Methods in Environmental
Sciences
N adehabitatHR Home Range Estimation
adehabitatlT Analysis of Animal Movements
adehabitatMA Tools to Deal with Raster Maps
akima Interpolation of Iregularly and Regularly
Spaced Data
alphahull Generalization of the Convex Hull of a

sample of Points in the Plane

Escriba "demo()' para demostraciones, 'help()' para el sistema on-line de ayuda, ash David Scott's ASH Routines
o 'help.start()" para abrir el sistema de ayuda HTML con su navegador. askpass Safe Password Entry for R, Git, and SSH
Escriba qO para salir de R. assertthat Easy Pre and Post Assertions

audio Audio Interface for R

>

B Project: (None) =

Version

14-5
1.7-16

0.4.19
0.3.25
0.3.14
0.6-2.1

o
b

1.0-15

0.2
0.1-7
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https://miriamll.github.io/Curso_CIAD/Rmd-Parte1

1.3. Inline code

Para los ejercicios necesitamos datos.

Instalar paquete

remotes: :install_github("cienciadedatos/datos")
#S1 usan install packages no descarga los datos de Pinguinos

Cargar datos

library(datos)

library(tidyverse)

Pingus<-datos: :pinguinos
Adelia<-Pingus%>%filter (especie=="Adelia")
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1.3. Inline code

Algunos resultados de nuestro cédigo se puede incluir en el texto usando los backticks

(tildes inversos) antes y después de {r} (para este caso solo se usa una tilde invertida).

Por ejemplo:

Podemos escribir esto en el texto.

Tenemos un total de 'r nrow(Pingus)  muestras, de las cuales
‘r nrow(Adelia)" corresponden a los pinguinos de Adelia.

Y nos aparece esto:

Tenemos un total de 344 muestras, de las cuales 152 corresponden a los pinguinos de

Adelia.
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14. ldioma

Para cambiar el idioma se puede ir a: Tools>Project Options>Spelling>Main language
cambiar a Spanish

- OR

2| MiRmd.Rmd

4 »

W~ bWk

e
~o
»

12 -~
13
14

15
16

Console

~/4Cursos/1CIAD/11Presentaciones/Curso_CIAD/

>

=i 3

s U @ kit~
title: "Rmd"
author: "MiriamL"

date: "2/3/2021"
output: html_document

" {r setup, include=FALSE]
knitr::opts_chunk$set(echo

## R markdown
This is an R Markdown docun
authoring HTML, PDF, and Ms

Markdown see <http://rmarke

when you click the **Knit*
includes both content as we

within the document. You cé
" {r cars}
uuuuuuuuu o amm ™

3 RMd =

Terminal R Markdown Jobs

# Go to file/function

G- ~ Addins ~
Project Options
Dictionaries
General
Use (Default) to inherit the global default dictionary
Code Editing Main dictionary language: Spanish v
French =
R Markdown German
German (New)
@ sweave Greek
Hungarian
A oellin Indonesian
peling Italian
) Latvian
 Build Tools Lithuanian
Norwegian
W Gitswn Polish
Portuguese (Brazil)
‘ EivivarimanEs Portuguese (Portugal)
Romanian
', Russian
Python Serbian
Serbo-Croatian
Slovak
Slovenian

s

rironment

=

History  Connectio

~* Import Dataset ~ !’

] Global Environment ~ O

Environment is empt'

Plots Packages Help
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1.5. Ortografia

Se puede activar corrector de ortografia usando:

Edit>Spellchecking>F7

Sin embargo, el corrector no es muy bueno

o

rs0_CIAD - main - RStudio
Edit | Code View Plots Semion Build

Debug  Prefile  Tools Help

- Addins ~

’a'

k the **Knit** button a document will be generated that

= Run ~

Markdown document. Markdown is a simple formatting syntax for
L, PoF, and MS word documents. For more details on using R

includes both content as well as the output of any embedded R code chunks

Back CtrisF3 . " +
[+] ::( » C:”J.c A Go to file/function G
¢ Undo Ctrl2
Redo Ctri+¥
Cut Ctr+X 5ﬁ- Knit = x
Copy Ctrl+C
Paste Crl+V
Paste with Indent Ctrl+ Shift+V =
amL
Folding " 1"
Eqpand Al Cupat document
Collapse All Qutput
Clasr Output
S o8 et include=FALSE}
Goto Line-. arshit-c hunk$set (echo = TRUE)
Find... Ctrl+F
Find Next F3
Find Previous Shaft=F3
Use Selection for Find CtrisF3
Replace and Find CtrlShifte)
Find in Files... Ctrl+Shift«F
Hpeckopsng - i <http://rmarkdown. rstudio.com>.
Word Count
Clear Consale. Ctrl-L
within the document. You can embed an R code chunk like this:
17
18> " {r cars}
a0 PAITTP RPN e |
2:1 3 RMd 2
Console  Terminal R Markdown Jobs
~/4Cursos/1CIAD/11Presentaciones/Curso_CIAD/
>

=0
R Markdown
Including Plots

R Markdown 3

=

Environment History Connectior
# [ | 7 Import Dataset ~ | &
R } Global Environment =

Environment is empty

Files Plots Packages Help
Q
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1.6. Bibliografia

Como citar?
Para citar se usa el arroba (@) y el nombre que le demos a la cita

Para formatear las referencias

Generalmente las revistas tienen un .csl (citation style language) que se puede
descargar.

Lo tnico que necesitas hacer es agregar el csl a tu YAML.

Ejemplo: csl: biomed-central.csl

o [@'Leer sobre csl

o (A'Estilos

o @'Descargar desde zotero
o [@'Desde ScienceDirect
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https://docs.citationstyles.org/en/1.0.1/primer.html
https://github.com/citation-style-language/styles
https://www.zotero.org/styles
https://rpubs.com/med11/referencias_rmarkdown

1.6. Bibliografia

Para editar formato de las referencias:

e Para agregar italicas
{\it Especie sp.}
« Para agregar acentos

0 se escribe como {\'{o}}

Recursos:

e AExcluir referencias
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https://rmarkdown.rstudio.com/authoring_bibliographies_and_citations.html

1.6.1. Bibliografia

Para crear las referencias.

Para agregar bibliografia tenemos que crear un archivo *bib

Que se debe agregar al YAML.,

Ejemplo:

title: "EjercicioPrueba”

author: "MiriamL"

date: "29/3/2021"

output: word_document

bibliography: El_nombre_de_tu_archivo.bib
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1.6.1. Bibliografia

Para crear el archivo bib dentro de RStudio puedes ir a
File>NewFile>Text File

Y guardarlo como Bibliografia.bib
En el mismo lugar donde guardaste tu Rmd

La bibliografia regularmente aparece al final de tu documento
Por esto, te recomiendo agregar un titulo al final que diga: Referencias
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1.6.2. Mendeley

Para obtener las referencias en formato bib.
Desde Mendeley software
Click derecho>Copy as>BibTex Entry

m Mendeley Desktop — X
File Edit View Tools Help
B~ &z = ® < @ Q- Search Miriam
Add Folders Related  Sync Help
" A
- Literature Search ([ Mis publicaciones | Edit Settings
My Library * © [ Authors Title Year Published In Added Detals  Notes  Contents
& o 4 Lerma, Miriam; Castillo- Lead, cadmium and mercury in the blood of the blue-foote 2016 Marine Pollution 03/07/19 . 5 o)
(50 Al Documents 8] Guerrero, José Alfredo; Rue...  booby Update Details E- Type: | Journal Artice M
£ Recently Added - - o .
= Recently Adde . @ Llema, Miriam; Castilo- Non€ on poiedD . 03/07/19 Lead, cadmium and mercury in
[ Recently Read = querrero, José Alfredo; Pala... Habitz Rz PR ES the blood of the blue-footed
I Favorites . @ lerma, Miriam Thesi Open File 03/07/13 booby (Sula nebouxii) from the
© Needs Review - - coast of Sinaloa, Gulf of
0 My Publications v . @ Lerma, Miriam; Castilo- Forag Open File Extemally 2020 MarineBioogy  04/06/20 California, Mexico
= Guerrero, JA; Herndndez-V...  Tropic Open Containing Folder
Filter by Authors v . @ Lerma, Miriam; Castillo- Zincc . 2020 Journal of Sea 25/09/20 M. Lerma, J. Castilo-Guerrero,
Al = Guerrero, José Alfredo; Gar... eags, Rename Document Files... Research Authors: 1. Ruelas-Inzunza et al.
Castilo-Guerrero, JA . @ Lema, Miriam Body Merge Documents 2016 22/11/18
Castillo-Guerrero, José Alfredo = footer Mark A b #A| View research catalog entry for this paper
Fernandez, Guilermo A . i Ak - —
Garcia-Hernandez, Jaqueine .| Quispe, Rene; Lerma, Mlnam, Forag 2020 Marine 08/08/20 . X
Garthe, Stefan = Serratosa, Juan; Lunajorqu... humby Copy As » Formatted Citation Journal: - Marine Pollution
Hernéndez-Vazquez, Salvador Export... LaTeX Citation Command Year: 2016
Lerma, Miriam i . Volume: 110
Luna-jorquera, Guillermo Export PDF(s) with Annotations... BibTeX Entry —
Palacios, Eduardo
Quispe, ’Rene Select All Pages: 293-298
Ruelas-Inzunza, Jorge .
Serratosa, Juar; Remove from Felder Abstract:
(2 Delete Documents
Tags:
Author Keywords:
Age-related differences; Breeding stage; Heavy
metals; Seabird; Sex-related differences; age-
related differences
( 5 Publisher: v

ﬂ |
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1.6.3. Zotero

Para obtener las referencias en formato bib.
Desde Zotero
File>Export Library

Otra opcién es cambiar Preferences>Export>Defatult>Bibtek y se puede arrastrar la
bibliografia directo a tu documento bib en RStudio

2 Zotero - O
File Edit ew JTools Help
o v O~ A W~ &~ [ 24 £ ¥ All Fields & Tags e
v (3 My Library Title Creator & B
[ My Collection
My Publications
77 Duplicate ltems
Unfiled ltems
[ Trash

Lead, cadmium and mercury in the bl... Lerma et al.

Export... X

Format: |Zotero RDF &
Translatq BiblaTeX
Expo) Bibliontology RDF

BibTeX
Ex
L Exee Bookmarks 1item in this view

COinS

CSLJSON

csv

Endnote XML
MODS
Refer/BiblX
RefWorks Tagged
RIS

Simple Evernote Export
Sex-related differences TEI

= Unqualified Dublin Core RDF

Wikipedia Citation Templates

age-related differences

Age-related differences ling stage

Heavy metals Seabird

Zotero RDF
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1.6.4. GoogleScholar

Desde Googlescholar

Dale click primero a las comillas y luego elige BibTeX.

© & httpsy//scholar.google.com/scholar?hi=es&as_sdt=0,5&q=Lerma+\' [E = & % In @ ®

Citar

Lerma, M., Castillo-Guerrero, J. A., Hemandez-Vazquez, S, &
Garthe, S. (2020). Foraging ecology of a marine top predator in
the Eastern Tropical Pacific over 3 years with different ENSO
phases. Marine Biology, 167, 1-11.

ISO 690 LERMA, Miriam, et al. Foraging ecology of a marine top predator
in the Eastern Tropical Pacific over 3 years with different ENSO
phases. Marine Biology, 2020, vol. 167, p. 1-11.

Lerma, Miriam, et al. "Foraging ecology of a marine top predator
in the Eastern Tropical Pacific over 3 years with different ENSO
phases." Marine Biology 167 (2020): 1-11.

EndNote RefMlan  RefWorks
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1.6.5. Citr

Para agregar Addins se puede instalar el paquete citr

devtools::install_github("crsh/citr")

Este paquete te permite insertar citas de manera dinamica

T T

- Addins - K citr ~

GH

[+ R+ S A Go to file/function
&) demo.Rmd New recording )
7 A @ Knit - - 1 Insert - Run - ‘&~

1+ —
2 title : "citr demonstration®”
3 author : "Frederik Aust”
4
5 bibliography: ["references.bib”, "r-references.bib"]
6
7  output : html_document
8 -
9

16 Human memory is fallible .

11

10:26  (Top Level) = R Markdown =

History  Ct i a0
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1.6.6. Apendices

La bibliografia aparece al final del documento.
Pero agregar apendices o figuras al final del documento es una prdactica usual.

Para solucionar esto hay que usar

# Referencias
<div id="refs"></div>

# Appendice/Figuras

' Ver otras opciones
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https://bookdown.org/yihui/rmarkdown-cookbook/bibliography.html

2. Ejercicios

4



2.1. Ejercicios

« Agregar texto con inline coding
« Crear un archivo bib
« Agregar texto con referencia

Texto GoogleScholar bib YAML Citar

Agregar texto con inline coding

Tenemos un total de 'r nrow(Pingus)  muestras.
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http://127.0.0.1:6591/Rmd-Parte2.html?panelset=texto#panelset_texto
http://127.0.0.1:6591/Rmd-Parte2.html?panelset=googlescholar#panelset_googlescholar
http://127.0.0.1:6591/Rmd-Parte2.html?panelset=bib#panelset_bib
http://127.0.0.1:6591/Rmd-Parte2.html?panelset=yaml#panelset_yaml
http://127.0.0.1:6591/Rmd-Parte2.html?panelset=citar#panelset_citar

Mdas funcionalidades



3.1. Tablas de contenido

Para agregar tablas de contenido, se escribe en el YAML.:

o toc: true: agrega tablas de contenidos

o toc_float: true: en htmls te permite tener una tabla de contenido flotante (es
decir se adapta al espacio del documento)

« number_sections: true: agrega numeros a las secciones

Ejemplo:
output:
html_document:
toc: true

toc_float: true
number_sections: true

Importante: tiene que ir indentado (por lo menos dos espacios vacios), y tenemos que
agregar dos puntos después de html_document.

Ademas tenemos que tener en nuestro texto los titulos con el numeral y un espacio el
numeral y el titulo.
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3.2. Listas

Se pueden iniciar listas usando astericos * simbolos de mas +, O menos -
P

Esto:

- Elemento de lista
- Otro elemento de la lista
- Tercer elemento de la lista

Se convierte en esto:
e Elemento de lista

e Otro elemento de la lista
e Tercer elemento de la lista
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3.3. Enlaces

Para crear enlaces se usa [ ] ()

« Se pueden crear enlaces dentro del mismo documento

[Primera diapositival(#7. Rmarkdown)

Primera diapositiva

e O a paginas de internet

[Pagina web] (www.miriam-lerma.com)

Pagina web
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http://127.0.0.1:6591/www.miriam-lerma.com

3.4. Ecuaciones

 Las ecuaciones se escriben con signo de délar.
Sin espacio entre los signos y la ecuacién

E = mc?

SE = mc*{2}S

» Los sobreindice se escriben con el texto entre (virgulilla)
CO2

$C0~2~$

e Los superindices se escriben con * (acento circunflejo)
R2

SR"{2}$
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3.5. Otras opciones

Help>Markdown Quick Reference
[Z'Cheatsheet

Acceso rdapido desde RStudio al cheatsheet.

& Rstudio File Edit Code View Plots Session Build Debug Profile Tools Window [IEE 3 D % = o) = o) Tuel38PM Q=
ece ~[Documents/rmarkdow Search |
Q- - » C unctic & - 2 - Addins ~ R Help & rmarkdown
Console R Markdown About RStudio | a0
Check for Updates F

~/Documents/rmarkdown/demos /12-website/
> | RStudio Docs
RStudio Support

=0

Cheatsheets RStudio IDE Cheat Sheet
Data Manipulation with dplyr, tidyr
= Data Visualization with ggplot2
Roxygen Quick Referen g Markdown cheat sheet R Markdown Cheat Sheet
Diagnostics > R Markdown Reference Guide
' Shiny Web Applications
Package Development with devtools

Markdown Quick Reference
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https://rstudio.com/wp-content/uploads/2016/03/rmarkdown-cheatsheet-2.0.pdf?_ga=2.240247812.66492107.1614708075-36514926.1579182721

4. Ejercicios
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4.]. Ejercicios

« Agrega una lista
« Agrega un enlace
« Agrega una tabla de contenido

Lista Enlace Tabla de contenido

Agregar en el texto:

Objetivos
- Evaluar si la aleta de los pinglinos ayuda a predecir su peso
- Evaluar si hay diferencias en los pesos entre hembras y machos

Nota Cuidado con los espacios
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5. Plantillas



5.1. Paquete rticles

Exiten varios paquetes con plantillas.

Uno de ellos es rticles.
Para instalar el paquete rticles hay dos opciones

install.packages("rticles")
remotes::install_github("rstudio/rticles")

Para ver plantillas de varias revistas [ZClick aqui
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https://github.com/rstudio/rticles

5.2. Paquete rticles

Para usarlo.

« Tener instalado la version mas reciente de RStudio
 Tener instalado el paquete
e Usar un nuevo R Markdown para crear el template

File>NewFile>RMarkdown

Mew R Markdown

|:-‘| Document Template: ? Using R Markdown Templates
b : Journal of Statistical Software {rticles}

I;l resentation R Journal Submission {rticles}
From Template useR Conference Abstract {rticles}

Name:

|Umit|ed

Directory:

|~ Browse...

™ Create in New Directory

A new directory with the same name as the file will be
created. The new R Markdown file and all its resources
will be placed in the new directory.

| OK | Cancel
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5.3. Paquete Papaja

El paquete papaja tambien tiene plantillas para escribir articulos.

Para instalar

devtools::install_github("crsh/papaja")
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6. Compartir

« Opcién 1: Compartir todo.
Enviar documento Rmd, tal cual y la otra persona puede darle click a las partes
grises en el botén verde (siempre y cuando tenga la base de datos)

e Opcién 2: Compartir instrucciones.
Mando el documento Rmd en html y pueden copiar las instrucciones con sus
propios datos.

« Opcién 3: Escribir reportes o articulos.
Exportar documentos sin cédigo.

e Opcién 4: Compartir con opcion a cédigo

En el YAML agregar code_folding: hide y esconde el codigo pero te agrega un
boton para ver el codigo se ser necesario.
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Contacto

Recapitulando

Resultados en el texto
Bibliografia

Tablas de contenido
Enlaces

Ecuaciones

Plantillas

Para dudas, comentarios y sugerencias:
Escribeme a miriamjlerma@gmail.com

Este material esta accesible y se encuentra en
mi [Z'github y mi [(Zpagina

Volver


https://github.com/MiriamLL/Curso_CIAD/
https://miriamlerma.netlify.app/materiales.html
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