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Introduction

This document explains the installation of the POOSL IDE. This is a plug-in for Eclipse that relies on
the POOSL simulator (Rotalumis) of Eindhoven University of Technology
(https://github.com/ObeoNetwork/POOSL).

The latest version of this installation manual can be found at http://poosl.esi.nl/ . Further
information about the use of the POOSL IDE can be accessed through the built-in help.



https://github.com/ObeoNetwork/POOSL
http://poosl.esi.nl/

1 Installation

1.1 Minimal system requirements
The POOSL IDE requires one of the following operating systems:

e Windows 7, 32 bit or 64 bit (Windows XP is not supported)
e Ubuntu 12.04, 32 bit or 64 bit (Ubuntu 18.04 is confirmed to work)
e Mac 0S X 10.10 (Yosemite)

In addition it requires the following installed software:

e Eclipse IDE, version 2020-09 or newer (Eclipse 2020-12 is confirmed to work)

1.2 Installing Eclipse

If a correct version of the Eclipse IDE has already been installed, you can skip this section. Otherwise,
download the Eclipse Installer from https://www.eclipse.org/downloads/ and execute it. Select
“Eclipse Modeling Tools”, choose installation folder and accept licenses.

® Note: the Eclipse Installer includes a JRE (required to run Eclipse). It is also possible to install
Eclipse via a package (https://www.eclipse.org/downloads/packages/) but this requires

manual installation of a JRE (at least version 11) and is therefore not recommended. For the
JRE and Eclipse, make sure that both are 32-bit versions, or both are 64-bit versions.

1.3 Installing the POOSL IDE plug- in
To install the POOSL IDE plug-in in Eclipse follow these steps:

1. In Eclipse go to Help -> Install new software
2. In “Work with: “, click the Add... button. The Add Repository dialog box appears:
3. Select one of the update site listed here: https://obeonetwork.github.io/POOSL/
4. Enter a name for the repository and click OK.
-
-
Name: | POOSL M1 | Local..
Location:‘ https://obeonetwork.github.io/POOSL/release/M1_alpha_05 ‘ Archive...
oK
@ Add | Cancel L

5. Select the Poosl IDE plug-in from the update site.


https://www.eclipse.org/downloads/
https://www.eclipse.org/downloads/packages/
https://obeonetwork.github.io/POOSL/
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Check the items that you wish to install.

Work with: | POOSL M1 - https://obeonetwork.github.io/POOSL/release/M1_alpha_05 v Add... Manage...

| type filter text Select All

Name Version Deselect All

[ ] Uncategorized

<

1 item selected

Details

Poosl 1.0.0.7833cLWinh8s7375317E15A39
Show only the latest versions of available software
Group items by category What is already installed?

Hide items that are already installed

[ ] Show only software applicable to target environment

Contact all update sites during install to find required software

@ < Back Finish Cancel

6. Click “Next” twice and accept the license agreement, click “Finish” to start the installation.
Because the software is not signed by Eclipse it will give a security warning. Click OK on the

security warning to continue installation.
e Installing the POOSL IDE plugin will automatically install the simulator (Rotalumis).

7. When asked, restart Eclipse.

If an error is reported during installation, please consult section 4.3, 4.4 and 4.5.

1.4 Updating the POOSL IDE
To update the POOSL IDE follow these steps:

1. In Eclipse select Help -> Check for Updates. If a newer version of the POOSL IDE or the
simulator (Rotalumis) are available, they will appear in the list of software to update.

Click Next to install the new updates.
In Eclipse select Project -> Clean... -> Clean all projects. This ensures that the metadata about

the POOSL models is updated.

1.5 Installation problems
In case errors occur after installing the POOSL IDE when opening files or running or debugging

models, make sure that the correct versions of the following software are installed:



e Java Runtime Environment (JRE) version 11 or newer

e Eclipse IDE version 2020-09 or newer

(see section 1.1)
(see section 1.1)

2 Testyour installation using the examples
This section describes a procedure to check whether the installation was successful, and whether the

POOSL IDE has enough permissions on your computer. To use the POOSL IDE to its full potential, it

needs enough permissions to write files and to create socket connections on your machine.

2.1 Import the example and library POOSL projects

To create POOSL projects with the examples and libraries, follow these steps:

1. Click on File -> New -> Example... -> POOSL Examples

2. Click Finish to import the projects.

2.2 Testyour installation using an example

1. Click on Window -> Perspective -> Open Perspective -> Other... -> POOSL Edit, which changes
the screen layout in order to support the editing POOSL models.

2. Double-click on the file producer_consumer.poosl. Check that the contents of the file is

shown in a syntax-highlighted way.

& POOSL Edit - nl.esi.poosl.examples/models-basic/ProducerConsumer/producer_consumer.poosl - Eclipse
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[F] producer_consumer.poosl &2
1 // This example demonstrates most elementar

2 // It models a Producer and a Consumer that

ff mmmmm e e

/* Data class for a Packet that stores an j
~data class Packet extends Object
variables

B W

g /* Identity stored inside a Packet. *
18 ID : Integer

11 methods
12 /* Sets the ID value of the packet. */

138 setIdentity(I : Integer) : Packet

14= ID :=1 ;

15 return self

16 /* Gets the ID value of the packet. */
178 getIdentity : Integer

138 return ID

19 /* Creates the String value that is shc
282 printString : String

21 return("[" + ID printString + "]")
22

23 ff e
24

25 /* Process class that produces messages. */
26~ process class Producer(

27 /* Time delay in between produced mess:
28 IdleTime : Integer)

29 ports

L] /% This is the only port; it is used fd
31 Out
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3. Right-click on the file producer_consumer.poosl and select Debug as -> POOSL simulation. The
screen layout is changed in order to support the debugging of POOSL models.

When it is the first time starting a simulation, a “Windows Security Alert” window will pop-up
with the question if it should block rotalumis.exe. To continue and run the simulation, click

i Windows Security Alert @

@ Windows Firewall has blocked some features of this program

Windows Firewall has blocked some features of rotalumis.exe on all public and private networks.
m ame: rotalumis.exe
Publisher: Unknown
Path: C:\eclipse_mars\plugins\windows \&4bitirotalumis.exe

Allow rotalumis.exe to communicate on these networks:
[¥]Private networks, such as my home or wark network.

[]Public netwarks, such as those in airports and coffee shops {not recommended:
besause these networks often have ittle.ar no sequrity),

What are the risks of allowing a program through a firewall?

[ Allow access ]l Cancel

“Allow access”.
If a pop-up appears with the message “The system cannot find the path specified” follow the
instructions in section 4.7.

4. If no element is selected in the Debug view (top-left corner), then select any element.

5. Inthe top-left corner, click on the green Resume button (indicated by the green arrow in the
picture below). Check that the Sequence Diagram in the bottom-right corner fills up with
messages.



-

& POOSL Debug - nl.esi.poosl.examples/models-basic/Produ
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ﬁnehuM = B
4 |78 producer_consumer.poos [Simulated time: 0]
g Bus
4 g ProducerConsumer
i# Producer
i Consumer

6. Inthe top-left corner, click on the red Terminate button (indicated by the red arrow in the

picture above).
7. Inthe top-right corner, click on POOSL Edit or the logo to change back to the screen layout

for editing. The edit perspective logo looks like: ~ ED

Quick Access B | By E E e
' = 75 | [ Resource |2 POOSL Edit | %5 POOSL Debug

= g

3 User manual
The user manual for the POOSL IDE can be found inside the Eclipse environment. It can be opened in

several ways:

1. Click on the Help menu, and select “Help Contents”.
This will open the Eclipse built-in help in a separate window. The POOSL documentation is

located under Contents in the Poosl booklet.
= @ Poosl
¥ Editing
A Running and debugging
L] Importing and exporting
B Preferences

B raQ

The recommended starting point for new users is Editing -> Create Projects and Models.



2. Click on the Help menu, and select “Dynamic help” (Or use keyboard shortcut <F1>).

This will open a window inside Eclipse. It shows brief information about the selected view, in
combination with references to the help Contents.

{® Help 32 = m

Search 05 Related Topics [ID Bookmarks [ Index

G
2

Contents

About Poosl Editor

The POOSL editor provides you with POOSL specific text editing support.

This includes syntax highlighting, hovers, navigation, validation and
content assist (<CTRL>+<SPACE>).

See also:
B Creating models
B Editing models

More results:

% Search for About Poos! Editor

To switch between the main documentation (“Contents”) and the dynamic help (“Related
Topics”), use the tabs on top of the help page.



4+ FAQ

4.1 <CTRL>-<SPACE> does not work.

This is a general Eclipse problem. Some suggestions for solutions can be found online, such as:

1. Create a new workspace, and import your existing projects. Remember to check “Copy projects
into workspace” to copy all your existing work to new workspace.

2. Make sure that the <CTRL>+<SPACE> combination is not hijacked by any other application (such as
text input features).

3. Make sure “regional and language options” is in English language. For example, Windows, Control
panel —> Region and language options. Then

e Administrative (tab) —> Language for non-Unicode program. Make sure English (United
States) is selected, others may not work.

e Keyboards and Languages (tab) —> Change Keyboards. You'll see a list of languages
installed; remove any that you don’t want (click the language and then click the Remove
button) until you only have the ones you want left.

4. Change the key combination in Eclipse, via Window -> Preferences -> General -> Keys. The default
binding for command “Content Assist” is “Ctrl + Space”, but this can be changed into something else.

4.2 Internal null pointer exception when trying to run/debug a model.
The following error may occur when you try to run or debug a model:

An internal error occurred during: "Launching ...poosl". java.lang.NullPointerException

It usually indicates that your version of the Java Runtime Environment (JRE) is too old. Please check
the minimal system requirements in section 1.1.

4.3 Cannot complete the install because of a conflicting dependency.
The following error may occur during the installation of the POOSL IDE:

Cannot complete the install because of a conflicting dependency

If the remaining message refers to different version of the Eclipse Workbench, then it usually
indicates that your version of Eclipse is too old. Please check the minimal system requirements in
section 1.1.

4.4 An error occurred while collecting items to be installed
The following error may occur during the installation of the POOSL IDE:

An error occurred while collecting items to be installed
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session context was:(profile=epp.package.java,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Followed by the repositories it cannot find:
No repository found containing: osgi.bundle,nl.esi.poosl.generatedxmlclasses,3.2.0.201501141011
No repository found containing: ... ... ...

This is a known problem in Eclipse and it can be solved by reloading the software site.

1. Go to Help-> Install New Software, then select “Available Software Sites".

£ Install I =

Available Software

Select a site or enter the location of a site.

Work with:  type or select a site - Add...
type filter text
MName Version

[[] (D There is no site selected.

Select All Deselect All
Details
Show enly the |atest versions of available software [¥] Hide items that are already installed
[#] Group items by category What is already installed?

[T Show enly software applicable to target environment
[#] Contact all update sites during install to find required software

@ cme | met> =

2. Select thé POOSL IDE site, and click “edit”. Change the location by removing or adding the trailing "/”,
and click "OK".
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= Preferences |M‘
type filter text Available Software Sites s T Ty
» General
> Ant -
e filter text

> Code Recommenders e
b Help MName = Lecation Add...
4 Instoll/Update +] POOSL IDE http://poosl.esi.nl/downloads/ide/updates/release

Automatic Updates &] Q L - - Ed

Available Software Sites DQ & Edit Site | B |
» oo ==

o+
:: m:::; 4 Name:  POOSLIDE
b Mylyn o« Location:  https://obeonetwork.github.io/POOSL/release/
1> Plug-in Development o —
1> Run/Debug o« Import...
= ©) o[ e |
» WindowBuilder
[ XML
[ ¥tend
[ Ktext
] il +

< [ 3
@ [ ok ][ cancel

3. Select the POOSL IDE site, and click “Reload”. Reloading may take a minute.

4. Once the software site has been reloaded, click “OK" to go back to the “Install New Software” screen.

(= Instal -

Available Software

Select a site or enter the location of a site, J o
-\_)i.
Work with:” [)[ Add. [ Manage. |

type or select a site
type filter tes --All Available Sites--

Eclipse EPP 4.7 (Oxygen) - http://download.eclipse.org/technology/epp/packages/oxygen/
Name POOSL P2 update-site - http beonetwork.github.io/POOSL/release/

The Eclipse Project Updates - http://download.eclipse.org/eclipse/updates/4.7

Select All | [ Deselect Al
Details
[¥] Show only the latest versions of available software [¥] Hide iterns that are already installed
[V] Group items by category What is already installed?

[] Show only software applicable to target environment
Contact all update sites during install to find required software

@ < Back Next » Finish

5. The problem should now be resolved. Select the POOSL IDE site from the dropdown box to continue the
installation at point 5 of the manual (section 1.3).
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4.5 Something doesn’t (seem to) work.

First of all, check whether your system meets the minimal installation requirements (see section 1.1),
and the other FAQ. Depending on the problem, the following information may support experts in
solving the problem that you experience:

e Version of the Java Runtime Environment
o At the command prompt, type: java -version
e Version of Eclipse
o Help -> About Eclipse
e Version of Xtext, Sirius and Rotalumis
o Help -> About Eclipse -> Installation Details -> Installed Software
e Eclipse log
o Help -> About Eclipse -> Installation Details -> Configuration -> View Error Log
e Log of the communication between Eclipse and the simulator
o Setthe logging level in the preferences
o The Logging.html file can be found in the root of the Eclipse installation
e Console output and/or Eclipse screenshot
e The .poosl files causing the problem

4.6 The installation could not be completed as requested
When installing/updating to POOSL IDE 3.4.1 in Eclipse Luna, the following error will occur: “The
installation cannot be completed as requested”,

The original error contains:

Cannot complete the install because one or more required items could not be found.
Missing requirement: nl.esi.poosl.sirius 3.4.0.201506301149 (nl.esi.poosl.sirius 3.4.0.201506301149)
requires 'bundle org.eclipse.sirius 3.0.0' but it could not be found

Version 3.4.0 of the POOSL IDE is the last version that supports Eclipse Luna, up to Luna SR2 (4.4.2).
Updating to a higher version of POOSL IDE requires you to install Eclipse Mars or newer, as described
in section 1.2.

The following error looks similar and can occur when installing the POOSL IDE in Eclipse Mars:

Cannot complete the install because one or more required items could not be found.
Missing requirement: POOSL IDE3.4.0.201506301149 (nl.esi.poosl.sdk.feature.group
3.4.0.201506301149)
requires 'bundle org.eclipse.sirius 0.0.0' but it could not be found

When installing the POOSL IDE plug-ins the “Contact all update sites during installation to find
required software” checkbox was not selected. Restart the installation or press the back button and
continue from section 1.3 at step 5.
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4.7 “The system cannot find the path specified” when running a model
The following error can occur when trying to run or debug a model:

- ~
£ Problem Occurred l =Nl X
&¥a 'Launching producer_consumer.poos!’ has encountered a
= problem.

The system cannot find the path specified

OK | [ << Details

The system cannot find the path specified -
The system cannot find the path specified

N

This can mean that Eclipse has restricted access in the Eclipse installation folder. To solve this issue,
either run Eclipse as administrator (Right-click on eclipse.exe, select “Run as administrator”), or move
the Eclipse installation folder to a location where it has full read and write access.
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