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1. Overview
‘PhotoBook Tools’ is a collection of scripts and tricks intended to create photo album pages in a fast
and flexible way with Scribus. This tutorial covers an entire workflow. 

First we will do a little exercise to get a taste of the ‘PhotoBookLayoutMaker’-script. This exercise 
includes saving the layout in the scrapbook as a template for further use. After that we will explain 
in detail the options and possibilities of this script.

Then we will learn how to import some photo’s and put them into the image frames in a semi-
automatic way. We will use the ‘PhotoBookFillFramesCentered’-script to automatically scale the 
images to fill the selected frames. Then we apply the ‘PhotobookImageCropResize’-script that crops
and resamples the pictures. With this script we can dramatically reduce the size of the images in our
photo book and the time to convert it to pdf.

Finally we will convert the pages generated in Scribus into a pdf-document or into several jpeg-files
for uploading to your printing company.

In the Appendix we will explain you how to install the Python Pillow-package (needed for the 
‘PhotoBookImageCropResize’-script).

2. Setup
There are two ways to get the scripts work:

1. Copy the script files to the default Scribus scripts folder (Scribus_installation_ folder\share\
scripts\). Scribus_installation_folder depends on your Operating System.

2. From the Scribus menu select Script → Execute script... and browse to the script file with 
the Run script dialogue.

3. PhotoBook Layout Maker

3.1. Starting with a simple example

1. Copy the files ending on *.py and *.cfg from the download into your Scribus scripts 
folder.

2. Open a new document within Scribus. Set document layout to single page and page size 
to A4, orientation to landscape, unit to mm and all margins to 10mm.

3. In the Scribus menu Script → Scribus Scripts, click on PhotoBookLayoutMaker.
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4. You now get the options window as below:

5. After changing the columns into ‘2’, leave the other options and press the “OK”-button.

6. The script generates two empty image frames as seen below:

7. Select the image frame on the right, then execute the script again with columns = 1 and 
rows = 2.
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8. Now your first layout is ready. We will send it to the scrapbook for future use. Open the 
menu Windows → Scrapbook. Click the icon in the upper left corner (Create a new 
scrapbook page) and create and select a new folder called ‘PhotoBook Layouts’. Then in 
the main window apply menu Edit → Select All (or Ctrl+A). Then click right mouse 
button and Sent to → Scrapbook → PhotoBook Layouts. Name it ‘A4L_1P_2L’ (for A4 
Landscape page with 1 Portrait frame on the left and 2 Landscape frames on the right 
side).

9. Close your document.

10. Open a new Scribus document as in step 2 above. Menu Page → Snap to Items. Then 
menu Windows → Scrapbook. Grab the ‘A4L_P1_2L’-layout with the mouse and drag it 
into the corner of the top and left margins. Close the scrapbook window. You now have 
applied your saved layout to this page.
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3.2. Menu options explained in detail

1. Split/merge rectangle of selected item(s) or area within page margins in columns and 
rows: ‘selected frame(s)’ means the rectangular area containing all the selected items 
(image frames, text frames, etc.). They can be on one or more pages but they must be on 
the same layer. If nothing was selected, the area within the current page margins will be 
taken. The source rectangle will be split (or merged) into equal rectangles by the number 
of columns and rows entered. Grouped items are not allowed as source because their 
border line is included in their measures.

2. Gap in document units: sets the inner margins between two or more generated image 
frames. Horizontal and vertical gaps are equal in size and are to be given in document 
units (pt, mm, inch, …).

3. New frame(s) aspect ratio (0=maximum area) – width to height: here you can enter the 
width and height values which are divided by one another to give the desired aspect ratio. 
Any positive number can be entered here. Some frequently used dimensions are 1 to 1 for 
square, 2 to 3 for DSLR photo’s in portrait mode and 3 to 2 for landscape mode. Filling in
width ‘1920’ (pixels) and height ‘1080’ results in 1,778 which is the same as entering ‘16’
and ‘9’. If the height value of the aspect ratio is set to ‘0’ then the generated image 
frame(s) will fill the entire source area, otherwise the available area will be filled with 
rectangles as big as possible taken into account the calculated aspect ratio.

4. New frame(s) scaling in %: the rectangle of the generated frames with their gaps and 
captions included as % of the source rectangle. Note that the gap and caption measures 
will not be scaled but remain their absolute values. Percentages above 100 are allowed. 
By setting 112% in the example before you get a borderless image on the page. You may 
set even a higher % for covering the bleed.
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5. New frame(s) alignment – horizontal and vertical: in the case the generated image 
frame(s) do not entirely fill the source area (desired aspect ratio is different from aspect 
ratio of source rectangle or scaling is applied), the you can align them horizontally and 
vertically.

6. Text caption below image frame and caption height in document units: if selected, a text 
frame of the indicated height will be placed below the generated image frames. The name 
of the image frame will be displayed, but you can change texts manually afterwards. 
Initially the default font will be used and font size is set to 2/3rd of the caption text height.
A style called ‘paragraphStyleCaptionText’ will be created together with a 
‘characterStyleCaptionText’.  With the menu Edit → Styles → Paragraph Styles resp. 
Character Styles you can change alignment, font, text colour, text background colour and 
opacity for all caption texts at once.  A negative caption height value results in a text 
placed inside the image frame at the bottom of it.

7. Remove selected source items: all unlocked selected items will be deleted. If you are not 
sure, uncheck this option and delete the items manually afterwards.

8. Alternative border style for new frame(s): All generated image frames have the 
‘frameBorderLineStyle1’ border of 1pt with the ‘frameBorderColor1’ set to dark grey. 
The ‘frameFillColor’ is set to light grey. You can change these ‘default’ styles for all 
image frames at once with the menu Edit → Styles → Line Styles. Same for the colours 
with menu Edit → Colours and Fills (scroll to the bottom for the colours added by this 
script). If for some reasons you want to apply an alternate border style 
‘frameBorderLineStyle2’ on the image frames you are to generate, then you must check 
this option (an example for this would be a white border around images which are placed 
over another image to increase visibility).

9. Save above parameters for future use: You can save your settings in a configuration file 
called ‘PhotoBookLayoutMaker.cfg’ which resides in the same directory of the 
PhotoBookLayoutMaker.py – file.

Important note: As for most of the above parameters there are no limits set, it is up to 
you to enter data that make sense. Not all possible generated lay-outs are useful or good 
designs!
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3.3. Some advanced examples

1. A multi-page layout: generate the maximum frame on both opposite pages with the 
default parameters. Select both frames and re-run the script with 3 columns and 1 row and
enter a gap value. Select the two frames on the left and merge them into one.

2. Picture in picture layout with inside captions: A rectangle was created centered on an 
A4 page at 115% in order to cover margins of 10mm and bleeds of 3mm. Then a new 
instance of the script was run with parameters as below. The line width of 
‘frameBorderLineStyle2’ was changed to 2mm. The ‘characterStyleCaptionText’ was set 
to Roboto Slab Light and text background colour to White.
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Result:

4. Importing your photo’s in bulk and fill the image frames
After you have created your page layouts and saved them to the scrapbook, we start a new 
document with the same dimensions. We can enter a number of pages at the documents creation or 
apply menu Page → Insert.

We apply menu Page → Snap to Items. Then menu Windows → Scrapbook. Grab the chosen layout 
with the mouse and drag it into the corner of the top and right margins. Continue for the next pages.

When you are finished, you select an image frame and right-click on it and select Get Image… from
the context menu. Then select one or more images and press OK. A special cursor with a preview of
the image appears. Now click in the image frame you wanted it and continue with the next image 
and so on. Do not worry about the scaling yet. You can fill images on several pages at once and you 
can stop at any moment by pressing “Esc” or repeat this process several times.

Then menu Edit → Advanced Select All... Mark ‘on Current Layer’ and ‘With the Following 
Attributes’: select ‘Item Type’ and choose ‘Image Frame’ (note: the ‘Current Layer’  has to be 
unlocked). You now have selected all image frames on all pages. Alternatively you can select the 
images to scale manually or by pressing ‘Ctrl-A’ for an entire page. Then run the script 
‘PhotoBookFillFramesCentered’ (menu Script → Scribus Scripts). All images are now scaled at 
their maximum with preserving proportions and centered in their frame. Be aware that this script 
can take several minutes, especially with high resolution images.

We can manually adjust image placement and scaling by selecting an image frame, menu Windows 
→ Content Properties and change X-Pos and Y-Pos and apply Free Scaling (do not forget to click 
the ‘chain’-icon on the right to preserve proportions).
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5. Cropping and resampling your images
Select your images as described above in chapter 4. Then run the script 
‘PhotoBookImageCropResize’ (menu Script → Scribus scripts). You will be asked for the resolution
(default is 300 dpi for print), colour mode (since Scribus converts your images into CMYK in the 
pdf creation, you can leave it to RGB here or eventually you can convert to grey scale), file format 
(jpg, png or tif) and resampling method (bicubic, bilinear or lanczos). Then press ‘ok’ to run. Copies
of your images will be created using the selected parameters and the suffix ‘_cropped’ will be added
to the file names. If the file name already exists, you are asked to overwrite or not.

Note: This script uses the Python Pillow-package for the image cropping and resampling. This is 
not standard included in Scribus. See the Appendix for installation.

6. Exporting your photo book to the pdf-format
Menu File → Export → Save as PDF... Use the default parameters and press Save. That’s all!

Remark: There is also an export option → Save as Image... which saves each page as a separate 
JPG or PNG image.

7. Appendix: Installation of Python Pillow-package
See also: https://pillow.readthedocs.io/en/stable/installation.html

7.1. (Unofficial) Windows installation

Go to https://pypi.org/project/Pillow/#files and download the wheel file that corresponds with your 
Scribus Python version (My Scribus Python version is 3.7, so I download the Pillow-8.3.1-1-cp37-
cp37m-win_amd64.whl file). With 7-zip I extract the directories and files and copy them into the 
directory C:\Program Files\Scribus\python\lib\site-packages. After restarting Scribus, this works for
me.

7.2. Linux installation

If not already installed, run following commands in terminal:

• python3 -m pip install --upgrade pip

• python3 -m pip install --upgrade Pillow
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