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1. Introduction 

S1988 is a vintage sampler emulation plugin inspired by the legendary AKAI S1000 hardware sampler 
from the late 1980s. This plugin captures the distinctive character of early digital sampling while adding 
modern creative capabilities including granular time-stretching, resonant filtering, and lo-fi degradation 
effects. 

The AKAI S1000 was renowned for its warm, slightly gritty character that came from its 16-bit converters, 
analog filters, and the inherent limitations of early digital audio. S1988 faithfully recreates these 
characteristics while providing intuitive controls for everything from subtle vintage coloring to extreme 
sound mangling. 

Whether you're adding authentic retro character to drums and samples, creating experimental 
soundscapes with time-stretching, or designing lo-fi textures, S1988 delivers that coveted late-80s 
sampler sound with modern flexibility. 

  



 

 

2. Key Features 

2.1 Vintage Sampler Character 

• 18 dB/octave resonant low-pass filter modeled after classic sampler topology 
• 18 dB/octave high-pass filter for frequency shaping 
• Warm preamp saturation with musical gain compensation 
• Filter drive for additional harmonic content 

2.2 Lo-Fi Processing 

• Variable sample rate reduction (4000 Hz - 44100 Hz) 
• Bit depth reduction (4-bit to 16-bit) for authentic digital degradation 
• DC blocking to maintain clean output even with extreme settings 

2.3 Time Stretch Engine 

• Granular time-stretching with variable grain size (2-200 ms) 
• Time factor from 25% to 400% for dramatic tempo manipulation 
• Optional pitch compensation to maintain original pitch during stretching 
• Transpose control (±24 semitones) for pitch shifting 
• Reverse playback mode for creative effects 

2.4 Flexible Output 

• Equal-power dry/wet mix for parallel processing 
• Auto-gain compensation to maintain consistent output levels 
• Mono/Stereo processing modes 
• Zero latency operation 

  



 

 

3. User Interface 

The S1988 interface is organized into logical sections that follow the signal flow. Controls are grouped 
by function for intuitive operation: 

• Input Section: Input level and preamp controls 
• Filter Section: High-pass, low-pass filters with resonance and drive 
• Lo-Fi Section: Sample rate and bit depth reduction 
• Time Stretch Section: Granular time manipulation controls 
• Output Section: Mix, output level, and processing mode 

 

4. Input Section 

The input section provides gain staging and saturation controls that shape the signal before filtering. 

Parameter Range Default Description 
Input -20 to +20 dB 0 dB Input gain control. Sets the level 

entering the processor. 
Preamp 0 - 100% 0% Warm saturation stage. Adds harmonic 

content and soft clipping with 
automatic gain compensation. 

Auto Gain Off / On Off Automatic output level compensation 
based on preamp, filter drive, and 
resonance settings. 

 

5. Filter Section 

The filter section provides S1000-style 18 dB/octave filters with resonance and drive capabilities. These 
filters respond immediately to parameter changes for dynamic, responsive filtering. 

5.1 Filter Parameters 

Parameter Range Default Description 
HP Filter 20 - 2000 Hz 20 Hz High-pass filter cutoff frequency. 18 

dB/octave slope removes low 
frequencies. 

LP Filter 200 - 20000 Hz 20000 Hz Low-pass filter cutoff frequency. 18 
dB/octave slope with resonance. 

Resonance 0 - 100% 0% Filter resonance (Q). Higher values 
create emphasis at the cutoff 
frequency. 

Filter Drive 0 - 100% 0% Post-filter saturation. Adds grit and 
edge to the filtered signal. 

5.2 Filter Topology 

The S1988 uses cascaded filter stages to achieve its 18 dB/octave slopes: 

• Low-Pass Filter: 12 dB biquad with resonance + 6 dB one-pole cascade 
• High-Pass Filter: 6 dB one-pole + 12 dB biquad cascade 

This topology matches the behavior of classic hardware samplers while maintaining stability at high 
resonance settings. 

  



 

 

6. Lo-Fi Section 

The Lo-Fi section recreates the digital degradation characteristics of vintage samplers with variable 
sample rate and bit depth reduction. 

Parameter Range Default Description 
Sample Rate 4000 - 44100 Hz 44100 Hz Reduces the effective sample rate. 

Lower values create aliasing and digital 
artifacts. 

Bit Depth 4 - 16 bits 16 bits Reduces bit resolution. Lower values 
create quantization noise and stepped 
waveforms. 

6.1 Classic Settings Reference 

Hardware Era Sample Rate Bit Depth Character 
AKAI S1000 (1988) 44100 Hz 16-bit Clean, warm 

Early Samplers (1985) 22050 Hz 12-bit Gritty, classic 
8-bit Era (1980s) 11025 Hz 8-bit Crunchy, lo-fi 
Extreme Lo-Fi 4000 Hz 4-bit Destroyed 
 

7. Time Stretch Section 

The time stretch engine uses granular synthesis to manipulate time and pitch independently. This 
section enables creative effects from subtle time adjustments to extreme sonic manipulation. 

Parameter Range Default Description 
Stretch Off / On Off Enables the time stretch engine. When 

off, audio passes through normally. 
Time Factor 25 - 400% 100% Time stretch ratio. 50% = half speed, 

200% = double speed. 

Grain Size 2 - 200 ms 50 ms Size of granular windows. Smaller = 
smoother transients, larger = more 
artifacts. 

Pitch Comp Off / On On Pitch compensation. When on, 
maintains original pitch during time 
stretching. 

Transpose -24 to +24 st 0 st Pitch shift in semitones. Independent 
of time factor. 

Reverse Off / On Off Reverses playback direction through 
the grain buffer. 

7.1 Grain Size Guidelines 

• 2-10 ms: Very smooth, minimal artifacts, best for subtle stretching 
• 20-50 ms: Balanced, good for most material 
• 50-100 ms: Audible granular artifacts, creative textures 
• 100-200 ms: Extreme granular effects, rhythmic stuttering 

  



 

 

7.2 Important: Time Stretch Buffer & Rendering Workflow 

Understanding the Real-Time Buffer 

When the Stretch feature is enabled, S1988 uses a real-time granular buffer of approximately 7 seconds. 
This means: 

• Audio passes through a circular buffer before being processed by the time-stretch engine 
• There is inherent latency introduced by this buffer 
• The plugin processes audio in real-time, which differs from offline/rendered processing 

Initial Buffer Warm-Up 

Important: When you first enable the Stretch function, the granular buffer needs a moment to fill with 
audio data. During this initial period, the output may sound incomplete or glitchy. 

To get optimal sound quickly: 

1. Enable the Stretch button 
2. Let audio play for a few seconds to fill the buffer 
3. Move the Time Factor and Grain Size knobs slightly – this helps the granular engine settle into a 

stable state 
4. The sound will soon become smooth and consistent 

This is normal behavior for real-time granular processing and only occurs when first activating the 
stretch engine or after significant parameter changes. 

Why Rendering Is Required 

Because S1988's time stretch operates in real-time on a live buffer, the processed audio must be 
rendered to a new audio track (also called "bouncing in place", "committing", or "freezing") to: 

1. Lock in the timing – Ensure the stretched audio aligns correctly with your project timeline 
2. Capture the exact processing – Commit the granular artifacts, pitch compensation, and reverse 

effects permanently 
3. Free up CPU resources – Remove the real-time processing load once you're happy with the 

result 
4. Enable further editing – Work with the stretched audio as a standard audio file 

Recommended Workflow 

1. Set up your time stretch parameters (Time Factor, Grain Size, Pitch Comp, Transpose, Reverse) 
2. Adjust until you achieve the desired sound 
3. Render/Bounce the track to a new audio track using your DAW's built-in function 
4. Disable or remove S1988 from the original track once rendered 
5. Continue mixing with the rendered audio 

  



 

 

DAW-Specific Render Commands 

Below is a quick reference for rendering/bouncing audio in place across popular DAWs: 

Studio One 

Function Access Method Shortcut 
Transform to Rendered Audio Right-click track → Transform to Rendered 

Audio 
(Custom) 

Bounce to New Track Event menu → Bounce to New Track Ctrl+Alt+B / Cmd+Option+B 

 

Ableton Live 

Function Access Method Shortcut 
Freeze Track Right-click track → Freeze Track Ctrl+Alt+Shift+F 
Bounce Track in Place Right-click track → Bounce Track in Place --- 
Bounce to New Track Right-click clip → Bounce to New Track --- 

 

Logic Pro 

Function Access Method Shortcut 
Bounce Regions in Place File → Bounce → Regions in Place Control+B 
Bounce Track in Place File → Bounce → Track in Place Control+Cmd+B 
Freeze Track Right-click track → Freeze Track --- 

 

Pro Tools 

Function Access Method Shortcut 
Freeze Track Click snowflake button / Right-click → Freeze --- 
Commit Track Right-click track → Commit Alt+Shift+C 
Track Bounce Track menu → Bounce Shift+Alt+Ctrl+B 

 

Cubase / Nuendo 

Function Access Method Shortcut 
Render in Place Edit → Render in Place (Custom) 
Bounce Selection Audio → Bounce Selection (Custom) 
Freeze Track Right-click → Freeze Instrument Track --- 

 

FL Studio 

Function Access Method Shortcut 
Consolidate Playlist → Tools → Consolidate Tracks Ctrl+Alt+C 
Render to Audio Right-click mixer track → Render to Audio --- 
Export as WAV File → Export → WAV Ctrl+R 
Note: FL Studio does not have a native "Freeze" function. Use Consolidate to create a rendered audio version of 
your track. 

 



 

 

Reaper 

Function Access Method Shortcut 
Render/Freeze Track Track → Render/Freeze tracks --- 
Glue Items Item → Glue items --- 
Render to File File → Render Ctrl+Alt+R 

 

Bitwig Studio 

Function Access Method Shortcut 
Bounce in Place Right-click clip → Bounce in Place Shift+B 
Bounce Right-click clip → Bounce Ctrl+B / Cmd+B 
Freeze Track Right-click track → Freeze --- 

 
 

8. Loop Section 

The loop section enables real-time audio looping with tempo synchronization capabilities. When enabled, 
incoming audio is captured and played back in a continuous loop, allowing you to freeze and manipulate 
audio material. 

Parameter Range Default Description 
Loop Off / On Off Enables loop capture and playback. 

When turned on, audio is captured 
and looped continuously. 

Loop Sync Free / 1/1 / 1/2 / 1/4 / 1/8 
/ 1/16 / 1/32 / 1/64 / 1/128 

Free Loop timing mode. Free uses 
milliseconds; other values sync to 
host tempo using note divisions. 

Loop Length 10 - 4000 ms 500 ms Loop duration in milliseconds when 
Loop Sync is set to Free. Ignored 
when using tempo-synced divisions. 

8.1 Loop Behavior 

When Loop is enabled, the plugin immediately begins capturing incoming audio. Once the capture buffer 
reaches the specified loop length, playback begins automatically. The loop continues to play until Loop 
is turned off. 

The loop is processed BEFORE the time stretch engine, which means you can apply time stretching, 
pitch shifting, and reverse effects to the looped audio in real-time. This creates powerful sound design 
possibilities. 

8.2 Tempo Sync 

When Loop Sync is set to a note division (1/1 through 1/128), the loop length is calculated from the host 
DAW tempo. For example, at 120 BPM with Loop Sync set to 1/4, the loop will be exactly one beat (500 
ms). This ensures your loops stay perfectly synchronized with your project. 

  



 

 

9. Output Section 

The output section provides final gain staging and processing mode options. 

Parameter Range Default Description 
Mix 0 - 100% 100% Dry/wet blend using equal-power 

crossfade. 0% = dry only, 100% = wet 
only. 

Output -20 to +20 dB 0 dB Final output level with safety limiting to 
±1.0. 

Processing Mono / Stereo Stereo Processing mode. Mono sums L+R 
before output. 

 

10. Signal Flow 

Understanding the signal flow helps optimize your settings and troubleshoot any issues: 

Input → Input Gain → Stretch Buffer → Time Stretch → Loop → 

Preamp → HP Filter → LP Filter → Filter Drive → 

Sample Rate Reduction → Bit Reduction → DC Block → 

Mono/Stereo → Auto Gain → Mix → Output 

10.1 Key Signal Flow Notes 

• Loop is processed after time stretch, so loop changes take effect immediately 
• Time stretch is processed first, so filters respond to stretched audio 
• Preamp saturation feeds into filters, creating harmonic interactions 
• Filter drive is post-filter for raw edge on clean-filtered signal 
• Lo-fi processing occurs after filtering to preserve filter character 
• DC blocker removes offset from bit crushing artifacts 
• Mix blending uses equal-power curves for musical parallel processing 

  



 

 

11. Complete Parameter Reference 

This section provides a complete reference of all automatable parameters in S1988. 

Parameter Range Default Notes 
Input -20 to +20 dB 0 dB Input gain 
Preamp 0 - 100% 0% Warm saturation 
Auto Gain Off / On Off Level compensation 
HP Filter 20 - 2000 Hz 20 Hz 18 dB/oct HPF 
LP Filter 200 - 20000 Hz 20000 Hz 18 dB/oct LPF 
Resonance 0 - 100% 0% Filter Q 
Filter Drive 0 - 100% 0% Post-filter saturation 
Sample Rate 4000 - 44100 Hz 44100 Hz Rate reduction 

Bit Depth 4 - 16 bits 16 bits Bit reduction 
Stretch Off / On Off Enable stretch 
Time Factor 25 - 400% 100% Stretch ratio 

Grain Size 2 - 200 ms 50 ms Granular window 
Pitch Comp Off / On On Maintain pitch 
Transpose -24 to +24 st 0 st Pitch shift 
Reverse Off / On Off Reverse playback 
Loop Off / On Off Enable loop 

Loop Sync Free / 1/1 - 1/128 Free Loop sync mode 
Loop Length 10 - 4000 ms 500 ms Loop duration (Free mode) 

Mix 0 - 100% 100% Dry/wet blend 
Output -20 to +20 dB 0 dB Output level 

Processing Mono / Stereo Stereo Channel mode 
  



 

 

12. Tips & Tricks 

11.1 Authentic Vintage Sampler Sound 

• Set Sample Rate to 22050 Hz and Bit Depth to 12 for classic late-80s character 
• Add subtle Preamp (10-20%) for warmth without obvious distortion 
• Roll off highs with LP Filter around 12-15 kHz for that "sampled" quality 

11.2 Filter Techniques 

• High Resonance (70-100%): Creates acid-style squelchy filter sweeps 
• Filter Drive with Low LP: Aggressive bass tones with controlled highs 
• HP + LP together: Create bandpass effects by bringing both filters toward center 

11.3 Creative Time Stretch 

• Extreme slow (25-50%): Creates ambient pads from any source material 
• Large grain (100-200ms) + Reverse: Granular textures with reversed grains 
• Pitch Comp Off: Classic varispeed-style pitch/time relationship 
• Transpose without Stretch: Quick pitch shifting for harmonies 

11.4 Lo-Fi Drums 

• Bit Depth 8-10 bits adds crunch while maintaining punch 
• Sample Rate around 16-22 kHz removes harsh transients naturally 
• Use Mix at 50-70% to blend lo-fi character with clean attack 

11.5 Gain Staging 

• Enable Auto Gain when using heavy Preamp or Resonance settings 
• Watch output levels when stacking Preamp + Filter Drive 
• Use negative Output gain to compensate for boost from saturation 

Support 

For technical support, updates, and additional information:  
Website: ravegeneration.io  
Email: support@ravegeneration.io 


