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Outline

• Interactive client-server visualization on Cedar and Graham
I rendering on a cluster’s GPU
I software rendering on a single CPU
I parallel software rendering on multiple CPUs

• State of VNC (remote desktop)

• Running off-screen visualization scripts on Cedar and Graham
I batch jobs on CPU nodes

• serial interactive jobs – purely for debugging or testing your scripts
• serial (non-interactive) batch jobs
• parallel (non-interactive) batch jobs

I batch jobs on GPU nodes

• Visualization on virtual machines on Arbutus (part of CC cloud)
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Why remote visualization?

• Dataset could be too big to download

• Dataset and its analysis workflow cannot fit into desktop’s memory

• Desktop rendering is too slow (limited CPU/GPU power)

• In-situ visualization = instrumenting a simulation code on the cluster to
output graphics and/or connect to a visualization frontend (ParaView,
VisIt) on the fly

• Required visualization software is licensed on Compute Canada systems
(only for commercial packages)
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Dataset

3D “sine-envelope wave” function defined inside a unit cube (xi ∈ [0, 1])

f (x1, x2, x3) =
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 , where ξi ≡ 30(xi − 0.5)

discretized on a 1003 Cartesian grid

• You’ll find the code buildSine.c inside remote.zip (see the first
slide)

$ export LD_RUN_PATH=/path/to/netcdf/lib
$ gcc buildSine.c -o buildSine -I/path/to/netcdf/include \

-L/path/to/netcdf/lib -lnetcdf
$ ./buildSine

• This will produce the file sineEnvelope.nc which ParaView can read
(also included in remote.zip)
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Cedar and Graham clusters

• General-purpose clusters for a variety of workloads

• Entered production in June 2017

• Respectively:
I located at SFU and UofWaterloo
I 27,696 and 32,136 CPUs
I 584 and 320 NVIDIA P100 Pascal GPUs (12GB/16GB on-board memory)
I specs at https://docs.computecanada.ca/wiki/Cedar and
https://docs.computecanada.ca/wiki/Graham

• Multiple types of nodes, with 128GB/256GB/0.5TB/1.5TB/3TB memory

• Batch-oriented environment for parallel and serial jobs, use Slurm
scheduler and workload manager

• Identical software setup
https://docs.computecanada.ca/wiki/Available_software
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Perhaps you don’t need 3D?
Off-screen Matplotlib example on Cedar/Graham

• In Python’s matplotlib can script the entire workflow without opening
windows – use a non-interactive backend

• More details at http://matplotlib.org/faq/usage_faq.html#what-is-a-backend
• See http://matplotlib.org/gallery.html for plotting examples

covering many 1D/2D use cases

import m a t p l o t l i b as mpl
mpl . use ( ’Agg ’ ) # f o r PNG; c o u l d a l s o use PS or PDF b a c k e n d s
import m a t p l o t l i b . pyplot as p l t
from numpy import ∗
x = l i n s p a c e (0 , 3 )
y = 10.∗ exp(−2.∗x )
p l t . f i g u r e ( f i g s i z e = ( 1 0 , 8 ) )
p l t . p l o t ( x , y , ’ ro−’ )
p l t . s a v e f i g ( ’ tmp . png ’ )

$ module load python/2.7.13
$ pip install --user matplotlib # will install into ~/.local/
$ python simple.py # should produce tmp.png
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3D general-purpose vis: VisIT and ParaView

• Open source, under active
development, multi-platform
(Linux/Mac/Windows)

• Scalar, vector, tensor fields

• Wide variety of discretizations
(structured, unstructured,
particles, irregular in 2D/3D)

• Support extremely large datasets
(GBs to TBs)

• Scale to large (103 − 105 cores)
systems via MPI

• Nice interactive GUI and Python
scripting

• Client-server mode

• Support over 100 input data
formats

• Support parallel I/O

• Huge array of visualization
features

• VTK support, OpenGL graphics

• We teach both (full-day, in-person
workshops)

- In this webinar all examples will use ParaView
- Same general ideas apply to remote VisIt visualization (client-server and

batch rendering) ⇒ let me know if you want more details for VisIt
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I assume you are already familiar with ParaView basics

• Main elements of the GUI

• How to load a dataset (and
convert your data into a
Paraview-readable format)

• How to switch between
different views
(representations)

• How to colour visualization
by a variable

• How to use filters to build a
pipeline

If not, please see our regular ParaView workshop materials at
http://bit.ly/paraviewzip (slides/data/codes) and the official docs

http://www.paraview.org/documentation
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Few words on X11 forwarding
From cluster’s login or compute node to your laptop

• Could connect with X11 forwarding (ssh -Y) and run the script on the
login (GPU-less) node
$ ssh -Y cedar.computecanada.ca # or graham.computecanada.ca
$ module load paraview/5.3.0
$ paraview

or even on a compute node inside an interactive job
$ ssh -Y cedar.computecanada.ca # or graham.computecanada.ca
$ module load paraview/5.3.0
$ salloc --x11 --time=0:30:0 --ntasks=1 ...
$ paraview

• Not a good idea for a number of reasons!
I login nodes are shared by many users
I X11 connection requires lots of round trips and is not very efficient

(designed in mid-1980s!) ⇒ slow response and unnecessary network traffic
I requires an X11 server on your laptop
I instead we suggest using client-server or batch scripts (more on VNC later)
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OpenGL context for off-screen rendering on a GPU

To render on a GPU from an OpenGL application such as ParaView, you need:

(1) OpenGL support in the GPU driver, and
(2) an X server that handles windows and surfaces onto which client APIs

can draw
I run X11 server (started by root) on the GPU compute node, set

DISPLAY=:0.$gpuindex (get GPU index from Slurm)

Latest NVIDIA GPU drivers include EGL (Embedded-System Graphics Library)
support enabling creation of an OpenGL context for off-screen rendering
without an X server.

• Your OpenGL application needs to be recompiled with EGL support ⇒ use a special
version of ParaView to render graphics on a GPU without an X server; currently compiled
into a module paraview-offscreen-gpu/5.4.0 that provides both pvserver for
client-server and pvbatch for batch rendering

• Unlike X11, EGL does not require any special setting to scale to very high
resolutions, e.g., 4K (3840× 2160) – simply ask it to render a 4K image
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ParaView’s distributed parallel architecture

Three logical components inside ParaView – these units can be embedded in
the same application on the same computer, but can also run on different
machines:

• Data Server – The unit responsible for data reading, filtering, and
writing. All of the pipeline objects seen in the pipeline browser are
contained in the data server. The data server can be parallel.

• Render Server – The unit responsible for rendering. The render server
can also be parallel, in which case built-in parallel rendering is also
enabled.

• Client – The unit responsible for establishing visualization. The client
controls the object creation, execution, and destruction in the servers, but
does not contain any of the data, allowing the servers to scale without
bottlenecking on the client. If there is a GUI, that is also in the client. The
client is always a serial application.
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Interactive jobs on Cedar/Graham

• Client-server workflow is by definition interactive

• Interactive jobs should automatically go to one of Slurm interactive
partitions (CPU or GPU)

$ sinfo | grep interac
# will list nodes and their states (idle, mixed, allocated, ...)

• salloc without a script name will start an interactive shell inside a
submitted job on a compute node

$ salloc --time=1:0:0 ... --account=def-user-role
$ echo $SLURM_... # access Slurm variables, or set your environment
$ ./serial
$ srun ./mpi # run an MPI code
$ exit # terminate the job (go back to the login node)
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Interactive client-server rendering on a cluster’s GPU
Details in http://bit.ly/2wrSvKV

(1) On Cedar/Graham submit an interactive job to the GPU partition, e.g., a
serial job:
$ salloc --time=0:30:0 --ntasks=1 --gres=gpu:1 \

--mem-per-cpu=4000 --account=def-razoumov-ac

When the job starts, it’ll return a prompt on the assigned compute node.

(2) On the compute node inside the job start the ParaView server using a
special version of ParaView with EGL support
$ module load paraview-offscreen-gpu/5.4.0
$ unset DISPLAY # so that PV does not attempt to use X11 rendering context
$ pvserver # --egl-device-index=0 not needed: first GPU is #0 inside the job

For multiple GPUs can use
$ nvidia-smi -L # will return 0, 1, ...

The pvserver command will return something like
Waiting for client...
Connection URL: cs://cdr347.int.cedar.computecanada.ca:11111
Accepting connection(s): cdr347.int.cedar.computecanada.ca:11111
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Interactive client-server rendering on a cluster’s GPU
... continued

(3) On your desktop set up ssh forwarding to the ParaView server port:

$ ssh username@cedar.computecanada.ca -L 11111:cdr347:11111

(4) On your desktop start ParaView 5.4.x and edit its connection properties
under File - Connect - Add Server (name = Cedar, server type =
Client/Server, host = localhost, port = 11111), click Configure → Manual
→ Save, then select the server from the list and click on Connect
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Interactive client-server rendering on a cluster’s GPU
... continued

• ParaView’s client and server must have matching major versions (5.4.x)

• Occasionally during client-server connection might get an error “Only
EGL 1.4 and greater allows OpenGL as client API”

I the GPU is stuck in a strange state ⇒ need to reboot the node (let us know!)

• In ParaView’s preferences can set Render View -> Remote/Parallel
Rendering Options -> Remote Render Threshold (beyond which
rendering will be remote)

I default 20MB ⇒ small rendering will be done on your laptop’s GPU,
interactive rotation with a mouse will be fast, but anything modestly
intensive (under 20MB) will be shipped to your laptop and might be slow

I 0MB ⇒ all rendering (including rotation) will be remote, so you will be
really using the cluster’s GPU for everything
• good for large data processing
• not so good for interactivity

I experiment with the threshold to find a suitable value
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Serial client-server software rendering
Details in http://bit.ly/2x5zIB6

(1) On Cedar or Graham submit a serial interactive job:

$ salloc --time=0:30:0 --ntasks=1 --account=def-razoumov-ac

When the job starts, it’ll return a prompt on the assigned compute node.

(2) On the compute node inside the job start a ParaView server

$ module load paraview-offscreen/5.3.0
$ pvserver --use-offscreen-rendering --mesa-swr-avx2

The pvserver command will return something like

Waiting for client...
Connection URL: cs://cdr544.int.cedar.computecanada.ca:11111
Accepting connection(s): cdr544.int.cedar.computecanada.ca:11111

(3) On your desktop set up ssh forwarding to the ParaView server port:

$ ssh username@cedar.computecanada.ca -L 11111:cdr544:11111

(4) On your desktop start ParaView 5.3.x and edit its connection properties under File - Connect
- Add Server (name = Cedar, server type = Client/Server, host = localhost, port = 11111), click
Configure → Manual → Save, then select the server from the list and click on Connect
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Parallel client-server software rendering
Details in http://bit.ly/2x5zIB6

(1) On Cedar or Graham submit a parallel interactive job:

$ salloc --time=0:30:0 --ntasks=4 --mem-per-cpu=2000 --account=def-razoumov-ac

When the job starts, it’ll return a prompt on the assigned compute node.

(2) On the compute node inside the job start a parallel ParaView server

$ module load paraview-offscreen/5.3.0
$ srun pvserver --use-offscreen-rendering

The pvserver command will return something like

Waiting for client...
Connection URL: cs://cdr544.int.cedar.computecanada.ca:11111
Accepting connection(s): cdr544.int.cedar.computecanada.ca:11111

(3) On your desktop set up ssh forwarding to the ParaView server port:

$ ssh username@cedar.computecanada.ca -L 11111:cdr544:11111

(4) On your desktop start ParaView 5.3.x and edit its connection properties under File - Connect
- Add Server (name = Cedar, server type = Client/Server, host = localhost, port = 11111), click
Configure → Manual → Save, then select the server from the list and click on Connect
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Parallel client-server software rendering
... continued

• Works faster on 4 cores!

• Switch to surface view, pass your dataset through Filters -
ProcessIdScalars, colour by ProcessId to check that rendering is
happenning in parallel
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VNC: no solution in place yet

• Cedar: at first one of standard login nodes (no GPUs) will be dedicated to
software rendering

I secure VNC setup with user authentication, not under the scheduler
I more such nodes might be added later
I next few months

• Graham: several GPU login nodes will be added to the system, to be
used for visualization

I secure VNC setup with user authentication, not under the scheduler
I multiple users sharing individual physical GPUs
I no ETA yet

• Wide variety of VNC-like setups on legacy systems across the country
I on legacy WestGrid clusters users start a VNC server manually inside a

submitted job, set up VNC port forwarding, connect a client
I same can be done right now on Cedar and Graham, but the setup is a little

bit cumbersome
I no user-space VNC servers are allowed on login nodes
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Off-screen batch rendering with scripts

• Very large renderings cannot be done interactively (they take too long!)
⇒ submit a batch rendering job and come back to a nice visualization in a few

hours or the next day
I can be performed on any combination of GPUs or CPUs, but details vary

• Automate mundane or repetitive tasks, e.g., making mutiple frames of a
movie

Workflow in any Linux-compatible visualization tool with a programming
interface (in a compiled or interpreted language) can be scripted on a cluster
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Open-source 3D vis. tools with scripting interfaces

• Many domain-specific packages support scripting, e.g., VMD (Visual
Molecular Dynamics) provides Python and Tcl interfaces

I to get batch visualization help with any domain-specific tool, please contact
us

• General-purpose tools

I VTK (Visualization Toolkit) library has C++, Tcl/Tk, Java and Python
interfaces – can be used as a standalone renderer

I Mayavi2, a serial 3D interactive scientific data visualization package, has an
embedded Python shell

I both VisIT and ParaView provide Python scripting (and compiled language
interfaces for in-situ visualization)
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Writing ParaView Python scripts

(1) Use Tools→ Start/Stop Trace to
produce a volume rendering script

(2) Debug the script either in
client-server or standalone on your
laptop

(3) Before multi-hour batch
renderings, make sure the script
works with cluster’s ParaView:

I file paths
I cluster’s ParaView version (its

Python library is evolving
quickly!)

I support for third-party libraries,
formats, etc.
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Running ParaView scripts

• I put an optimized version of the script static.py inside remote.zip

• Many ways to run this script:
I open ParaView’s built-in Python interpreter Tools→ Python Shell, load the

script with Run Script
I paraview --script=static.py
I pvpython will give you a Python shell (connected to a ParaView server

without the GUI) into which you can copy and paste the script
I pvbatch --use-offscreen-rendering static.py
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Another quick script to test parallel rendering

The script spheres.py

1 uses ProcessIdScalars filter to assign a
unique scalar (0, 1, 2, ...) to each
subdomain of the dataset according to
which processor it resides on,

2 colours the corresponding subdomain
with a unique colour and renders it as a
semi-transparent volume,

3 drops 5000 random spheres and scales
them by the value of the function at that
location,

4 colours these spheres by the colour of its
host subdomain
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Software batch rendering
Off-screen batch visualization on CPU nodes

(1) On Cedar or Graham prepare our environment

$ module load paraview-offscreen/5.3.0
$ cd ~/remote && /bin/rm *.png

(2) Start with an interactive job

$ salloc --time=0:30:0 --ntasks=1 --mem-per-cpu=2000 --account=def-razoumov-ac
$ pvbatch --use-offscreen-rendering static.py # should produce volume.png
$ exit # terminate the interactive job

• It would read data from disk, do rendering, and write the resulting image
to disk – all without opening any windows
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Software batch rendering
... continued

(3) Next run it as a serial batch (non-interactive) job

# ! / b in / bash
#SBATCH - -t ime = 0 0 : 0 5 : 0 0 # w a l l t i m e in d−hh :mm or hh :mm: s s f o r m a t
#SBATCH - -j ob−name=" q u i c k t e s t "
#SBATCH - -mem=2000 # in MB
#SBATCH - -a c c o u n t =d e f−razoumov−ac
pvbatch - -use−o f f s c r ee n−rendering s t a t i c . py

$ /bin/rm *.png
$ sbatch s1.sh # should produce volume.png
$ squeue -u razoumov
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Software batch rendering
... continued

(4) Now run it as a parallel batch job

# ! / b in / bash
#SBATCH - -n t a s k s =4 # number o f MPI p r o c e s s e s
#SBATCH - -t ime =0−00:05 # w a l l t i m e in d−hh :mm or hh :mm: s s f o r m a t
#SBATCH - -mem−per−cpu =2000 # in MB
#SBATCH - -a c c o u n t =d e f−razoumov−ac
srun pvbatch - -use−o f f s c re e n−rendering s t a t i c . py

$ /bin/rm *.png
$ sbatch p1.sh # runs static.py on 4 cores, should produce volume.png
$ squeue -u razoumov
$ sbatch p2.sh # runs spheres.py on 4 cores, should produce regions.png
$ sbatch p3.sh # runs spheres.py on 8 cores, should produce regions.png
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GPU batch rendering on Cedar/Graham

Let’s run a serial GPU job

# ! / b in / bash
#SBATCH - -g r e s =gpu : 1 # GPUs p e r node
#SBATCH - -mem=2000M # memory p e r node
#SBATCH - -t ime =0−05:00 # w a l l t i m e in d−hh :mm or hh :mm: s s f o r m a t
#SBATCH - -a c c o u n t =d e f−razoumov−ac
unset DISPLAY
pvbatch s t a t i c . py

$ /bin/rm *.png
$ module load paraview-offscreen-gpu/5.4.0
$ sbatch gpu.sh # should produce volume.png
$ squeue -u razoumov
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Extending the script
Typing commands inside ParaView’s Python shell with an active view

>>> help ( GetActiveCamera )
Help on funct ion GetActiveCamera in module paraview . simple :

GetActiveCamera ( )
Returns the a c t i v e camera for the a c t i v e view . The returned object
i s an i n s t a n c e of vtkCamera .

>>> dir ( GetActiveCamera ( ) ) # l i s t a l l t h e f i e l d s and methods o f t h e o b j e c t
[ ’ AddObserver ’ , ’ ApplyTransform ’ , ’ Azimuth ’ , ’ BreakOnError ’ , ’

ComputeViewPlaneNormal ’ , ’ DebugOff ’ , ’DebugOn ’ , ’DeepCopy ’ , ’ Dolly ’ , ’
E levat ion ’ , ’ Fas tDe le te ’ , ’ GetAddressAsString ’ , ’
GetCameraLightTransformMatrix ’ , ’ GetClassName ’ , ’ GetClippingRange ’ , ’
GetCommand ’ , ’ GetCompositeProjectionTransformMatrix ’ , ’ GetDebug ’ , ’
G e t Di re c t io nO fP r o j ec t i on ’ , ’ GetDistance ’ , ’ GetEyeAngle ’ , ’ GetEyePlaneNormal ’ ,

’ GetEyePosit ion ’ , ’ GetEyeSeparation ’ , ’ GetEyeTransformMatrix ’ , ’ GetFocalDisk
’ , ’ GetFocalPoint ’ , ’ GetFreezeFocalPoint ’ , ’ GetFrustumPlanes ’ , ’
GetGlobalWarningDisplay ’ , ’ GetLeftEye ’ , ’GetMTime ’ , ’ GetModelTransformMatrix ’
, ’ GetModelViewTransformMatrix ’ , ’ GetModelViewTransformObject ’ , ’
GetOrientat ion ’ , ’ GetOrientationWXYZ ’ , ’ G e t P a r a l l e l P r o j e c t i o n ’ , ’
G e t P a r a l l e l S c a l e ’ , ’ GetPos i t ion ’ , ’ GetProject ionTransformMatrix ’ , ’
GetPro jec t ionTransformObject ’ , ’ GetReferenceCount ’ , ’ GetRoll ’ , ’
GetScreenBottomLeft ’ , ’ GetScreenBottomRight ’ , ’ GetScreenTopRight ’ , ’
GetThickness ’ , ’ GetUseHorizontalViewAngle ’ , ’ GetUseOffAxisPro ject ion ’ , ’
GetUserTransform ’ , ’ GetUserViewTransform ’ , ’ GetViewAngle ’ , . . . ]
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Extending the script (cont.)

>>> help ( GetActiveCamera ( ) . Azimuth )
Help on b u i l t−in func t ion Azimuth :

Azimuth ( . . . )
V. Azimuth ( f l o a t )
C++: void Azimuth ( double angle )

Rotate the camera about the view up vector centered at the f o c a l
point . Note t h a t the view up vector i s whatever was s e t via
SetViewUp , and i s not n e c e s s a r i l y perpendicular to the d i r e c t i o n
of p r o j e c t i o n . The r e s u l t i s a h o r i z o n t a l r o t a t i o n of the
camera .
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Extending the script (cont.)

• Inside static.py let’s replace the line
SaveScreenshot(’/home/razoumov/remote/volume.png’, renderView1)

with the following:
camera = GetActiveCamera()
numberOfFrames = 90
for i in range(numberOfFrames):

camera.Azimuth(1) # rotate by 1 degree
SaveScreenshot(’/home/razoumov/remote/frame%04d’%(i)+’.png’,

view=renderView1)

and save the script as spin.py

• Run it as a single-processor batch job
# ! / b in / bash
#SBATCH - -t ime = 0 0 : 1 5 : 0 0 # g i v e i t a l i t t l e b i t more t ime
#SBATCH - -j ob−name=" q u i c k t e s t "
#SBATCH - -mem=2000 # in MB
#SBATCH - -a c c o u n t =d e f−razoumov−ac
pvbatch - -use−o f f s c re e n−rendering spin . py

$ sbatch s2.sh # should produce frame{0000..0089}.png
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Creating a movie

• This produces 90 files frame0000.png, ..., frame0089.png each rotated by
one degree compared to the previous one

• Can merge them into a movie with a third-party tool, e.g., ffmpeg from
nixpkgs/16.09 module:
$ which ffmpeg
/cvmfs/soft.computecanada.ca/nix/var/nix/profiles/16.09/bin/ffmpeg
$ ffmpeg -r 30 -i frame%04d.png -c:v libx264 -pix_fmt yuv420p \

-vf "scale=trunc(iw/2)*2:trunc(ih/2)*2" spin.mp4
...
$ ls -l spin.mp4
-rw-rw-r-- 1 razoumov razoumov 220K Oct 1 16:43 spin.mp4

Very smooth three-second 800× 800 movie!
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Multiple files and garbage collection

• Very often a researcher deals with a sequence of files, e.g., with outputs
from a time-dependent simulation at specific regular intervals

• For many file formats, ParaView has built-in ability to recognize a
sequence of similar files (or multiple variables in a single file) as a time
sequence and animate them without any special effort, producing a
movie (*.avi, *.ogv, *.png sequence)

• When this does not work, it can be useful to write the script for a single
frame and then enclose it into a loop by hand

1 read a data file #i

2 produce visualization

3 output an image #i

• It is important to delete all memory-intensive objects at the end of each
loop
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Visualization on VMs in Compute Canada Cloud
Details in http://bit.ly/2xaHWI0

Arbutus system at the University of Victoria
• OpenStack cloud providing virtual machines (VMs)
• users have root access inside a VM, can install their own software stack
• now at 7,640 CPU cores / 500TB persistent storage / 76TB RAM
• in production since September 2016

Prerequisites for visualization in a VM:

à your own cloud VM
https://docs.computecanada.ca/wiki/CC-Cloud

à system dependencies for compiling ParaView or VisIt
à a copy of ParaView or VisIt compiled with Python, Mesa (open-source

OpenGL implementation supporting software rendering), support for
your input file format – need to compile your own!

You can find all compilation and client-server usage instructions for both
ParaView and VisIt in a cloud VM in http://bit.ly/2xaHWI0
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Summary: these orthogonal decisions are yours to make

(1) interactive vs. batch
• interactive client-server for a quick look, exploration or debugging

I another option is to download a scaled-down version of your dataset, debug a script
locally on your laptop, and then run it as a batch job on the original full-resolution
dataset on the cluster

• batch really preferred for production jobs and producing animations

(2) CPU vs. GPU
• in general, no single answer which one is better

I you can throw many CPUs at your rendering job
I modern software rendering libraries such as OSPRay (Intel’s ray tracing) and

OpenSWR (Intel’s rasterizer) can be very fast, depending on your visualization

• might have to resort to software rendering if no GPUs are available (e.g.,
all are taken by GP-GPU jobs)

• no GPUs in the cloud system
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Questions?

• Webstream viewers: email info@westgrid.ca

• Vidyo viewers: unmute & ask question or use Vidyo Chat
(chat bubble icon in Vidyo menu)

• Email me anytime alex.razoumov@westgrid.ca

• Support email support@computecanada.ca
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