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Scientific Visualization with VisIt

ALEX RAZOUMOV
alex.razoumov@westgrid.ca

slides in collaboration with Marcelo Ponce (SciNet)

3 install VisIt from http://goo.gl/KcGWHa

3 slides and data files at http://bit.ly/visitzip (∼26 MB)
F optional data for movies at http://bit.ly/2dTxkqx (∼361 MB)
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Workshop outline
9AM-NOON ë MORNING SESSION, COFFEE BREAK @ ∼10:30AM

Introduction to scientific visualization
I general ideas, tools, plotting vs. multi-dimensional visualization
I overview of current general-purpose multi-dimensional visualization tools

VisIt basics: GUI, loading files, plots and operators
I working with plots: overview, pseudocolour, contour, volume, ...
I working with operators: slice, clip, threshold, isosurface, ...

Quantitative analysis with VisIt
I invited session by Artem Korobenko (Mechanical and Manufacturing Engineering)
I data at http://bit.ly/2pCYMis (127MB)

VisIt: professional quality plots (fine tuning) & animation

NOON-1PM ë YOU ARE ON YOUR OWN FOR LUNCH

1PM-4PM ë AFTERNOON SESSION, COFFEE BREAK @ ∼2:30PM

Python scripting in VisIt
Remote and distributed visualization with VisIt
Summary
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Ready to show your research or your visualization skills?

Spring: SEEING BIG showcase (since 2015)
I researchers submit visualizations to showcase their own research
I March-01 to May-31 submission window
I entries are displayed in a video loop on a large 3840× 2160 flat screen in

the conference lobby at HPCS in June
I now accepting 2017 submissions http://bit.ly/2l9FrR7
I don’t be afraid to submit your work: we can help you with visualization!

Fall: VISUALIZE THIS! challenge (since 2016)
I all participants work on the same dataset or problem
I competition with prizes; points awarded for interactive 3D visualization,

innovative techniques to display multiple variables
I one-month competition in 2016, likely two months in 2017
I emphasis on creating something useful for the scientific community;

techniques will be published online
I always looking for interesting problems; suggestions welcome!
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Introduction
to scientific visualization
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Visualization is the
process of mapping
(scientific) data into
“visual form”

Much easier to
understand images than a
large set of numbers

For interactive data
exploration, debugging,
communication with
peers

Many examples from
different fields of science
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1D/2D plotting vs. multidimensional visualization

è1D and 2D plotting

plotting 1D/2D functions and tabulated
data, charts, using eg. gnuplot, xmgr, or
Python’s matplotlib, bokeh and other li-
braries, R’s ggplot2 and its derivatives, or
various derivatives of D3.js
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è multidimensional visualization
usually displaying 3D datasets, typically spa-
tially extended data on structured grids, or on
unstructured meshes that have some topology
in 2D/3D
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Open-source vs. proprietary

Whatever you do, may be a good idea to avoid proprietary tools,
unless those tools provide a clear advantage (most likely not)

large $$

limitations on where you can run them, which
machines/platforms, how many cores, etc.

once you start accumulating scripts, you lock yourself into using
these tools forever, and consequently paying $$ on a regular basis

quite often the user base is smaller than for open-source tools,
hence more difficult to get help from the community

with a little bit of coding, there is nothing you cannot do with
open-source tools, and we are happy to help!
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1D/2D: Matplotlib gallery with hundreds of examples

http://matplotlib.org/gallery.html – click on any plot
to get its source code
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1D/2D: Bokeh gallery

Open-source project from Continuum Analytics
http://bokeh.pydata.org/docs/gallery.html

Produces dynamic data visualizations in the web browser via
html5
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Multidimensional open-source visualization packages
è gnuplot: command-driven interactive 2d and 3d plotting program

è Gephi, GraphViz: graph visualization

è HDFview: visual tool for browsing and editing HDF4 and HDF5 files

è ImageMagick: manipulation of image

è MayaVi: serial 3D scientific data visualizer (Python + VTK)

è Molden: pre/post-processing for molecular and electronic structures

è OpenDX: very old, not mantained, but really nice interface and ideas

è ParaView: parallel scientific visualization

è SciLab: open-source platform for numerical computation

è VisIt: large-scale scientific visualization

è XCrysDen: crystaline and molecular structure visualization

è yt: Python library for visualizing AMR datasets

è VMD: visualization for molecular dynamics
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2D/3D visualization packages
Desired features for large-scale scientific visualization

Visualize scalar and vector fields
Structured and unstructured meshes in 2D and 3D, particle data,
polygonal data, irregular topologies
Ability to handle very large datasets (GBs to TBs)
Ability to scale to large (103 − 105 cores) computing facilities
Interactive manipulation
Support for scripting, common data formats, parallel I/O
Open-source, multi-platform, and general-purpose
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Visualization Toolkit (VTK) library
http://www.vtk.org

For 3D computer graphics, image
processing and visualization
Open source, multi-platform
Supports distributed computation
models
Extensible modular architecture
Collection of C++ libraries

Leveraged by many applications

Divided into logical areas
I filtering
I information visualization
I volume rendering

Cross-platform, using OpenGL for
GPU acceleration
Wrapped in Python, Tcl, Java

VTK file formats can encode spatial data defined on Cartesian, rectilinear, curvilinear
grids, on particles, on unstructured 2D (polygonal) and unstructured 3D meshes

ç ParaView and VisIt are end-user applications supporting:
ß parallel data reading/processing/rendering
ß single-node, client-server, MPI cluster rendering
ß 100+ input file formats, many different rendering options
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VisIt overview
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VisIt
http://visit.llnl.gov

Developed by the DOE Advanced Simulation and
Computing Initiative (ASCI) to visualize results of
terascale simulations
First release fall of 2002, mantained by LLNL
Currently ∼ 20 developers from different
organizations and universities
v2.12 available as source and binary for Linux,
Mac, Windows http://bit.ly/2dMH091
Over 80 visualization features (contour, mesh,
slice, volume, molecule, ...)
Reads over 120 different file formats
http://bit.ly/2egAkzA

Interfaces with C++, Python, and Java
Uses MPI for distributed-memory parallelism on
HPC clusters
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VisIt

Can run locally, remotely, in the
client/server mode

GUI looks pretty much the same on each
platform

New database plugin readers can be
developed

Provides a library for in-situ visualization
(libsim), to instrument your simulation code for
VisIt to connect to, as though the simulation was
a VisIt compute engine

Supported mesh types:

I 1D curves
I 2D/3D: Cartesian, rectilinear, curvilinear,

unstructured, points, AMR, molecular,
CSG (constructive solid geometry)

è VisIt Architecture

VCL = VisIt Component Launcher
VisIt Workshop May 2017 16 / 111
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VisIt: multiple interfaces

GUI (graphical user
interface)
Python programming
interface
Java programming
interface
C++ programming
interface

Use multiple interfaces simultaneously

è use VisIt as an application or a library
è C++, Python, Java interfaces allow other
applications to control VisIt
è we’ll see an example of this with Python
where we can attach a Python shell to a
VisIt session running on a specific port on
your laptop
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VisIt: GUI
GUI window

ß select files to visualize
ß create and manage plots
ß set plot attributes
ß add operators
ß set look and props. for

visualization
ß “Apply to...” really useful

Viewer window

ß display all of the data being
visualized

ß mouse navigation
ß up to 16 vis windows
ß popup menu
ß toolbars
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VisIt’s pipeline and core abstractions

1 Open a database
2 Create a plot
3 Set plot attributes
4 Apply operators to plot to

modify data
5 Set operator attributes
6 Compute engine generates

a plot displayed in the vis.
window

7 Iterate/repeat ...
8 Save your visualization

ß Databases
I interchangeable with “dataset” or “file”
I data can be defined on nodes (ParaView’s

points) or zones (ParaView’s cells)
ß Plots

I visualize (render) the data
I similar to ParaView’s representations

(Surface, Volume, Wireframe, etc)
ß Operators

I manipulate (process) the data
I similar to ParaView’s filters

ß Expressions
I derive quantities
I similar to ParaView’s Calculator filter and

Programmable Filter
ß Queries

I obtain quantitative info
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Importing data into VisIt
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Importing your dataset into VisIt

3 If your code generates one of 120+ formats natively understood by VisIt
⇒ you are all set

3 If you want to save a 2D/3D array of a scalar or vector variable (defined
on a Cartesian grid) ⇒ store your data in NetCDF or VTK

I NetCDF libraries are available for pretty much any programming
language (C, C++, F90, Python, R, Java, ...)

3 If your grid is rectilinear, curvilinear (e.g., cylindrical or spherical),
unstructured, or your variable is on particles (atoms, N-body) ⇒ store
your data in one of the VTK formats

3 For small datasets can import CSV (forward four slides)

3 Anything else (e.g., structured non-spatial data) ⇒ let me know

For large datasets do not:

7 store your data as ASCII: ∼5X more space/bandwidth than binary

7 use raw binary: not portable, no descriptive metadata
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Importing your dataset into VisIt: VTK file formats

Legacy serial format (*.vtk): ASCII header
lines + ASCII/binary data

I check two purely ASCII examples

(1) datasets/volume.vtk is 3× 4× 6
Structured Points

(2) datasets/density.vtk is 2× 2× 2
Structured Grid

I can use these as templates for small files

XML formats (extension depends on VTK
data type): XML tags +
ASCII/binary/compressed data

- newer, much preferred to legacy VTK
- supports parallel file I/O, compression, portable binary

encoding (big/little endians byte order), etc.
- could link your code against a compiled VTK library in

C/C++, or install it in Python 2.x (not available in
Python 3.x) with a package manager, e.g., conda

- another option is PyEVTK library, although does not
provide all the bells and whistles
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PyEVTK library https://bitbucket.org/pauloh/pyevtk

hg clone https://bitbucket.org/pauloh/pyevtk
cd pyevtk
python setup.py install --prefix=/Users/razoumov/miniconda

Works in both Python 2 and Python 3
Many examples in src/examples/{image,points,
rectilinear,structured,group,lowlevel}.py

from evtk . hl import imageToVTK
from numpy import zeros
n = 30
data = zeros ( ( n , n , n ) , dtype= f l o a t )
f o r i in range ( n ) :

x = ( ( i +0 .5)/ f l o a t ( n )∗2 . −1 . )∗1 . 2
f o r j in range ( n ) :

y = ( ( j +0 .5 )/ f l o a t ( n )∗2 . −1 . )∗1 . 2
f o r k in range ( n ) :

z = ( ( k +0.5)/ f l o a t ( n )∗2 . −1 . )∗1 . 2
data [ i ] [ j ] [ k ] = ( ( x∗x+y∗y−0.64)∗∗2 + ( z∗z−1. )∗∗2) ∗ \

( ( y∗y+z∗z−0.64)∗∗2 + ( x∗x−1. )∗∗2) ∗ \
( ( z∗z+x∗x−0.64)∗∗2 + ( y∗y−1. )∗∗2)

imageToVTK ( " decoCube " , pointData ={ " s c a l a r " : data } )
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Exercise: visualizing 3D data with legacy VTK

We will come back to this exercise after we cover the basics

Visualize a 3D “cylinder” function
inside a unit cube (x, y, z ∈ [0, 1])

f (x, y, z) = e−|r−0.4|

where r =
√
(x− 0.5)2 + (y− 0.5)2

à reproduce the view on the right

You have two options:

(1) datasets/cylinder.dat contains data in ASCII
I add an appropriate header to create a legacy VTK file
I use either datasets/volume.vtk as a template

(2) Use PyEVTK in Python to create an XML VTK file with binary data
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Example of reading a CSV: country prosperity index

Data from the Legatum 2015 Prosperity Index
http://www.prosperity.com/#!/ranking (click on
Scores, best to copy/paste from Firefox)

Take a look at the data in legatum2015.csv:
8 rankings for each country

3D position by economy +
entrepreneurshipOpportunity + governance,
colour by education

AddH → Scatter , select the axes and then

click Draw , in plot properties under
Appearance tab set Point Type = Sphere, set
radius

In the plot on the right size by safetySecurity
was done in ParaView, a little bit more difficult
to do this in VisIt

Can use Controls → Expressions... to name

variables to appear on the axes

This is quick demo of reading a CSV

ß do not attempt to run this now
ß we’ll dive into the GUI details

shortly
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Why CSV is not such a good idea for large datasets

Let’s generate and store 106 particles with x, y, z ∈ [0, 1]:

the following produces a 43M file (without spaces!)

from random import random
for i in range(int(1e6)):

print str(random())+’,’+str(random())+’,’+str(random())

the following produces a 14M file (still in double precision)

from writeNodesEdges import writeObjects
from random import random
coords = []
for i in range(int(1e6)):

coords.append([random(),random(),random()])
writeObjects(coords, fileout=’test’, method = ’vtkUnstructuredGrid’)

In this VTK there is no data on top of the mesh, but still easy to visualize:
AddH → Mesh → mesh

With both gzip-compressed, still a factor of 2X discrepancy
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VisIt basics
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Reading data from files

Importing datasets

File → Open file...
and select the data
file (e.g.,
noise.silo)
It becomes available
in Active source
File
→ File information...
will give you some
info about the dataset

Restoring a previous session

File → Restore session...
loads the previous state of
the given session (that
needs to be specifically
saved)

File
→ Restore session w/sources...
is extremely useful for
re-identifying datasets that
could have been moved or
renamed

Be aware that by default VisIt won’t save your work (session) nor ask
you when you try to exit the program!
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Contours

(1) AddH → Contours
 hardyglobal and
then click Draw
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Contours

(1) double-click on
Contour-hardyglobal

(2) under Select by, choose N
levels = 5 Enter

(3) change opacity levels, e.g.
50%, 60%, 60%, 48%, 24%

(4) Apply & Dismiss

(5) Hide/Show or Delete
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PseudoColor & IsoSurfaces

(1) AddH → Pseudocolor

 hardyglobal→ Draw

(2) OperatorsH → Slicing

→ Isosurface → Draw

(3) click I to expand, double click on [Isosurface]

(4) under Select by, choose Percent (s) = 50 Apply & Dismiss

(5) change the opacity of [Pseudocolor]
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PseudoColor & IsoSurfaces

(1) unselect the [Apply ...]
check-boxes

(2) add one more
Pseudocolor+Isosurface
w/Percent(s)=80 &
adjust its opacity

(3) select/check the [Apply...] boxes

(4) OperatorsH → Selection → Clip and select a combination of
unequal planes to modify the Clip
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General remarks

Operators/plots can be removed Delete or hidden Hide/Show

Save your work frequently: File → Save session...
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Slices

(1) Start from scratch

(2) AddH → Pseudocolor

 hardyglobal→ Draw

(3) OperatorsH → Slicing

→ ThreeSlice → Draw
(4) Optionally reposition the

planes
(5) Optionally add a second light

at ∼ 45◦ elevation on a side
Controls → Lighting...

(don’t forget to enable it)
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Vector field representation with glyphs

(1) With noise.silo loaded and no prior
plots
AddH → Vector  grad and click

Draw
(2) Double-click on Vector and set Vector

placement = Uniformly located throughout
mesh, Vector amount = 3000

(3) Optionally can play with the glyph
properties under Glyph tab

(4) Under VariablesH can switch to a
different vector field (see on the right)
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Vector field representation with streamlines
(1) With noise.silo loaded and no prior plots

AddH → Pseudocolor → operators → IntegralCurve  grad, click Draw
(2) Double-click on IntegralCurve, in Integration tab set Source type = Plane, Origin = (0,0,0),

Normal = (0,1,0), Up axis = (0,0,1), Sampling type = Uniform, 15 samples in X/Y, Distance in
X/Y = 20, Integration direction = Both, Max number of steps = 1000

I the "up axis" serves as the "Y" axis embedded in the plane
I distance in X/Y is the size of the source rectangle in the plane

(3) OperatorsH → Geometry → Tube , click Draw

(4) Double-click on Tube, set Radius = 0.003
(5) Uncheck “Apply operators to all plots”

(6) AddH → Pseudocolor  hardyglobal

(7) OperatorsH → Selection → Clip

(8) Double-click on Clip, modify its properties to reproduce
the picture on the right

(9) Next, experiment with with different Source types in
IntegralCurve
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Streamlines: final touches

Now the volume is coloured by hardyglobal, and the streamlines
by grad
Let’s colour streamlines by hardyglobal

I Double-click on IntegralCurve, under Appearance tab set Data
value = Variable, and from the menu on the right select Scalars
 hardyglobal, click Apply

I Inspect your visualization to verify that both are coloured by the
same variable

Very easy to turn on/off legends, user info, axes via Controls
→ Annotation...

File → Save Window to save the image
I by default, on Mac/Linux will go into either the home directory, or

the directory from which VisIt was launched
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Exercise: slice

Try to reproduce the picture on the
right

Delete the Clip

Slice the previous plot AddH
→ Pseudocolor  hardyglobal
with OperatorsH → Slicing

→ Slice
Invert the background
Change both colour maps
Make the tubes thicker
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Exercise: volume rendering

Try to reproduce the picture on the right

Delete the slice and the hardyglobal plot, keep
the streamlines

Add AddH → Volume  hardyglobal

Double-click on Volume, under 1D transfer
function tab set the Opacity, under Renderer
Options tab set “Ray casting: compositing”,
click Apply and Draw

I on my laptop takes ∼10s to render
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Controls

We already saw some Controls
menu items

I Lighting... to set new lights,
disable old ones, set their
position, colour, brightness

I Annotation... to set legends,
axes, dataset name, user info

Some other useful ones
I Database Correlations... to

create correlations between 6=
datasets

I Expressions... to create
expressions (new quantities)
from variables/datasets

I View... to list all camera setup
variables
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Hands-on

Load some of the other datasets (testRectilinearGrid.vtk,
headsq.vti) or your own data!!!
Try to explore the data and visualize it, using some of the tools we
have discussed
If you have used other visualization packages (ParaView?),
compare whether it is possible (and how easy) to obtain similar
results with those tools
Which tool/package/library is more intuitive, elegant, useful for
you and your research?

More datasets available for playing, at: http://www.visitusers.org/index.php?title=Tutorial_Data
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Quantitative analysis
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Quantitative analysis

Expressions (similar to ParaView’s Calculator filter)

Pick modes: zone/node, spreadsheet, time curves

Lineout mode (similar to ParaView’s Plot Over Line filter)

Queries

Creating new database correlation time sliders
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Expressions

Create new derived variables from existing ones

Mathematical expressions can operate on scalars, vectors, tensors

Option 1: use Standard Editor to select existing functions and
expressions

I similar to ParaView’s Calculator filter

Option 2: use Python Expression Editor - this is an advanced
option for working with VTK objects

I similar to ParaView’s Programmable Filter
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Expressions

* Load noise.silo , visualize hardyglobal with Pseudocolor

Controls → Expressions... → New , set name = squared , type = Scalar Mesh
Variable, definition = hardyglobalˆ2 , click Apply
Now in the list of variables switch to squared

* Controls → Expressions... → New , set Name = gradient , Type = Vector
Mesh Variable, Definition = gradient(hardyglobal)
You can use the dropdown menus to accelerate typing (gradient will be found in
Insert Function→ Miscellaneous)
Add a vector plot to show gradient , picking “Uniformly located troughout the
mesh”, displaying 5000 vectors, making them bigger, overlaying onto a
semi-transparent Pseudocolor plot of hardyglobal

* Controls → Expressions... → New , set Name = truncated , Type = Scalar
Mesh Variable, Definition = max(2,hardyglobal)
Now make a Pseudocolor plot of truncated
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Expressions

* Load noise.silo , visualize hardyglobal with Pseudocolor

Controls → Expressions... → New , set name = squared , type = Scalar Mesh
Variable, definition = hardyglobalˆ2 , click Apply
Now in the list of variables switch to squared

* Controls → Expressions... → New , set Name = gradient , Type = Vector
Mesh Variable, Definition = gradient(hardyglobal)
You can use the dropdown menus to accelerate typing (gradient will be found in
Insert Function→ Miscellaneous)
Add a vector plot to show gradient , picking “Uniformly located troughout the
mesh”, displaying 5000 vectors, making them bigger, overlaying onto a
semi-transparent Pseudocolor plot of hardyglobal

* Controls → Expressions... → New , set Name = truncated , Type = Scalar
Mesh Variable, Definition = max(2,hardyglobal)
Now make a Pseudocolor plot of truncated
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Expressions

* Load noise.silo , visualize hardyglobal with Pseudocolor

Controls → Expressions... → New , set name = squared , type = Scalar Mesh
Variable, definition = hardyglobalˆ2 , click Apply
Now in the list of variables switch to squared

* Controls → Expressions... → New , set Name = gradient , Type = Vector
Mesh Variable, Definition = gradient(hardyglobal)
You can use the dropdown menus to accelerate typing (gradient will be found in
Insert Function→ Miscellaneous)
Add a vector plot to show gradient , picking “Uniformly located troughout the
mesh”, displaying 5000 vectors, making them bigger, overlaying onto a
semi-transparent Pseudocolor plot of hardyglobal

* Controls → Expressions... → New , set Name = truncated , Type = Scalar
Mesh Variable, Definition = max(2,hardyglobal)
Now make a Pseudocolor plot of truncated
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Zone/node pick mode

Interactively pick values inside the visualization window

Load noise.silo , visualize hardyglobal with Pseudocolor, apply
OperatorsH → Selection → Clip and click Draw

Data here is defined on nodes, not zones

Right click on the visualization, select Mode → Zone Pick (or
use a mode button in the vis window toolbar), and click anywhere
on the vis – it’ll display 8 nodes forming the zone, and their
variable values

I each pick point leaves a marker that you can look up in the Pick
window

I the Pick window displays information in tabs arranged by a point

Similarly, Mode → Node Pick will display a single node, its
variable, and its 8 “incident” zones
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Spreadsheet pick mode and time curves in the picks

Selecting Mode → Spreadsheet Pick shows a spreadsheet view
of one of the dataset variables highlighting the picked node (i,j,k)
and its value of the variable

I the spreadsheet window is controlled from the pipeline!

Mode → Navigate will take you back to default interaction

Try loading a time-dependent dataset, e.g., 2d0**.vtk , and display
it in Pseudocolor

I a time slider will become active
I depending on the data use either Zone Pick or Node Pick
I inside the Pick window in the Time Pick tab select “Do time curve

with next pick”
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Lineout mode

Extracts 1D curves from 2D data (unlike ParaView’s Plot Over Line
filter, does not seem to work on 3D datasets)

Load a 2D dataset or apply OperatorsH → Slicing → Slice to a
3D dataset

Select Mode → Lineout and draw a line ⇒ the profile will be
plotted in a new window
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Queries

Controls → Query...

Option 1: use Standard Queries
I very useful: Memory Usage
I quick ways to probe data: MinMax, NumNodes, NumZones,

Average Value, Volume
I Lineout and Pick are also queries (this time enter selection

manually)
I certain queries provide a “Do Time Query” button that calculates

the query on each time step and creates a curve

Option 2: use Python Query Editor for custom queries
I this is an advanced topic for working with VTK objects
I instead we’ll use Query() in Python scripting (later today)
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Database correlations

In VisIt each time-varying database (if more than one loaded) gets its own
independent slider

Sometimes it’s useful to compare two time-varying databases, but one would
need to set them both to the same moment(s) in time

Controls → Database Correlations... lets you do this with a single time slider
for both databases, using one of four correlation methods

Can try creating a single time slider from 2d0**.vtk and modified0**.vtk

(1) load both databases, for each draw Pseudocolor and apply
OperatorsH → Transforms → Elevate , make them both visible

(2) verify you can animate either switching the active time slider
(3) now select Controls → Database Correlations... , click New , use

Correlation Method = Padded Index, select both Sources and move
them to Correlated Sources, click Create Database Correlation

(4) a new active time slider appears that lets you animate both
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Advanced topics in quantitative analysis

Cross-mesh field evaluation (CMFE) and database comparison
http://bit.ly/2faoAKs

I CMFE expressions evaluate a field from a donor mesh onto a target
mesh to form a new field

I Different ways to access it:

(1) Controls → Data-Level Comparisons...

(2) Controls → Expressions...
(3) Python scripting
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More controls: professional
quality plots and animation
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Professional quality plots

Annotations
Colors
Lighting
Views
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Annotations

Annotations
objects in the vis.
window that convey
information about the
plots
make clear what is being
visualized and make the
visualization appear
more polished

Types of annotations
database name
user name
plot legends
plot axes and labels (2D
& 3D)
3D triad
2D, 3D text
time slider
images
lines and arrows
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2D & 3D annotations

à Controls → Annotation...
è["2D" tab] à Controls → Annotation...

è["3D" tab]
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Colors and backgrounds

à Controls → Annotation...
è["Colors" tab]

Set background/foreground
Background styles:

I solid
I gradient
I image (flat image)
I image sphere (image that

rotates with the view)
I number of image repetitions
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Annotation objects

à Controls → Annotation... è["Objects" tab]
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Lighting
Affects the brightness of plots
3D visualizations may require
multiple light sources
VisIt allows up to 8 sources
Each light source can be
positioned and coloured

à Controls → Lighting...

[Edit]: configure light sources
[Preview]: all sources visible Only the active light can be

modified
Types of lights: ambient,
camera, object light
Position, colour, brightness
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View
(1) “View” can be set interactively in the vis. window (click and drag, ...)

(2) Or using a “View Window” Controls → View...

“Locked view”: when the view changes in any locked window, all
other locked windows readjust to it

I accessible from the [Advanced] tab or Lock menu item in the vis. window
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Saving images to file

(1) File → Set Save option...
allows you to control the
properties of the image: file
type, resolution, naming
convention, etc.

(2) File → Save window
generates the image/file of
the currently displayed
window
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Movie generation

à Sequence in time
(evolution)

à Motion through
space or any property
of any pipeline object
(see the Scripting
section)
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Basic timestep animation
Simplest case: sequence of similar files in time
Allows database behaviour over time to be quickly inspected
(without the complexity of scripting)
Controlled through [VCR]-type buttons in the main window
Load either datasets/evolution/2d*.vtk or
aneurysm_data/aneurysm0*.silo

[Time Slider]

[Main Window]

[Animation Window]

Controls → Animation...
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Movie wizard

à File → Save Movie...

Guided movie generation
can produce several formats
and resolutions, at the same
time
stereo movies
can use currently allocated
processors or spawn another
VisIt session for movie
generation
can use movie templates to
assemble complex sequence
of frames
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Keyframing
Advanced form of animation to “play back attributes”

Attributes that can be keyframed: plots attributes, database states, view
8 operator attributes are mentioned in docs but don’t seem to play back (a bug?)

E.g., can make a plot slowly fade out, slowly spin, etc.

Controls →
Keyframing...

(1) Enable “keyframing mode”

(2) Adjust number of frames
Add a first keyframe: open a plot’s attribute window, change

settings, click its Apply button

Add a second keyframe: move the keyframe time slider to a

later time, change the plot attribute(s) again, click its Apply

button 8 this part often does not seem to work (a bug?)
Each time you add a keyframe to the animation, a small black
diamond (keyframe indicator) will appear
You can drag the keyframe indicator to set the time range for
each attribute
Right-click on a keyframe indicator to delete it

à If time slider present, it changed to “Keyframing Animation” – in this case
simply select the desired active time slider from the pull-down menu
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Hands-on

Using the “aneurysm”
dataset or your own data,
generate a
time-sequence movie
Experiment with
keyframming, lighting,
..., or any of the other
techniques we have
been discussing

More info about this dataset at

http://www.visitusers.org/index.php?title=Blood_Flow_Aneurysm_Tutorial_Dataset_Exploration
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Python scripting in VisIt
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Why scripting?

Automate repetitive GUI tasks

Reproducibility
I a script is a documented workflow
I can easily pass a script to someone else
I can run it yourself years later

Batch processing on large systems (clusters)
I perhaps, no GUI
I submit a rendering job
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Python scripting in VisIt

Launching VisIt’s Python scripts from the Unix command line
without the GUI
$ /path/to/VisIt -nowin -cli -s script.py

I flag -nowin for offscreen (typically OSMesa) rendering
I similar to ParaView’s pvbatch
I very useful for running a batch rendering job on a cluster

Launching VisIt’s Python scripts from the GUI
I VisIt has a built-in Python 2.7 shell through Controls
→ Launch CLI... ; it’ll start VisIt’s Python interpreter in a terminal
and attach it to the running VisIt session on a specific port on your
laptop with a one-time security key

I alternatively, Controls → Command... provides a text editor
with Python syntax highlighting and an Execute button, lets save
up to eight snippets of Python code
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Python scripting in VisIt

Recording scripts from the GUI
I Controls → Command... window lets you record your GUI

actions into Python code that you can use in your scripts (similar to
ParaView’s Trace Tool)

Other places to use Python in VisIt’s GUI
(1) in Controls → Expressions... → Python Expression Editor

(similar to the Programmable Filter in ParaView)
F expressions on VTK datasets
F tutorial at http://bit.ly/2ezF6qr
F can modify the geometry of the dataset, e.g., warp the grid in 3D or

create a projection
F result appears in the list of variables to plot
F more advanced topic for another time

(2) in Controls → Query... → Python Query Editor
F queries on VTK datasets
F more advanced topic for another time
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Adding plots (typing in interactive shell)

Starting from scratch, run Python shell Controls → Launch CLI...
and type in the following commands (adjust the file path!):

OpenDatabase ( "~/teaching/visitWorkshop/ d a t a s e t s /noise . s i l o " )
AddPlot ( " Pseudocolor " , " hardyglobal " )
DrawPlots ( )

Each plot in VisIt has a number of attributes that control its
appearance

To access them, first create a plot attributes object by calling a
function PlotNameAttributes(), e.g., PseudocolorAttributes(), or
VolumeAttributes()

If changing attributes, pass the object to the SetPlotOptions()

If setting new defaults, pass the object to SetDefaultPlotOptions()
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Probing and setting plot attributes (interactive shell)

Note the colour map range in the current plot.
Next, add the following commands:

p = PseudocolorAtt r ibutes ( )
p # w i l l p r i n t out a l l a t t r i b u t e s
p . min , p . max = 1 , 3 # c o l o u r map range
p . minFlag , p . maxFlag = 1 , 1 # turn i t on
SetPlotOpt ions ( p ) # s e t a c t i v e p l o t a t t r i b u t e s
help ( SetPlotOpt ions )

Revert to the original colour map range:

p . minFlag , p . maxFlag = 0 ,0 # turn i t o f f
SetPlotOpt ions ( p )

Pick a different colour map:

p . colorTableName = " Greens " # new c o l o u r map
SetPlotOpt ions ( p )
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Running scriptName.py from inside GUI

Option 1: paste the code into Controls → Command... window
and click Execute

Option 2: inside the Python shell change to the directory
containing your scripts (can use relative or absolute paths) and
source your script

os . getcwd ( ) # t o c h e c k t h e c u r r e n t d i r e c t o r y
os . chdir ( ’/Users/razoumov/teaching/visitWorkshop/ s c r i p t s ’ )
# os . c h d i r ( ’C:\ Users\ J o s h \Desktop \20130216 ’) # Windows example
Source ( ’ scriptName . py ’ )
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Setting attributes before drawing

With noise.silo loaded, let’s draw a plot:
# t h i s i s o ra ng e . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Pseudocolor " , " hardyglobal " )
p = PseudocolorAt tr ibutes ( )
p . colorTableName = " Oranges "
SetPlotOpt ions ( p )
DrawPlots ( )
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Scripting an operator

With noise.silo loaded, run the following:
# t h i s i s addOpera to r . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Pseudocolor " , " hardyglobal " )
AddOperator ( " I s o s u r f a c e " )
i s o A t t s = I s o s u r f a c e A t t r i b u t e s ( ) # c r e a t e an o p e r a t o r a t t r i b u t e s o b j e c t
i s o A t t s . contourMethod = i s o A t t s . Level # c o n t o u r by l e v e l ( s )
i s o A t t s . v a r i a b l e = " hardyglobal "
SetOperatorOptions ( i s o A t t s ) # s e t o p e r a t o r a t t r i b u t e s t o a b o v e v a l u e s
DrawPlots ( )
p r i n t i s o A t t s # d e f a u l t i s 10 i s o s u r f a c e l e v e l s

Now let’s produce 3 single-isosurface plots at hardyglobal = 2., 3.5, 5., respectively:

# t h i s i s t h r e e S u r f a c e s . py
i s o A t t s . contourMethod = i s o A t t s . Value # c o n t o u r by v a l u e ( s )
f o r i in range ( 3 ) :

i s o A t t s . contourValue = 2 . + i ∗1 .5
SetOperatorOptions ( i s o A t t s )

These images play back, but aren’t saved to disk ...
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Saving images to disk

s = SaveWindowAttributes ( )
s . format = s .PNG
s . fileName = ’someName ’
s . outputToCurrentDirectory = 0 # f o r some r e a s o n t h i s i s ’ y e s ’
s . outputDirectory = "/path/to/ d i r e c t o r y "
SetSaveWindowAttributes ( s )
. . .
bui ld and display a p l o t
. . .

name = SaveWindow ( ) # r e t u r n s t h e name o f t h e f i l e i t wro t e

Now let’s save the three surfaces to disk:
# t h i s i s s a v e S u r f a c e s . py
s = SaveWindowAttributes ( )
s . format , s . fileName , s . outputToCurrentDirectory = s .PNG, ’ i s o ’ , 0
s . outputDirectory = "/Users/razoumov/Documents/teaching/visitWorkshop "
SetSaveWindowAttributes ( s )
f o r i in range ( 3 ) :

i s o A t t s . contourValue = 2 . + i ∗1 .5
SetOperatorOptions ( i s o A t t s )
name = SaveWindow ( )
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Animating camera position: create a plot

With noise.silo loaded, draw a single isosurface at hardyglobal = 3.8 in
green:

# t h i s i s o n e S u r f a c e . py
D e l e t e A l l P l o t s ( )
AddPlot ( ’ Contour ’ , ’ hardyglobal ’ )
contAtt = ContourAttr ibutes ( )
contAtt . contourMethod = contAtt . Value
contAtt . contourValue = ( 3 . 8 )
contAtt . colorType = contAtt . ColorBySingleColor
contAtt . s ing leColor = ( 0 , 255 , 0 , 255)
SetPlotOpt ions ( contAtt )
DrawPlots ( )

# t h i s i s p r in tVi ew . py
p r i n t GetView3D ( ) # p r i n t a l l i t s a t t r i b u t e s o f t h e c u r r e n t view
# GetView3D ( ) . viewNormal # can a l s o p r i n t a s i n g l e a t t r i b u t e
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Animating camera position: set a view by hand

Create a view by hand by explicitly setting the important attributes:
# t h i s i s s e t C o n t r o l P o i n t . py
from math import ∗
c0 = View3DAttributes ( )
phi = 0 # 0 <= p h i <= 2∗ p i
t h e t a = 0 # −p i / 2 <= t h e t a <= p i / 2
c0 . viewNormal = ( cos ( t h e t a )∗ cos ( phi ) , cos ( t h e t a )∗ s in ( phi ) , s i n ( t h e t a ) )
c0 . focus , c0 . viewUp = ( 0 , 0 , 0 ) , ( 0 , 0 , 1 )
c0 . viewAngle , c0 . p a r a l l e l S c a l e , c0 . imageZoom = 30 , 1 7 . 3 2 0 5 , 1
c0 . nearPlane , c0 . farPlane , c0 . p e r s p e c t i v e = −34.641 , 3 4 . 6 4 1 , 1
SetView3D ( c0 )

Note: with a trackpad, the zoom scroll is not very smooth, but we can
always set the zoom level with

v a t t s = View3DAttributes ( )
v a t t s . imageZoom = 3
SetView3D ( v a t t s )

or via Controls → View... and setting Image zoom in the GUI
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Animating camera position: set a view by hand
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Animating camera: rotate around the vertical axis

# t h i s i s r o t a t e A r o u n d V e r t i c a l . py
nsteps = 300
f o r i in range ( nsteps ) :

phi = f l o a t ( i )/ f l o a t ( nsteps −1)∗2.∗ pi
c0 . viewNormal = ( cos ( t h e t a )∗ cos ( phi ) , cos ( t h e t a )∗ s i n ( phi ) ,

s i n ( t h e t a ) )
SetView3D ( c0 )
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Animating camera: fly into the volume and out

# t h i s i s f l y I n O u t . py
nsteps = 100
x f i r s t = 0
x l a s t = −40
f o r i in range ( nsteps ) :

x = x f i r s t + f l o a t ( i )/ f l o a t ( nsteps −1)∗( x l a s t−x f i r s t )
c0 . focus = ( x , 0 , 0 )
SetView3D ( c0 )

f o r i in range ( nsteps ) :
x = x l a s t + f l o a t ( i )/ f l o a t ( nsteps −1)∗( x f i r s t−x l a s t )
c0 . focus = ( x , 0 , 0 )
SetView3D ( c0 )
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Animating camera: play the perspective angle

# t h i s i s p e r s p e c t i v e . py
nsteps = 100
a1 = 30
a2 = 60
f o r i in range ( nsteps ) :

c0 . viewAngle = a1 + f l o a t ( i )/ f l o a t ( nsteps −1)∗( a2−a1 )
SetView3D ( c0 )

f o r i in range ( nsteps ) :
c0 . viewAngle = a2 + f l o a t ( i )/ f l o a t ( nsteps −1)∗( a1−a2 )
SetView3D ( c0 )
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Camera animation: interpolate between control points

First, define a function to copy all attributes from one control point to
another

# t h i s i s copyView . py
def copyView ( a , b ) :

b . viewNormal = a . viewNormal
b . focus = a . focus
b . viewUp = a . viewUp
b . viewAngle = a . viewAngle
b . p a r a l l e l S c a l e = a . p a r a l l e l S c a l e
b . nearPlane = a . nearPlane
b . fa rP lane = a . fa rP lane
b . p e r s p e c t i v e = a . p e r s p e c t i v e
b . imageZoom = a . imageZoom
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Camera animation: interpolate between control points

Next, set three new control points, based on c0

# t h i s i s t h r e e C o n t r o l P o i n t s . py
c1 = View3DAttributes ( )
copyView ( c0 , c1 )
phi = pi /2
c1 . viewNormal = ( cos ( t h e t a )∗ cos ( phi ) , cos ( t h e t a )∗ s in ( phi ) ,

s in ( t h e t a ) )

c2 = View3DAttributes ( )
copyView ( c1 , c2 )
t h e t a = pi /6
c2 . viewNormal = ( cos ( t h e t a )∗ cos ( phi ) , cos ( t h e t a )∗ s in ( phi ) ,

s in ( t h e t a ) )

c3 = View3DAttributes ( )
copyView ( c2 , c3 )
c3 . focus = ( 0 , −30, −20)
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Camera animation: interpolate between control points

Finally, interpolate between the control points with a small step

# t h i s i s i n t e r p o l a t e . py
# d e f i n e a t u p l e o f c o n t r o l p o i n t s
cpts = ( c0 , c1 , c2 , c3 )

# d e f i n e a c o r r e s p o n d i n g t u p l e o f t h e i r p o s i t i o n s in t ime
# from 0 t o 1 , in t h i s c a s e ( 0 , 1 / 3 , 2 / 3 , 1 )
x , n = [ ] , len ( cpts )
f o r i in range ( n ) :

x = x + [ f l o a t ( i ) / f l o a t ( n−1)]

# i n t e r p o l a t e be tween c o n t r o l p o i n t s t o c o v e r [ 0 , 1 ]
# t ime i n t e r v a l wi th a much s m a l l e r s t e p
nsteps = 200
f o r i in range ( nsteps ) :

t = f l o a t ( i ) / f l o a t ( nsteps − 1)
c = EvalCubicSpline ( t , x , cpts )
SetView3D ( c )
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Animating an operator: no animation yet

# t h i s i s c l i p S t a t i c . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Pseudocolor " , " hardyglobal " )
c0 = View3DAttributes ( )
c0 . viewNormal = ( 0 . 9 , 0 . , 0 .4358898943540673)
c0 . focus , c0 . viewUp = ( 0 , 0 , 0 ) , ( 0 , 0 , 1 )
c0 . viewAngle , c0 . p a r a l l e l S c a l e = 30 , 17 .3205
c0 . nearPlane , c0 . farPlane , c0 . p e r s p e c t i v e = −171.473 , 1 7 1 . 4 7 3 , 1
SetView3D ( c0 )

l i g h t 0 = L i g h t A t t r i b u t e s ( )
l i g h t 0 . enabledFlag , l i g h t 0 . type = 1 , l i g h t 0 . Camera
l i g h t 0 . d i r e c t i o n = ( 0 . , −0.6 , −0.8)
l i g h t 0 . color , l i g h t 0 . b r i g h t n e s s = ( 2 5 5 , 255 , 255 , 2 5 5 ) , 1
Se tL ight ( 0 , l i g h t 0 )

AddOperator ( " Clip " )
c l i p A t t s = C l i p A t t r i b u t e s ( )
c l i p A t t s . funcType , c l i p A t t s . p lane1Sta tus = c l i p A t t s . Plane , 1
c l i p A t t s . plane1Origin , c l i p A t t s . plane1Normal = ( 0 , 0 , 0 ) , ( 0 , 0 , 1 )
SetOperatorOptions ( c l i p A t t s )
DrawPlots ( )
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Animating an operator: exercise

Exercise: Try to do the following:

(1) Modify the previous slide’s script to animate the clip plane
through the volume from bottom to top

(2) Write each image to disk as PNG

(3) Use a third-party tool to merge these into a movie; e.g., in
Linux/MacOSX can use ffmpeg to merge frames into an efficiently
compressed Quicktime-compatible MP4
ffmpeg −r 10 −i image%02d . png −c : v l i b x 2 6 4 −pix_fmt yuv420p \
−vf " s c a l e =trunc ( iw / 2 )∗2 : trunc ( ih /2)∗2 " movie . mp4
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Scripting queries: minMax of Pseudocolor

Controls → Query... produces a query dialogue with dozens of
options
# t h i s i s q u e r y P s e u d o c o l o r . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Pseudocolor " , " hardyglobal " )
DrawPlots ( )
p r i n t Query ( "MinMax" )
val = GetQueryOutputValue ( )
p r i n t val

hardyglobal −− Min = 1.09554 ( node 105026 a t coord <0.612245 , −10, 7 .14286 >)
hardyglobal −− Max = 5.88965 ( node 83943 a t coord <7.55102 , 1 . 4 2 8 5 7 , 3 .46939 >)
(1 .0955432653427124 , 5 .889651775360107)

Now try commenting out DrawPlots() and running the script again

V i s I t : Error − MinMax r e q u i r e s an a c t i v e non−hidden P l o t .
P lease s e l e c t a p l o t and t r y again .

... so, do we query the original data or the plot?
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Scripting queries: minMax of Contour

Let’s query an isosurface plot:

# t h i s i s queryContour . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Contour " , " hardyglobal " )
contAtts = ContourAttr ibutes ( )
contAtts . contourMethod = contAtts . Value
contAtts . contourValue = ( 3 . 8 )
SetPlotOpt ions ( contAtts )
DrawPlots ( )
p r i n t Query ( "MinMax" )
val = GetQueryOutputValue ( )
p r i n t val

Produces exactly the same query output!
4 We definitely query the original 3D data, not the plot.
+ Why require a plot when we run a query not on the plot but on

the original data?...
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Scripting queries: weighted variable sum of Slice

Answer: query script authors can make it operate on anything in the
pipeline, so best to check documentation and/or test your script

# t h i s i s q u e r y S l i c e . py
D e l e t e A l l P l o t s ( )
AddPlot ( " Pseudocolor " , " hardyglobal " )
AddOperator ( " S l i c e " )
DrawPlots ( )
f o r i in range ( 1 0 ) :

p o s i t i o n = i ∗2 − 9
p r i n t ’ p o s i t i o n = ’ , p o s i t i o n
s = S l i c e A t t r i b u t e s ( )
s . axisType = s . XAxis
s . originType = s . I n t e r c e p t
s . o r i g i n I n t e r c e p t = p o s i t i o n
SetOperatorOptions ( s )
Query ( "MinMax" ) # q u e r i e s t h e 3D volume !
p r i n t ’ minMax = ’ , GetQueryOutputValue ( )
Query ( " Weighted Var iable Sum" ) # q u e r i e s t h e 2D s l i c e !
p r i n t ’ sum = ’ , GetQueryOutputValue ( )
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Recording GUI actions to Python scripts

Controls → Command... window lets you convert your GUI
workflow into a Python code (similar to ParaView’s Trace Tool)
(1) delete all plots and databases
(2) select Controls → Command... window to open the Commands

window
(3) press Record
(4) load the file noise.silo , add a plot, draw it
(5) press Stop
(6) you’ll see an automatically generated script in the Commands

window

Often the output will be very verbose and contain many
unnecessary commands, which can be edited out

I exercise: try translating object rotation around an axis into Python;
which variables are important and which ones are not?

Some GUI operations will not be recorded the way you expect
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Scripting a time-sequence animation

One of them is File → Save movie... recording which will
produce an identical script for each frame, resulting in a very ...
long code

In this case, you want to record a single frame and then wrap
everything into a Python loop

I for time-dependent datasets at each loop iteration make sure to
(1) read a new file and
(2) write a new image

Exercise: Script a movie from the time-dependent aneurysm data
from http://bit.ly/2dTxkqx (∼361 MB) or from a simpler
2D dataset datasets/evolution/2d*.vtk from
http://bit.ly/visitfiles (∼24 MB)
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Other places to use Python in VisIt

Python Expression Editor (mentioned earlier)

Python Query Editor (mentioned earlier)

Setting up your own buttons in the VisIt GUI, creating other
custom Qt GUIs based on VisIt

Setting up callbacks that get called whenever events happen in
VisIt

I requires GUI and Python interface running at the same time
I example 1: as you move the time slider by hand, have the position

of a slice plane adjust automatically, or have your visualization
window pan and/or zoom in automatically on different regions of
interest

I example 2: click on your visualization with Pick and have a script
process coordinates of the picked points and produce something
interesting based on that

I more advanced topic for another time
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Could be useful: plotting 2D terrain in 3D

Natural Resources Canada provides free topographic maps for the
entire country http://bit.ly/2dDcywN

We’ll use one of their 1:50,000 maps showing a part of coastal BC
near Vancouver

The file is a 2D digital elevation map (DEM) file – VisIt can
understand DEM files natively

OpenDatabase ( "~/teaching/visitWorkshop/ d a t a s e t s /092g06 . dem" )
AddPlot ( " Pseudocolor " , " height " )
DrawPlots ( )

Wouldn’t it be nice to plot it in 3D?
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3D terrain

# t h i s i s t e r r a i n 3 d . py
D e l e t e A l l P l o t s ( )
OpenDatabase ( "~/teaching/visitWorkshop/ d a t a s e t s /092g06 . dem" )
AddPlot ( " Pseudocolor " , " height " )

AddOperator ( " E levate " )
e = E l e v a t e A t t r i b u t e s ( )
e . useXYLimits = 1 # i f X/Y a r e l o n g i t u d e / l a t i t u d e , z−h e i g h t would be o f f
SetOperatorOptions ( e ) # => s imp ly r e s c a l e a l l 3 a x e s t o a cube

AddOperator ( " Transform " )
t = TransformAttr ibutes ( )
t . doScale = 1 # turn on s c a l i n g
t . scaleX , t . scaleY , t . sca leZ = 1 , 1 , 0 . 0 5 # and make z−h e i g h t s s m a l l e r
SetOperatorOptions ( t )

DrawPlots ( )

DEM files are raster images
ESRI shapefiles with vector data (roads, buildings, etc) can also be converted to
3D to be plotted on top of terrain, details at http://bit.ly/2eoAzaj
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Molecular visualization

VisIt can read LAMMPS, PDB (Protein Data Bank), XYZ files, and
a few other molecular structure file formats

Molecular options are very basic compared to VMD

Rendering 106 atoms at medium quality takes 4.5 s on my laptop,
so with scripting it is feasible to render ∼ 64× 106 atoms of a virus
shell with few minutes per frame

More details on molecular data features of VisIt at
http://bit.ly/2epWHn3
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Molecular visualization

Let’s try a molecule with 12,837 atoms:
# t h i s i s drawMolecule . py
OpenDatabase ( "~/teaching/visitWorkshop/ d a t a s e t s /molecules /1 l5q . pdb" , 0 )
AddPlot ( " Molecule " , " element " , 1 , 1 )
DrawPlots ( )

m = MoleculeAttr ibutes ( )

m. drawAtomsAs = m. SphereAtoms # NoAtoms , SphereAtoms , ImposterAtoms
m. scaleRadiusBy = m. Fixed # Fixed , Cova l ent , Atomic , V a r i a b l e
m. atomSphereQuality = m. Medium # Low , Medium , High , Super
m. radiusFixed = 0 . 5

m. drawBondsAs = m. CylinderBonds # NoBonds , LineBonds , Cy l inde rBonds
m. colorBonds = m. ColorByAtom # ColorByAtom , S i n g l e C o l o r
m. bondCylinderQuality = m. Medium # Low , Medium , High , Super
m. bondRadius = 0 . 0 8

m. elementColorTable = " cpk_jmol "
m. legendFlag = 1
SetPlotOpt ions (m)
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Conclusions for scripting part

VisIt’s Python interface is very concise and clean (good!)

Access attributes by creating an attributes object through
PlotNameAttributes(), OperatorNameAttributes(),
View3DAttributes(), SaveWindowAttributes(), LightAttributes()

Every time you change attributes, don’t forget to set them with
SetPlotOptions(), SetOperatorOptions(), SetView3D(),
SetSaveWindowAttributes(), SetLight()

Several ways to use Python
I command line: /path/to/VisIt -nowin -cli -s script.py
I Python shell: Controls → Launch CLI...
I Python editor: Controls → Command...

Use the built-in recorder to produce Python scripts from scratch
Controls → Command... → Record
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Remote and distributed
visualization with VisIt
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Visualizing remote data (interactively or not)

So far we covered working with standalone VisIt on your desktop. If
your dataset is on cluster.consortium.ca, you have many options:

(1) download data to your desktop and visualize it locally
limited by dataset size and your desktop’s CPU+GPU/memory

(2) run VisIt remotely on a larger machine via X11 forwarding
your desktop ssh −X−−−−→ larger machine running VisIt

(3) run VisIt remotely on a larger machine via VNC or x2go
your desktop VNC−−−→ larger machine running VisIt

I any node with X11 server (for VNC only); scheduled or a
login/head/development node with/without a GPU

(4) run VisIt in client-server mode
VisIt viewer on your desktop 
 VisIt on larger machine

(5) run VisIt via a GUI-less batch script (interactively or scheduled) –
ideal for large routine visualizations
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X11 forwarding

Need a client-side X11 server (comes by default on Linux and Mac
laptops) to which a remote application sends its window

ssh -X lets you forward X11 graphics and mouse/keyboard
interactions through ssh (encrypted!)

Can forward through several consecutive connections, e.g.,

laptop ssh −X−−−−→ login node
qsub −X
−−−−−→ interactive compute node

X11 forwarding is very chatty (lots of roundtrips!) and can be very
slow on a high-latency network ... in general we don’t
recommend it
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VNC (Virtual Network Computing)

Remote graphical desktop system

Has gone to tremendous effort to optimize communication via
data compression and caching

X11 server is on the remote side
Does not handle user authentication (by itself not secure)

I best to run VNC server on either (1) an externally inaccessible compute node or (2) a
login node with a really good firewall not allowing any incoming connection on the
VNC port

I in both cases need to set up an SSH tunnel between the VNC ports to connect
(virtually without a performance drop)

I in addition, always employ a non-empty VNC password for higher security

Your remote collaborators can connect to the same VNC session with
full keyboard/mouse control as long as they have the VNC password
(different from your cluster password which should never be shared!)

Setting it up is a little bit more involved but well worth it
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x2go: an alternative to VNC

Also remote desktop like VNC, but there are some differences:
I windows are managed by the client-side (laptop’s) X11 server
I x2go server can be run system-wide for all users, supports user

authentication ⇒ can easily be run on the login node for all users
I persistent sessions (can reconnect to a suspended desktop)

Open-source implementation of NX protocol

X2go server must be on Linux

Client could be on Linux, Mac, Windows
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New national systems

New clusters Cedar (SFU) and Graham (Waterloo) online in ∼May
https://docs.computecanada.ca/wiki/Cedar
27,696 CPU cores and 584 GPUs
https://docs.computecanada.ca/wiki/Graham
33,576 CPU cores and 320 GPUs

We are aiming to implement an interactive visualization setup on
several nodes on these cluster, details yet to be determined

how many nodes exactly
whether accessible directly from outside (likely!)
whether with GPUs
if yes, how to share individual GPUs among multiple users

In addition, users will be able to run batch-mode (non-interactive)
visualizations on regular compute (CPU and/or GPU) nodes via the
job scheduler
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Remote VisIt via VNC on WestGrid (page 1 of 2)
full details at http://bit.ly/remotevnc

(1) Install TigerVNC (http://tigervnc.org) or TurboVNC
(http://www.turbovnc.org) on your desktop

(2) Log in to parallel.westgrid.ca and run the command vncpasswd ,
at the prompt set a password for your VNC server (don’t leave it
empty) – you’ll use it in step 6

(3) Submit an interactive job to the cluster:
qsub -q interactive -I -l nodes=1:ppn=1:gpus=1,walltime=1:00:00
When the job starts, it’ll return a prompt on the assigned compute
node.

(4) On the compute node start the vncserver:
vncserver
It’ll produce something like “New ’X’ desktop is cn0553:1”, where
the syntax is nodeName:displayNumber
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Remote VisIt via VNC on WestGrid (page 2 of 2)
full details at http://bit.ly/remotevnc

(5) On your desktop set up ssh forwarding to the VNC port on the
compute node:
ssh username@parallel.westgrid.ca -L xxxx:cn0553:yyyy
Here xxxx = 5901 is the local VNC port, and yyyy = 5900 (VNC’s
default) + displayNumber and is usually 5901 as well

(6) Start TurboVNC viewer on your desktop, enter localhost:1 (that’s
xxxx-5900) and then enter the password from step 2 above

(7) A remote Gnome desktop will appear inside a VNC window on
your desktop

(8) Inside this desktop start a terminal, use it to start VisIt with a
VirtualGL wrapper
vglrun /global/software/visit/visit271/bin/visit
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Client-server VisIt in a Cloud West VM (page 1 of 2)
more details at http://bit.ly/2kUTCNL

Your local VisIt will start remote VCL (VisIt
Component Launcher) responsible for launching
other remote VisIt components

On your laptop (VisIt client) set up Host and
Launch profiles (could run on a server/login
node or even launch a serial/parallel VisIt job via
sqsub + mpirun)

I for a cloud VM only need a host profile

I don’t need a GPU for rendering (most cloud VMs don’t

have one!)

Ports 5600 - 5609 should be open throughout

Once set up, to connect simply open a data file on
the remote system
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Client-server VisIt in a Cloud West VM (page 2 of 2)
more details at http://bit.ly/2kUTCNL

Prerequisites:
à your own cloud VM
https://docs.computecanada.ca/wiki/CC-Cloud
à a bunch of system dependencies for compiling VisIt
à a copy of VisIt compiled with Python, Mesa (open-source OpenGL
implementation supporting software rendering), support for your
input file format – usually need to compile your own

(1) Options → Host profiles... to set nickname (cloud west), host
name (VM’s public IP address), path to remote VisIt installation
(/home/centos/visit), username (centos), tunnel through ssh

(2) Options → Save Settings

(3) File → Open file... → Host= cloud west
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Batch scripting on HPC (page 1 of 2)
example on parallel.westgrid.ca’s GPU node

Example 1: serial rendering via a scheduled interactive job

qsub −q i n t e r a c t i v e −I −l nodes =1:ppn=1: gpus =1 , wallt ime = 1 : 0 0 : 0 0
. . . wait f o r an i n t e r a c t i v e s h e l l . . .
f i r s t g p u =$ ( head −n 1 " $PBS_GPUFILE " )
gpuindex=$ { f i r s t g p u : ( −1 ) }
export DISPLAY = : 0 . $gpuindex
/globa l/software/ v i s i t / v i s i t 2 7 1 /bin/ v i s i t −nowin −c l i −s s c r i p t . py
−−− s c r i p t . py −−−
your debugged V i s I t Python s c r i p t
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Batch scripting on HPC (page 2 of 2)
example on parallel.westgrid.ca’s GPU node

Example 2: parallel rendering via a scheduled batch job

qsub −q i n t e r a c t i v e ./ v i s u a l i z a t i o n . sh
−−− v i s u a l i z a t i o n . sh −−−
# ! / b i n / bash
#PBS −S / b in / bash
#PBS −q gpu
#PBS − l nodes =1: ppn =4: gpus=1
#PBS − l pmem=2000mb
#PBS − l w a l l t i m e = 0 1 : 0 0 : 0 0
cd $PBS_O_WORKDIR
f i r s t g p u =$ ( head −n 1 " $PBS_GPUFILE " )
gpuindex=$ { f i r s t g p u : ( −1 ) }
export DISPLAY = : 0 . $gpuindex
/globa l/software/ v i s i t / v i s i t 2 7 1 /bin/ v i s i t −np 4 −nowin −c l i −s s c r i p t . py
−−− s c r i p t . py −−−
your debugged V i s I t Python s c r i p t
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VisIt resources

à Website
https://wci.llnl.gov/simulation/computer-codes/visit

https://wci.llnl.gov/codes/visit

à Documentation
https://wci.llnl.gov/simulation/computer-codes/visit/manuals

à Gallery
https://wci.llnl.gov/simulation/computer-codes/visit/gallery

à Visit users’ wiki
http://www.visitusers.org

à Tutorials
http://www.visitusers.org/index.php?title=VisIt_Tutorial

à Examples datasets
http://www.visitusers.org/index.php?title=Tutorial_Data
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Online WestGrid visualization webinars

Bimonthly during the academic year (January, March, May,
September, November), advertised at
https://www.westgrid.ca

One-hour long, usually very specific topics

Past webinars are available with slides and video at
https://www.westgrid.ca/events/archive

I “Introduction to batch visualization”
I “Graph visualization with Gephi”
I “3D graphs with NetworkX, VTK, and ParaView”
I “CPU-based rendering with OSPRay”
I “Scripting and other advanced topics in VisIt visualization”
I “Visualization support in WestGrid / Compute Canada”
I “Using ParaViewWeb for 3D visualization and data analysis in a web browser”
I coming up: “3D visualization on new CC systems”

We are looking for topic suggestions!
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Non-VisIt resources

http://www.paraview.org/Wiki/The_ParaView_Tutorial

https://www.westgrid.ca/support/visualization

email support@westgrid.ca

http://bit.ly/cctopviz

https://docs.computecanada.ca/wiki/Visualization

support@computecanada.ca
email vis-support@computecanada.ca

Questions?
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