openapi: 3.2.0 info: title: direct-access-agents Direct Access Agent Configuration API version: '' servers: - url: https://{tenant}.{region}.qlikcloud.com variables: region: default: us description: The region the tenant is hosted in tenant: default: your-tenant description: Name of the tenant that will be called tags: - name: direct-access-agent-configuration paths: /api/v1/direct-access-agents/{agentId}/actions/{agentAction}: post: tags: - direct-access-agent-configuration summary: Restart an agent responses: '204': description: Service restarted successfully. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Error restarting the service. '403': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: The requestor does not have the required permissions for the gateway's space. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Service doesn't exist. '409': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Conflict '500': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Internal Server Error parameters: - in: path name: agentAction schema: type: string required: true description: The type of action to perform. Permitted values are `restart` (will not restart the agent if a reload is in `RELOADING` status) and `force-restart` (will restart the agent even if a reload is in `RELOADING` status). - in: path name: agentId schema: type: string required: true description: The agent ID description: Restarts the specified agent. If a reload is in `RELOADING` status the `restart` action will be ignored. Use `force-restart` to restart the agent even if a reload is in `RELOADING` status. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.2+. operationId: restartConnectorAgentServiceAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 /api/v1/direct-access-agents/{agentId}/configurations: get: tags: - direct-access-agent-configuration summary: Get agent configuration responses: '200': content: application/json: schema: $ref: '#/components/schemas/ConfigurationResponse' description: The dictionary of key/value pairs retrieved from the configuration file. '403': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: The requestor does not have the required permissions for the gateway's space. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID - in: query name: queryProperties schema: type: array items: type: string description: Individual properties within the agent configuration description: Retrieves the connector agent configuration from the specified agent. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.2+. operationId: getConnectorAgentConfigAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 patch: tags: - direct-access-agent-configuration summary: Update agent configuration responses: '204': description: Patch applied. '207': content: application/json: schema: $ref: '#/components/schemas/PatchOperationResponse' description: Patch applied, validation results show success or failure of each individual patch operation. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '403': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: The requestor does not have the required permissions for the gateway's space. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. '415': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Unsupported content-type. This endpoint must include `application/json` as a valid content-type for API compliance, but C# JsonPatchDocument doesn't support it. Requests must use `application/json-patch+json`. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID description: Makes changes to the local agent configuration using JSON Patch. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.2+. operationId: patchConnectorAgentConfigurationAsync requestBody: content: application/json: schema: type: array items: $ref: '#/components/schemas/Operation' application/json-patch+json: schema: type: array items: $ref: '#/components/schemas/Operation' description: The JSON Patch document x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 /api/v1/direct-access-agents/{agentId}/connectors/{connectorType}/files: get: tags: - direct-access-agent-configuration summary: Get connector configuration files responses: '200': content: application/json: schema: $ref: '#/components/schemas/ConnectorFlatFileConfigurationResponse' description: The list of files for the specified connector. '403': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: The requestor does not have the required permissions for the gateway's space. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID - in: path name: connectorType schema: enum: - file-connector - rest-connector - odbc-connector type: string required: true description: The connector to retrieve the list of files for description: Retrieves the configuration files associated with the connector. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.4+. operationId: getConnectorFileListAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 /api/v1/direct-access-agents/{agentId}/connectors/{connectorType}/files/{fileType}: get: tags: - direct-access-agent-configuration summary: Get connector configuration responses: '200': content: application/json: schema: $ref: '#/components/schemas/ConnectorFlatFileConfigurationResponse' description: The list of configuration values from the file. '403': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: The requestor does not have the required permissions for the gateway's space. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID - in: path name: connectorType schema: enum: - file-connector - rest-connector - odbc-connector type: string required: true description: The connector type to retrieve - in: path name: fileType schema: enum: - CustomTypesMapping - PlainTextConfiguration - AllowedPaths - AllowedDrivers - AllowedDsns - CustomAllowedExtensions type: string required: true description: The type of file to retrieve description: Retrieves the configuration items in the flat file for the specified connector. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.4+. operationId: getConnectorFlatFileConfigurationAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 put: tags: - direct-access-agent-configuration summary: Set connector configuration responses: '204': description: Updated. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. '409': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Conflict. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID - in: path name: connectorType schema: enum: - file-connector - rest-connector - odbc-connector type: string required: true description: The connector type to update - in: path name: fileType schema: enum: - CustomTypesMapping - PlainTextConfiguration - AllowedPaths - AllowedDrivers - AllowedDsns - CustomAllowedExtensions type: string required: true description: The file type to update description: Completely replaces the contents of the connector's configuration file. Partial updates are not supported. Requestor must be assigned the `TenantAdmin` role and needs to be either a Gateway's space owner or a member in the Gateway's space with `Can Consume Data` role. Available in Direct Access Gateway V1.7.4+. operationId: putConnectorFlatFileConfigurationAsync requestBody: content: application/json: schema: $ref: '#/components/schemas/UpdateConfigurationFlatFileRequest' description: The contents of the file to be updated x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 /api/v1/direct-access-agents/{agentId}/connectors/file-connector/files/allowed-paths: get: tags: - direct-access-agent-configuration summary: Get file connector allowed paths configuration responses: '200': content: application/json: schema: $ref: '#/components/schemas/FileConnectorAllowedPathsResponse' description: The list of configuration values from the file. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID description: Retrieves the allowed paths settings for the File Connector. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.6+. operationId: getApiV1DirectAccessAgentsByAgentIdConnectorsFileConnectorFilesAllowedPaths x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 x-operation-id-source: normalized x-operation-id-original: getConnectorFileListAsync put: tags: - direct-access-agent-configuration summary: Set file connector allowed paths configuration responses: '204': description: Updated. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. '409': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Conflict. parameters: - in: path name: agentId schema: type: string required: true description: The agent id description: Completely replaces the contents of the allowed paths configuration file for the File Connector. Partial updates are not supported. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.6+. operationId: putApiV1DirectAccessAgentsByAgentIdConnectorsFileConnectorFilesAllowedPaths requestBody: content: application/json: schema: $ref: '#/components/schemas/UpdateFileConnectorAllowedPathsRequest' description: The contents of the file to be updated x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 x-operation-id-source: normalized x-operation-id-original: putConnectorFlatFileConfigurationAsync /api/v1/direct-access-agents/{agentId}/connectors/odbc-connector/files/custom-data-type-mappings: get: tags: - direct-access-agent-configuration summary: Get connector type mapping configuration responses: '200': content: application/json: schema: $ref: '#/components/schemas/OdbcCustomDataTypeResponse' description: The list of configuration values from the file. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID. description: Retrieves the custom data type mapping settings for the Generic ODBC Connector. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.5+. operationId: getOdbcCustomTypeMappingsAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 put: tags: - direct-access-agent-configuration summary: Set connector type mapping configuration responses: '204': description: Updated. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. '409': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Conflict. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID. description: Completely replaces the contents of the custom data type mapping configuration file for the Generic ODBC connector. Partial updates are not supported. There are property naming differences between the API and the file contents. Use the API property format when making changes. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.5+. operationId: putOdbcCustomTypeMappingsAsync requestBody: content: application/json: schema: $ref: '#/components/schemas/UpdateOdbcCustomTypeMappingsRequest' description: The contents of the file to be updated. x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 /api/v1/direct-access-agents/{agentId}/tools/metrics-collector/configuration: get: tags: - direct-access-agent-configuration summary: Get metrics collector settings responses: '200': content: application/json: schema: $ref: '#/components/schemas/MetricsCollectorSettingsApiResponseConnectorConfigurationResponse' description: The list of configuration values from the file. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID. description: Retrieves the settings for the metrics collector. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.9+. operationId: getMetricsCollectorSettingsAsync x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '1' limit: 1000 put: tags: - direct-access-agent-configuration summary: Set metrics collector settings responses: '204': description: Updated. '400': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Bad request. '404': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Configuration file not found. '409': content: application/json: schema: $ref: '#/components/schemas/ErrorResponse' description: Conflict. parameters: - in: path name: agentId schema: type: string required: true description: The agent ID. description: Completely replaces the contents of the metrics collector settings configuration file. Partial updates are not supported. Requestor must be assigned the `TenantAdmin` role. Available in Direct Access Gateway V1.7.9+. operationId: putMetricsCollectorSettingsAsync requestBody: content: application/json: schema: $ref: '#/components/schemas/UpdateMetricsCollectorSettingsRequest' description: The contents of the file to be updated. x-qlik-stability: stable x-qlik-visibility: public x-qlik-deprecated: false x-qlik-tier: tier: '2' limit: 100 components: schemas: UpdateConfigurationFlatFileRequest: type: object properties: contentsToSave: type: - array - 'null' items: type: string example: C:\\filepath description: Individual lines of the file. Must be escaped when sending as json. description: The request to update a connector flat file additionalProperties: false ConfigurationLineBase: type: object oneOf: - $ref: '#/components/schemas/ConfigurationLineNumeric' - $ref: '#/components/schemas/ConfigurationLineString' additionalProperties: false MetricsCollectorSettingsApiResponseConnectorConfigurationResponse: type: object properties: result: $ref: '#/components/schemas/MetricsCollectorSettingsApiResponse' errorMessage: $ref: '#/components/schemas/ErrorResponse' additionalProperties: false UpdateMetricsCollectorConnectorConfigurationsRequest: type: object required: - connectorAgent - fileConnector - odbcConnector - restConnector - sapBwConnector - sapPackageConnector - sapSqlConnector - systemMetrics properties: fileConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' odbcConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' restConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' systemMetrics: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' connectorAgent: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' sapBwConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' sapSqlConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' sapPackageConnector: $ref: '#/components/schemas/MetricsCollectorIndividualConnectorConfigurationRequest' additionalProperties: false FileConnectorAllowedPathsResponse: type: object properties: result: type: - array - 'null' items: $ref: '#/components/schemas/FileConnectorAllowedPath' errorMessage: $ref: '#/components/schemas/ErrorResponse' additionalProperties: false OdbcCustomDataTypeResponse: type: object properties: result: type: - array - 'null' items: $ref: '#/components/schemas/OdbcCustomDataType' errorMessage: $ref: '#/components/schemas/ErrorResponse' additionalProperties: false MetricsCollectorConnectorConfigurationsApiResponse: type: object properties: fileConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' odbcConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' restConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' systemMetrics: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' connectorAgent: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' sapBwConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' sapSqlConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' sapPackageConnector: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationApiResponse' additionalProperties: false MetricsCollectorSettingsApiResponse: type: object properties: connectorConfigurations: $ref: '#/components/schemas/MetricsCollectorConnectorConfigurationsApiResponse' metricsCollectorSettings: $ref: '#/components/schemas/MetricsCollectorSettings' additionalProperties: false ConfigurationLineString: type: object properties: name: type: - string - 'null' value: type: - string - 'null' connector: type: - string - 'null' uiActions: type: - array - 'null' items: enum: - Read - Write type: string apiActions: type: - array - 'null' items: enum: - Read - Write type: string description: type: - string - 'null' displayName: type: - string - 'null' defaultValue: type: - string - 'null' pendingValue: type: - string - 'null' permittedValues: type: - array - 'null' items: type: string pendingApplication: type: boolean allowMultipleValues: type: boolean applyWithoutRestart: type: boolean additionalProperties: false PatchOperationResponse: type: object properties: data: type: - array - 'null' items: $ref: '#/components/schemas/PatchOperationValidationResult' errorMessage: type: - string - 'null' httpStatusCode: type: integer format: int32 failedPatchError: $ref: '#/components/schemas/ErrorResponse' additionalProperties: false ConfigurationLineNumeric: type: object properties: name: type: - string - 'null' value: type: - string - 'null' connector: type: - string - 'null' uiActions: type: - array - 'null' items: enum: - Read - Write type: string apiActions: type: - array - 'null' items: enum: - Read - Write type: string description: type: - string - 'null' displayName: type: - string - 'null' defaultValue: type: - string - 'null' pendingValue: type: - string - 'null' permittedRangeEnd: type: integer format: int32 pendingApplication: type: boolean allowMultipleValues: type: boolean applyWithoutRestart: type: boolean permittedRangeStart: type: integer format: int32 additionalProperties: false PatchOperationValidationResult: type: object properties: valid: type: boolean operation: $ref: '#/components/schemas/Operation' validationResult: type: - string - 'null' additionalProperties: false ErrorResponse: type: object properties: errors: type: - array - 'null' items: $ref: '#/components/schemas/ErrorMessage' traceId: type: - string - 'null' hasErrors: type: boolean readOnly: true additionalProperties: false FileConnectorAllowedPath: type: object required: - path properties: path: type: string example: \\\\Server\\Share\\example minLength: 1 description: The Path property in the File connector allowed paths file. spaces: type: - array - 'null' items: type: string default: '' description: Space identifier that has access to this path example: - Foo - Bar description: The Spaces property in the Odbc custom type mappings file. additionalProperties: false ConnectorSettings: type: object properties: settings: type: - array - 'null' items: $ref: '#/components/schemas/ConfigurationLineBase' connectorName: type: - string - 'null' additionalProperties: false UpdateFileConnectorAllowedPathsRequest: type: object properties: fileConnectorAllowedPaths: type: - array - 'null' items: $ref: '#/components/schemas/FileConnectorAllowedPath' description: The request to update file connector allowed paths configuration additionalProperties: false UpdateMetricsCollectorSettings: type: object required: - baseScrapeIntervalSeconds - dataRetentionCheckIntervalMinutes - enabled - localDatabaseFileLocation - localDataRetentionDays - port properties: port: type: integer format: int32 default: 5052 maximum: 65535 minimum: 1 description: 'The port number that the metrics collector API will run on. This must match the port that the SYSTEM connector runs on to enable network metrics collection.' enabled: type: boolean default: false maximum: 1 minimum: 0 description: Indicates whether the metrics collector is enabled. localDataRetentionDays: type: integer format: int32 default: 30 maximum: 2147483647 minimum: 1 description: The number of days to retain local data. baseScrapeIntervalSeconds: type: integer format: int32 default: 1 maximum: 2147483647 minimum: 1 description: 'The base interval in seconds for the metrics collection loop. This defines how frequently the collector checks whether to scrape each connector, not the interval at which each connector is scraped. Must be equal to or less than the lowest individual connector scrape interval.' localDatabaseFileLocation: type: string default: '' description: The file location for the local metrics database. If not specified, defaults to `C:\ProgramData\Qlik\Gateway\tmp`. dataRetentionCheckIntervalMinutes: type: integer format: int32 default: 60 maximum: 2147483647 minimum: 1 description: The interval in minutes the metrics collector checks for and deletes old data. localDataRetentionDatabaseSizeInMb: type: integer format: int32 default: 500 maximum: 2147483647 minimum: 1 description: The maximum size of the local database in megabytes. Default is 500 MB. additionalProperties: false Operation: type: object required: - op - path - value properties: op: enum: - add - replace - remove type: string path: enum: - AGENT_LOG_LEVEL - AGENT_HEALTH_FAIL_MINUTES_LIMIT - AGENT_LOG_OPTIONS - EXTEND_FIRST_REQUEST_TIMEOUT - RELOAD_CACHE_MEMORY_MB - DCAAS_LOG_LEVEL - ODBC_LOG_LEVEL - ODBC_MAX_PROCESS_COUNT - ODBC_PROCESS_ISOLATION_MODE - ODBC_RELOAD_SESSION_LIFE - SAPBW_LOG_LEVEL - SAPBW_MAX_PROCESS_COUNT - SAPBW_PROCESS_ISOLATION_MODE - SAPSQL_LOG_LEVEL - SAPSQL_MAX_PROCESS_COUNT - SAPSQL_PROCESS_ISOLATION_MODE - SAPPACKAGE_LOG_LEVEL - SAPPACKAGE_MAX_PROCESS_COUNT - SAPPACKAGE_PROCESS_ISOLATION_MODE - FILE_LOG_LEVEL - FILE_MAX_PROCESS_COUNT - FILE_PROCESS_ISOLATION_MODE - REST_LOG_LEVEL - REST_MAX_PROCESS_COUNT - REST_PROCESS_ISOLATION_MODE - ODBC_TABLES_LIMIT_FOR_GENERICODBC - OVERRIDE_CHUNKS_CACHE_DIR - CHUNK_RECOVERY_RESUME_THRESHOLD_MINUTES - REST_ALLOW_LOCALHOST_CONNECTION - OPTIONAL_CAPABILITIES - AGENT_LOG_MAX_FILE_SIZE_MB - AGENT_LOG_RETENTION_DAYS - METRICS_LOG_MAX_FILE_SIZE_MB - METRICS_LOG_RETENTION_DAYS - DCAAS_LOG_RETENTION_DAYS - ODBC_LOG_RETENTION_DAYS - SAPBW_LOG_RETENTION_DAYS - SAPSQL_LOG_RETENTION_DAYS - SAPPACKAGE_LOG_RETENTION_DAYS - REST_LOG_RETENTION_DAYS - FILE_LOG_RETENTION_DAYS type: string value: type: string ConfigurationResponse: type: object properties: connectors: type: - array - 'null' items: $ref: '#/components/schemas/ConnectorSettings' dcaasSettings: type: - array - 'null' items: $ref: '#/components/schemas/ConfigurationLineBase' connectorAgentSettings: type: - array - 'null' items: $ref: '#/components/schemas/ConfigurationLineBase' additionalProperties: false UpdateMetricsCollectorSettingsRequest: type: object required: - connectorConfigurations - metricsCollectorSettings properties: connectorConfigurations: $ref: '#/components/schemas/UpdateMetricsCollectorConnectorConfigurationsRequest' metricsCollectorSettings: $ref: '#/components/schemas/UpdateMetricsCollectorSettings' additionalProperties: false MetricsCollectorConnectorConfigurationApiResponse: type: object required: - metricsCollectionEnabled - scrapeIntervalSeconds properties: scrapeIntervalSeconds: type: integer format: int32 default: 30 description: Frequency in seconds at which metrics are collected from this connector. metricsCollectionEnabled: type: boolean default: false description: Indicates whether metrics collection is enabled for this connector. additionalProperties: false ConnectorFlatFileConfigurationResponse: type: object properties: result: type: - array - 'null' items: type: string errorMessage: $ref: '#/components/schemas/ErrorResponse' additionalProperties: false ErrorMessage: type: object properties: code: type: - string - 'null' title: type: - string - 'null' detail: type: - string - 'null' additionalProperties: false OdbcCustomDataType: type: object required: - id - nativeDataType - qlikDataType properties: id: type: string example: Amazon Athena ODBC (x64) minLength: 1 description: The Identifier property in the ODBC custom data type mapping file. bit: type: boolean example: true description: The IsBit property in the ODBC custom data type mapping file. size: type: integer format: int32 default: 0 description: The Size property in the ODBC custom data type mapping file. qlikDataType: type: string example: String minLength: 1 description: The QlikDataType property in the ODBC custom data type mapping file. nativeDataType: type: string example: varchar minLength: 1 description: The NativeDataType property in the ODBC custom data type mapping file. additionalProperties: false MetricsCollectorIndividualConnectorConfigurationRequest: type: object required: - metricsCollectionEnabled - scrapeIntervalSeconds properties: scrapeIntervalSeconds: type: integer format: int32 default: 30 description: Frequency in seconds at which metrics are collected from this connector. metricsCollectionEnabled: type: boolean default: false description: Indicates whether metrics collection is enabled for this connector. additionalProperties: false UpdateOdbcCustomTypeMappingsRequest: type: object properties: odbcCustomDataTypes: type: - array - 'null' items: $ref: '#/components/schemas/OdbcCustomDataType' additionalProperties: false MetricsCollectorSettings: type: object required: - baseScrapeIntervalSeconds - dataRetentionCheckIntervalMinutes - enabled - localDataRetentionDays - port properties: port: type: integer format: int32 default: 5052 description: 'The port number that the metrics collector API will run on. This must match the port that the SYSTEM connector runs on to enable network metrics collection.' enabled: type: boolean default: false description: Indicates whether the metrics collector is enabled. localDataRetentionDays: type: integer format: int32 default: 30 description: The number of days to retain local data. baseScrapeIntervalSeconds: type: integer format: int32 default: 1 description: 'The base interval in seconds for the metrics collection loop. This defines how frequently the collector checks whether to scrape each connector, not the interval at which each connector is scraped. Must be equal to or less than the lowest individual connector scrape interval.' localDatabaseFileLocation: type: - string - 'null' default: '' description: The file location for the local metrics database. If not specified, defaults to `C:\ProgramData\Qlik\Gateway\tmp`. dataRetentionCheckIntervalMinutes: type: integer format: int32 default: 60 description: The interval in minutes the metrics collector checks for and deletes old data. localDataRetentionDatabaseSizeInMb: type: integer format: int32 default: 500 description: The maximum size of the local database in megabytes. additionalProperties: false