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Description  
These tutorial will demonstrate how to use Dynamo Visual Programming for Autodesk® 

Revit® software and Autodesk Vasari. The lab will provide users with resources and 

step-by-step examples for automating geometry creation, adjusting family parameters 

using external data, and sharing information with different design platforms.   

Dynamo Visual Programming  

Computational Design refers to the ability to link creative problem solving with powerful 

and novel computational algorithms to automate, simulate, script, parameterize, and 

generate design solutions.  Computational Design has had a profound impact on 

Architectural practice in recent years.  Design practices, large and small, have begun to 

invest in new computational capabilities that allow them to customize their process and 

pursue new, innovative design agendas.  Computation might be leveraged for a variety 

of tasks such as automating a redundant production process or to construct an 

expressive form-generator.  Regardless of the end-use, what is clear is that designers 

need frameworks that let them construct their own tools.  

 

ñVisual Programming Languageò is a concept that provides designers with the means for 

constructing programmatic relationships using a graphical user interfaces.  Rather than 

writing ócodeô from scratch, the user is able to assemble custom relationships by 

connecting pre-packaged nodes together to make a custom algorithm.  This means that 

a designer can leverage computational concepts, without the need to write code.  

Dynamo is an open source Add-in for Autodesk Vasari and Revit.  Dynamo allows 

designers to design custom computational design and automation processes through a 

node-based Visual Programming interface.   Users are given capabilities for sophisticated 

data manipulation, relational structures, and geometric control that is not possible using 

a conventional modelling interface.  In addition, Dynamo give s the designer the added 

advantage of being able to leverage computational design workflows within the context 

of a BIM environment.  The designer is able to construct custom systems to control 

Vasari Families and Parameters 

 

Dynamo exposes a fundamentally new way of working with geometric information within 

Autodesk Vasari and Revit.  Users can create control frameworks for creating, 

positioning, and visualizing geometry.  The Visual Programming framework lets the user 

create unique systems and relationships and expand how BIM can be used to drive 

design ideation. 
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Getting Around in Dynamo  

The Basics  

Dynamo is primarily a plug-in for Autodesk Revit and Vasari.  It works in Revit 2013, 

2014 and Vasari Beta 3, and this tutorial requires that you have one of these 

applications installed.  Dynamo can also run as a stand-alone application with all the list 

and logic functionality, and with some experimental geometry tools available using the 

Autodesk Shape Manager kernel.  Work is also being done to port Dynamo functionality 

to other platforms. 

 

Dynamo is open source under the Apache 2.0 lisence.  The software can be downloaded 

from http://dynamoBIM.org , and source code is available at 

https://github.com/ikeough/Dynamo .   

The Dynamo Interface  

 

A 

B 

C 

D 

E 

http://dynamobim.org/
https://github.com/ikeough/Dynamo


Dynamo:  Visual Programming for Design 

 

 Page 5 of 56 

 

 

A. Pulldown Menus 

Use the File pulldown to Open dynamo files, make new ones, Save-As a new file name, 

and export an image of your current workspace.  Use edit to do copy/paste operati ons, 

create new custom nodes, and add comments.  Use the View pulldown to activate 

background previews, view the console (log), and change wire appearance. 

 

B. Search Bar 

Use the Search Bar to find loaded Nodes 

 

C. Node Library 

Browser for picking nodes. Click on a node title to add to the Dynamo workspace  

 

D. Workspace 

The Workspace is the main environment for creation of Dynamo visual programs.  The 

Home Workspace is the default workspace.  When a user creates or edits a custom 

node, it will appear as a new tab.  

 

E. Execution Bar 

The Execution Bar allows the user to run or execute the current workspace 

The ñRun Automatically" checkbox will cause the workspace to run if the user changes 

the workspace or any of the watched Revit Elements in Revit or Vasari The ñDebug" 

checkbox will invoke a more detailed method of execution 

 

Concepts , Definitions, Terminology  

 

Workspace 

 

The active Workspace  is the area where you interact with the elements of your visual 

program. When you start Dynamo you are in a blank  Home  Workspace . You start 

creating your visual program here by placing Nodes  and connecting with Wires . 
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You can save the Workspace as a .dyn , or Dynamo file for later reuse. Dynamo files can 

be opened from the File menu or the  Samples menu. Opening a Dynamo file clears the 

previous workspace and opens the file as the new active Workspace. 

A Workspace is executed when you press the Run button or will execute automatically if 

you activate the ñRun Automaticallyò check box 

By default, the background of the worksp ace displays all geometric output of the graph. 

This background can be turned off in the view menu.  To navigate the background, 

press Cntrl-G, to return to graph navigation, press Cntrl -G again. 

 

Nodes 

 

Nodes  are the objects you place and connect together with Wires  to form a visual 

program. 

Nodes can represent Revit Elements like Model Lines or Reference Points. 

Nodes can also represent operations like Math Functions. 

Nodes have inputs and outputs. 

The colors of Nodes change to indicate state. 

 

a. Orange Nodes are well-connected and have all of their inputs successfully connected. 

They are part of the active Program Flow. 

 

b. Grey Nodes indicate one of 2 states.  Generally it means they are inactive and need to 

be connected with Wires to be part of the Pro gram Flow in the active Workspace.  

Dynamo also allows for users to pass only partially connected nodes to downstream 

functionality, allowing for more complex interactions.  This state is also represented in 

grey 

 

c. Red Nodes are in an Error state. You can see what the error is by hovering your 

mouse over the node and reading the tooltip.  

 

d. Currently selected Nodes have an aqua highlight. You can drag selected nodes around 

the workspace or right -click to see their properties. 

 

e. Nodes have input Ports  on the left side and output Ports on the right side. 

Directionality of execution and program flow usually goes left to right.  

 



Dynamo:  Visual Programming for Design 

 

 Page 7 of 56 

 

 

Wires 

 

Wires connect between Nodes to create relationships and establish a program flow. You 

can think of them literally as electr ical wires that carry pulses of information from one 

object to the next.  

 

Wires connect the output Port from one Node to the input Port of another node.  

You create a Wire using the mouse left-clicking on an output Port and dragging with the 

mouse button held down, then connect to the input port of another node. Wires appear 

as dashed while being dragged and solid lines when successfully connected.  To 

disconnect a Wire, left-click on the output Node and pull the Wire away.   

 

Ports 

 

Ports  are the light rect angular areas on Nodes, they are the receptors for Wires. 

Information flows through the Ports from left to right. a. Inputs Ports are on the left side 

of the Node. b. Outputs Ports are on the right side of the Node.  

 

Ports are expecting to receive certain types of data, for example a Node might work on 

Point objects or Line objects. Try to connect like outputs to like inputs (XYZ ->XYZ for 

example). Passing a Line object into the input Port of a Node that is expecting a Point 

will result in an error.  

 

You can tell what a specific Node is expecting to receive or to return from the text label. 

If the name is cut off, simply hover over the port and a tooltip will appear.  

 

 

Program Flow 

 

Workspaces have a Program Flow that represents where to start program execution, 

what to do in the middle and how to know when program execution is complete. When 

you press ñRunò Dynamo executes the visual program according to the established 

Program Flow. 
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Directionality of Execution 

 

Typically Dynamo visual programs are executed from left to right and you can read the 

program that way to understand the Program Flow.  

 

There are some exceptions as you get into advanced topics like recursion, but for the 

purposes of this class simply read from left to right.  

 

Custom Nodes 

 

You can create your own reusable Nodes in Dynamo without programming. These 

Nodes can be used in the current Workspace or in other Workspaces on your machine. 

You can also share these Nodes with others. Create new nodes from File>New Custom 

Node or by selecting existing nodes in the workspace and in Edit>Create Node From 

Selection (or right click in the canvas). Give the node a name and a category (selecting 

from the pulldown or by entering a new name. Notice the background color changes 

when you are editing a user-created node. 

Custom Nodes appear in the Node List  like the other nodes. You can double click to 

edit these nodes at any time or by selecting their name from the View menu pulldown.  

 

Custom Nodes are graphically distinguished from other Nodes by looking like a stack of 

nodes. When you see a node with a dotted shadow underneath, it is an indication you 

can double-click on it to edit the contents.  

 

You can share nodes you create with other colleagues by using Package Manager tools. 

By selecting a custom node, and going to the Package Manager in the dropdown menu, 

you can publish the node for others to use.  Similarly, you can search the online 

catalogue for functionality published by other users . 

 

Custom Nodes can be nested inside of themselves to create recursive functionality, such 

as Fibonacci sequences or fractals. 

 

Workflow  The active environment that will be executed. The aggregation of the active 

workspace, python scripts and all dependent user-created nodes. 
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Examples 
 

The following workflows use Dynamo files that are located in the Help menu of the 

application under Samples.  Many have associated Revit family (rfa) and project (rvt) 

files that, by default, are located at C:\Autodesk\Dynamo\Core\samples.  All the 

examples in this document can be used in either Revit or Vasari. 

 

For ease of opening rfa and rvt files, you might want to add this folder to your Places 

open dialog. 
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Create a Point , or ñHello World!ò In Dynamo 

 

Creating a reference point is the most basic operation you could want to do in Dynamo.  

Itôs the venerable ñHello World!ò for the application.  To get there, you will need to learn 

some high level concepts and understand some of the basic principles of working in the 

Revit and Vasari environment 

¶ Learn how to launch Dynamo in the righ t environment for your needs  

¶ Tour the User Interface, Understand search/browse, and navigate the Dynamo 

Workspace 

¶ Place nodes and wire them together 

¶ Learn about the difference between geometry and Revit Elements 

 

 
A workspace for creating a dynamically controlled Reference point 

1. Launch Vasari. 

2. We are going to be placing Reference Points, which can only be done in the 

Mass, Curtain Panel by Pattern, or Adaptive Component family environments (not 

the ñprojectò or .rvt environment).  Click   >  New > Family> Mass.rft.  Or, in 

the recent documents screen, under Families, Click on ñNew Conceptual Massò. 
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3. Dynamo will operate on the .rfa or .rvt file that is active at the time Dynamo is 

launched.  Now that we have a Mass file open, go to Add-ins tab and launch 

Dynamo 

4. From the Dynamo File Menu, go to File/Samples/ 1. Create Point / create 

point.dyn  

 

       

 

5. Notice a couple of nodes (XYZ and Ref Point ) in the workspace. Run  to create 

a single Reference Point at 0,0,0. 

6. There is a difference between an XYZ and a Reference Point.  An XYZ is a 

coordinate point in space, while a Reference Point is a full-fledged Revit Element 

with many aspects and associated meta-data.   

Abstract geometry, like this XYZ, is displayed in the background of the Dynamo 

workspace.  You can toggle between navigating the background 3d space and 

the flat graph by pressing Control-G.  You can also turn this preview off in the 

View menu> Background 3d Preview. 

7. Select and move nodes by using the left mouse button.   

a. Type Delete in order to delete a node or right click and click Delete.   
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b. The right click menu will also show a number of other functionalities.  

Click on the help button to see more information on a selected node  

c. Select all the nodes and right click to set their alignment.  

d. Zoom in and out using the mouse wheel and pan using middle click and 

hold 

8. Now we will learn how to re -wire the workspace to add more inputs:  

a. Type ñNumberò into the search bar to find the Number  node to add it 

into the Workspace.  This can be done by either typing enter with the 

number node selected in Search or clicking the node in the node lib 

b. Find the Number Slider  node and add that as well 

c. On the XYZ node, select the end of the  wire connecting to the  Y port . 

Drag it off into space to disconnect. Do the same for the  Z port . 

d. Connect the new Number  node to the Y port  and 

the Number  Slider  node to the Z port .         

 

 

 

e. At the bottom of the canvas, check ñRun Automaticallyò. 

  

 

 

f. Move the slider to see the point move around  

g. In the Vasari toolbar, pick Model> Draw>Spline Through Points, and 

draw a spline with one of the points using the Dynamo created Reference 

Point.  Move the Number Slider and see both Dynamo created stuff and 

manually created stuff update.  
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h. Select the Dynamo created Reference Point and, in Dynamo, right click in 

the canvas and pick ñFind Nodes from selected elementsò 

9. Create a Custom Node by Selecting the XYZ and Reference Point nodes, then 

right click out in the ca nvas, and pick New Node from Selection.  Name your 

custom node something meaningful. 

 

 

 

10. In the Edit Menu, pick Create Note to annotate your workflow (or type Cntrl -W).  

Double click on the Note to edit it (or edit from the right click menu)  
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Placing  Families with Sequences, Ranges, Lines and Grids    

 

This tutorial aims to introduce the following:  

¶ How to use node Lacing  to evaluate the members of a list in different ways  

¶ Generate lines, grids, and lattices  of Reference Points 

¶ Place family instances with Dynamo 

 

 

 

Dynamo after opening the create point_sequence.dyn file 

1. Close any other open Vasari files 

2. From Vasari, Click  >   (Open).     

3. Navigate to  C:\ Autodesk \ Dynamo \ Core \ samples  

4. Open Mass with Loaded Families.rfa  from the  Samples  directory 

5. From the Dynamo Help menu, go to Samples/ 1. Create Point  / create 

point_sequence.dyn  

6. Hit the ñRunò button to see the following: 
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A sequence of points created by running this example  

 

7. Right click on the Number Sequence  and select Helpé to see what 

kinds of inputs and outputs the number sequence expects.   

8. Notice the little icon in the bottom right corner of the XYZ node.  This 

indicates the Lacing  fo r this particular node.  Lacing allows you to 

automatically apply the node to the sequence created by the 

Number Sequence node.  

 

 
 

The XYZ node with lacing set to ñLongestò 

 

9. Try changing the Lacing strategy to First by right clicking on the XYZ 

node and s electing First.  You should see the icon in the bottom 

right corner of the node change.  

 

10. Hit Run again.  You should see a single point located at the origin.  

This is because the XYZ node is only evaluating the first element in 

the list created by the Numb er Sequence node.  
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11.  Change the lacing on the XYZ node to Cross Product .  If you hit Run 

again, you should again see a vertical line of regularly spaced 

points.  

12.  Click the output port button on the Number Sequence node and 

connect it to the XYZ node by click ing on the Y input.  Your 

workspace should look like this:  

 

 
 

A workspace for creating a grid of XYZ points in the YZ plane 

 

13.  By running again, you should see an orthogonal grid in the YZ 

plane, like this:  

 

 
A square grid of XYZ points. 

You can experimen t by connecting the sequence to the X and Y 

ports to get a plane in XY plane.     
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14. Connect all 3 input ports of the XYZ node to the output of the 

Number Sequence Node and Hit Run.  You should get a cubic 3d 

lattice:   

 
 

A cubic lattice of XYZ points. 

15.   Letõs scale back a bit and go back by connecting the Number 

node, set to 0, to the Z port of the XYZ node.  Weõll have just a grid 

in the XY plane . 

 

 

Now we will extend this workspace to do something more useful than just 

creating points.  Weõll place Family Instances!  

 

16. Go to the Search Bar  and type in ñFamilyò, this filters the available nodes 

down and allows easier access from the Node List.   You should now only see 

nodes related to ñFamilyò. 

17. Add one Create Family Instance  node and one Select Family Type node 

into the workspace.  Look at the Help menu for both of these nodes by right 

clicking.   

18. Connect the Select Family Type  output to the  Create Family Instance 

ñtypò input port.  

19.  Now select the Cone  Family Type from the pulldown on Select Family Type and 

connect the XYZ output from the  XYZ Node  to the XYZ input of the  Create 

Family Instance node.  Your workspace should look like this: 
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The workspace after adding the Select Family Type and Create Family Instance nodes 

20.  Hit Run and you should see something like this: 

 

 
 

A grid of cone families laid out on the XY plane. 

 

21.   Experiment with different values for the number sliders or different family 

types.  By turning on Run Automatically you can do this interactively.  
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Nested Lists  and Basic Data Management  

 

¶ Understand the importance of lists in any standard workflow  

¶ Explore some of the tools for making data do what you want it to do  

 

This tutorial gives a very brief introduction to the process of sorting data in lists.  

Indexed lists are the backbone of algorithmic design, and getting control of both the 

tools and concepts is essential for achieving even moderate complexity. 

1. From Vasari, Click  >   (Open).     

2. Navigate to  C:\ Autodesk \ Dynamo \ Core \ samples  

3. Open Mass with Loaded Families.rfa  from the  Samples  directory 

4. Go to Add-ins tab and launch Dynamo.  If you already had it open, close and re -

open it to re -associate Dynamo with the newly opened .rfa file.   

5.  From the Dynamo Help menu, go to Samples/ 1. Create Point  / create 

point_sequence.dyn  

6. Running the workspace will create a vertical line of xyzs, we will now adjust this 

to make a horizontal grid of xyz.  

7. Unplug the z input for the xyz node, and wire the Number Range node into the X 

and Y ports of the XYZ node. Right click on the Z port of the XYZ and activate 

ñUse Default Valueò:   

  
8. Right click on the XYZ Node and set Lacing to Cross Product.  Run the 

workspace and inspect the results, a nested list or list of lists.   
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9. Now we will extract a single row of information from the nested list.  In the search 

bar, find Get From List, or browse to the node in Core>Lists>Query.  Extract the 

first row of data by passing the list of lists into the Get From List ñListò port, and 

choosing the first index row by passing in a 0 number node.  Pick the Get From 

List node to see the row isolated in the background preview. 

 
10. Copy/Paste your Number and Get From List nodes, and place a Transpose node 

in between the XYZ and Get From List.  Adjust the index input.  Now you have 

swapped rows for columns and have a different set of geometry to use.  
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For more examples of list operations, take a look at the  other files in samples > 24 Lists.  

There is also an extensive set of List samples for advanced data management at 

https://github.com/ikeough/Dynamo/tree/master/test/core/list   

https://github.com/ikeough/Dynamo/tree/master/test/core/list
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Advanced Family Placement:  Adaptive Components  

 

Dynamo can use geometry extracted from the Revit environment and perform lots of 

different operations on that geometry.  That geo metry can be manipulated in various 

ways using list operations.  Finally, you can take that information to place adaptive 

components.  In this example, youôll learn how to: 

¶ Select and use Revit geometry in  Dynamo 

¶ Place Adaptive Components. 

 

1. Close any Vasari files that you have open.  

2. From Vasari, C lick  >  (Open).     

3. Navigate to:  

    C:\ Autodesk \ Dynamo \ Core \ samples \ 18 Adaptive Components  

4. Open  Adaptive Component Placement.rfa  

 

 
The contents of Adaptive Component Placement.rfa. 

 

5. From the Dynamo Help menu, go to:  

 Samples/ 18 Adaptive Components  / Adaptive Component 

Placement  
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 The nodes in Adaptive Component Placement.dyn 

 

6.  Youôll notice that each of the Select Curve nodes has a button in it .  That 

button can be used to select a curve inside of Revit.  Arrange your Dynamo 

window so that you can see the Vasari canvas.  Click the first Select Curve 

nodes ñSelect Instanceò button and select the first curve (Leftmost on the 

preceding image).  You should see the node change to this: 

 

 
A curve has been selected 

 

7.  Do the same on the other two nodes, continuing with first with the middle 

curve.  Now, we have selected three curves for use in Dynamo. 

8. Now, hit Run.  You should see the following:  




































































