Subject: What I'm getting out of this exchange...

From: Mike Warns <mikewarns@...>
Date: Tue, 20 Jun 2006 08:21:48 -0700 (PDT)

...is that everybody has pretty much given up on turning the Mailstation into the next Model 100 or a forth laptop and that the most satisfying thing most of us have managed is to get it to use an email service besides Earthlink.  Am I right or have I been missing out on the great leaps forward because my computer has placed me on a diet and is refusing cookies from Yahoo Groups?
 		
---------------------------------
Yahoo! Messenger with Voice. PC-to-Phone calls for ridiculously low rates.

---

From: "John R." <jhoger@...>
Date: Tue, 20 Jun 2006 08:27:18 -0700

[ Attachment content not displayed ]

---

From: "Neil Morrison" <neilsmorr@...>
Date: Tue, 20 Jun 2006 11:08:09 -0700

No, we still want to do that. It's a matter of time - it's not a trivial task. Earthlink are getting out of that business, perhaps they will release the codes etc? Couldn't hurt to ask.

Neil

  ----- Original Message ----- 
  From: Mike Warns

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Tue, 20 Jun 2006 20:25:33 -0000

--- Mike Warns <mikewarns@...> wrote:
>
> ...is that everybody has pretty much given up on turning the 
> Mailstation into the next Model 100 or a forth laptop 

I haven't given up.  It has been probably more than 6 months since
I have done much, though.  Kind of burned out I guess.  It does
seem to be capable of sucking up an unlimited amount of time!  :-)

--CJ

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 22 Jun 2006 12:28:27 -0700 (PDT)

Is there such a beast as a mailstation emulator? The
would be the way to go for testing and debugging new
code..

--- Neil Morrison <neilsmorr@...> wrote:

> No, we still want to do that. It's a matter of time
> - it's not a trivial task. Earthlink are getting out
> of that business, perhaps they will release the
> codes etc? Couldn't hurt to ask.
> 
> Neil
> 
> 
>   ...is that everybody has pretty much given up on
> turning the Mailstation into the next Model 100 or a
> forth laptop and that the most satisfying thing most
> of us have managed is to get it to use an email
> service besides Earthlink.  Am I right or have I
> been missing out on the great leaps forward because
> my computer has placed me on a diet and is refusing
> cookies from Yahoo Groups? 
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Neil Morrison" <neilsmorr@...>
Date: Thu, 22 Jun 2006 12:45:20 -0700

You'd need to analyze the code to make one. This sort of work has been done 
before, as in the TRS-80 computers which were thoroughly analyzed.

Neil

----- Original Message ----- 
From: Gary Clouse

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 23 Jun 2006 04:40:05 -0000

> would be the way to go for testing and debugging new

If anyone has one, they haven't said anything about 
it here.  But it sure would be cool!!!

I think we know enough about the mailstation hardware
to make one, but it is not a "one night" project.

--CJ

---

From: "John R." <jhoger@...>
Date: Fri, 23 Jun 2006 00:17:45 -0700

> would be the way to go for testing and debugging new

There would be less work to do to just develop code directly on real
hardware, given the existence of Mailbug, Z80 assemblers, C compilers
(like SDCC), etc. You would need to adapt the standard library to
mailstation but that's less work than having to reverse engineer and
document every component in the mailstation which is what would be
needed to make an emulator.

That said there are already CP/M emulators around which can run raw
Z80 code, so you could do testing for large swaths of code in a CP/M
environment.

Anyway it's more fun to develop on "the real thing." At least that's
my bias as an embedded systems developer. WIth mailbug you're doing
"target debugging" anyway, so you get the advantages of working on a
desktop while testing code on a real Mailstation.

-- John.