Subject: IDE/Editor

From: "donhamilton2002" <donhamilton2002@...>
Date: Sat, 19 Jan 2008 20:57:11 -0000

What IDE/Editor are people using with SDCC ??

don

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 26 Jan 2008 17:55:56 -0000

> What IDE/Editor are people using with SDCC ??

Hi Don,

I am using programmers notepad, which I got as part of
winavr.  All I had to do to get it to work with SDCC was 
to create a new makefile, with commands to compile with 
SDCC.

I discovered how easy it was to use with SDCC by
accident, when I was looking at some sdcc code in 
wordpad.  I think my brain has gotten used to seeing 
C code with color syntax highlighting, and it was kind 
of grating to look at everything in the same color.

So I thought I would open the file in winavr's 
"programmers notepad", just to edit it, and then
compile it with the bat file I had been using with
wordpad.  Well, it didn't take too long for me to
wonder if I could get a makefile to run the bat
file.  Before I tried that, it clicked in my head
that I did not need the bat, I could just use
the makefile!

You don't need winavr to get programmers notepad, but 
I think you might need at least the gnu binutils
to use "make" (installs as part of winavr suite).

There is one quirk to programmers notepad (and it
may have something to do with the fact I am using it
under win98), but the "output window" has a habit
of disappearing, and sometimes dialogs (like "open")
appear underneath the other windows.  It's only
mildly annoying after you understand what is happening.

Some features I really like are the "tabbed" multiple 
editor windows, where you can keep several files open, 
and the ability to select columns of text for 
cutting/pasting.  Also, it makes error messages (even
from SDCC) into clickable links, and puts cursor
on the error line when you click one.  And the color
syntax hightlighting, of course!

CJ