Subject: using the Mailstation for email

From: "mgkall" <mark.kall@...>
Date: Wed, 21 Jun 2006 17:38:10 -0000

If someone could figure out:
1/ how to stop the Mailstation from sending the XTND command, that 
would make it useful again on many POP3 services. When it send the 
XTND command and gets -err back, it basically decides the mailserver 
is busy and disconnects. Some old POP3 servers ignored the XTND and 
did not send -err but many today do send the -err and make the 
Mailstation useless for email.

2/ if someone could figure out how to make the mailstation 
authenticate for sending mail as many POP3 services now want 
authentication to prevent spammers from using their servers, we could 
use the mailstations with many more POP3 services.

---

From: "Neil Morrison" <neilsmorr@...>
Date: Wed, 21 Jun 2006 13:26:43 -0700

If we can really crack the system code we can do all of that and more.

Regards,

Neil Morrison

  ----- Original Message ----- 
  From: mgkall

---

From: "wayne" <waynem@...>
Date: Thu, 22 Jun 2006 08:52:17 -0700

Essentially, what you need is a full decode of the program that is in the
mailstation !!

The place to start, is the US patent office, and look at the patent's that
are on the unit.
After reading one of them it gives you an idea of how the unit works, and
what format it
uses to do that with.

But what is needed is for somebody that understands the program language or
code that
it is programmed in to dump it out on paper, and then it can be
re-constructed to do what is
needed.

I used to work with the Z80 code, way back in my life time. Now I think they
have a computer
program that will take the data and print the programming out for you.  On
the newer units,
I am not sure what computer code they are using ??

We still have not really figured out how the parallel port programs the unit
on all versions
at this point. That is needed to fully allow anything to happen.

I would like to find who the manufacturer of the unit is ??  Somebody built
these, and it
wasn't Earthlink ???  It would even be nice to be able to have a unit
re-programmed to the
original programming, or get a unit repaired.  Earthlink cannot repair these
units nor direct you
to anybody that can !!!

Unfortunately, there are some people who do know these units but can only
talk about them
so much because they are still being used by Earthlink, and those people
have contracts with
Earthlink to provide services for these units.

If Earthlink ever decides to drop the units, and no longer allow them on
their system, then maybe
these people would be able to talk about the units and their programming
more. But until that happens,
I can understand why they would be reluctant to come forward and discuss
anything.

Although, it would be helpful to get some direction on getting bad units
repaired or reprogrammed so
they could at least go back in service on Earthlink !!!!

As far as the units using XNTD signaling ??   I would assume that the unit
could be reprogrammed to
eliminate that signal.  If you have an Email server you have control over,
you could probably change the
"Sendmail" or "Procmail" program on it to ignore or use the XNTD signal.
But that is not the only
item that this mail program does. It uses an MD5 encryption code for the
unit.  That code has to be
sent correctly for the unit to program and possibly work correctly.  It can
only be sent in a MIME format,
which leaves out most of the mail formats from sending it.

What I am really surprised is, that NOBODY else has come out and built a
mail machine to do something
similar ?? You would think AOL or somebody else would do that ??  I know
there is a use for the machines,
I have 2 units out there at my relatives.  They are not that computer
literate, but they can use the mail units
easily, and now they can't live without them. So somebody could build a unit
that would work on any POP3
system and easily sell it !!!!  All you need is a couple of 800 telephone
trunks, and an Email/DNS Server
unit, and you are in business.  Just steer clear of the "Mailstation"
patent.  I don't think POP3 has a patent,
but the "mailstation" unit does, so you would have to make a unit that was
designed strictly for POP3,
and was an open architecture, with none of the special MD5 keys and such
that the mailstation was using.

Good luck !!!

Wayne

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Neil Morrison
  Sent: Wednesday, June 21, 2006 1:27 PM
  To: [email-masked]
  Subject: Re: [mailstation] using the Mailstation for email

  Regards,

  Neil Morrison

    ----- Original Message -----
    From: mgkall

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 22 Jun 2006 12:23:54 -0700 (PDT)

The mailstations were originally sold under the brand
name Cidco. The processor is not actually a z80, but a
z80 compatible microcontroller with several
enhancements, including several on-chip serial and
parallel ports. The cpu appears to be a either a house
numbered and or discontinued variant of a Rabbit
Semiconductors 2000. Rabbit Semiconductor does not
list the processor, but it is similar to the chips
used in some of the TI programmable calculators.
Somewhere on this board is a complete memory dump of
one of the models.

>     use the mailstations with many more POP3

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 23 Jun 2006 03:26:29 -0000

> used in some of the TI programmable calculators.

The mailstation was manufactured by Inventec, for Cidco.
Inventec also manufactured several of TI's calculators,
and the TI Avigo PDA.

You said "The cpu appears to be a either a house
numbered and or discontinued variant of a Rabbit
Semiconductors 2000".  

Can you tell us why it appears that way???

I could be wrong, I often am, but here is why I
think it is *NOT* a Rabbit part:

1) The pinout does not match any Rabbit part.  Not even close.
   Are there any discontinued Rabbit parts?  I think the 2000 may have
   been the first part they made.

2) There appears to be no ROM or RAM built into
   the 3SI176 (it has an address and data bus).  The mailstations
   codeflash, dataflash, and ram are all in external chips.
   So, It would not have/need a way to program internal flash.

3) If I remember correctly, the Rabbit parts have extended
   opcodes that z80 does not have.  Mailstation code
   appears to use just standard z80 opcodes.

4) The rabbit bank-switching seems quite a bit different than the 
   mailstation's.  The mailstation does bank-switching more like
   the MSX, Gameboy, and Avigo.

It has been a few years since I did my research on this 
subject, but that is what I remember finding.  

--CJ

---

From: Gary Clouse <niklaus37217@...>
Date: Tue, 27 Jun 2006 16:37:22 -0700 (PDT)

> Can you tell us why it appears that way???

I did find a listing for the part number on a chip
broker site that listed the mfr as rabbit
semiconductor. At the time, It was apparently produced
at an asian factory under contract to rabbit. From
what I can tell, Rabbit was bought out by a larger
company, who made it a subsidary. They seemed to
reorganize and dropped the old lines the came out with
the much enhance series that included the 2000. My
guess is it had to do with intellectual property
rights.

> subject, but that is what I remember finding.  

You are most likely correct. However, even Zilog
extended the original Z80 opcodes with later chips. It
may be likely that the TI inventec chip and the 3SI176
are "first cousins" so to speak. 
I metasearched the part and found several chinese chip
brokers have them available, and some may have
datasheets. Unfortunately, I don't know chinese.

So are you familiar with the Z80 chipe in the TI calc?

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 6 Jul 2006 15:56:38 -0700 (PDT)

I don't think it is a Rabbit 2000, but an earlier
design that the 2000 replaced.