Subject: 3Com Audrey

From: "Neil Morrison" <neilsmorr@...>
Date: Sun, 18 Jul 2004 20:39:04 -0700

http://www.audreymadness.com/Audrey.aspx

---

From: "Neil Morrison" <neilsmorr@...>
Date: Fri, 24 Sep 2004 19:24:45 -0000

One of a few hacking sites: http://www.audreyhacking.com/

NM

--- In [email-masked], "Neil Morrison" <neilsmorr@h...>

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Fri, 24 Sep 2004 12:37:42 -0700

Hey man don't clutter up the list with OT stuff!

Just kidding. It's a welcome change the only other thing from this list
in months is a spam mail.

One of these days I'll get back to the mailstation. Cyrano Jones, if
you're out there, are you happily loading firmware over the parallel
port yet?

-- John.

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 24 Sep 2004 20:47:39 -0000

I made a version of my remote debugger, and flashed it
into an unmodified mailstation.  Breakpoints do not work (yet)
with this version.  I have been hammering on the PC half of
the software, trying to get it into a presentable form.

The reflashing protocol that I posted a while ago seems to
work!  As far as any "new" code, all I have done is poke a
short routine into ram via debugger (hex edit), and 
execute it.  It reads a key from keyboard, stores the
scan code in ram, and turns on the mail LED.  :-)

I have not found any way (yet) to save the existing code
to disk before reflashing.  That means that you have to
wipe out most of the mailstation code when you flash
the remote debug code.  You even have to wipe out the
font data, so I haven't done any output to LCD yet.  
No "Hello world" yet.   :-(

It is probably gonna be "easy" to use the LCD code from
the reflash routines, I just have not got 'round to it yet.
I have not been able to play with this project as much as I 
would like to lately.

If I post pascal code (compiles with Freepascal), is anyone
here gonna be able to use it?  Or should I post binary???
And does anyone know where the summer went????

--
CJ

--- In [email-masked], "John R. Hogerhuis" <jhoger@p...>

---

From: "Neil Morrison" <neilsmorr@...>
Date: Fri, 24 Sep 2004 13:52:43 -0700

Is it possible to load/flash a dump routine into 'ram' and use that to
download the code?

Neil

----- Original Message ----- 
From: "Cyrano Jones" <cyranojones_lalp@...>

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Fri, 24 Sep 2004 14:04:38 -0700

> the software, trying to get it into a presentable form.

What target debugger are you using?

> No "Hello world" yet.   :-(

So you're saying you haven't found any "read block" command? That's a
bummer. Certainly manageable given we're replacing it anyway and someone
already has provided an image, but it would be nice to be able to get an
backup of any given mailstation.

> I have not been able to play with this project as much as I 

I know that feels...

> And does anyone know where the summer went????

My Pascal knowledge is rusty but certainly workable. If you want to put
the code under open source license I could get us a SourceForge project
set up.

-- John.

---

From: "Ronny Julian" <k4rjj@...>
Date: Fri, 24 Sep 2004 17:42:48 -0400

I thought everyone had given up on this.  I see it's not the case.

Has anyone been able to change the server settings from Earthlink?  I've
still got 2 brand new units here.  I was going to take one and toy around
with the idea of spoofing their IP inside my own DNS and creating my own
dialup port.  With WiFi being "everywhere" around Atlanta it's not really
worth the trouble anymore though.

I had tried back when these were "free" to get a womens shelter to get them.
They said they were only accepting PII or better machines for donation and
they "preferred laptops".  Well La De Dah!  I never thought I'd see the day
you could not give away a free machine!

Good luck, good hacking!

Ronny

---

From: "Neil Morrison" <neilsmorr@...>
Date: Fri, 24 Sep 2004 15:31:01 -0700

Which models? The Yahoo ones seem to be best.

Neil

----- Original Message ----- 
From: "Ronny Julian" <k4rjj@...>

> still got 2 brand new units here....

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Fri, 24 Sep 2004 15:36:04 -0700

> you could not give away a free machine!

I am interested in running alternative firmware on the thing... say with
ZCN or maybe a hacked up TRS-80 Model 100 ROM, or a make it a
stand-alone Forth machine...

In fact interfacing to the outside world is a challenge on the
mailstation. It's highest speed interface is its parallel port.

Once we have alternative firmware, I think a MailStation will be every
bit as useful as the various smart keyboards that are around. Only thing
that would make it much better is if it had a USB port.

CJ has already done the heavy lifting by reverse engineering the code
enough to produce a tool which can program the flash over the parallel
port.

Unforunately I don't know much about using the existing firmware. There
are various notes over at linux-hacker which you've probably already
found.

-- John.

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 25 Sep 2004 06:44:36 -0000

If you use the native reflash function, it will erase the
old code before you can flash any new "download" code into
the code rom.

I don't know how to get any code into ram, let alone how 
to make the mailstation execute it if you did.

There is the possibility of loading code into the dataflash,
but so far the only way I can think of to get it to execute
it would require minor surgery on the pc board.

The existence of the 2.53yr rom dump makes dumping the code
an academic exercise, for the brown mailstations at least.

The ergonomic case models have a different keyboard layout,
so I would guess that you would not want to flash the 2.53yr 
code into one of those (assuming that the key matrix is 
different, too).

Until someone rewrites all the functionality that is in the
original rom (keyboard scanning, LCD display, flash filesystems,
modem driver, etc., etc.), reusing the original code seems
like a real good idea.  

I had hoped that it would be possible to reuse that code, 
WITHOUT the need to download it from some BBS somewhere.  
But I have noticed that the word "copyright" does not seem 
to be found anywhere in the code, so perhaps it is not as 
important as I thought???

One of the things on my "To Do List" is to make a version
of the debug code that can be overlaid on the 2.53yr dump, 
and then reflashed, but it would probably only work on the
brown (version 2.somethin) models.

--CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 25 Sep 2004 07:01:10 -0000

...
> What target debugger are you using?

It's all home-grown stuff.  And kinda ugly in some respects.
I never really set out to create what I have now, it just
kind of grew.  And it shows!  

--CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 25 Sep 2004 07:27:07 -0000

...
> My Pascal knowledge is rusty but certainly workable. 
> If you want to put the code under open source license 
> I could get us a SourceForge project 

I do plan to put it up here, under some sort of open licence.
I think I would prefer to post it as source, so I don't have
to worry about virus issues.  And maybe someone will want to 
port it to another language?  I'm not big on c, but I have
thought about re-doing it in perl myself.

The reason it is in Pascal is that it grew out of a program
I wrote a long time ago, to poke around inside of the arcade 
Pacman code.  It seemed easier at the time (when I started
messing with the mailstation) to just extend the old code.

--CJ