Subject: Mailstation memory map

From: "bradfayette" <bfayette@...>
Date: Tue, 14 Nov 2006 02:55:28 -0000

Am I correct in assuming that I have 16K of ram available to use
starting at 0x4000? I would like to expand on the scancode program and
maybe try to get forth running.

Regards,

Brad

---

From: "Neil Morrison" <neilsmorr@...>
Date: Mon, 13 Nov 2006 19:48:52 -0800

It appears there is at least one page of memory available.

Neil

  ----- Original Message ----- 
  From: bradfayette 

  Regards,

  Brad
  .

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Tue, 14 Nov 2006 08:59:53 -0000

> maybe try to get forth running.

Yes.  When mbug starts, it banks page #01 of RAM
into slot4000, so unless you change it, it should
still be there.  

Mbug does not use this for anything itself, it just
puts it there as a convenience.  

The mailstation divides the 64 kByte z80 address space 
into four 16 KByte regions, which I have been calling 
slot0000, slot4000, slot8000, and slotC000.

The pages of ram, codeflash, and dataflash are also
16 KBytes.  The mailstation has 128 KBytes of ram,
ram pg #00 thru ram pg #07.

Slot0000 is always codeflash pg #00, and slotC000 is
always ram pg #00

Mailbug command "6" will display the current inhabitants 
of slot4000 and slot8000, the two "bankable slots". 

--
CJ