Subject: Mail station 120 v4.05e and SMTP (non) authentication

From: "Carl Hauser" <chauserx@...>
Date: Sat, 23 Jul 2005 16:07:02 -0000

After successfully reconfiguring the MS for my ISP (all2easy.net in this case) I found that I was not able to send mail to addresses other than all2easy.net subscribers. The message from the MS was along the lines of "server busy or unavailable, try later".

Investigation showed that the ISP SMTP server is configured to require an AUTH command and subsequent login in order to send mail to non-subscribers. This is an anti-spam feature. AUTH is a so-called ESMTP feature. My MS does not support it; with this ISP the MS can retrieve mail and send to other subscribers of the ISP but cannot send to other internet users. 

The only obvious solution is "get another ISP". I expect that ISP's will increasingly require AUTH for sending mail so the useful lifetime of the MS as an email appliance may be limited.

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Sat, 23 Jul 2005 11:24:44 -0700

On Sat, 2005-07-23 at 16:07 +0000, Carl Hauser wrote:

> The only obvious solution is "get another ISP". I expect that ISP's
> will increasingly require AUTH for sending mail so the useful lifetime
> of the MS as an email appliance may be limited.
> 
> 
> 

I had the same problem with NetZero.

I think unless we replace the mail client with new firmware you are
probably right about limited utility of the built in client.

Of course you could set up a linux dial-up server with whatever settings
you like.

-- John.

---

From: "Carl Hauser" <chauserx@...>
Date: Sat, 23 Jul 2005 18:31:59 -0000

You don't actually need a dial-up server to solve this problem: since the SMTP server's address is configured separately in the MS you just need to make your own SMTP relay server at a routable IP address. In fact this was how I figured out what was going on. 

There is an smtpd.py package in the python distribution that will do what you need--though anyone using it should take steps to avoid creating an open mail relay and suddenly finding themselves the purveyor of other people's spam.

-- Carl

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Sat, 23 Jul 2005 15:25:33 -0700

On Sat, 2005-07-23 at 18:31 +0000, Carl Hauser wrote:
> You don't actually need a dial-up server to solve this problem: since
> the SMTP server's address is configured separately in the MS you just
> need to make your own SMTP relay server at a routable IP address. In
> fact this was how I figured out what was going on. 
> 
> There is an smtpd.py package in the python distribution that will do
> what you need--though anyone using it should take steps to avoid
> creating an open mail relay and suddenly finding themselves the
> purveyor of other people's spam.
> 
> -- Carl

Excellent point, Carl!  I hadn't thought of that. 

So one or more of us could set up a proxy server we could bounce our
SMTP packets off of to do the auth. Then we could use whatever dialup
server we like.

Anyone have ideas on what we could do to avoid becoming an open relay
since the client doesn't support smtp authentication?

-- John.