Subject: Re: [mailstation] Digest Number 74

From: Brad Fayette <bfayette@...>
Date: Fri, 18 Mar 2005 20:26:03 -0500

Well, I loaded MBOOT/MBUG on a Mailstation DET1 ver 2.54Y. The screen on 
the mailstation now says "Welcome to Mbug", which I assume is a good thing.

How do I load the "Hello World" program?

Regards,

Brad Fayette
"The geeks shall inherit the Earth."

[email-masked] wrote:
> There is 1 message in this issue.
> 
> Topics in this digest:
> 
>       1. Debugger
>            From: "Cyrano Jones" <cyranojones_lalp@...>
> 
> 
> ________________________________________________________________________
> ________________________________________________________________________
> 
> Message: 1         
>    Date: Thu, 10 Mar 2005 08:13:52 -0000
>    From: "Cyrano Jones" <cyranojones_lalp@...>
> Subject: Debugger
> 
> 
> I have uploaded a current copy of my remote debugger 
> to the files section (a DOS executable, mailbug.exe).
> 
> It includes code to flash the remote target code
> (MBOOT/MBUG) into a mailstation.  I have tested
> it on version 2.22r and 2.53yr.  It should work with 
> 2.54, too.  I don't know about any of the others, 
> but it might.  You need a parallel laplink cable to 
> use it.  I think a windows DCC (direct cable connect)
> is essentially the same thing.
> 
> If you don't feel adventurous, it should be possible 
> to make a version that is more likely to work on
> unknown versions, it just is not done yet.
> 
> It also includes a "RAM" target, that emulates only the
> mailstation ROM (you don't need to connect to real mailstation).
> This will allow "on the fly" disassembly of the rom code,
> including comments, but not execution.  (unzip don
> hamiltons dump in subdir "hamilton", and debugger
> will convert it to .rom files.)
> 
> Installing the MBUG target will erase most of the
> mailstation code, but the low level stuff is preserved.
> MBUG will allow on the fly disassembly, uploading to
> ram, and executing, among other things.  Breakpoints
> still do not work.
> 
> There is also an extremely simple "hello world" program 
> (both .asm & .hex). It makes a call to a system routine, 
> and displays on the LCD.
> 
> The source code is included for the remote part, with
> an explanation of how it (remote) works.  The source 
> for the PC side is not included, 'cause it is not ready yet.  
> There is no documentation on using it yet either, but
> the menu should help.  
> 
> It uses the same code I posted earlier (unit_tribbles.pas)
> but with new timeout code that should work regardless
> of cpu speed now.  And it is still a DOS app (just be glad
> it is not still CP/M!!!).  If anyone knows how to turn
> tribbles.pas into a win32 device driver, then I could
> make a win32 version.
> 
> I only included comment file for page #00 of the rom
> for now.  I have a lot more, but it is taking time to get
> everything in order.  I hope to post more soon.  But I
> wanted to get something out now.
> 
> I'm sure I have forgot something....
> 
> Oh, if something goes wrong, you could toast your
> mailstation.  I now have 4 units with unbootable rom code.
> 
> And I would highly advise not to leave the laplink
> connected between your PC and the mailstation when
> booting the PC.
> 
> --
> CJ
> 
> 
> 
> 
> 
> ________________________________________________________________________
> ________________________________________________________________________
> 
> 
> 
> ------------------------------------------------------------------------
> Yahoo! Groups Links
> 
> 
> 
>  
> ------------------------------------------------------------------------
> 
> 
> 
> 
>

---

From: Brad Fayette <bfayette@...>
Date: Fri, 18 Mar 2005 20:30:20 -0500

Also, how do I shut off the mailstation now that it is flashed with the 
Mbug code? Thanks.

Regards,

Brad Fayette

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 19 Mar 2005 04:04:20 -0000

--- In [email-masked], Brad Fayette <bfayette@n...>  
> the mailstation now says "Welcome to Mbug", which I assume is a good 
 thing.

Correct!
 
> How do I load the "Hello World" program?

First make sure the target is set to "MBUG", and not "RAM".
The T key toggles between the two.

Then either set the "workfile" with W key, type hello.hex
(or just proceed with load, and enter filename when it asks.)

Next type L 4000
(as in "Load 4000)

Then type G 4000
(as in "Go 4000)

And it should execute the extremely short program, 
which calls the display routine, and then jump back 
into MBUG (it leaves MBUG in control when done).

For the addresses, you can also specify the device 
and page, or else it will use whatever device/page 
is at the z80 address  you give.  

You can enter a path with the filename, but the default 
dir is the 253yr subdir, and that is where hello.hex is.  
There is also a z80 cross assembler (dos) in the mbug 
directory.  

--
CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 19 Mar 2005 04:08:28 -0000

> Also, how do I shut off the mailstation now that it is flashed with 
the 

Unplug the power!

The mailstation shuts off under software control,
and that sowtware is not running now, so the
power button does nothing.  

--
CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 19 Mar 2005 05:46:49 -0000

> the mailstation now says "Welcome to Mbug", which I assume is a good 
thing.

I was wondering what os/cpu/mhz you are running under?

Do the comments display with the disassemble command (D xxxx)?

Disassembly works with either the mbug or ram targets, 
but it is slower with mbug because it is pumping the
code over the laplink as it scrolls down screen.

--
CJ