Subject: App record help

From: "CyranoJ" <cyranojones_lalp@...>
Date: Fri, 15 Jul 2011 06:18:59 -0000

I approved this message using the group web-interface, but it 
just disappeared.  Group log shows it was approved, too.
I tried to approve the copy in my email, but when I click
"approve" link, it tells me message no longer exists.

So, I am pasting in a copy of it here.

Thursday, July 14, 2011 9:09 PM
From:
"wizardofhaas1024" <sean@........>
To:
[email-masked]
Hi,
I am trying to write in an app record on my mailstation.
I am using an ivory DET1 and the instructions(Method C) from the docs that come with FyOS.
I got it to work on an emulator using the Demo Mailstation ROM.
I write in the code on the Hex editor, but when I get back to MailstationOS it doesn't have the app record under extras.
Any ideas?

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Fri, 15 Jul 2011 19:09:25 -0000

> I write in the code on the Hex editor, but when I get back to MailstationOS it doesn't have the app record under extras.

What address did you put your app at?

Did you also edit the "app directory" at 0x020000 in the dataflash?

I realize my documentation is rather sketchy, and I am not
very familiar with documentation for FYOS.....

....OK, I downloaded fyos doc, skimmed thru it, and I have to
say, large hunks of it bear a striking resemblance to my docs.

It seems what fyos calls an "app record" is what I would call
an "app directory" entry.  So, I will assume you have not 
entered the actual app code yet, and are just wanting to see
if you can add an empty selectable item to the "extras" menu.
(by the way, if your mailstation has the "yahoo" folder, the
new app will appear there, and not in extras.)

So, you need to edit page 0x08 of the dataflash, which is at
raw address 020000 
(i fergit how many leading zeroes are displayed in mailstation's 
hex editor.)  you want to make it look like this:

020000  01 00 01 00 00 00 00 00   00 18 00 00 00 00 00 00

CJ

---

From: "wizardofhaas1024" <sean@...>
Date: Fri, 15 Jul 2011 22:55:06 -0000

Got It!
Thanks for the help.
Didn't realize I had the Yahoo folder. I thought it was just a link to Yahoo.
Thanks!