Subject: Re: [mailstation] Anyone broken the locked down POP3 settings?

From: Robert Pittman <pittmanr99@...>
Date: Sun, 26 Sep 2004 00:59:35 -0700 (PDT)

I've looked at the possibility of breaking the key code, but this could be dangerous in light of the DMCA.
 
The method of sending updates to a Mailstation is covered by US Patent 6,697,942.  The "security key" is discussed in this patent, and the patent mentions "Simple DES" cyphers.  I'm no expert in cryptography, so I wouldn't know how to go about generating a valid key, and even if I did, there's no guarantee that the method described in the patent is the method used.
 
Any attempt to circumvent the security process could result in legal issues. This is why I haven't looked into this area very closely. I've created and sent messages to my Mailstation without a security key and have had no luck in updating anything. It seems that the security key verifies that the message is legit, and without it you're going to have no luck in changing any settings.
 
Another member is exploring the possibility of changing the contents of the on-board flash through the parallel port built in to the machine. I think there's more possibility of success using that approach, but it requires extra equipment that I don't have right now.
 
The processor is a Z80-derivative, so information is readily available on the Web. The problem is that there could be several megabytes of code to wade through to find the code that verifies the key, and it may not be easy to recognize when you see it. I'm not saying it's impossible; it's just not your typical weekend project. I'm sure it's only a matter of time before someone isolates that code and finds a way around it.

"Anthony Z." <hunter_az@...> wrote:
Just wanted to let everyone know that the �Function +
D + Reset� is only for Restoring the default account.
The default account is the
@.... this is handy if you
are giving a mailstation away and don�t want to leave
any information (e-mails, settings, or address book
information) in the unit.

I know the "Function + Shift + T + Power On" should
work for putting your own settings in. When you use
"Function + Shift + T + Power On" that should leave
you at the �Diagnostic Menu�. First you need to do the
�Fast Test�, this should be option number 2. This will
test �Flash, Key, Printer Port, RAM and ROM�, after
that screen it will go to the �Battery TESTING�
screen. You then need to hit the �Enter� key twice,
this will drop you back to the �Diagnostic� Menu, now
hit �Q� for quit. You should see the �Test Over!�
message, then it will dump you out at the standard
reset menu, just hit �No Clear� and if all went well
you should see a prompt like �Please create a new user
account�. Just hit OK and slap you info in to the
unit.

Also I was able to find some interesting information
on the XTND commands. The XTND commands are used in
configuration of the mailstation. When a configuration
is generated the key code is also created verifying
that it�s a real configuration. The unit will then
take all the configuration information and configure
its-self.

From what i have gathered there are 2 parts to the
mailstation service. First you have your standard POP3
Mailbox and they have a Mail Proxy that sits over it.
The Mail Proxy chops up long e-mails and strips out
some advertisements that would normally cause the mail
not to come though. I don�t know what method the proxy
uses to figure what parts to strip but if anyone has
idea please let me know.

|-------| |-----| |-------|
|POP3 |<->|PROXY|<--|MAIL |
|Mailbox| | | |STATION|
|-------| |-----| |-------|

Anyways this leaves me with several questions about
the key code. I�m thinking that the Mail Proxy
verifies the key and sends all the configuration
information to the mailstation. I have tried to
simulate configuration messages but to no avail.
Anyone else working in this direction?

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail 

Yahoo! Groups Links

---------------------------------
Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!

---

From: "Anthony Z." <hunter_az@...>
Date: Sun, 26 Sep 2004 04:12:00 -0700 (PDT)

aahhh I see. Well, I can understand wanting to stay
out of legal/DMCA issues. Well I guess we will have to
look at something else. I for one dont want to get in
trouble over a mailstation. Well I'm going to do some
more thinking, and see what I can figure out. I'll
keep you posted.

It seems the parallel flash is going to be the best
bet to do anything with the mailstation :)

Oh well, just a though....

---------------------------------------

I've looked at the possibility of breaking the key
code, but this could be dangerous in light of the
DMCA.
 
The method of sending updates to a Mailstation is
covered by US Patent 6,697,942.  The "security key" is
discussed in this patent, and the patent mentions
"Simple DES" cyphers.  I'm no expert in cryptography,
so I wouldn't know how to go about generating a valid
key, and even if I did, there's no guarantee that the
method described in the patent is the method used.
 
Any attempt to circumvent the security process could
result in legal issues. This is why I haven't looked
into this area very closely. I've created and sent
messages to my Mailstation without a security key and
have had no luck in updating anything. It seems that
the security key verifies that the message is legit,
and without it you're going to have no luck in
changing any settings.
 
Another member is exploring the possibility of
changing the contents of the on-board flash through
the parallel port built in to the machine. I think
there's more possibility of success using that
approach, but it requires extra equipment that I don't
have right now.
 
The processor is a Z80-derivative, so information is
readily available on the Web. The problem is that
there could be several megabytes of code to wade
through to find the code that verifies the key, and it
may not be easy to recognize when you see it. I'm not
saying it's impossible; it's just not your typical
weekend project. I'm sure it's only a matter of time
before someone isolates that code and finds a way
around it.

_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---

From: "Neil Morrison" <neilsmorr@...>
Date: Sun, 26 Sep 2004 09:16:19 -0700

If it's done outside of the USA - no problems. Why is it that "the land of the free" is so very unfree?

Regards,

Neil Morrison

  ----- Original Message ----- 
  From: Robert Pittman 

  ...