Subject: Procedures for MS 250 V1.12 and some wishes for repurposing it

From: "ebjoew" <jwatsjunk@...>
Date: Fri, 30 Mar 2012 01:23:11 -0000

Hello All,

I am a new arrival. I acquired a MailStation 250 at an auction for a grand total of $1. It did not include an AC adapter nor a base unit. It is a model DET2B with V1.12 firmware in a silvery grey case. I opened it up to find out what was inside and to consider hacking this gizmo.

Since I do not have a base unit that communicates by RF with the MailStation itself, the first thing I did was remove the antenna and its connecting cable since it was useless. I rather expect to be doing some hardware work inside this thing and I felt removing the antenna and its cable from the board just simplified things a little.

Thanks to the details scattered around in the messages and files produced in past by this group, I have found out how to get into those extra menus which let one "Restore Default Account" and enter the Hex Viewer and Hex Editor. I also stumbled into what to do to cause it to let me bring up the "Please create a new user account" prompt where it lets me enter ALL the settings for a user account including the ISP Account, ISP Password, Primary DNS, etc., etc.

While I have no wish to use the MailStation for its usual email purpose, I have played with it enough and read enough messages here to know that this might be useful info for somebody else so I thought I should document it here for others. So here is how I go about it.

 1. Be sure the unit has power, either via AC adapter or batteries.

 2. Start with the unit off.

 3. We will begin by removing any old existing user account settings and setting the unit to the default user account. I have read in many places where all one has to do is hold down the "Function" and "D" keys while pressing the reset button but I have found that often does not work for me. Some experimenting has taught me that this slight variation on that procedure makes it work reliably for me. I turn the unit on with the power button and let the unit come up into the main MailStation 250 menu. Then, with it still in that screen, I hold down the "Function" and "D" keys and press the reset button and continue to hold down the "Function" and "D" keys during a pause of several seconds, followed by a brief "Scanning memory data" progress bar, whereupon the unit presents the "Reset System Data" menu. At this point the "Function" and "D" keys may be released. The "No Clear" menu item is highlighted. Press the down arrow key once to move the highlight to the "Restore Default Account" menu item and then press the "Enter" key to select it.

 4. The unit prompts with the question "Are you sure to clear?" and the answer "Yes" is highlighted. Press the "Enter" key. We end up in the main "MailStation 250" menu. Just below the "MailStation 250" text at the top of the screen, we see that the unit's email address now consists of the unit's serial number followed by "@mailstation.com". If one selects "Extras" and then "Settings", we can see that the user name has been set to "New Customer". In any case, press the power button to turn the unit off.

 5. Next we simultaneously hold down the "Function" key, the "Q" key, and the "A" key and momentarily press the power button. We can release all the keys when we then get a prompt that consists only of a wide empty rectangle in the middle of the screen.

 6. Type (without the quotes) "qa781206" and press the "Enter" key. We arrive at the "DIAGNOSTIC MAIN MENU" screen.

 7. Hold down either Shift key while you press the F5 key. The F5 key is the rightmost unlabeled button located just below the screen. You will arrive at the Hex Viewer screen. The Hex Viewer is not labelled as such. It just appears as a screen full of hexadecimal digits with a wide column of alphanumeric and/or graphic characters on the right.

The first three pairs of digits at the start of each line is a memory address. The first such address appearing on the top line of the screen will be 00 00 00 followed by a colon (:) and then the hexadecimal contents of each of the 16 bytes of memory starting at that address.  When I do this I see all zeros for those 16 bytes. In fact, I see all zeros for the hexadecimal contents all down this page.

At this point you could use the arrow keys, the "Pg up" key, and the "Pg dn" key to move around in memory to see its contents but we next need to change the contents of one particular memory cell.

 8. In order to be able to change any cells we must enable the Hex Viewer to enter its Hex Editor mode. That requires entering something of a special passcode. To do that, type in the following string (without the quotes) "g710304x" and then press the "Back" button. As soon as you press the "g" key, a small box will appear to allow you to enter the rest of the string. Do not worry that there is not enough room for the "x" at the end of the string in that box. In fact, you will not even see the "x" on the screen but it is still important. When you press the "Back" button, the input box will simply disappear and things will look the same as they were before you typed in that special command.

 9. Type in this string (without the quotes) "g022900" and press the "Enter" key. While typing it in, the input box will again appear momentarily to allow you to finish typing the command. When you press the "Enter" key, the Hex Viewer will begin displaying the data for the memory cells beginning at address 022900. We can confirm this is where we are in memory by reading that the start of the first line reads like this: 02 29 00 : 01 00 4e 65 77 20 and so forth. If we look at the panel of alphanumeric/graphic characters on the right side of the screen, we see that the first line contains the words "New Customer". Also, a few lines after that, we see the default email address consisting of the unit's serial number followed by "@..." We can also note that the first digit (a zero) following that colon on the first line of the screen is highlighted. Press the right arrow key one time to move the highlight to the very next character which is a "1".

10. I suspect that this "1" indicates that there is one email account set up in the unit but that is just my best guess. In any case, I find that for me this next step gets me to where I want to go. Press the "S" key. We see that the right part of the screen changes to indicate that we have entered the Hex Editor. It shows us that we could press Ctrl+S to Save & Exit, Back to Exit, Arrow to move the cursor, or 0-9,A-F for input. We also see that the highlight is still on that "1". (By the way, although it says "Ctrl+S" is used to "Save & Exit", all that is really needed is just "S".)

11. Press the "0" key (the zero key, not the alphabetic "O" key). Now the two digit number following that colon near the start of the first line reads "00" instead of "01". Next press the "S" key to save this small memory change and return to the Hex Viewer display screen. I believe that we have just told the MailStation there are no email accounts currently set up.

12. Press the "Back" button to exit the Hex Viewer and return to the "DIAGNOSTIC MAIN MENU" screen.

13. Press the "Q" key to exit this screen. A "Test Over" message briefly appears on the screen and then we see a "Scanning memory data" progress bar followed by the the "Reset System Data" menu again. This time, it does not include the "Restore Default Account" menu item. The "No Clear" menu item is highlighted. Press the "Enter" key. We now see a prompt for "Please create a new user account." with an "OK" response highlighted. Press the "Enter" key. We now see a "User Settings" screen where we can input a response to each of the following prompts:

      User Name:
     Dial-Up No:
       Reply-To:
_____________________________________________________
 E-Mail Address:
E-Mail Password:
    POP3 Server:
    SMTP Server:
    ISP Account:
   ISP Password:
    Primary DNS:

Once we have assigned a value to each prompt, press the F1 key which is now labelled "Save" at the bottom of the screen. The new user account data is saved and we are left in the main "MailStation 250" menu.

For my own personal purposes, I would like to see the MailStation be set up to run just about any type of operating system or other underlying system that then supports some version of Microsoft Basic. It could be MBasic under CP/M or it could be a Basic interpreter from one of the TRS-80 computers. I would even consider the very original Microsoft Basic interpreter, the one written for the Altair 8800. I helped a friend build his Altair 8800 many years ago and we wrote many programs on his system. I would at least want the version intended for 8K because the 4k version did not really support character strings. So I am pretty easy to satisfy. I have become aware of FyberOptic and his FyOS operating system but have not had time to totally gage its current state, availability, and applicability. In any case, I congratulate Jeff, Cyrano, Don, and others who have contributed so much of their time and sweat to uncover the secrets of these neat little computers.

Joe

---

From: waynem@...
Date: Fri, 30 Mar 2012 20:28:55 -0700 (MST)

Fantastic job !!!!

Do you think this might also work with the model 350 ?
Wayne

> Hello All,
>
> I am a new arrival. I acquired a MailStation 250 at an auction for a grand
> total of $1. It did not include an AC adapter nor a base unit. It is a
> model DET2B with V1.12 firmware in a silvery grey case. I opened it up to
> find out what was inside and to consider hacking this gizmo.
>
> Since I do not have a base unit that communicates by RF with the
> MailStation itself, the first thing I did was remove the antenna and its
> connecting cable since it was useless. I rather expect to be doing some
> hardware work inside this thing and I felt removing the antenna and its
> cable from the board just simplified things a little.
>
> Thanks to the details scattered around in the messages and files produced
> in past by this group, I have found out how to get into those extra menus
> which let one "Restore Default Account" and enter the Hex Viewer and Hex
> Editor. I also stumbled into what to do to cause it to let me bring up the
> "Please create a new user account" prompt where it lets me enter ALL the
> settings for a user account including the ISP Account, ISP Password,
> Primary DNS, etc., etc.
>
> While I have no wish to use the MailStation for its usual email purpose, I
> have played with it enough and read enough messages here to know that this
> might be useful info for somebody else so I thought I should document it
> here for others. So here is how I go about it.
>
>  3. We will begin by removing any old existing user account settings and
> setting the unit to the default user account. I have read in many places
> where all one has to do is hold down the "Function" and "D" keys while
> pressing the reset button but I have found that often does not work for
> me. Some experimenting has taught me that this slight variation on that
> procedure makes it work reliably for me. I turn the unit on with the
> power button and let the unit come up into the main MailStation 250 menu.
> Then, with it still in that screen, I hold down the "Function" and "D"
> keys and press the reset button and continue to hold down the "Function"
> and "D" keys during a pause of several seconds, followed by a brief
> "Scanning memory data" progress bar, whereupon the unit presents the
> "Reset System Data" menu. At this point the "Function" and "D" keys may
> be released. The "No Clear" menu item is highlighted. Press the down
> arrow key once to move the highlight to the "Restore Default Account"
> menu item and then press the "Enter" key to select it.
>
>  4. The unit prompts with the question "Are you sure to clear?" and the
> answer "Yes" is highlighted. Press the "Enter" key. We end up in the main
> "MailStation 250" menu. Just below the "MailStation 250" text at the top
> of the screen, we see that the unit's email address now consists of the
> unit's serial number followed by "@...". If one selects
> "Extras" and then "Settings", we can see that the user name has been set
> to "New Customer". In any case, press the power button to turn the unit
> off.
>
>  5. Next we simultaneously hold down the "Function" key, the "Q" key, and
> the "A" key and momentarily press the power button. We can release all
> the keys when we then get a prompt that consists only of a wide empty
> rectangle in the middle of the screen.
>
>  6. Type (without the quotes) "qa781206" and press the "Enter" key. We
> arrive at the "DIAGNOSTIC MAIN MENU" screen.
>
>  7. Hold down either Shift key while you press the F5 key. The F5 key is
> the rightmost unlabeled button located just below the screen. You will
> arrive at the Hex Viewer screen. The Hex Viewer is not labelled as such.
> It just appears as a screen full of hexadecimal digits with a wide column
> of alphanumeric and/or graphic characters on the right.
>
> The first three pairs of digits at the start of each line is a memory
> address. The first such address appearing on the top line of the screen
> will be 00 00 00 followed by a colon (:) and then the hexadecimal contents
> of each of the 16 bytes of memory starting at that address.  When I do
> this I see all zeros for those 16 bytes. In fact, I see all zeros for the
> hexadecimal contents all down this page.
>
> At this point you could use the arrow keys, the "Pg up" key, and the "Pg
> dn" key to move around in memory to see its contents but we next need to
> change the contents of one particular memory cell.
>
>  8. In order to be able to change any cells we must enable the Hex Viewer
> to enter its Hex Editor mode. That requires entering something of a
> special passcode. To do that, type in the following string (without the
> quotes) "g710304x" and then press the "Back" button. As soon as you press
> the "g" key, a small box will appear to allow you to enter the rest of
> the string. Do not worry that there is not enough room for the "x" at the
> end of the string in that box. In fact, you will not even see the "x" on
> the screen but it is still important. When you press the "Back" button,
> the input box will simply disappear and things will look the same as they
> were before you typed in that special command.
>
>  9. Type in this string (without the quotes) "g022900" and press the
> "Enter" key. While typing it in, the input box will again appear
> momentarily to allow you to finish typing the command. When you press the
> "Enter" key, the Hex Viewer will begin displaying the data for the memory
> cells beginning at address 022900. We can confirm this is where we are in
> memory by reading that the start of the first line reads like this: 02 29
> 00 : 01 00 4e 65 77 20 and so forth. If we look at the panel of
> alphanumeric/graphic characters on the right side of the screen, we see
> that the first line contains the words "New Customer". Also, a few lines
> after that, we see the default email address consisting of the unit's
> serial number followed by "@..." We can also note that the
> first digit (a zero) following that colon on the first line of the screen
> is highlighted. Press the right arrow key one time to move the highlight
> to the very next character which is a "1".
>
> 10. I suspect that this "1" indicates that there is one email account set
> up in the unit but that is just my best guess. In any case, I find that
> for me this next step gets me to where I want to go. Press the "S" key. We
> see that the right part of the screen changes to indicate that we have
> entered the Hex Editor. It shows us that we could press Ctrl+S to Save &
> Exit, Back to Exit, Arrow to move the cursor, or 0-9,A-F for input. We
> also see that the highlight is still on that "1". (By the way, although it
> says "Ctrl+S" is used to "Save & Exit", all that is really needed is just
> "S".)
>
> 11. Press the "0" key (the zero key, not the alphabetic "O" key). Now the
> two digit number following that colon near the start of the first line
> reads "00" instead of "01". Next press the "S" key to save this small
> memory change and return to the Hex Viewer display screen. I believe that
> we have just told the MailStation there are no email accounts currently
> set up.
>
> 13. Press the "Q" key to exit this screen. A "Test Over" message briefly
> appears on the screen and then we see a "Scanning memory data" progress
> bar followed by the the "Reset System Data" menu again. This time, it does
> not include the "Restore Default Account" menu item. The "No Clear" menu
> item is highlighted. Press the "Enter" key. We now see a prompt for
> "Please create a new user account." with an "OK" response highlighted.
> Press the "Enter" key. We now see a "User Settings" screen where we can
> input a response to each of the following prompts:
>
>       User Name:
>      Dial-Up No:
>        Reply-To:
> Once we have assigned a value to each prompt, press the F1 key which is
> now labelled "Save" at the bottom of the screen. The new user account data
> is saved and we are left in the main "MailStation 250" menu.
>
>
>
> For my own personal purposes, I would like to see the MailStation be set
> up to run just about any type of operating system or other underlying
> system that then supports some version of Microsoft Basic. It could be
> MBasic under CP/M or it could be a Basic interpreter from one of the
> TRS-80 computers. I would even consider the very original Microsoft Basic
> interpreter, the one written for the Altair 8800. I helped a friend build
> his Altair 8800 many years ago and we wrote many programs on his system. I
> would at least want the version intended for 8K because the 4k version did
> not really support character strings. So I am pretty easy to satisfy. I
> have become aware of FyberOptic and his FyOS operating system but have not
> had time to totally gage its current state, availability, and
> applicability. In any case, I congratulate Jeff, Cyrano, Don, and others
> who have contributed so much of their time and sweat to uncover the
> secrets of these neat little computers.
>
> Joe
>
>
>

---

From: Mark Burch <markmup@...>
Date: Fri, 30 Mar 2012 21:19:01 -0700 (PDT)

I bought one 4 years ago and stare at it lately.  I appreciate your sharing.
 
Mark

________________________________
 From: "waynem@...t" <waynem@...>
To: [email-masked] 
Sent: Friday, March 30, 2012 10:28 PM
Subject: Re: [mailstation] Procedures for MS 250 V1.12 and some wishes for      repurposing it
 
Fantastic job !!!!

> unit's serial number followed by "@mailstation.com". If one selects

------------------------------------

Yahoo! Groups Links

    http://docs.yahoo.com/info/terms/

---

From: "ebjoew" <jwatsjunk@...>
Date: Sun, 01 Apr 2012 18:27:31 -0000

Your guess is as good as mine about the 350 since I have never seen one. I do know from reading many of the messages in this group that the 350 does not use the same type of central processor chip and that means the firmware in its ROMs will likely be very different. Does that mean that the data in RAM is laid out the same? Well, it could be but I would bet against it. So I would expect that these procedures would not work exactly as I have written them but it is always possible that they might.

Be careful. In my case, I was not too worried about messing up my 250 since I only had a dollar invested in it and the only time I had invested was with reading hundreds of messages and a few files located in this group.

Good Luck,
Joe