Subject: Mbug

From: Brad Fayette <bfayette@...>
Date: Sat, 19 Mar 2005 09:39:39 -0500

I should have figured that out about the power.  I guess there is some 
work left to do :-)

I am running it on a Toshiba T4700CS laptop, 50mhz 486, Win 95.  Runs 
fine in a dos window.

I am seeing comments when I disassemble.  I assume the code is coming 
out of the mailstation, and the comments out of a file. I guess this is 
something to be aware of in case you change something.

Do you have any advice on how not to trash the mailstation when 
writing/loading/running applications?

Does the mailstion 250 have a Z80?  I have a 350, but it has some 
toshiba 16 bit processor, so I'm getting rid of it.  The interesting 
thing is that for wireless devices, the FCC has tons of stuff online, 
like schematics.  All you need is the FCC Id. Maybe some of it for the 
250 would apply to other devices as well.

CJ, where are you located?  I'm in North Carolina, USA.

-- 
Regards,

Brad Fayette
"The geeks shall inherit the Earth."

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sun, 20 Mar 2005 05:50:30 -0000

--- In [email-masked], Brad Fayette <bfayette@n...> 
wrote:
> I should have figured that out about the power.  I guess 
> there is some work left to do :-)

It won't be hard to get it to shut off, I just
haven't tried.  Actually, I don't think it ever
really shuts itself off in "normal" use,  I think
it just "goes to sleep".  

Try "G 1AC0"
That will execute what I believe the ms does
when it "turns off".  My screen went blank when
I tried it!  I thought I would have to power cycle
or reset to get it back, but the power button
wakes it up!!! 

I actually leave mine on most of the time, running
with the wall-wart.   (And that has been how I 
killed 3 of the 4.)  If you are using batteries, I
guess you need to take them out to get it 
completely off.

> I am running it on a Toshiba T4700CS laptop, 
> 50mhz 486, Win 95.  Runs fine in a dos window.

That's cool.  I hadn't even thought about that end
of the spectrum. :-)    How much ram is in it?
The debugger allocates over 3 meg of buffers,
and it probably should run with a disk cache
(win 95 provides one, right???) because the comment
files are not buffered inside of the program 
(and it reads them from the beggining every
time screen scrolls.)

> I am seeing comments when I disassemble.  I assume 
> the code is coming out of the mailstation, and the 
> comments out of a file. I guess this is 

Right.  If you installed the v2.53 files, and converted
to .rom files, then you can use the "ram" target, and
browse the disassembly/comments, and the code
will be read from pc ram, and it is noticeably
faster.  I started to add the concept of "projects"
so you could have different versions use different
comment files, but that is not done yet.

I'm just distributing the comment files, without
the disassembly, because I don't want to
worry about any copyright issues.
 
If you use command ^h it will render the disassembly
and comments to a hyperlinked .html files.  I don't
know how long it will take at 50 MHz to do pages
00 thru 3f, but you can tell it to do just page 00.
(I recommend using ram target for this.  But it
should work from mbug, just slower.)

> Do you have any advice on how not to trash the 
> mailstation when writing/loading/running applications?

The first one I trashed was due to me asking the
debugger to erase a page that held part of the 
then-current bootup code.  The only way to avoid 
that is to be careful.  :-)  :-)

The second and third were due to changes I 
made to keep the mailstation from getting locked up
when rebooting the PC.  Previously it had
been thru countless reboots, with the
only ill effect being that it was unresponsive to
commands, and required a hard reset.  

I was getting tired of having to 
poke a pencil in the reset hole.  I
figured what was happening was that
either windows or the PC firmware was
"printing" some garbage to the parallel port
during boot up (you know how a printer will
sometimes print garbage when a PC is booting.)
So, I added some error detection, making
the remote code restart whenever it got
a command that didn't make sense.  All I
can figure is that what happened is that
I gave the gibberish a fresh shot from
the start everytime it sent nonsense,
making it much more likely to hit on the
command "erase page 00" eventually.

The first time it happened I really didn't
know what had happened.  I grabbed a
new mailstation, and installed the very same
version of mboot.  Within a week that one
was toast, too.  I figured it must have something
to do with the most recent changes.  So
I decided I should fix it before wrecking
another mailsation.  In the meantime, I
was fiddling with a stock mailstation 
(without my code) trying to read the serial
number thru the laplink (that works!).

But I left the thing connected (and powered)
when I was done.  Several days went by,
with several pc reboots, and then one day
I noticed that this *stock* mailstation
had apparently gotten erased.  Live and learn.

I now *unplug* the laplink when I quit
the debugger (It now displays a 
reminder when quitting!)
I actually thought I had fixed it
so this couldn't happen, but as I
look at the code now, it appears that
the reminder is how I fixed it.
If only I had the time to do everything I
want to...

But I havent had any problem since
December.  The next version should
have a better safeguard.

There really is no way to prevent
a haywire program from finding the reflash 
code, other than removing it completely.
I mean, even if you thought you had
a secure lockout, what if the program
running amok jumps in right after the lock?
But I don't think we really need to worry
about that.  Just unplug the laplink when
you are done, for now!  And brown
mailstations are real cheap on ebay. :-)
 
> Does the mailstion 250 have a Z80?  

Yes.  It's essentially the same as the
brown/white/100's.  Except for the
modem, and the radio circuitry.  And
keyboard.  And callerid chip.  But the 
cpu/ram/codeflash/dataflash are the same.

> I have a 350, but it has some 
> toshiba 16 bit processor, so I'm getting rid of it.  

I'll bet you can get over $100 for it on
ebay.  I've seen several sell in the $130 range.

The 350 appears to use some other
protocol (if any) for it's update function.

> The interesting 
> thing is that for wireless devices, the FCC has 
> tons of stuff online, like schematics.  All you 
> need is the FCC Id. Maybe some of it for the 

Yes!  Where is the search page?  I saw the link
on linux hacker for the 350 data.  But I can't
find a search page that will return that page.
Is there any reason we shouldn't look at this,
like with the patent info?

We already have most of the port/pinout/address info
courtesy of rogblake, and one friendly panther
(who I understand almost went blind tracing the circuit).
 
> CJ, where are you located?  I'm in North Carolina, USA.

I'm in the Detroi..... Uh, I mean I'm in my ship, hovering 
500 miles over the Detroit area, safely out of reach of 
any Earth regulations such as DMCA (or even YMCA!)
Don't let my ip address fool you, I'm attached to 
some earthlings open wi-fi link.  Yeah, that's it.

--
CJ