Subject: I developed a small module to transfer saved files from the Mailstation into a PC via USB

From: Jon Kirwan <jonk@...>
Date: Fri, 03 Jun 2011 00:36:35 -0700

I started a project two weeks ago to help me transfer saved
email files from Mailstation units into PC's using the USB
ports that are usually available.  It connects to the printer
port on the Mailstation unit and uses the standard "print"
button to start the transfer.  (A program does need to be
running on the PC to capture the file and save it, but it
uses a virtual COM port over the USB so any serial port
capturing program can be used [or easily written using VB,
for example.])

It's cheap to build so I wouldn't mind making more if anyone
is interested.  Basically, it's a USB-powered module
(circuit) that has a USB connector and a parallel port
connector and once the virtual COM port software is installed
you just snap in the USB cable on one end and the Mailstation
on the other and the PC acts like a printer to it.  Except
that it can save the ASCII text to a file, of course.

Schematics, parts, and software would be available to those
wanting to try their own hand building these.  They aren't
complex to do.

Jon

---

From: "thartsell" <tom.hartsell@...>
Date: Sat, 04 Jun 2011 11:59:35 -0000

Looks like a cool project especially since I'm an electronics guy but I'm having enough trouble keeping 91 year old mother-in-law from pulling the telephone line out of the wall or putting the batteries in backwards... wouldn't EVEN want to try to teach her something new.
At some point I'll get these back and will have a chance to play with it.

---

From: Brad Fayette <brad@...>
Date: Sat, 04 Jun 2011 08:27:48 -0400

Hi Jon,

This sounds like a very cool device that would have applications beyond 
the mailstation. I would be interested in learning more about it.  Thanks!

Regards,

Brad FayetteThis actually

---

From: Jon Kirwan <jonk@...>
Date: Sat, 04 Jun 2011 06:56:11 -0700

On Sat, 04 Jun 2011 11:59:35 -0000, tom.hartsell wrote:

> Looks like a cool project especially since I'm an
> electronics guy but I'm having enough trouble keeping 91
> year old mother-in-law from pulling the telephone line out
> of the wall or putting the batteries in backwards...
> wouldn't EVEN want to try to teach her something new.
>

Hehe.  Well, there is that!!  It's a simple device, though.
I'm working on some .NET software for the PC end to make that
even easier to use and apply (seemless, I hope.)

Jon

>------------------------------------
>
>Yahoo! Groups Links
>
>
>

---

From: Jon Kirwan <jonk@...>
Date: Sat, 04 Jun 2011 07:19:02 -0700

>the mailstation. I would be interested in learning more about it.  Thanks!

Well, the parts are the following:

  1)  TI MSP430 Launchpad tool -- I paid $4.30 and that's
      with shipping costs to my door, included in the price.

https://estore.ti.com/MSP-EXP430G2-MSP430-LaunchPad-Value-Line-Development-kit-P2031.aspx

  2)  DB25 male connector (had one in a drawer.)
  3)  fragment of vector board.
  4)  one 3.9k resistor
  5)  eight 10k resistors
  6)  one 47k resistor
  7)  one 560pF
  8)  wire, solder, soldering iron, pliers, etc.

The TI MSP430 Launchpad board comes with two cpus.  The
MSP430G2231 and the MSP430G2211.  Both are 14 pin devices. It
also comes with a 32kHz crystal, 2 sets of male and female
10-pin connectors for my vector board as a daughter card
above it, and a USB cable.

I could have ordered a 20-pin MSP430 device and added 6 more
I/O pins to use -- might have been enough to do everything
with one micro that way.  But I decided that since I still
needed that vector board to mount the DB25 on... that I might
was well just use the parts that actually come in the kit. To
get the needed I/O I had to use both cpus.
    
The daughter board cpu has access to the parallel port and
uses port 1 (P1) to read in the 8 data bits when strobed.  It
also has two more I/O pins plus an NMI input.  I use the NMI
as the /STROBE input and trigger on falling edge.  The other
two I/O pins serve as BUSY and ACK.  To communicate with the
main board's cpu, the BUSY line is copied down via the
connector to one of pins there.  Also, two of the 8 data bus
pins perform double-duty:  as data from the parallel port
when BUSY is not active and when BUSY is active, the two cpus
uses two of the 8 lines as CLOCK and DATA to transfer the
byte over (that's about all the spare pins on the main board,
as it uses P2's pins for the 32kHz xtal and two more for TxD
and RxD into the virtual com port into the PC and some for
LEDs and for switches.

There are many other interesting details and calculations
involved, but that should get the basic idea across.

Software for both cpus is done and working fine and I've been
shipping files across without difficulty.

Basically, this takes advantage of the heavy lifting already
done by an EXTREMELY cheap development board put out by TI,
adding software, vector board, a connector, and a few cheap
passives.  The whole project, from initial decision to start
until finished and working software and in spare time only,
was a little over two weeks.  Thought it might be a good idea
on the 13th of May.  Had no exact idea at the time how to do
it; only a rough feasibility check given I/O pins available
and a few thoughts about how I might go about it.

Jon

---

From: "musicalman77" <musicalman77@...>
Date: Sun, 05 Jun 2011 16:54:38 -0000

Jon,

That is SO cool! Twice now I really could've used that.  My sister and I arranged for a "card party" for mom's 90th and 93rd birthdays and were looking for an easy way to get her MailStation address book exported so we could e-mail her contacts from a real PC, easily and without her knowledge. The way I overcame it was by printing out her addy list using the printer port on her MailStation (hooked up to an old HP4L laser printer I had with a DB-25), then scanning the hard copy prints using OCR, but as you can imagine, this two-step process was somewhat slow and it still took some editing & proofing hassle.  Your toy would've been SOOOOO much faster, easier & 100% accurate.

Mom passed away February 21, a week short of that 93rd birthday, and I now have her MailStation.  Not sure what to do with it. May sell it on eBay someday but for now, keeping it for sentimental reasons.

Your project looks like fun & fairly inexpensive! Keep us posted.

~Jon (that's me also!)

---

From: Jon Kirwan <jonk@...>
Date: Sun, 05 Jun 2011 11:11:04 -0700

If interested in selling the unit, let me know.  I will be
making more of these things and may as well find good homes
for the combined devices.

They aren't just for old people, with this.  The Mailstation
is very convenient (AA batteries, light weight, low cost) to
use anytime one is sitting at the doctor's office waiting, or
anywhere it's likely one has time to kill (on rail transport
or a bus, etc) and would like to write with the idea that if
the device is lost or stolen it's not several hundreds of
dollars of loss.

The Kindle is great for reading.  But it is useless if you
want to produce writing content, for example..

Anyway, I'm going to start producing a finished product for
these and collecting up those units people want to dispose of
for whatever reasons.  Probably not to sell, so much, as to
give away as presents for those I think would get some use
out of it.

I purchased some from Office Depot when they were dumping
them at $5 each.  Crazy good price.  Too bad that supply is
gone!

I may, at some point, go further and design a unit that ties
in via the phone connector and lets it think it is dialing
Earthlink so that I can facilitate a two-way transfer between
PC and the unit.  Make it look like a file system on USB so
that files can be dragged and dropped onto (or off of) it.
But that's for another day.

I used this project to continue teaching my son more about
electronics, embedded software, reading and finding
appropriate documentation and using it well, creating
associated documentation for a final completion, testing and
using oscilloscopes and other tools, soldering, etc.  It was
a great experience for him (and for me.)

Jon

---

From: Kelly Boal <kjoanne403@...>
Date: Sun, 5 Jun 2011 21:23:36 -0700 (PDT)

Hi Jon,
I have two of them that you can have.  I thought they were a good idea when I 
bought them off eBay but then I couldn't get either one online, so if you can 
use them, they're yours.  If you could pay the shipping, though, when I find out 
how much it is, I'd appreciate that.
Kelly

________________________________
From: Jon Kirwan <jonk@...>
To: Mailstation list <[email-masked]>
Sent: Sun, June 5, 2011 12:11:04 PM
Subject: Re: [mailstation] Re: I developed a small module to transfer saved 
files from the Mailstation into a PC via USB

Jon

On Sun, 05 Jun 2011 16:54:38 -0000, you wrote:

>Jon,
>
>That is SO cool! Twice now I really could've used that.  My sister and I 
>arranged for a "card party" for mom's 90th and 93rd birthdays and were looking 
>for an easy way to get her MailStation address book exported so we could e-mail 
>her contacts from a real PC, easily and without her knowledge. The way I 
>overcame it was by printing out her addy list using the printer port on her 
>MailStation (hooked up to an old HP4L laser printer I had with a DB-25), then 
>scanning the hard copy prints using OCR, but as you can imagine, this two-step 
>process was somewhat slow and it still took some editing & proofing hassle.  
>Your toy would've been SOOOOO much faster, easier & 100% accurate.
>
>Mom passed away February 21, a week short of that 93rd birthday, and I now have 
>her MailStation.  Not sure what to do with it. May sell it on eBay someday but 
>for now, keeping it for sentimental reasons.
>

---

From: Jon Kirwan <jonk@...>
Date: Sun, 05 Jun 2011 23:11:04 -0700

>how much it is, I'd appreciate that.

That's very nice of you.  I'd love to take advantage of the
offer and I'd gladly pay shipping costs.  Back in 2009, I did
that with someone in Scottsdale and it cost them $10.05, if I
recall correctly.  But that's US to US, as I'm in Oregon.

I will find them good homes, for sure.  I'm working on
another idea to allow transfers both directions so that it
can be used as a "USB memory stick."  But that will "take me
a little longer."  :)

Anyway, I'm located near Portland, Oregon.  Let me know what
you get in terms of sending them by mail.  If it is too much,
I might just say to keep them.  But hopefully, the post
office up there won't take an arm and a leg to get them here.

<snip of address info mailed directly to email address>

If you are of a mind to call, feel free.  If you'd like to
talk for a minute, but would rather I pay, just let me have
your number and preferred times.  Otherwise, let me know the
"damage" your postal service tells you about.

I would use my bank's "bill pay" to send a bank check (should
be very quick to cash -- no delay, as it is drawn from the
bank and not from my account) to you, with your address of
course.

Sincere thanks for the possibility!

Jon

---

From: Jon Kirwan <jonk@...>
Date: Tue, 07 Jun 2011 13:28:59 -0700

>how much it is, I'd appreciate that.

Just in case my sending email to you directly didn't get
through (trash bin?), just letting you know that I did send
an email separately to you.  If you didn't get it, let me
know.  I haven't received a response.

And thanks,
Jon

---

From: Kelly Boal <kjoanne403@...>
Date: Tue, 7 Jun 2011 14:03:25 -0700 (PDT)

Sorry - yes, I got your email; I just haven't made it to the post office yet to 
find out how much shipping will be.  I'll find out sometime this week and let 
you know.
Glad you can use them!
Kelly

Sent: Tue, June 7, 2011 2:28:59 PM

And thanks,
Jon