Subject: Corrupted settings - model 120 v4.05e firmware

From: "c5687ef4580423904ba368b215a992a0" <c5687ef4580423904ba368b215a992a0@...>
Date: Sat, 30 Apr 2005 22:58:36 -0000

Most of my settings are y'd out.  It's a funky y with two dots on top, just above the 
raised arms.  so far my reply to address has that, but the primary dns is blank.  other 
settings appear normal.   
 
auto check mail is no  
auto check time is at 2 am 
call waiting is no  
ignore dial tone is no  
and speaker is yes  
  
My 120 wasn't hackable via any other means.  I decided to yank power 
just after hitting  
'save' settings. hehe oops.  It's not resetting to factory defaults 
now.  I guess I toasted it  
:)  
  
any idea if there's a jtag testing point on these buggers?  Also, 
what GNU/GPL tools can  
be used with this?  I've used the avr micro compiler to build 
firmware for atmels before.  
(c code to intel hex files).  
  
Thanks.

---

From: "John R. Hogerhuis" <jhoger@...>
Date: Sat, 30 Apr 2005 18:55:53 -0700

On Sat, 2005-04-30 at 22:58 +0000, c5687ef4580423904ba368b215a992a0
wrote:
> any idea if there's a jtag testing point on these buggers?

I'd suggest using mailbug. With it you can reflash the unit over the
serial port with whatever you want.

You could just use mailbug or burn NoICE in there.

>   Also, 

sdcc comes to mind. Probably others. More public domain or freeware
stuff than gpl...

-- John.

---

From: "c5687ef4580423904ba368b215a992a0" <c5687ef4580423904ba368b215a992a0@...>
Date: Sun, 01 May 2005 05:04:33 -0000

hold down function d, don't let go 
reset via the reset switch 
release after you see a menu 
select Restore Default Account 
Just as you're confirming Yes (enter) disconnect power. 
Upon reapplication of power, the unit will post with a memory check, and throw a msg 
saying you need to setup the account. (one time it said memory corruption). 
 
After reconfiguring my pop3 server (I own my own ppp gear and mail servers, among 
other things) I'll have to see what else happens. :) but from verbose debug logs, the mail 
server is catching the login, but it refuses the client because it truncates the email 
address when logging in, and I'm mass vhosting email... 
 
anyway, thanks! whaouuUUuuu! =) =) =) 

> You could just use mailbug or burn NoICE in there. 
 
No need now! wahou! 
 
> sdcc comes to mind. Probably others. More public domain or freeware 
 
Linux friendly stuff works for me.