Subject: Email to application idea

From: "wizardofhaas1024" <sean@...>
Date: Fri, 15 Jul 2011 01:24:37 -0000

When you get an email on your mailstation it is stored around 0x024d00, I was messing with some mail using the hex editor and thought of something, could you send an email that contained the hex code for a program to the mailstation and then use another program to relocate the email code to a location where you could access and run it?

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Sat, 16 Jul 2011 06:11:31 -0000

--- In [email-masked], "wizardofhaas1024" <sean@...> wrote:
>
> When you get an email on your mailstation it is stored 
> around 0x024d00, I was messing with some mail using the 
> hex editor and thought of something, could you send an 
> email that contained the hex code for a program to the 
> mailstation and then use another program to relocate the 
> email code to a location where you could access and run it?

I don't see why not.  

You might even be able to email a binary image, but I am
not sure it would make it through the email process undamaged.

What I was doing to get code loaded on a stock mailstation
was loading it to the splash screen image with mailbug.
Then, with mailstations hex editor, I entered a "jump"
to that image as a very short app (9 bytes).  When executed
from the "extras" or "yahoo" menu, it would then copy itself
to one of the "app" pages.

I only used that process to load a "bootapp", which acted
as the remote end of mailbug, my remote debugger.

After the bootapp was installed, I would load subsequent
apps to ram using mailbug, and then run them.  The technique
of having the app copy itself to the app space worked so good
I just kept using it to copy these ram images to the dataflash,
and never did add (to mailbug) a function to write directly to
dataflash.

CJ

---

From: "Neil Morrison" <neilsmorr@...>
Date: Sat, 16 Jul 2011 09:07:33 -0700

The ones with the Yahoo function could get small images it seems.

Neil

From: CyranoJ

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Sun, 17 Jul 2011 04:39:47 -0000

> The ones with the Yahoo function could get small images it seems.

If you mean the "TV listings" etc., they were just one big
graphic image.  But I imagine they were sent as mime attachments
of some sort.  I was wondering if you could send executable
binary code as the body of an email, and then just jump to the
saved email to run it.  But the more I think about it, I am
not sure just what you could send an email like that with.
Certainly not any standard email client.

Usually even attached files are encoded as text, aren't they?

It's probably a better idea to send intel hex format, and have
a loader on the mailstation decode it to binary.  And then
it could write the binary to a free app page!

Or load it into ram and execute it.  That might require
the mailstation reboot when done executing, unless you
could find enough ram that is unused (or rarely used???).

CJ

---

From: "Neil Morrison" <neilsmorr@...>
Date: Sat, 16 Jul 2011 21:57:26 -0700

ISTR they could get 'special' emails which set them to a particular ISP or whatever.

Not sure what the format of those was.

The Yahoo thing also did weather and a couple more things I think.

Neil

From: CyranoJ 

> I was wondering if you could send executable

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Sat, 16 Jul 2011 03:05:26 -0000

I don't see why not.  

You might even be able to email a binary image, but I am
not sure it would make it through the email process unmolested.

dataflash .

CJ