Subject: LCD Pinout

From: "texasmason1984" <stonemason@...>
Date: Sat, 03 Apr 2004 00:11:50 -0000

Does any one have a pinout for the LCD board?

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 03 Apr 2004 22:17:50 -0000

--- In [email-masked], "texasmason1984"
> Does any one have a pinout for the LCD board?

This info is for the LCD in the white mailstation, 
I think it is the same in all models except 300 & 350.

The display is 320 x 128 x 1, but it is really two 160 x 128
displays side by side.  Pins 7 & 10 select which half.

Each half has 20 columns, each column is 8 pix wide, and 128 pix high.

Data is written as if the lcd was a ram.  First the column address is 
written to address #38 while the column reg is selected (pin 8 low).
Then the pixel data for the 128 rows is written, one byte per row, to 
addresses #38 thru #B7 (while pin 8 is held high). 

My guess as to why the rows are numbered #38 thru #B7 is that 
the controller IC inside the LCD can address more than 128
rows, and these were just the most convenient pins to use.

IIRC, the first half is on the left, col 0 is on the right of
each half, row #38 at the top, and d0 at the left of each byte, 
but you might want to check that.

Contrast is controlled with a variable resistor (10k pot with 
wiper shorted to one end) from pin2 to GND.

PINOUT
1	GND
2	contrast
3	+5.2v
4	+5v
5	+5v
6	display enable (or /disable if you prefer)
7	/first half select
8	/column register select
9	/write
10	/second half select
11	A0
12	A1
13	A2
14	A3
15	A4
16	A5
17	A6
18	A7
19	D0
20	D1
21	D2
22	D3
23	D4
24	D5
25	D6
26	D7
27	GND
28	GND

It might not be obvious, but the connector on the main board is a zif.
While it is not difficult to pull the cable out without opening, 
it is rather difficult to get it back in!   :^)  

Just use two thumbnails on the ears at either end to pop it open.

Disclaimer:  I don't have data sheets, I used a meter, and looked at
the code.  Some of this is from memory, and any of it may be wrong.
No animals were harmed in compiling this data.  
(But a few mailstations were.)

Cyrano Jones