Subject: Re: New file uploaded to mailstation

From: fuentesea@...
Date: 06 Aug 2014 05:45:16 -0700

What kind of spam is this?

---

From: Neil Morrison <neilsmorr@...>
Date: Wed, 6 Aug 2014 06:52:35 -0700

All you ever wanted to know about Jesus - and much, much more.

Neil
-----

---

From: fyberoptic@...
Date: 06 Aug 2014 07:39:56 -0700

I never even thought about asking Jesus for technical details on the Mailstation.  Could have saved us a lot of work!

---

From: Ethan Dicks <ethan.dicks@...>
Date: Wed, 6 Aug 2014 10:42:39 -0400

> I never even thought about asking Jesus for technical details on the Mailstation.  Could have saved us a lot of work!

What Would Jesus Read?

But seriously... can an admin get this guy blocked and clean up the mess?

-ethan