Subject: Stand Alone LCD Module

From: "benjaminmaggi" <benjaminmaggi@...>
Date: Mon, 19 Jun 2006 10:48:58 -0000

Hi,
I've carefully read all data on this board regarding LCD pinouts and
the work flow approximations. (Message #38, and the .doc file)
With this info and and some coffee i decided to hack the LCD module of
one of my 2 mailstation DTE1, and hook it up to the parallel port of
my PC.
Of course i realized there's not enough data on this matter to proceed
with this task (timings, and so on...), i know most of the
documentation for this little baby is done by pure brute force hacking. :)
Still i wonder if any one has reached some level of communications
with the LCD ????
Any help will be very appreciated.

Benjamin.

---

From: "wayne" <waynem@...>
Date: Mon, 19 Jun 2006 08:25:36 -0700

What is it you are trying to do with this LCD unit ??
Maybe there is a better way ???

Wayne
Iwireless

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of benjaminmaggi
  Sent: Monday, June 19, 2006 3:49 AM
  To: [email-masked]
  Subject: [mailstation] Stand Alone LCD Module

  Hi,

  Benjamin.

---

From: "Eddy Wright" <eddy@...>
Date: Mon, 19 Jun 2006 10:48:24 -0500

I'd love to replace the main board with one of my own.  I'd have to build a
driver for the LCD display or find a way to salvage the existing one.
 
I want to build a custom wireless serial terminal and the mailstation is an
excellent form factor for that.
 
Eddy
http://www.wrighthobbies.net

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of wayne
Sent: Monday, June 19, 2006 10:26 AM
To: [email-masked]
Subject: RE: [mailstation] Stand Alone LCD Module

Wayne
Iwireless

-----Original Message-----

Hi,

Benjamin.

---

From: "wayne" <waynem@...>
Date: Mon, 19 Jun 2006 19:56:49 -0700

Let me save you some time and hassle, if by what you are saying as a
wireless serial
terminal you mean something to call a paging company, and enter a page, then
it
would be cheaper and easier to go to EBAY and pick up an Alphamate or
Wordsender
unit.  They are already setup to do that, have a modem in them, and are
pretty cheap,
between $ 10 to $25 each.

If you mean to send SMS (texting) to your cell phone, then you are going to
have to do a lot
of work and then find a program that will do SMS from whatever CPU unit you
have
hooked up to that mailstation. I don't think the CPU chip on the mailstation
will work for
that use, it probably does not have the sufficient memory to run a SMS
program.

However, some carriers (both Paging and Cellular) do have an Email gateway
(SMTP), that will let you
send an email to your Pager or Cell phone number.  In that respect, the
mailstation would work
as it was originally configured, and would just send an email to that
address.  The Carrier's
gateway computer would then get it and send it to your Pager or Cell Phone
unit.

You can either sign up with Earthlink or re-configure the DET1 by the "hack"
on here and
get on somebody else's ISP service.

Wayne
Handy Page

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Eddy Wright
  Sent: Monday, June 19, 2006 8:48 AM
  To: [email-masked]
  Subject: RE: [mailstation] Stand Alone LCD Module

  I'd love to replace the main board with one of my own.  I'd have to build
a driver for the LCD display or find a way to salvage the existing one.

  I want to build a custom wireless serial terminal and the mailstation is
an excellent form factor for that.

  Eddy

----------------------------------------------------------------------------
--

  Wayne
  Iwireless

    -----Original Message-----

    Hi,
    documentation for this little baby is done by pure brute force hacking.
:)

    Benjamin.

---

From: "Eddy Wright" <eddy@...>
Date: Mon, 19 Jun 2006 22:19:15 -0500

I need a portable TTL serial device to communicate with microcontrollers. I
use serial communications to debug software and a wireless, portable device
would make my life a lot easier. I use a laptop now which is overkill for
what I need. I want to write a custom interface specific to the projects
that I do, primarily robotics and home automation. I've already decoded the
keyboard and built a prototype board, but I had to go with a different
graphic LCD which doesn't fit the original case.
 
There are a few handheld serial terminals available commercially but none
have the formfactor of a mailstation.  
 
Eddy

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of wayne
Sent: Monday, June 19, 2006 9:57 PM
To: [email-masked]
Subject: RE: [mailstation] Stand Alone LCD Module

 

Wayne
Handy Page

-----Original Message-----

 
Eddy

  _____  

 
Wayne
Iwireless

-----Original Message-----

Hi,

Benjamin.

---

From: "Neil Morrison" <neilsmorr@...>
Date: Mon, 19 Jun 2006 20:32:09 -0700

A Model 100 TRS-80 works great for that. You see them on eBay all the time.

Neil

  ----- Original Message ----- 
  From: Eddy Wright 

  I need a portable TTL serial device to communicate with microcontrollers. I use serial communications to debug software and a wireless, portable device would make my life a lot easier. I use a laptop now which is overkill for what I need. I want to write a custom interface specific to the projects that I do, primarily robotics and home automation. I've already decoded the keyboard and built a prototype board, but I had to go with a different graphic LCD which doesn't fit the original case.

  There are a few handheld serial terminals available commercially but none have the formfactor of a mailstation.  

  Eddy

------------------------------------------------------------------------------

---

From: "John R." <jhoger@...>
Date: Mon, 19 Jun 2006 21:27:13 -0700

[ Attachment content not displayed ]

---

From: "Eddy Wright" <eddy@...>
Date: Tue, 20 Jun 2006 00:35:38 -0500

Thanks for the suggestion guys.  Since I want to make it wireless, I'll end
up needing to customize any unit that I find. I was considering the mail
station because of the graphic LCD, but I may take a look at the Tandys and
see if I can hack the LCD in one of those. I've not had much luck on the
mailstation so far...
 
Eddy

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of John R.
Sent: Monday, June 19, 2006 11:27 PM
To: [email-masked]
Subject: Re: [mailstation] Stand Alone LCD Module

On 6/19/06, Eddy Wright <eddy@...> wrote: 

 
Eddy

Here are a few laptops ready to work for this purpose:

Model 100, 200, 102
Tandy WP-2
Cambridge Z88
Amstrad NC100, NC200

All have similar form factor to the Mailstation, and actually have much
better keyboards. They all have a built-in terminal program. The WP-2, Z88,
NC100, NC200 will give you an 80 column screen. However I like the
simplicity and the community of users of the Model T: Tandy 102 and Tandy
200 myself, though these units only have a 40 column screen. 

-- John.

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Tue, 20 Jun 2006 21:32:48 -0000

--- "benjaminmaggi" <benjaminmaggi@...> wrote:
>
> Hi,
> I've carefully read all data on this board regarding 
> LCD pinouts and the work flow approximations. (Message #38, 
> and the .doc file)
> With this info and and some coffee i decided to hack 
> the LCD module of one of my 2 mailstation DTE1, 
> and hook it up to the parallel port of my PC.  
> Of course i realized there's 
> not enough data on this matter to proceed
> with this task (timings, and so on...), i know most of 
> the documentation for this little baby is done by pure 
> brute force hacking. :)

I would bet that the timing is not important, as long
as you don't try to go too fast, and I would guess that
the parallel port would not be able to go too fast for the LCD.

How are you gonna make the physical connection?  That is probably
the hardest part.  Oh, and you will need a latch or a counter,
since parallel port does not have enough bits to drive the LCD data,
address, and control signals directly.

But what I would recommend for controlling the LCD is the mailstations
CPU board.  It has the right connector for the LCD ribbon cable,
and heck, it is even already plugged into it!

> Still i wonder if any one has reached some level of 
> communications with the LCD ????

There is an example "Hello World" program in the files section,
http://groups.yahoo.com/group/mailstation/files/Mailbug/mailbug_0.0.3/hello/

That hello world prog will work on the old or the newer mailstations.

There is a more complex example, with scrolling screen output and
keyboard input, but it is just for the older mailstations.
http://groups.yahoo.com/group/mailstation/files/Mailbug/scancode/

--CJ

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 22 Jun 2006 12:40:19 -0700 (PDT)

It might be easier to hack the base unit for a
mailstation 350 wireless to bypass the modem. As for
the tandy 100s and wp2 laptops, the serial ports are
not ttl compatible, but in the case of the model 100,
they have a system bus that is accessible.

--- Eddy Wright <eddy@...> wrote:

> LCD pinouts and
> the LCD module of

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Eddy Wright" <eddy@...>
Date: Thu, 22 Jun 2006 15:41:15 -0500

At this point, I'll probably scavenge the parts I need from a couple of sources including a keyboard from the mailstation or a Tandy (I have both) and make a custom case for it all.  I've built the unit around an Atmel AVR controller with a graphic LCD.  I was trying to avoid making a custom case but I think it will be easier to build the case than to try and connect to the existing LCD controller.

I'm not familiar enough with the processors in the mailstation or the Tandys to try and write a new application for them. It's easier for me to replace the main board with a microcontroller that I work with regularly.

Thanks for the suggestions!
Eddy

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 23 Jun 2006 04:47:28 -0000

--- Gary Clouse <niklaus37217@...> wrote:
> mailstation 350 wireless to bypass the modem. 

The modem is in the main unit.

The base unit is essentially a cordless phone base.
And the main unit has what amounts to the cordless 
handset built in.

You would need another modem at the base end to recover
serial data.

--CJ

---

From: "wayne" <waynem@...>
Date: Fri, 23 Jun 2006 08:42:54 -0700

350 base unit also has an internal modem, as it has a telephone plug in to
bypass
the wireless unit.

Wayne

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Cyrano Jones
  Sent: Thursday, June 22, 2006 9:47 PM
  To: [email-masked]
  Subject: [mailstation] Re: Stand Alone LCD Module

  --CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 23 Jun 2006 16:53:56 -0000

--- In [email-masked], "wayne" <waynem@...> wrote:
> bypass  the wireless unit.

The base unit:

rj14 on wall --- rj14 on base  --+-- cordless phone base --- antenna
|
|
desk phone --- rj14 on base  --+

The main unit:

CPU --- Modem --- cordless phone handset --- antenna