Subject: mailstation 100 problem

From: fuentesea@...
Date: Mon, 11 Mar 2013 14:15:52 -0000

Hi,
I have a mailstation 100, I've managed to put it in test mode and I pressed 2 to do a fast test.
Then the LCD screen cleared and the device never returned to an usable state.

There is no indication of activity, I have reseted it, disconnected it for several hours, but no luck.

There is a way to restore it to a default state?
I know that if I left it in test mode and turn it off and on the machine is still in test mode until I press Q

Rom version is 1.08 (from memory) and is a device customized for Telefonica de Argentina.

Regards,
Eduardo.

---

From: Govind C <govindc@...>
Date: Tue, 12 Mar 2013 03:54:02 +0530

have you tried FN key + D and reset?

On Mon, Mar 11, 2013 at 7:45 PM, <fuentesea@...> wrote:

> **

---

From: Eduardo Fuentes <fuentesea@...>
Date: Mon, 11 Mar 2013 16:17:45 -0700 (PDT)

Yes,
Fn+D do not work in this device neither in a working one (ROM 1.68).

________________________________
De: Govind C <govindc@...>
Para: [email-masked] 
Enviado: lunes, 11 de marzo de 2013 19:24
Asunto: Re: [mailstation] mailstation 100 problem

---

From: "bob" <searsz80@...>
Date: Tue, 12 Mar 2013 01:41:49 -0000

> Then the LCD screen cleared and the device never returned 

Did it do the tests?  

Did it pass all of them?

I don't have any version lower than 2.21, but if we assume the
test mode is the same in your 1.68, then "2 fast test" should
display:

1.Flash            PASS
2.Key              PASS
3.Printer Port     SKIP
4.RAM              PASS
5.ROM             <checksum>

step 5 takes about 15 seconds, and then it displays:

Battery TESTING
Battery Down

at this point I have to hit enter to proceed, and
it adds "FALSE" to display.  (I don't have any battery installed.)

I have to hit enter again to get back to test menu.

Are you running on wall power supply, or batteries?????
Could your batteries have died during the test?????

---

From: Eduardo Fuentes <fuentesea@...>
Date: Mon, 11 Mar 2013 21:30:37 -0700 (PDT)

It didn't do any test, may be the only signal after I pressed 2 was the mail LED that flashed one time.
I don't know if some tests have passed because the LCD is completely blank.
I'm running on wall only.
It's weird, the device was working until I tried to do fast test, other tests ran OK.
Other symptoms that both units have in common (when the two were operational) are:
    When I try to connect to send or receive mail, the units reset themselves and the Reset system data menu appears after boot.
    In test mode F/A Tester(3) selected, DTMF(7) or E-mail(8) tests reset the device.
 
Device with ROM 1.08 is almost dead for now.
Device with ROM 1.68 is working and can run tests, except for those that are related to the modem (reboot).

________________________________
De: bob <searsz80@...>
Para: [email-masked] 
Enviado: lunes, 11 de marzo de 2013 22:41
Asunto: [mailstation] Re: mailstation 100 problem

Did it do the tests? 

Did it pass all of them?

1.Flash PASS
2.Key PASS
3.Printer Port SKIP
4.RAM PASS
5.ROM <checksum>

Battery TESTING
Battery Down

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Thu, 14 Mar 2013 06:20:24 -0000

> I don't know if some tests have passed because the LCD is completely blank.

Is it possible that the brightness got turned down?  

There is a thumbwheel on edge of case, and it is easy to turn down accidentally.

CJ

---

From: Eduardo Fuentes <fuentesea@...>
Date: Thu, 14 Mar 2013 06:09:01 -0700 (PDT)

No, I've turned it up, down, middle and no luck.
I think that it's a hardware problem. I was looking for an internal jumper or similar to reset the device to a factory state.
The weird thing is that it was working until I tried to do a fast test..
I'll try to set up a logic analyzer and I'm going to measure Z80 bus or RAM/ROM/dataflash CS signals activity. Perhaps the cold reset circuit is faulty.

________________________________
De: CyranoJ <cyranojones_lalp@...>
Para: [email-masked] 
Enviado: jueves, 14 de marzo de 2013 3:20
Asunto: [mailstation] Re: mailstation 100 problem

CJ

---

From: fuentesea@...
Date: Sat, 16 Mar 2013 00:58:02 -0000

I could make it boot.
I've put a bridge between 6V rail and the positive leg of C306.
I know that I'm a little out of spec for 5V components (I'm getting 5.6V currently). I'll use a 7805 tomorrow until I find a solution for this problem.
I think may be the 74HC74 may be faulty, because the key test pass OK for the on/off button but it does not starts when I press it without the bridge. With the bridge on when I press the button the device behaves as if it were turned off, keyboard don't respond any more but the screen is still on due the bridge.
Do you think that 74HC74 may be burned out or there are other things that may be bad in the on/off circuit?
Does anybody has the schematics?

---

From: "CyranoJ" <cyranojones_lalp@...>
Date: Sat, 16 Mar 2013 23:01:34 -0000

> Does anybody has the schematics?

You said you had two units, both behaving strange.
Are you using the same power supply for both?

I would check that it is not faulty power supply before replacing
any chips on mailstation board.  Or maybe the line voltage is too low (brownout)?

Perhaps the easiest way to to check would be to put the AA batteries
in it, and see if that fixes it.  Even if the regulator reads 6v 
with a meter, it might not be clean.

CJ

---

From: Eduardo Fuentes <fuentesea@...>
Date: Sat, 16 Mar 2013 16:44:46 -0700 (PDT)

Hi CJ,
I've replaced the power supply for a new one (CIDCO original). The unit that is still working now passes all tests including DTMF and Modem.
The one that does not boot is still in the same situation, with the bridge on it passes all tests too. May be the old power supply burned the power on/off circuit.
I'll try with AA batteries, but I would not bet on that works.
 
I've found the schematics for a 250, I think it;s is very simmilar to 100. Looking at it seems U303(74HC74) or Q304 (2SJ244)  can be the culprit.
I'll try to activate/deactivate the unit bridging G leg of Q304 to check if it works. I'll measure the voltage at G leg pressing On/off switch to see if the flipflop is working ok.
 
Regards,
Eduardo.
PS: Thank you to be so kind to respond my questions.

Enviado: sábado, 16 de marzo de 2013 20:01

CJ