Subject: I have an Idea!

From: "konablend" <konablend@...>
Date: Mon, 16 Jan 2006 07:34:37 -0000

I'm sure I'm not the first. I have a DET1 Blah blah blah...2.54Y 
Firmware.  Let me get to the point.  I can get into the edit mode of 
the hex viewer.  As I understand it, what i'm looking at is all user 
mem and not ROM.  But the ROM is flashable.  And there are 
instructions already in place to do it.  And you can enter your own 
apps by hand in hex and run them in the yahoo! feature or wherever.  
All I want to do in turn XTND off or at least change the strings to 
something else the POP3 server wont puke on (-ERR).  0C1D30 in the rom 
is what I'm looking to change. 0C1C70, AND 0C1DB0 as well.  06bab0 has 
a couple of strings but thats all they are for what I know.  So 
basically what I want to do is change XTND to something that wont 
return -ERR on most POP3 servers, and I want to do it without flashing 
the ROM externally.  I am more than willing to enter hex for a few 
hours to make it work.  Maybe someone will write an editor for the rom 
someday.  Any idea's anyone?

--Hoping this will get read, ERIC

---

From: Gary Clouse <niklaus37217@...>
Date: Mon, 23 Jan 2006 10:00:46 -0800 (PST)

The Rabbit cpu used in the mailstations have a
hardware flashmemory function that works through the
parallel port. I don't know how to access it through
the printer port, but someone on the list probably
does. 

> --Hoping this will get read, ERIC

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Neil Morrison" <neilsmorr@...>
Date: Mon, 23 Jan 2006 10:31:56 -0800

Did you look at old messages, or the files section? 

Neil

----- Original Message ----- 
From: "Gary Clouse" <niklaus37217@...>

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Mon, 30 Jan 2006 05:48:30 -0000

--- In [email-masked], Gary Clouse <niklaus37217@y...> 
> the printer port, but someone on the list probably

Why do you think it is a Rabbit cpu???  It does not even 
come close to matching the pinouts of the standard 
Rabbit chips that I am aware of.  As far as I know, 
it is not a Rabbit part.  

In my personal opinion, it is a custom ASIC.

But there is a built-in reflash function, in *software*.  
One of the things that my "mailbug" debugger does is 
interface with this native reflash capability 
(via parallel port & laplink cable), allowing you to 
re-program the mailstations codeflash.

So far, the only thing *I* have flashed in any of my 
mailstations is code that lets me boot up the remote 
debugger.  But it can be used to flash whatever you want.
Ferinstince, if someone was inclined to write completely 
new firmware, mailbug can flash it into a stock mailstation.  
Or, if you just want to make some changes to existing 
mailstation firmware, it can reflash with your modified 
firmware.

I have been working (Ha!) on a new version of the boot code
(code that boots up the remote debug functions of mailbug)
that can be used without erasing the existing mailstation 
code.  (The native reflash erases most of the codeflash 
*before* you get a chance to "back it up".)

This new version will (when I get it working) let you load
and execute your own code over the laplink, without killing 
the existing mailstation code.  It also will let you save
to disk an intact image of your particular firmware version.

After saving your firmware to a file on PC, you can edit it
with whatever tools you like, and then flash your new 
version back to your mailstation.

If you are working with mailstation firmware 2.53yr or 2.54, 
you can do this now, with the currently posted mailbug 0.0.3.  
There are images of those two firmware versions in the group 
download area.  So, for those two, you don't really need to 
save your own images.

One catch, mailbug 0.0.3 will not let you change the first
four pages of codeflash with the native reflash.  If you 
load the remote debug boot code, then you can flash anything
anywhere.  Mailbug 0.0.4 will flash the whole codeflash
without needing to load the remote debugger.  

-- CJ

> --- konablend <konablend@y...> wrote:
> 

This is a test, and this line starts at left margin.

     This line is indented 5 spaces.

<    someone suggested   that  angle  brackets  might  keep  lines  
from  being   "fixed"  by  the  friendly  yahoo  people.... I wonder 
if it will???>

we now return to our regularly scheduled program.

---

From: Gary Clouse <niklaus37217@...>
Date: Mon, 30 Jan 2006 14:30:42 -0800 (PST)

> Rabbit chips that I am aware of.  As far as I know, 

Of the 2 that I have ( 1 120 and a 150 ) the 120 has a
rabbit chip in it. It is apparently a discontinued
part that was replaced by the 2000. The Rabbit 2000 is
functionally similar. both are based on a Z180
compatible core. I'll have to take a peek at theh
150's innards and see what it has.

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Tue, 31 Jan 2006 05:35:57 -0000

--- Gary Clouse <niklaus37217@y...> wrote:
>
>
> --- Cyrano Jones cyranojones_lalp@y... wrote:
>

Are you saying that you have something other than
the 3SI176 chip, or that the 3SI176 is a Rabbit part?

I have opened up a lot of different models, and found
the same chip in all (3SI176), except for the 350, which
had a Toshiba TMP91C820AF.

These are the models I know of:
http://groups.yahoo.com/group/mailstation/database?method=reportRows=1

-- CJ

just testin' rich text editor...
this line starts at left margin this line is indented

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 2 Feb 2006 16:10:59 -0800 (PST)

I opened up my other one and it has the
 same chip set. Several months ago I did find the 
part number on a chip directory, which listed it
 a rabbit semiconductor CPU as compatible. I think
the 3si176 is a chinese clone.  

--- Cyrano Jones <cyranojones_lalp@...> wrote:

> > > Why do you think it is a Rabbit cpu??? It does
> not
> > > even

---

From: Sean Walton <ab8kf@...>
Date: Fri, 3 Feb 2006 15:07:04 -0800 (PST)

Can you get the details on both chips (and any
differences)?  I have tried many times to get hardware
and programming specs from various mfr's, but they are
only willing to selling the chips.
-Sean Walton

---

From: "konablend" <konablend@...>
Date: Tue, 14 Feb 2006 07:19:08 -0000

I should have mentioned that I dont have a laplink cable nor do I 
desire to find one unless I really have to.  I had already thought 
about the method you present here and was pretty sure it ould work 
but I really want to try to do it without hooking my PC up to it.  
More fun/torture that way.  Besides, I have been trying to learn 
z80/81 assembler for some weird reason.

--- In [email-masked], "Cyrano Jones"

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Wed, 15 Feb 2006 06:56:41 -0000

> z80/81 assembler for some weird reason.

z81???

-- CJ