Subject: Mailstation 350

From: "iwireless2001" <waynem@...>
Date: Thu, 09 Feb 2006 21:41:20 -0000

I have 2 mailstation 350's, one is a version 1.37 and the
other is a version 1.39.

If I do a Power up with Control, Q, A, held down on the 
1.39, I get a input box, I have tried the qa781206 data,
and it comes back and says "wrong ISP".

If I do the same Power up with the 1.37, it comes up in
diagnostic menu mode.

When you check something, and then Quit and re-power, the
setup menu comes up, with everything cleared,

HOWEVER, you can NOT get into the "email Address" line.
If you try to SAVE, a box says that all entries have to be filled and 
then takes you to the "email address line".  But you can NOT enter
anything in it ???????

In the tests, which are:
1. S/A test 1. LCD
            2. keyboard
            3. Rom
            4. RAM
            5. Flash
            6. Phone
            7 DTMF
            8  Current
There is an OPTION to "CLEAR FLASH" ??????????
If I Cleared the flash, would that JUST clear the email and network 
entries, or clear ALL the PROGRAMMING ????

Also on the main screen is a place for the S/N and ship ID, but I can 
not seem to get into that area to write anything ??

Any suggestions  ????

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Fri, 10 Feb 2006 13:46:22 -0000

> If I do the same Power up with the 1.37, it comes up in

On mine (350 v1.37), when I do ctrl-q-a qa781206  I get the 
message "This device can't recognize the ID, please contact
your service provider."

The version info under the menu setup>mailstation> is
V.1.37 XTND:ON C

I don't know what the C means.

Is this the same on yours?
I wonder what might be different?

> then takes you to the "email address line".  But you can NOT enter

That is how mine behaves when I hold ctrl-d while booting, and then 
interrupt it (reset button) while it is doing the "restore factory 
settings".

To get past the part where it insists all entries be filled, but 
will not let you fill one of them, I have to restore factory settings 
again, without interrupting.

>             8  Current

I have never got this menu on a 350.  Can you get it into
the hex edit mode?  On the other models, from the first
test mode menu, you enter a ctrl-f5 to start the hex editor.

> entries, or clear ALL the PROGRAMMING ????

I don't know for sure, but my best guess is it would only clear data,
and not code.  If I could get mine to this point, I don't think I
could suppress my curiosity, and I would just try it.  
But that's me.  :-)

The fact that they call out rom & flash separately in the menu would
seem to suggest that they are calling the codeflash "Rom", and the
dataflash "Flash".
 
> Also on the main screen is a place for the S/N and ship ID, but I 
> can not seem to get into that area to write anything ??
> 
> Any suggestions  ????

What's in those areas now?  The serial number is on a sticker 
on the bottom of unit, maybe ship ID is the other number on that 
sticker?

The older models just display the sn at the bottom of the
test mode menu.  You can't change it on those models.

-- CJ

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sat, 11 Feb 2006 02:25:09 -0000

BEWARE OF TESTING FLASH ON 350!!!!!  (more below)

I was playing a bit more today, and figured out some more,
so I am replying to myself... 
<inline below>

---  "Cyrano Jones" <cyranojones_lalp@...> wrote:
>
> ---  "iwireless2001" <waynem@> wrote:
> >

I figured out the correct id for 350's, but not the master.
It is based on the serial number (sticker on bottom).
If your serial number is SN023903xxxx
then the ID would be qa350xxxx

This also works for the 120's & 150's, but it is qa120xxxx
(it's qa120xxxx even on the 150).

I tried qa783508 for the master instead of qa781208, 
            ^^^                                ^^^
but it did not work.

> V.1.37 XTND:ON C   (I don't know what the C means)

Maybe the "C" means "closed", as opposed to "open",
(iow, "locked" or "unlocked")???

<snip>

> test mode menu, you enter a ctrl-f5 to start the hex editor.

I got to the test mode menu now, but ctrl-f5 does not work
to put 350 into hex edit.  :-(

> > If I Cleared the flash, would that JUST clear the email and 
> > network entries, or clear ALL the PROGRAMMING ????
> 
> I don't know for sure, but my best guess is it would only 
> clear data, and not code.  If I could get mine to this point, 
> I don't think I could suppress my curiosity, and I would just 
> try it.  But that's me.  :-)

I didn't yet try the "CLEAR FLASH", but I did try the 
"TEST FLASH" option.  It apparently cleared out the
"factory setting" values, and now I cannot get out of
the "can't set email, and can't quit till you set email"
infinite loop.  Oh well, I will try some more, and maybe
the "CLEAR FLASH" will get me out.  

<snip>

-- CJ

---

From: bmarcum@...
Date: Sat, 11 Feb 2006 14:05:02 -0500

> test mode menu, you enter a ctrl-f5 to start the hex editor.
Cool! I got into the hex editor on my 150, had to press ctrl-shift-f5.
What can you do in the hex editor?  Write Z80 machine code?  How do you 
execute it?  The memory seems to contain mostly zero bytes except for a 
few hundred bytes at the end.

-- 
Do not meddle in the affairs of troff, for it is subtle and quick to anger.

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sun, 12 Feb 2006 07:54:18 -0000

> Cool! I got into the hex editor on my 150, had to press 

I should have said shift-f5.  That works on all but the 350,
and puts you into a "secret" hex-viewer mode.

If you want to actually edit some bytes, you need to enable
the "double secret" hex-edit mode.  Type G710304x<back>  :-)
(uh... without the smiley, of course!)

After enabling, ctrl-s will shift you into edit mode.  Another
ctrl-s exits edit mode, and saves the new bytes to dataflash.
Each screenful in hex edit mode is a single 256 byte sector of
the dataflash.  You have to save each sector before you can
move to another sector.

> What can you do in the hex editor?  Write Z80 machine code?  
> How do you execute it?  The memory seems to contain mostly 
> zero bytes except for a few hundred bytes at the end.

You can edit any byte in the dataflash.  The first 5 pages
of dataflash can contain 5 applications.  Control is transfered
to the first byte of those pages when you select the corresponding
icon from the mailstation menu.  You add the apps to the menu
by editing the "app count" in page #08 of the dataflash.

If you form your app code like the mailstation wants, you will
have an icon and caption as part of your app.  The mailstation
will display it in the menu, under "Yahoo" if you have a
yahoo folder, or under "Extras" if you don't have a yahoo folder.

If you don't include icon & caption, you will just get a
blank space in the menu, or maybe a garbage icon if your
code sits where the icon is 'sposed to be.  It's pretty
obvious where the new item is regardless of whether you
include icon.

-- CJ

---

From: bmarcum@...
Date: Sun, 12 Feb 2006 15:19:16 -0500

> by editing the "app count" in page #08 of the dataflash.
OK, got it.  Now to try and make a "hello world" app...

-- 
Show me a man who is a good loser and I'll show you a man who is playing
golf with his boss.

---

From: bmarcum@...
Date: Sun, 12 Feb 2006 14:57:09 -0500

On Sat, Feb 11, 2006 at 02:05:02PM -0500, bmarcum@... wrote:
> What can you do in the hex editor?

I found out, the hex editor seems to be read-only.  Maybe it needs a 
different password to allow writing.

-- 
Beam me up, Scotty!  It ate my phaser!

---

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Sun, 12 Feb 2006 21:21:04 -0000

> different password to allow writing.

Sounds like you are in plain old hex-viewer mode.

You need to *enable* edit mode after you get in viewer mode.

Then, you need to kick it into edit mode for each sector.

reread msg 447 
http://groups.yahoo.com/group/mailstation/message/447

-- CJ