Subject: Inventec

From: "Cyrano Jones" <cyranojones_lalp@...>
Date: Wed, 28 Jun 2006 05:56:31 -0000

This site has some info on TI Avigo PDA.
The 6SI117 CPU is made by Inventec.
http://www.datamath.org/Personal/Avigo10.htm

Also from another page on that site:
http://www.datamath.org/Featured_Companies.htm
> Inventec Corporation was founded  in Taiwan, on July 1, 1975 
> to produce simple  calculators and telephone sets. In 1984 
> Inventec was Taiwan's largest manufacturer of  calculators. 
> In the year 1986 an overseas manufacturing base was founded 
> in Penang,  Malaysia to take advantage of competitive labour 
> rates. Inventec Micro-Electronics  Corporation (IMC), one of 
> the Inventec Group companies, established a factory in  Shanghai, 
> China during 1995. Inventec manufactures most of Texas Instrumentï¿½s 
> graphing  calculators from the TI-73 to the TI-89 and the 
> data collection systems CBL2 and CBR. IMC was renamed IME 
> after Inventec group's reorganization in 1999. 

I have read a lot of web pages regarding Inventec, and I get the
impression that they are a *HUGE* company.  They make notebooks and
pdas and phones for a lot of other companies.  They also make 
the iPod for apple.

Googling [inventec z80] finds this site:
http://72.14.203.104/search?q=cache:lao-3vhKzuoJ:electro-tech-online.com/viewtopic.php%3Ft%3D15332%26sid%3D0483339950207f7a33ddb214e4c43d2e+inventec+z80&hl=en&gl=us&ct=clnk&cd=1&client=firefox-a

Well, that link will likely be garbled.  It was
top hit for that search, and I had to view it via 
googles cache, because page seems to be gone now.
 
The pertinent part of page was a post asking for info:

> I'm in search of data for an Inventec processor. 
> The chip came from a TI-83+ graphing calculator 
> as bares the text:
> 
> Inventec
> 6SI837 0A
> Japan 0216EAI
> PDARD
> F0254ZAA
> 
> ...if it helps, this is a Z80-enabled CISC processor. 
> I've tried googling and came up empty. Any data on pinouts, 
> or clocking data would be appreciated.

There was no answer posted.  Note the manufacturer,
the similar part number, and most curiously the "PDARD".
I believe the Avigo 6SI117 also says "PDARD", but I can't
find a good picture of it right now.  In case it didn't
jump right out at you, the Avigo is a PDA, as in PDARD.

I don't have any guess what the RD stands for, but
RSDRD ends with RD, too.  I have not been able to come
up with any meaning for RSD as of yet.

Googling for [rsdrd inventec] returns two sites
that list 3SI176 as manufactured by "RSDRD".
The line just above 3SI176 is for a 3SI0870A manufactured 
by "Inventec". 
http://www.digchip.com/distributors/parts/3s/parts_3s.php

I think the brokers are just jumping to conclusion
that the RSDRD is the manufacturer, because for some
reason, they did not print "Inventec" on the package.

-- CJ

---

From: Gary Clouse <niklaus37217@...>
Date: Thu, 6 Jul 2006 15:45:57 -0700 (PDT)

I believe the RD stands for "Research Design"

> reason, they did not print "Inventec" on the

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "wayne" <waynem@...>
Date: Wed, 28 Jun 2006 07:48:20 -0700

There is a big book that is available every year that lists EVERY chip made
by part number,
and who the manufacturer is.  I have a very old one 1980's, I will check in
it, but you
probably need to find somebody that has a new one and look it up.

Also, the RD at the end means R & D, as in research and development...The
chip may
not be a full production line model yet, or it was just a "modified" version
of another chip
for a specific customer to use ??

Wayne

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Cyrano Jones
  Sent: Tuesday, June 27, 2006 10:57 PM
  To: [email-masked]
  Subject: [mailstation] Inventec

http://72.14.203.104/search?q=cache:lao-3vhKzuoJ:electro-tech-online.com/vie
wtopic.php%3Ft%3D15332%26sid%3D0483339950207f7a33ddb214e4c43d2e+inventec+z80
&hl=en&gl=us&ct=clnk&cd=1&client=firefox-a

  -- CJ

---

From: "FyberOptic" <fyberoptic@...>
Date: Sun, 24 Jan 2010 06:21:28 -0000

I remembered the old half-working Avigo PDA I had stashed away supposedly having a Z80 CPU, and it was made my Texas Instruments, so I thought that I'd just take a look to see if it too might have ended up with an Inventec CPU.

Turns out, the answer is yep!  I took a photo, but then when searching for the CPU I found this, which is much better quality than mine:

http://www.datamath.org/Personal/JPEG_Avigo10.htm#ASIC

It's a 6SI117.

Memory map look familiar?

$0000 - $3FFF System ROM region	
$4000 - $7FFF ROM bank access region 	
$8000 - $BFFF RAM bank access region 	
$C000 - $FFFF System RAM region

It has 1MB of Flash, 128KB of RAM.  240x160 LCD.

Even though it has an FCC ID (DGI-PDA100) it doesn't exist in the database.  DGI is another ID for Inventec and all, though.  Unfortunately none of their earlier submissions have any files, so even if it's there with another ID, I wouldn't know it.

I think if we could find the datasheet or information on ANY of the other Inventec CPUs, it would be useful for the Mailstation too.

---

From: "FyberOptic" <fyberoptic@...>
Date: Sun, 24 Jan 2010 07:59:49 -0000

Did some Avigo research.  Lookee what I came across:

http://home.earthlink.net/~rdgill/avigo/#I/O%20Ports

Not only does this possibly indicate the Mailstation does have a buzzer pin as I previously assumed, but it shows the possible ports to use the onboard serial pins.  But most importantly, look at the RTC ports!  They say that version of the CPU uses a TC8521 for the RTC.

http://pdf1.alldatasheet.com/datasheet-pdf/view/32098/TOSHIBA/TC8521AM/+22188uOlPGHwwcVhDCvYIV+/datasheet.pdf

A 4-bit Toshiba real-time clock, which just so happens to have a 1hz and 16hz timer, as well as alarm.  We know the Mailstation has a 1hz interrupt, but from my deductions, the other was 64hz.  Then again, since they built this directly into the CPU, they could have modified the divider, or more likely based on what we've seen, run it through a user-changeable divider (port $2F maybe??).  

I found many other 4-bit RTC chips which did have a 64hz alternate timer, and others with a 1024hz one (much more divideable), so who knows what they actually used in the Mailstation version of the CPU.  All I know is that the port addresses seem to match up perfectly for the one I linked, compared to the others I looked at, so that's a good start.  I want to try accessing that bit of ram on pages 2 and 3 of its address space sometime, just to confirm it's there.

Here's a snippet I took from the disassembly before of it setting up the RTC at one point.  Now we have an idea of what it's doing, based on the datasheet:

xor	a
set	2, a
out	(#1d), a
ld	a, #0e	
out	(#1f), a
ld	a, #0c	
out	(#1f), a

Avigo aside, this might also potentially be helpful, indirectly:

http://www.michaelv.org/programs/calcs/ports/

This is for a TI-83 calculator.  The interesting parts are the CPU speed and timer ports.  Some info might be able to be derived from them, since they might be similar in function, just not directly applicable.