Subject: Time to Update Your Datasheets

From: "FyberOptic" <fyberoptic@...>
Date: Sat, 23 Jan 2010 08:39:19 -0000

Go to http://www.fcc.gov/oet/ea/fccid/

Put "pqu" into the Grantee Code field.

Search, hit Details on each result, and prepare to possibly shit pants.

For those who are impatient and want to know what I found, how does "schematic diagram" sound?

It's detailed documents of two versions of the Mailstation 250 and one of the Mailstation 350.  Not only are there photos of the hardware, but also photos of the circuit boards, and then the best part, full schematics.  And oh yes they are full.  For example, I now know that the CPU crystal is 12.288mhz.  And, even better, I know the labels of every CPU pin, including the unused ones.

From there, I can see that it can address up to 8MB of memory.  I can see that it has TX/RX serial pins.  I can see that it does indeed have an additional unused device selector.  I can see what is very likely an oscillator out pin, which could possibly be used to determine the frequency currently used by the CPU after going through the divider.  I can see that it has a whole 'nother unused 8-bit port.  Many of the pin labels I simply don't know the purpose of at the moment, so who knows what else is in there.

And for the record, the 350 runs at 34.4mhz.

So, why only the 250 and 350?  Good question.  I'll start at the beginning of my search and go from there in explaining what I learned.

First, I went in search of the FCC number on the back of my Mailstation: 1EBCHN-27372-OT-E.  Turns out, this wasn't a normal FCC ID.  I didn't understand why it was different from what they wanted.  But regardless, I got nothing, so that was a dead-end.  So, by happenstance I dropped it into Google before giving up, and found some results.  Nothing big, it looked like just some FCC update notices of some kind.  Stuff that looks like this:

648-CX-2001             8145386-5
 NOTICE OF CHANGE NOT AFFECTING COMPLIANCE
 HAS BEEN FILED FOR THE FOLLOWING
 REG. NO.: 1EBCHN-27372-OT-E                
 GRANTEE: INVENTEC ELECTRONICS (NANJING) CO.,LTD.
 NATURE OF APPLICATION: 
 EQUIPMENT DESCRIPTION: E-MAIL TERMINAL MODEM DEVICE W/FAX WITH CALLER ID
 TRADE NAME: CIDCO
 MODEL: FB DET1, DET1A, DET1B, DET2 

I noticed the grantee name, "Inventec Electronics."  So, back to the FCC database with that.  Many results!  But I started going through'em anyway, clicking Details, then one of their external photos, just to see what it was.  Didn't take long, but the next thing I knew I was staring at the picture of a Mailstation, and I couldn't believe the other files I found in there with it.  Short of a datasheet for the CPU, a schematic of the whole thing is the next best thing you could have.

So, curious of what else Mailstation-related I might find buried away in there (like perhaps the older models), I searched just for grantees with that name, which you can do there on the left if you do an advanced search.  I got multiple results for Inventec Electronics.  One of them was listed as "Nanjing" though, which is in that text I pasted above that I found on Google.  It has the grantee code "PQU".  And sure enough, putting just that one into the search gives you only the Mailstation results.  Just the three, though, unfortuantely.

Eventually I found that the number on the back of my Mailstation isn't an FCC ID.  It's an FCC Registration Number, which is different.  The older Mailstation is classified under "Part 68" equipment, which apparently means it doesn't need extensive testing, since it's just a telephone network device.  However..!  The Mailstation 250 and up use wireless base stations to connect to their phone line.  This means they're using frequency spectrum, which means they require a full-on FCC ID.  I probably could have saved myself a few steps if I owned a 250 or 350 and had their FCC ID to begin with.  But hey, whatever works.  

In any case, there is one interesting thing of note about the FCC registration number.  The first three characters, 1EB, are this in their database:

1EB|INVENTEC ELECTRONICS (MALYASIA)|37 ANSON RD|10400 PENANG||MALYASIA|||08/29/1989|D REGINALD TIBBETTS|2151 CAMINO PABLO|MORAGA|CA|94556|

So, as it turns out, Inventec is definitely who developed the Mailstation.  Their name is on all of the schematics as well.  And a Google search shows their name in Cidco press releases/financial reports/whatever.

But here's the really interesting part: Inventec made a CPU for one of the TI calculators too, apparently.  Anyone who knows anything about those graphing calculators know that they used Z80 CPUs for years.  I found this in a Google search, of a guy asking for information on a chip:

---------

I'm in search of data for an Inventec processor. The chip came from a TI-83+ graphing calculator as bares the text:

Inventec
6SI837 0A
Japan 0216EAI
PDARD
F0254ZAA

...if it helps, this is a Z80-enabled CISC processor. I've tried googling and came up empty. Any data on pinouts, or clocking data would be appreciated.

---------

Notice the similarity of the part number!  The Mailstation's is 3SI176 0A.  A Google search on the 6SI one gives some results, but I found that I get other results when I put in "6S1837".  Somebody seems to have mistaken an I for a 1.

So, I emailed Inventec, and I guess we'll see if my email ever gets beyond the webmaster to anywhere that might possibly have information on the Mailstation CPU.

p.s.  For anyone interested, here's the somewhat vague at times patent application for what I'm almost certain is the Mailstation.

http://patft.uspto.gov/netacgi/nph-Parser?Sect1=PTO1&Sect2=HITOFF&d=PALL&p=1&u=%2Fnetahtml%2FPTO%2Fsrchnum.htm&r=1&f=G&l=50&s1=6,510,455.PN.&OS=PN/6,510,455&RS=PN/6,510,455

In case that link doesn't work right, the patent # is 6,510,455.

I almost debated posting anything here, but I'm fairly sure none of it is illegal to do so, because it's publicly-accessible information.

---

From: Jon Kirwan <jonk@...>
Date: Sat, 23 Jan 2010 02:02:36 -0800

On Sat, 23 Jan 2010 08:39:19 -0000, you wrote:

><snip>

Very nice and thanks!  I have a few 120's, 150's, and 250's
laying about here.  The 250 schematics are going to be a help
for those.  I would certainly like to have such info on the
120 and 150.

Thanks again.  I'm googling around, too.  But I suspect that
I am finding nothing more than you've already uncovered
already.

Jon

---

From: Brad Fayette <bfayette@...>
Date: Sat, 23 Jan 2010 08:31:50 -0500

These devices are in the FCC database because they have radio transceivers.

On 01/23/2010 03:39 AM, FyberOptic wrote:
>
> Go to http://www.fcc.gov/oet/ea/fccid/ <http://www.fcc.gov/oet/ea/fccid/>
>
> It's detailed documents of two versions of the Mailstation 250 and one 
> of the Mailstation 350. Not only are there photos of the hardware, but 
> also photos of the circuit boards, and then the best part, full 
> schematics. And oh yes they are full. For example, I now know that the 
> CPU crystal is 12.288mhz. And, even better, I know the labels of every 
> CPU pin, including the unused ones.
>
> >From there, I can see that it can address up to 8MB of memory. I can 
> see that it has TX/RX serial pins. I can see that it does indeed have 
> an additional unused device selector. I can see what is very likely an 
> oscillator out pin, which could possibly be used to determine the 
> frequency currently used by the CPU after going through the divider. I 
> can see that it has a whole 'nother unused 8-bit port. Many of the pin 
> labels I simply don't know the purpose of at the moment, so who knows 
> what else is in there.
>
> So, why only the 250 and 350? Good question. I'll start at the 
> beginning of my search and go from there in explaining what I learned.
>
> First, I went in search of the FCC number on the back of my 
> Mailstation: 1EBCHN-27372-OT-E. Turns out, this wasn't a normal FCC 
> ID. I didn't understand why it was different from what they wanted. 
> But regardless, I got nothing, so that was a dead-end. So, by 
> happenstance I dropped it into Google before giving up, and found some 
> results. Nothing big, it looked like just some FCC update notices of 
> some kind. Stuff that looks like this:
>
> 648-CX-2001 8145386-5
> I noticed the grantee name, "Inventec Electronics." So, back to the 
> FCC database with that. Many results! But I started going through'em 
> anyway, clicking Details, then one of their external photos, just to 
> see what it was. Didn't take long, but the next thing I knew I was 
> staring at the picture of a Mailstation, and I couldn't believe the 
> other files I found in there with it. Short of a datasheet for the 
> CPU, a schematic of the whole thing is the next best thing you could have.
>
> So, curious of what else Mailstation-related I might find buried away 
> in there (like perhaps the older models), I searched just for grantees 
> with that name, which you can do there on the left if you do an 
> advanced search. I got multiple results for Inventec Electronics. One 
> of them was listed as "Nanjing" though, which is in that text I pasted 
> above that I found on Google. It has the grantee code "PQU". And sure 
> enough, putting just that one into the search gives you only the 
> Mailstation results. Just the three, though, unfortuantely.
>
> Eventually I found that the number on the back of my Mailstation isn't 
> an FCC ID. It's an FCC Registration Number, which is different. The 
> older Mailstation is classified under "Part 68" equipment, which 
> apparently means it doesn't need extensive testing, since it's just a 
> telephone network device. However..! The Mailstation 250 and up use 
> wireless base stations to connect to their phone line. This means 
> they're using frequency spectrum, which means they require a full-on 
> FCC ID. I probably could have saved myself a few steps if I owned a 
> 250 or 350 and had their FCC ID to begin with. But hey, whatever works.
>
> In any case, there is one interesting thing of note about the FCC 
> registration number. The first three characters, 1EB, are this in 
> their database:
>
> 1EB|INVENTEC ELECTRONICS (MALYASIA)|37 ANSON RD|10400 
> PENANG||MALYASIA|||08/29/1989|D REGINALD TIBBETTS|2151 CAMINO 
> PABLO|MORAGA|CA|94556|
>
> So, as it turns out, Inventec is definitely who developed the 
> Mailstation. Their name is on all of the schematics as well. And a 
> Google search shows their name in Cidco press releases/financial 
> reports/whatever.
>
> But here's the really interesting part: Inventec made a CPU for one of 
> the TI calculators too, apparently. Anyone who knows anything about 
> those graphing calculators know that they used Z80 CPUs for years. I 
> found this in a Google search, of a guy asking for information on a chip:
>
> ---------
>
> I'm in search of data for an Inventec processor. The chip came from a 
> TI-83+ graphing calculator as bares the text:
>
> Inventec
> 6SI837 0A
> Japan 0216EAI
> PDARD
> F0254ZAA
>
> ...if it helps, this is a Z80-enabled CISC processor. I've tried 
> googling and came up empty. Any data on pinouts, or clocking data 
> would be appreciated.
>
> ---------
>
> Notice the similarity of the part number! The Mailstation's is 3SI176 
> 0A. A Google search on the 6SI one gives some results, but I found 
> that I get other results when I put in "6S1837". Somebody seems to 
> have mistaken an I for a 1.
>
> So, I emailed Inventec, and I guess we'll see if my email ever gets 
> beyond the webmaster to anywhere that might possibly have information 
> on the Mailstation CPU.
>
> p.s. For anyone interested, here's the somewhat vague at times patent 
> application for what I'm almost certain is the Mailstation.
>
> <http://patft.uspto.gov/netacgi/nph-Parser?Sect1=PTO1&Sect2=HITOFF&d=PALL&p=1&u=%2Fnetahtml%2FPTO%2Fsrchnum.htm&r=1&f=G&l=50&s1=6,510,455.PN.&OS=PN/6,510,455&RS=PN/6,510,455>
>
> I almost debated posting anything here, but I'm fairly sure none of it 
> is illegal to do so, because it's publicly-accessible information.
>
>

---

From: "cyranojones_lalp" <cyranojones_lalp@...>
Date: Sat, 23 Jan 2010 22:12:01 -0000

--- FyberOptic wrote:

Hey great!  Now we know the functions of the pins that are 
not hooked to anything!!!  ;^)

The names they put on the used pins don't seem as useful as the
names I gave them, though.

I googled the pin names on unused pins 91 thru 94, 
[LP FP FR SCP]  and got an interesting hit:

http://www.google.com/patents?id=1gMfAAAAEBAJ&printsec=abstract&zoom=4&source=gbs_overview_r&cad=0#v=onepage&q=&f=false

patent number is 5448259 just in case.

Seems likely there is a LCD controller in it, but I
can't say it is useful knowledge.  But who knows?

> I noticed the grantee name, "Inventec Electronics."  

It has been known who made it for a long time now:
http://tech.groups.yahoo.com/group/mailstation/message/544

<actually, Inventec was known before this group started,
I'm sure(???) it was on l-h board.>

In addition to the ti calculators, they made the ipod for apple.

> But here's the really interesting part:
<snip> 

I thought it was interesting when I found it, too.  ;^)
<see above link>

> So, I emailed Inventec, 

You speak Chinese?  :-)

Just kidding, they prolly have *someone* there who 
 speaks English... right???  :-)  :-)

Wouldn't it be a riot if they sent the datasheet.  I never
even thought to ask for it!

CJ

---

From: "FyberOptic" <fyberoptic@...>
Date: Sun, 24 Jan 2010 00:13:58 -0000

> for those.  I would certainly like to have such info on the

Somebody will have to correct me if I'm wrong, but as far as I know, the 250 and under are all practically identical in terms of guts (aside from the wireless capability), which would make the schematics fairly useful even for the older models.  It all looks very similar to my DET1 from what I've gone over so far.  The CPU is likely identical in any case, which was the biggest thing I was after in terms of info.  But a full schematic is nice too!

> I am finding nothing more than you've already uncovered

Doesn't hurt to look.  Sometimes a random search can put you on a certain track, which is how I found that stuff to begin with.

---

From: Jon Kirwan <jonk@...>
Date: Sat, 23 Jan 2010 16:24:25 -0800

On Sun, 24 Jan 2010 00:13:58 -0000, you wrote:

> Somebody will have to correct me if I'm wrong, but as far as
> I know, the 250 and under are all practically identical in
> terms of guts (aside from the wireless capability), which
> would make the schematics fairly useful even for the older
> models.  It all looks very similar to my DET1 from what I've
> gone over so far.  The CPU is likely identical in any case,
> which was the biggest thing I was after in terms of info. 
> But a full schematic is nice too!

I don't see the LCD display presented on the schematics,
though I suppose the connectors I see probably suffice.

> Doesn't hurt to look.  Sometimes a random search can put you
> on a certain track, which is how I found that stuff to begin
> with.

Yes.  One never knows.  And not just google, I suppose. There
are a lot of different engines around and some of the web
spiders are better at some things than others.

In any case, thanks for what you found already.  Big help, I
think.

Jon

---

From: "FyberOptic" <fyberoptic@...>
Date: Sun, 24 Jan 2010 00:51:08 -0000

> not hooked to anything!!!  ;^)

I'd have to look at the insides again to see just how tiny those pins were (they always seem bigger in my head), but now that we know for sure that there's a sixth device select, it might be pretty neat to take advantage of it.  Something like compact flash comes to mind, since the data and address lines would be easy to tap into from the eyelets on the board.

> can't say it is useful knowledge.  But who knows?

Ah nice, I was wondering about those, and have been doing some poking around myself for possible matches.  I dismissed a possible LCD at first, but after seeing that patent, I think it seems a little too similar to be a coincidence.

I'm thinking BZCLK might be a buzzer?  The 350 has a buzzer connection for whatever reason.  I don't know how that's used since I've never used that model before.  But I'm assuming one of the ports would set the frequency coming out of BZCLK.  Could be neat to have.  A clever programmer could probably manage music of some kind out of there.

Looks like there's an unused interrupt available too.  There's three bits unaccounted for on P3, so it's surely one of those.

All I've ever really known about the 350's guts is that it "has a different cpu".  I never looked into it further than that since I don't have one.  I just didn't realize how different it was.  This thing is 16-bit based on the data lines coming out of it.  It also seems to have two identical sized pieces of flash (which I'm sure 350 owners who have opened theirs already know), which at first you would think is a good thing, but the sector size seems to be 4KB.  Not quite as easy to work with at the 256-byte sectors of the old model dataflash.  At least it has more ram for holding temporary sectors.  And who knows how much the CPU can address at one time.  I'd love to know what CPU architecture it's based on, for curiosity's sake if nothing else.

One other tidbit I found out is from a trademark search.  Apparently Cidco also registered "Surfstation".

---

From: "FyberOptic" <fyberoptic@...>
Date: Sun, 24 Jan 2010 03:23:36 -0000

> though I suppose the connectors I see probably suffice.

I noticed that, even though the 350 schematics includes both the LCD and the keyboard matrix.  So maybe they're not quite as "full" as I originally implied.  But fortunately, we already know the keyboard and LCD!

http://tech.groups.yahoo.com/group/mailstation/files/part%20files/mailstation_LCD.doc

http://tech.groups.yahoo.com/group/mailstation/files/part%20files/mailstation_keyboard.html

> In any case, thanks for what you found already.  Big help, I

No problem, I'm just glad to contribute.  I was late to the Mailstation game and lack certain tools to be of more help on the hardware testing side, but I still try to see what I can muster up once in a while in other areas.  Good learning experience, too!