{ "cve": [ "CVE-2023-23918" ], "vulnerable": "14.x || 16.x || 18.x || 19.x", "patched": "^14.21.3 || ^16.19.1 || ^18.14.1 || ^19.6.1", "ref": "https://nodejs.org/en/blog/vulnerability/february-2023-security-releases/", "overview": "It was possible to bypass Permissions and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.", "affectedEnvironments": [ "all" ], "severity": "high" }